gnome-games.spec revision 12287
10139N/A#
10139N/A# spec file for package gnome-games
10139N/A#
17185N/A# Copyright (c) 2008 Sun Microsystems, Inc.
18593N/A# This file and all modifications and additions to the pristine
18632N/A# package are under the same license as the package itself.
18593N/A#
13600N/A# Owner: gman
10139N/A#
10139N/AName: gnome-games
10139N/ALicense: GPL
10139N/AGroup: Amusements/Games
10139N/AVersion: 2.21.90
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
20101N/AVendor: Sun Microsystems, Inc.
20101N/ASummary: GNOME games
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.21/%{name}-%{version}.tar.bz2
18632N/A# owner:dcarbery date:2008-01-02 type:bug bugzilla:509409
18632N/APatch1: gnome-games-01-skip-ggz-check.diff
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18593N/ADocdir: %{_defaultdocdir}/%{name}
17338N/AAutoreqprov: on
10139N/APrereq: GConf
10139N/A
15536N/A%define python_version 2.4
17811N/A%define libgnomeui_version 2.2.0
17811N/A%define scrollkeeper_version 0.3.11
17811N/A
15761N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
16554N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
17811N/ABuildRequires: intltool
16554N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/A
19967N/A%description
19967N/AThe gnome-games package includes some small games that come with the
19967N/AGNOME desktop environment but can be used under any desktop.
18384N/AThe games are mostly puzzle or solitaire games.
19967N/A
19967N/A%prep
19967N/A%setup -q
19967N/A%patch1 -p1
19105N/A
18384N/A%build
19967N/A%ifos linux
19967N/Aif [ -x /usr/bin/getconf ]; then
19967N/A CPUS=`getconf _NPROCESSORS_ONLN`
19967N/Afi
19967N/A%else
19967N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
19967N/A%endif
19967N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
19105N/A CPUS=1
19967N/Afi
19967N/A
19967N/Aexport install_user=$LOGNAME
19967N/Aexport install_group=`groups | awk '{print $1}'`
18384N/A
18384N/A# Force the update of aclocal.m4 to incorporate the modified sdl.m4. Otherwise
16633N/A# configure fails because /usr/bin/xgettext is checked instead of the CBE
11999N/A# version which is GNU xgettext.
15536N/Aaclocal --force $ACLOCAL_FLAGS -I m4
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
15536N/A --sysconfdir=%{_sysconfdir} \
10139N/A --bindir=%{_bindir} \
12830N/A --libdir=%{_libdir} \
12830N/A --includedir=%{_includedir} \
17811N/A --libexecdir=%{_libexecdir} \
12830N/A --with-scores-user=$install_user \
13914N/A --with-scores-group=$install_group \
13915N/A --disable-setgid \
17811N/A --disable-scrollkeeper \
14425N/A --with-libggz-includes=%{libggz_build_dir}/src \
16680N/A --with-libggz-libraries=%{libggz_build_dir}/src/.libs \
17811N/A --with-ggzmod-includes=%{ggzmod_build_dir}/ggzmod \
17811N/A --with-ggzmod-libraries=%{ggzmod_build_dir}/ggzmod/.libs \
15190N/A --enable-omitgames=aisleriot,blackjack,gnometris
16597N/A
15536N/Amake -j $CPUS \
17811N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
15216N/A
15418N/A%install
19825N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
17811N/A%makeinstall localstatedir=%{_localstatedir}/lib \
15418N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
16554N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
16554N/A
17811N/A## things we just don't want in the package
16554N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
16554N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
16597N/A
17811N/A## install desktop files
17811N/A
15516N/A%find_lang %{name}
17338N/A
17811N/A#Copy zh_HK from zh_TW
17811N/A#Fixes bug 4930405
17811N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
17811N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
17811N/A
17338N/A%post
15536N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
17811N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
15529N/Afor S in $SCHEMAS; do
17811N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
17811N/Adone
15761N/A
16020N/A%clean
16020N/Arm -rf $RPM_BUILD_ROOT
17811N/A
16020N/A%files -f %{name}.lang
16020N/A%defattr(-, root, root)
17964N/A%doc AUTHORS COPYING ChangeLog
17811N/A
17811N/A# these are not setgid games
17811N/A%{_bindir}/games-server.py
17811N/A%{_bindir}/gnect
16549N/A%{_bindir}/blackjack
17811N/A
19825N/A%{_localstatedir}/lib
17811N/A
16532N/A# these are setgid games
17811N/A%attr(2551, root, games) %{_bindir}/gnomine
19825N/A%attr(2551, root, games) %{_bindir}/same-gnome
17811N/A%attr(2551, root, games) %{_bindir}/mahjongg
17811N/A%attr(2551, root, games) %{_bindir}/gtali
17964N/A%attr(2551, root, games) %{_bindir}/gnobots2
17964N/A%attr(2551, root, games) %{_bindir}/gataxx
17964N/A%attr(2551, root, games) %{_bindir}/gnotravex
18036N/A%attr(2551, root, games) %{_bindir}/gnotski
18036N/A%attr(2551, root, games) %{_bindir}/gnibbles
18036N/A%attr(2551, root, games) %{_bindir}/glines
18036N/A%attr(2551, root, games) %{_bindir}/iagno
18190N/A
18190N/A%{_datadir}/applications
18190N/A%{_datadir}/blackjack
18251N/A%{_datadir}/gnect
18251N/A%{_datadir}/gnibbles
18251N/A%{_datadir}/gnobots2
18251N/A%{_datadir}/gnome
18384N/A%{_datadir}/gnome-games
18384N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
18384N/A%{_datadir}/omf
18384N/A%{_datadir}/pixmaps
18384N/A%{_datadir}/sounds
18384N/A%{_sysconfdir}/gconf/schemas/*
18384N/A%config %{_sysconfdir}/sound/events/*
18384N/A
18384N/A%changelog
18384N/A* Tue Jan 29 2008 - damien.carbery@sun.com
18384N/A- Bump to 2.21.90.
19967N/A* Fri Jan 25 2008 - damien.carbery@sun.com
19967N/A- Force the update of aclocal.m4 to incorporate the modified sdl.m4. Otherwise
19967N/A configure fails because /usr/bin/xgettext is checked instead of the CBE
18384N/A version which is GNU xgettext.
19967N/A* Tue Jan 15 2008 - damien.carbery@sun.com
18384N/A- Bump to 2.21.5.
18384N/A* Wed Jan 09 2008 - damien.carbery@sun.com
18384N/A- Remove 02-msgfmt patch, instead set ACLOCAL_FLAGS in SUNWgnome-games.spec to
18384N/A pick up modified intltool.m4.
18384N/A* Mon Jan 07 2008 - patrick.ale@gmail.com
19127N/A- Add patch gnome-games-02-msgfmt.diff
19127N/A* Mon Jan 07 2008 - damien.carbery@sun.com
19127N/A- Specify ggzmod location in configure.
19127N/A* Wed Jan 02 2008 - damien.carbery@sun.com
19825N/A- Use variable from SUNWgnome-games.spec to specify libggz location. Add patch
19825N/A 01-skip-ggz-check to set compiler flags to get libggz search test work.
19825N/A* Tue Dec 18 2007 - damien.carbery@sun.com
15536N/A- Bump to 2.21.4.
10139N/A* Tue Dec 04 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.3.
10139N/A* Tue Nov 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.2.
10139N/A* Tue Oct 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.21.1.
10139N/A* Fri Oct 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.20.1.
10139N/A* Tue Oct 9 2007 - damien.carbery@sun.com
10139N/A- Add --disable-setgid to configure so that the games are not setgid-bin, which
10139N/A violates ARC rules.
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
16554N/A- Bump to 2.20.0.1. Remove upstream patch, 01-func-decl.
10139N/A* Mon Sep 03 2007 - damien.carbery@sun.com
13898N/A- Bump to 2.19.92. Add patch, 01-func-decl, to fix #473327.
13898N/A* Wed Aug 29 2007 - damien.carbery@sun.com
13898N/A- Bump to 2.19.91.1.
10139N/A* Tue Aug 28 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.91. Remove upstream patch, gnome-menus-05-iconv-solaris.
10139N/A* Thu Aug 16 2007 - damien.carbery@sun.com
10139N/A- Add patch gnome-menus-05-iconv-solaris to fix #467309. Modify
10139N/A intltool-merge.in to allow use of non-GNU iconv.
10139N/A* Wed Aug 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.90.1.
10139N/A* Wed Aug 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.90b. Remove upstream patch, 01-build-gnometris.
10139N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.6. Remove upstream patches, 01-strrchr and 03-ggz-signed-char.
10139N/A Renumber remainder.
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.4. Remove upstream patches, 01-named-struct and 03-signed-char.
10139N/A* Mon Jun 11 2007 - damien.carbery@sun.com
10139N/A- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
17811N/A bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
15536N/A file (modified in patch3).
10139N/A* Fri Jun 08 2007 - damien.carbery@sun.com
15536N/A- Add patch, 03-signed-char, for #445556.
17811N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.3. Add patches to fix some build errors.
15536N/A* Fri May 18 2007 - matt.keenan@sun.com
15536N/A- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
10139N/A* Wed May 16 2007 - damien.carbery@sun.com
15536N/A- Bump to 2.19.2.
17811N/A* Wed May 09 2007 - damien.carbery@sun.com
17811N/A- Bump to 2.19.1.
10139N/A* Fri May 04 2007 - damien.carbery@sun.com
17338N/A- Bump to 2.18.1.1.
17811N/A* Thu Apr 12 2007 - damien.carbery@sun.com
17811N/A- Bump to 2.18.1.
17811N/A* Thu Apr 05 2007 - matt.keenan@sun.com
15536N/A- Remove glchess.desktop, until glchess is made functional on Solaris
18036N/A- Bugzilla : 426538, bugster : 6537569
18190N/A* Wed Mar 21 2007 - damien.carbery@sun.com
18251N/A- Bump to 2.18.0.1.
18384N/A* Tue Mar 13 2007 - damien.carbery@sun.com
18384N/A- Bump to 2.18.0.
18384N/A* Mon Mar 05 2007 - damien.carbery@sun.com
18384N/A- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
19127N/A* Thu Feb 15 2007 - damien.carbery@sun.com
19825N/A- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
16050N/A Specify build user/group so that chown calls don't fail; disable building
16020N/A of aisleriot game (removing code from SUNWgnome-games.spec).
17811N/A* Tue Feb 13 2007 - damien.carbery@sun.com
16020N/A- Bump to 2.17.91.
10139N/A* Wed Jan 24 2007 - damien.carbery@sun.com
16554N/A- Bump to 2.17.90.1.
17811N/A* Mon Jan 22 2007 - damien.carbery@sun.com
16554N/A- Bump to 2.17.90.
16554N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
10139N/A* Wed Dec 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.4.
17811N/A* Thu Dec 07 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
10139N/A Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
10139N/A Install python libs to vendor-packages dir and remove *.pyo files.
10139N/A* Fri Nov 24 2006 - damien.carbery@sun.com
10139N/A- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
15536N/A* Wed Nov 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.1.
10139N/A* Thu Nov 09 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.1.1.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.1.
10139N/A* Tue Sep 05 2006 - damien.carbery@sun.com
13898N/A- Bump to 2.16.0.
13898N/A* Tue Aug 22 2006 - damien.carbery@sun.com
19111N/A- Bump to 2.15.92.
19111N/A* Tue Aug 08 2006 - damien.carbery@sun.com
19111N/A- Bump to 2.15.6.
19111N/A* Mon Jul 24 2006 - damien.carbery@sun.com
19111N/A- Bump to 2.15.5.
19111N/A* Web Jul 21 2006 - dermot.mccluskey@sun.com
19111N/A- Bump to 2.15.4.
14526N/A* Mon Jun 26 2006 - laca@sun.com
10139N/A- remove patch menu-entry.diff since gnome-games is moving back to /usr
13898N/A* Fri Jun 23 2006 - brian.cameron@sun.com
18918N/A- Bump to 2.14.2.
13898N/A* Fri Apr 10 2006 - damien.carbery@sun.com
13898N/A- Bump to 2.14.
17965N/A* Mon Mar 13 2006 - damien.carbery@sun.com
17965N/A- Bump to 2.14.
15189N/A* Thu Feb 23 2006 - damien.carbery@sun.com
13898N/A- Bump to 2.13.8.
16554N/A* Mon Feb 13 2006 - damien.carbery@sun.com
16554N/A- Bump to 2.13.7.
16554N/A* Sat Jan 21 2006 - damien.carbery@sun.com
16554N/A- Remove upstream patch, 02-illegal-cast.
18384N/A* Tue Jan 17 2006 - damien.carbery@sun.com
17964N/A- Bump to 2.13.5
10139N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.4.
10139N/A* Sat Jan 07 2006 - damien.carbery@sun.com
10139N/A- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
10139N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10139N/A- Bump to 2.13.3
10139N/A* Fri Dec 02 2005 - srirama.sharma@wipro.com
10139N/A- Added gnome-games-01-sfw-path.diff to use the absolute path of the
13898N/A executable in the .desktop file as usr/sfw/bin should not be
13898N/A included in $PATH.
13898N/A Fixes bug #6345489.
13898N/A* Tue Nov 29 2005 - laca.com
13898N/A- remove javahelp stuff
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
16554N/A- Bump to 2.12.2.
17811N/A* Wed Oct 12 2005 - damien.carbery@sun.com
16554N/A- Remove patch as offending struct is no longer empty.
16554N/A* Tue Oct 11 2005 - damien.carbery@sun.com
16554N/A- Bump to 2.12.1
16554N/A* Sat Sep 17 2005 - glynn.foster@sun.com
16554N/A- Bump to 2.12.0
18384N/A* Mon Sep 05 2005 - damien.carbery@sun.com
18384N/A- Bump to 2.11.5.
18384N/A* Fri Sep 02 2005 - damien.carbery@sun.com
18384N/A- Add patch to fix zero sized struct Solaris build error.
18384N/A* Wed Aug 24 2005 - damien.carbery@sun.com
18384N/A- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
18384N/A* Mon Aug 15 2005 - damien.carbery@sun.com
17811N/A- Bump to 2.11.4.
17811N/A* Fri May 20 2005 - glynn.foster@sun.com
14124N/A- Bump to 2.10.1
13898N/A* Wed May 11 2005 - ciaran.mcdermott@sun.com
12834N/A- added gnome-games-05-g11n-desktop-fix.diff
10139N/A- to fix CR 6266891
10139N/A* Wed Apr 27 2005 - kieran.colfer@sun.com
10139N/A- added gnome-games-04-po-install-fixes.diff for CR 6243601
10139N/A* Fri Nov 12 2004 - laca@sun.com
13898N/A- added --libdir and --bindir to configure opts so they can be redirected on
13898N/A Solaris
13898N/A* Mon Sep 20 2004 - dermot.mccluskey@sun.com
13898N/A- removed sol from files
13898N/A* Thu Sep 04 2004 - laslzo.kovacs@sun.com
13898N/A- packaged sol
13898N/A* Thu Aug 26 2004 - damien.carbery@sun.com
13898N/A- Put scores files in %{_localstatedir}/lib.
13898N/A* Wed Aug 25 2004 - damien.carbery@sun.com
13898N/A- Add unpackaged files to %files.
13898N/A* Mon Aug 23 2004 - niall.power@sun.com
13898N/A- remove auto*-jds tool dependencies
13898N/A* Thu Jul 08 2004 - damien.donlon@sun.com
13898N/A- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
13898N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
13898N/A- added "-j $CPUS" to make to speed up builds
13898N/A* Tue Jun 1 2004 - glynn.foster@sun.com
13898N/A- Fix up schema install
13898N/A* Wed May 12 2004 - damien.donlon@sun.com
14376N/A- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
13898N/A* Fri May 07 2004 - matt.keenan@sun.com
13898N/A- Bump to 2.6.1
13898N/A* Wed Apr 21 2004 - laca@sun.com
13898N/A- disable javahelp conversion for stuff not built on Solaris
14376N/A* Sun Apr 18 2004 - laca@sun.com
13898N/A- enable javahelp conversion on Solaris
13898N/A* Fri Apr 02 2004 - brian.cameron@sun.com
13898N/A- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
10139N/A configure line.
10139N/A* Thu Apr 01 2004 - matt.keenan@sun.com
10139N/A- javahelp conversion
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
10139N/A* Wed Mar 24 2004 - glynn.foster@sun.com
10139N/A- Use JDS autotools
10139N/A* Tue Mar 23 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.6.0. Remove 2 potfile patches and
15536N/A replace with a single one.
13898N/A* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
10139N/A- added gnome-games-03-g11n-potfiles.diff
10139N/A* Fri Feb 06 2004 - <matt.keenan@sun.com>
13898N/A- Bump up 2.5.5, remove intltool-merge patch
13898N/A- re-engineered patch-01, as automake etc is commented out.
13898N/A- This could be changed again if automake 1.7 was being used not 1.6 !!
13898N/A* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
13898N/A- add patch 03 for intltool-merge and dep. on intltool
13898N/A* Fri Dec 29 2003 - <niall.power@sun.com>
13898N/A- comment out libtool, aclocal etc. which
13898N/A is causing build failure
13898N/A* Fri Dec 29 2003 - <glynn.foster@sun.com>
16617N/A- Bump to 2.5.3
17811N/A* Wed Dec 17 2003 - <glynn.foster@sun.com>
16617N/A- Bump to 2.5.2
16617N/A* Fri Oct 31 2003 - <glynn.foster@sun.com>
16617N/A- Remove the Sun Supported keyword from the desktop
16617N/A files. We're removing the Extras menu.
16617N/A* Wed Oct 22 2003 - <glynn.foster@sun.com>
16617N/A- Add blackjack into the build
16617N/A* Tue Oct 21 2003 - <michael.twomey@sun.com>
16617N/A- Updated to GNOME 2.4.0 version
16617N/A- Removed freecell entries
17811N/A- Moved gnome-games-03-menu-entry.diff patch to
14376N/A gnome-games-01-menu-entry.diff
13898N/A- Dropped gnome-games-04-glines-preferences.diff patch.
13898N/A* Thu Aug 14 2003 - <laca@sun.com>
13898N/A- remove *.so, *.a, *.la
13898N/A* Wed Aug 06 2003 - <glynn.foster@sun.com>
15536N/A- fix glines preference dialog
15536N/A* Thu Jul 17 2003 - <glynn.foster@sun.com>
15536N/A- remove more xbill stuff
17811N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
14376N/A- add in sun po files
13898N/A* Tue Jul 08 2003 - glynn.foster@sun.com
13898N/A- Add menu icon for freecell, and add aclocal, automake checks
13898N/A* Tue May 13 2003 - ghee.teo@Sun.COM
13898N/A- Created new spec file for gnome-games
15536N/A
15536N/A