gnome-games.spec revision 11256
10139N/A#
10139N/A# spec file for package gnome-games
10139N/A#
17185N/A# Copyright (c) 2005 Sun Microsystems, Inc.
18593N/A# This file and all modifications and additions to the pristine
18632N/A# package are under the same license as the package itself.
18593N/A#
13600N/A# Owner: gman
10139N/A#
10139N/AName: gnome-games
10139N/ALicense: GPL
10139N/AGroup: Amusements/Games
10139N/AVersion: 2.20.0.1
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
20101N/AVendor: Sun Microsystems, Inc.
20101N/ASummary: GNOME games
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.20/%{name}-%{version}.tar.bz2
18632N/AURL: http://www.gnome.org
18632N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
18593N/APrereq: GConf
17338N/A
10139N/A%define python_version 2.4
10139N/A%define libgnomeui_version 2.2.0
15536N/A%define scrollkeeper_version 0.3.11
17811N/A
17811N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
17811N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
15761N/ABuildRequires: intltool
16554N/ARequires: libgnomeui >= %{libgnomeui_version}
17811N/A
16554N/A%description
10139N/AThe gnome-games package includes some small games that come with the
19967N/AGNOME desktop environment but can be used under any desktop.
19967N/AThe games are mostly puzzle or solitaire games.
19967N/A
18384N/A%prep
19967N/A%setup -q
19967N/A
19967N/A%build
19967N/A%ifos linux
19105N/Aif [ -x /usr/bin/getconf ]; then
18384N/A CPUS=`getconf _NPROCESSORS_ONLN`
19967N/Afi
19967N/A%else
19967N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
19967N/A%endif
19967N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
19967N/A CPUS=1
19967N/Afi
19967N/A
19105N/Aexport install_user=$LOGNAME
19967N/Aexport install_group=`groups | awk '{print $1}'`
19967N/A
19967N/Aaclocal $ACLOCAL_FLAGS -I m4
19967N/Aautomake -a -c -f
18384N/Aautoconf
18384N/A./configure --prefix=%{_prefix} \
16633N/A --sysconfdir=%{_sysconfdir} \
11999N/A --bindir=%{_bindir} \
15536N/A --libdir=%{_libdir} \
10139N/A --includedir=%{_includedir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --with-scores-user=$install_user \
15536N/A --with-scores-group=$install_group \
10139N/A --enable-omitgames=aisleriot,blackjack,gnometris
12830N/A
12830N/Amake -j $CPUS \
17811N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
12830N/A
13914N/A%install
13915N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
17811N/A%makeinstall localstatedir=%{_localstatedir}/lib \
14425N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
16680N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
17811N/A
17811N/A## things we just don't want in the package
15190N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
16597N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
15536N/A
17811N/A## install desktop files
15216N/A
15418N/A%find_lang %{name}
19825N/A
17811N/A#Copy zh_HK from zh_TW
15418N/A#Fixes bug 4930405
16554N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
16554N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
17811N/A
16554N/A%post
16554N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
16597N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
17811N/Afor S in $SCHEMAS; do
17811N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
15516N/Adone
17338N/A
17811N/A%clean
17811N/Arm -rf $RPM_BUILD_ROOT
17811N/A
17811N/A%files -f %{name}.lang
17811N/A%defattr(-, root, root)
17338N/A%doc AUTHORS COPYING ChangeLog
15536N/A
17811N/A# these are not setgid games
15529N/A%{_bindir}/games-server.py
17811N/A%{_bindir}/gnect
17811N/A%{_bindir}/blackjack
15761N/A
16020N/A%{_localstatedir}/lib
16020N/A
17811N/A# these are setgid games
16020N/A%attr(2551, root, games) %{_bindir}/gnomine
16020N/A%attr(2551, root, games) %{_bindir}/same-gnome
17964N/A%attr(2551, root, games) %{_bindir}/mahjongg
17811N/A%attr(2551, root, games) %{_bindir}/gtali
17811N/A%attr(2551, root, games) %{_bindir}/gnobots2
17811N/A%attr(2551, root, games) %{_bindir}/gataxx
17811N/A%attr(2551, root, games) %{_bindir}/gnotravex
16549N/A%attr(2551, root, games) %{_bindir}/gnotski
17811N/A%attr(2551, root, games) %{_bindir}/gnibbles
19825N/A%attr(2551, root, games) %{_bindir}/glines
17811N/A%attr(2551, root, games) %{_bindir}/iagno
16532N/A
17811N/A%{_datadir}/applications
19825N/A%{_datadir}/blackjack
17811N/A%{_datadir}/gnect
17811N/A%{_datadir}/gnibbles
17964N/A%{_datadir}/gnobots2
17964N/A%{_datadir}/gnome
17964N/A%{_datadir}/gnome-games
18036N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
18036N/A%{_datadir}/omf
18036N/A%{_datadir}/pixmaps
18036N/A%{_datadir}/sounds
18190N/A%{_sysconfdir}/gconf/schemas/*
18190N/A%config %{_sysconfdir}/sound/events/*
18190N/A
18251N/A%changelog
18251N/A* Tue Sep 18 2007 - damien.carbery@sun.com
18251N/A- Bump to 2.20.0.1. Remove upstream patch, 01-func-decl.
18251N/A* Mon Sep 03 2007 - damien.carbery@sun.com
18384N/A- Bump to 2.19.92. Add patch, 01-func-decl, to fix #473327.
18384N/A* Wed Aug 29 2007 - damien.carbery@sun.com
18384N/A- Bump to 2.19.91.1.
18384N/A* Tue Aug 28 2007 - damien.carbery@sun.com
18384N/A- Bump to 2.19.91. Remove upstream patch, gnome-menus-05-iconv-solaris.
18384N/A* Thu Aug 16 2007 - damien.carbery@sun.com
18384N/A- Add patch gnome-menus-05-iconv-solaris to fix #467309. Modify
18384N/A intltool-merge.in to allow use of non-GNU iconv.
18384N/A* Wed Aug 15 2007 - damien.carbery@sun.com
18384N/A- Bump to 2.19.90.1.
18384N/A* Wed Aug 15 2007 - damien.carbery@sun.com
19967N/A- Bump to 2.19.90b. Remove upstream patch, 01-build-gnometris.
19967N/A* Mon Jul 30 2007 - damien.carbery@sun.com
19967N/A- Bump to 2.19.6. Remove upstream patches, 01-strrchr and 03-ggz-signed-char.
18384N/A Renumber remainder.
19967N/A* Tue Jun 19 2007 - damien.carbery@sun.com
18384N/A- Bump to 2.19.4. Remove upstream patches, 01-named-struct and 03-signed-char.
18384N/A* Mon Jun 11 2007 - damien.carbery@sun.com
18384N/A- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
18384N/A bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
18384N/A file (modified in patch3).
19127N/A* Fri Jun 08 2007 - damien.carbery@sun.com
19127N/A- Add patch, 03-signed-char, for #445556.
19127N/A* Wed Jun 06 2007 - damien.carbery@sun.com
19127N/A- Bump to 2.19.3. Add patches to fix some build errors.
19825N/A* Fri May 18 2007 - matt.keenan@sun.com
19825N/A- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
19825N/A* Wed May 16 2007 - damien.carbery@sun.com
15536N/A- Bump to 2.19.2.
10139N/A* Wed May 09 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.1.
10139N/A* Fri May 04 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.1.
10139N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.
10139N/A* Thu Apr 05 2007 - matt.keenan@sun.com
10139N/A- Remove glchess.desktop, until glchess is made functional on Solaris
10139N/A- Bugzilla : 426538, bugster : 6537569
10139N/A* Wed Mar 21 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.1.
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
16554N/A- Bump to 2.18.0.
10139N/A* Mon Mar 05 2007 - damien.carbery@sun.com
13898N/A- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
13898N/A* Thu Feb 15 2007 - damien.carbery@sun.com
13898N/A- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
10139N/A Specify build user/group so that chown calls don't fail; disable building
10139N/A of aisleriot game (removing code from SUNWgnome-games.spec).
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.91.
10139N/A* Wed Jan 24 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.90.1.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.90.
10139N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
10139N/A* Wed Dec 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.4.
10139N/A* Thu Dec 07 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
17811N/A Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
15536N/A Install python libs to vendor-packages dir and remove *.pyo files.
10139N/A* Fri Nov 24 2006 - damien.carbery@sun.com
15536N/A- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
17811N/A* Wed Nov 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.1.
15536N/A* Thu Nov 09 2006 - damien.carbery@sun.com
15536N/A- Bump to 2.16.1.1.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
15536N/A- Bump to 2.16.1.
17811N/A* Tue Sep 05 2006 - damien.carbery@sun.com
17811N/A- Bump to 2.16.0.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
17338N/A- Bump to 2.15.92.
17811N/A* Tue Aug 08 2006 - damien.carbery@sun.com
17811N/A- Bump to 2.15.6.
17811N/A* Mon Jul 24 2006 - damien.carbery@sun.com
15536N/A- Bump to 2.15.5.
18036N/A* Web Jul 21 2006 - dermot.mccluskey@sun.com
18190N/A- Bump to 2.15.4.
18251N/A* Mon Jun 26 2006 - laca@sun.com
18384N/A- remove patch menu-entry.diff since gnome-games is moving back to /usr
18384N/A* Fri Jun 23 2006 - brian.cameron@sun.com
18384N/A- Bump to 2.14.2.
18384N/A* Fri Apr 10 2006 - damien.carbery@sun.com
19127N/A- Bump to 2.14.
19825N/A* Mon Mar 13 2006 - damien.carbery@sun.com
16050N/A- Bump to 2.14.
16020N/A* Thu Feb 23 2006 - damien.carbery@sun.com
17811N/A- Bump to 2.13.8.
16020N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.7.
16554N/A* Sat Jan 21 2006 - damien.carbery@sun.com
17811N/A- Remove upstream patch, 02-illegal-cast.
16554N/A* Tue Jan 17 2006 - damien.carbery@sun.com
16554N/A- Bump to 2.13.5
10139N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.4.
10139N/A* Sat Jan 07 2006 - damien.carbery@sun.com
10139N/A- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
10139N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
17811N/A- Bump to 2.13.3
10139N/A* Fri Dec 02 2005 - srirama.sharma@wipro.com
10139N/A- Added gnome-games-01-sfw-path.diff to use the absolute path of the
10139N/A executable in the .desktop file as usr/sfw/bin should not be
10139N/A included in $PATH.
10139N/A Fixes bug #6345489.
15536N/A* Tue Nov 29 2005 - laca.com
10139N/A- remove javahelp stuff
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.2.
10139N/A* Wed Oct 12 2005 - damien.carbery@sun.com
10139N/A- Remove patch as offending struct is no longer empty.
10139N/A* Tue Oct 11 2005 - damien.carbery@sun.com
13898N/A- Bump to 2.12.1
13898N/A* Sat Sep 17 2005 - glynn.foster@sun.com
19111N/A- Bump to 2.12.0
19111N/A* Mon Sep 05 2005 - damien.carbery@sun.com
19111N/A- Bump to 2.11.5.
19111N/A* Fri Sep 02 2005 - damien.carbery@sun.com
19111N/A- Add patch to fix zero sized struct Solaris build error.
19111N/A* Wed Aug 24 2005 - damien.carbery@sun.com
19111N/A- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
14526N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.4.
13898N/A* Fri May 20 2005 - glynn.foster@sun.com
18918N/A- Bump to 2.10.1
13898N/A* Wed May 11 2005 - ciaran.mcdermott@sun.com
13898N/A- added gnome-games-05-g11n-desktop-fix.diff
17965N/A- to fix CR 6266891
17965N/A* Wed Apr 27 2005 - kieran.colfer@sun.com
15189N/A- added gnome-games-04-po-install-fixes.diff for CR 6243601
13898N/A* Fri Nov 12 2004 - laca@sun.com
16554N/A- added --libdir and --bindir to configure opts so they can be redirected on
16554N/A Solaris
16554N/A* Mon Sep 20 2004 - dermot.mccluskey@sun.com
16554N/A- removed sol from files
18384N/A* Thu Sep 04 2004 - laslzo.kovacs@sun.com
17964N/A- packaged sol
10139N/A* Thu Aug 26 2004 - damien.carbery@sun.com
10139N/A- Put scores files in %{_localstatedir}/lib.
10139N/A* Wed Aug 25 2004 - damien.carbery@sun.com
10139N/A- Add unpackaged files to %files.
10139N/A* Mon Aug 23 2004 - niall.power@sun.com
10139N/A- remove auto*-jds tool dependencies
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
13898N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
13898N/A- added "-j $CPUS" to make to speed up builds
13898N/A* Tue Jun 1 2004 - glynn.foster@sun.com
13898N/A- Fix up schema install
13898N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
16554N/A* Fri May 07 2004 - matt.keenan@sun.com
17811N/A- Bump to 2.6.1
16554N/A* Wed Apr 21 2004 - laca@sun.com
16554N/A- disable javahelp conversion for stuff not built on Solaris
16554N/A* Sun Apr 18 2004 - laca@sun.com
16554N/A- enable javahelp conversion on Solaris
16554N/A* Fri Apr 02 2004 - brian.cameron@sun.com
18384N/A- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
18384N/A configure line.
18384N/A* Thu Apr 01 2004 - matt.keenan@sun.com
18384N/A- javahelp conversion
18384N/A* Mon Mar 29 2004 - damien.donlon@sun.com
18384N/A- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
18384N/A* Wed Mar 24 2004 - glynn.foster@sun.com
17811N/A- Use JDS autotools
17811N/A* Tue Mar 23 2004 - glynn.foster@sun.com
14124N/A- Bump to 2.6.0. Remove 2 potfile patches and
13898N/A replace with a single one.
12834N/A* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
10139N/A- added gnome-games-03-g11n-potfiles.diff
10139N/A* Fri Feb 06 2004 - <matt.keenan@sun.com>
10139N/A- Bump up 2.5.5, remove intltool-merge patch
10139N/A- re-engineered patch-01, as automake etc is commented out.
13898N/A- This could be changed again if automake 1.7 was being used not 1.6 !!
13898N/A* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
13898N/A- add patch 03 for intltool-merge and dep. on intltool
13898N/A* Fri Dec 29 2003 - <niall.power@sun.com>
13898N/A- comment out libtool, aclocal etc. which
13898N/A is causing build failure
13898N/A* Fri Dec 29 2003 - <glynn.foster@sun.com>
13898N/A- Bump to 2.5.3
13898N/A* Wed Dec 17 2003 - <glynn.foster@sun.com>
13898N/A- Bump to 2.5.2
13898N/A* Fri Oct 31 2003 - <glynn.foster@sun.com>
13898N/A- Remove the Sun Supported keyword from the desktop
13898N/A files. We're removing the Extras menu.
13898N/A* Wed Oct 22 2003 - <glynn.foster@sun.com>
13898N/A- Add blackjack into the build
13898N/A* Tue Oct 21 2003 - <michael.twomey@sun.com>
13898N/A- Updated to GNOME 2.4.0 version
13898N/A- Removed freecell entries
13898N/A- Moved gnome-games-03-menu-entry.diff patch to
14376N/A gnome-games-01-menu-entry.diff
13898N/A- Dropped gnome-games-04-glines-preferences.diff patch.
13898N/A* Thu Aug 14 2003 - <laca@sun.com>
13898N/A- remove *.so, *.a, *.la
13898N/A* Wed Aug 06 2003 - <glynn.foster@sun.com>
14376N/A- fix glines preference dialog
13898N/A* Thu Jul 17 2003 - <glynn.foster@sun.com>
13898N/A- remove more xbill stuff
13898N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10139N/A- add in sun po files
10139N/A* Tue Jul 08 2003 - glynn.foster@sun.com
10139N/A- Add menu icon for freecell, and add aclocal, automake checks
10139N/A* Tue May 13 2003 - ghee.teo@Sun.COM
10139N/A- Created new spec file for gnome-games
10139N/A
10139N/A