gnome-games.spec revision 11172
12174N/A#
12174N/A# spec file for package gnome-games
12174N/A#
12174N/A# Copyright (c) 2005 Sun Microsystems, Inc.
12174N/A# This file and all modifications and additions to the pristine
18678N/A# package are under the same license as the package itself.
12174N/A#
12174N/A# Owner: gman
12174N/A#
20363N/AName: gnome-games
12174N/ALicense: GPL
10145N/AGroup: Amusements/Games
18593N/AVersion: 2.19.92
18593N/ARelease: 1
10145N/ADistribution: Java Desktop System
10145N/AVendor: Sun Microsystems, Inc.
10145N/ASummary: GNOME games
10145N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.19/%{name}-%{version}.tar.bz2
10145N/AURL: http://www.gnome.org
10145N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10145N/ADocdir: %{_defaultdocdir}/%{name}
18688N/AAutoreqprov: on
18688N/APrereq: GConf
20777N/A
10239N/A%define python_version 2.4
20829N/A%define libgnomeui_version 2.2.0
10145N/A%define scrollkeeper_version 0.3.11
10145N/A
13850N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10145N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
10697N/ABuildRequires: intltool
10145N/ARequires: libgnomeui >= %{libgnomeui_version}
10145N/A
12710N/A%description
10145N/AThe gnome-games package includes some small games that come with the
10145N/AGNOME desktop environment but can be used under any desktop.
20857N/AThe games are mostly puzzle or solitaire games.
16401N/A
10145N/A%prep
10145N/A%setup -q
10145N/A
10145N/A%build
10145N/A%ifos linux
10145N/Aif [ -x /usr/bin/getconf ]; then
10145N/A CPUS=`getconf _NPROCESSORS_ONLN`
10373N/Afi
19142N/A%else
16401N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10145N/A%endif
10145N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10145N/A CPUS=1
10145N/Afi
10145N/A
10373N/Aexport install_user=$LOGNAME
10145N/Aexport install_group=`groups | awk '{print $1}'`
10145N/A
10145N/Aaclocal $ACLOCAL_FLAGS -I m4
20829N/Aautomake -a -c -f
10145N/Aautoconf
10145N/A./configure --prefix=%{_prefix} \
10145N/A --sysconfdir=%{_sysconfdir} \
10145N/A --bindir=%{_bindir} \
10145N/A --libdir=%{_libdir} \
10145N/A --includedir=%{_includedir} \
20857N/A --libexecdir=%{_libexecdir} \
10145N/A --with-scores-user=$install_user \
10145N/A --with-scores-group=$install_group \
10145N/A --enable-omitgames=aisleriot,blackjack,gnometris
10145N/A
10145N/Amake -j $CPUS \
10145N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
10145N/A
10145N/A%install
10145N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10697N/A%makeinstall localstatedir=%{_localstatedir}/lib \
10697N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
10145N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
12754N/A
10145N/A## things we just don't want in the package
10145N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
10145N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
10145N/A
10145N/A## install desktop files
10145N/A
10145N/A%find_lang %{name}
10145N/A
12773N/A#Copy zh_HK from zh_TW
12773N/A#Fixes bug 4930405
12773N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10145N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10145N/A
20363N/A%post
10145N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10145N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
10145N/Afor S in $SCHEMAS; do
10145N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
10145N/Adone
10145N/A
10145N/A%clean
10145N/Arm -rf $RPM_BUILD_ROOT
10145N/A
10145N/A%files -f %{name}.lang
10145N/A%defattr(-, root, root)
10145N/A%doc AUTHORS COPYING ChangeLog
10145N/A
10145N/A# these are not setgid games
10145N/A%{_bindir}/games-server.py
10145N/A%{_bindir}/gnect
10614N/A%{_bindir}/blackjack
10614N/A
10614N/A%{_localstatedir}/lib
10697N/A
10697N/A# these are setgid games
10697N/A%attr(2551, root, games) %{_bindir}/gnomine
10697N/A%attr(2551, root, games) %{_bindir}/same-gnome
10145N/A%attr(2551, root, games) %{_bindir}/mahjongg
10145N/A%attr(2551, root, games) %{_bindir}/gtali
10145N/A%attr(2551, root, games) %{_bindir}/gnobots2
10145N/A%attr(2551, root, games) %{_bindir}/gataxx
16679N/A%attr(2551, root, games) %{_bindir}/gnotravex
10145N/A%attr(2551, root, games) %{_bindir}/gnotski
10145N/A%attr(2551, root, games) %{_bindir}/gnibbles
10145N/A%attr(2551, root, games) %{_bindir}/glines
10145N/A%attr(2551, root, games) %{_bindir}/iagno
10145N/A
10362N/A%{_datadir}/applications
10362N/A%{_datadir}/blackjack
10145N/A%{_datadir}/gnect
10145N/A%{_datadir}/gnibbles
10145N/A%{_datadir}/gnobots2
10145N/A%{_datadir}/gnome
10145N/A%{_datadir}/gnome-games
10145N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
10145N/A%{_datadir}/omf
10145N/A%{_datadir}/pixmaps
10362N/A%{_datadir}/sounds
10362N/A%{_sysconfdir}/gconf/schemas/*
11936N/A%config %{_sysconfdir}/sound/events/*
10362N/A
10697N/A%changelog
10697N/A* Mon Sep 03 2007 - damien.carbery@sun.com
10697N/A- Bump to 2.19.92.
14416N/A* Wed Aug 29 2007 - damien.carbery@sun.com
14423N/A- Bump to 2.19.91.1.
10145N/A* Tue Aug 28 2007 - damien.carbery@sun.com
10145N/A- Bump to 2.19.91. Remove upstream patch, gnome-menus-05-iconv-solaris.
10145N/A* Thu Aug 16 2007 - damien.carbery@sun.com
10145N/A- Add patch gnome-menus-05-iconv-solaris to fix #467309. Modify
10145N/A intltool-merge.in to allow use of non-GNU iconv.
10145N/A* Wed Aug 15 2007 - damien.carbery@sun.com
10145N/A- Bump to 2.19.90.1.
10145N/A* Wed Aug 15 2007 - damien.carbery@sun.com
10145N/A- Bump to 2.19.90b. Remove upstream patch, 01-build-gnometris.
10145N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10145N/A- Bump to 2.19.6. Remove upstream patches, 01-strrchr and 03-ggz-signed-char.
10145N/A Renumber remainder.
10145N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10145N/A- Bump to 2.19.4. Remove upstream patches, 01-named-struct and 03-signed-char.
10145N/A* Mon Jun 11 2007 - damien.carbery@sun.com
20777N/A- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
20777N/A bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
20363N/A file (modified in patch3).
20363N/A* Fri Jun 08 2007 - damien.carbery@sun.com
20363N/A- Add patch, 03-signed-char, for #445556.
18678N/A* Wed Jun 06 2007 - damien.carbery@sun.com
18678N/A- Bump to 2.19.3. Add patches to fix some build errors.
16679N/A* Fri May 18 2007 - matt.keenan@sun.com
16679N/A- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
14423N/A* Wed May 16 2007 - damien.carbery@sun.com
14423N/A- Bump to 2.19.2.
13850N/A* Wed May 09 2007 - damien.carbery@sun.com
13850N/A- Bump to 2.19.1.
13596N/A* Fri May 04 2007 - damien.carbery@sun.com
13596N/A- Bump to 2.18.1.1.
12710N/A* Thu Apr 12 2007 - damien.carbery@sun.com
12710N/A- Bump to 2.18.1.
12627N/A* Thu Apr 05 2007 - matt.keenan@sun.com
12627N/A- Remove glchess.desktop, until glchess is made functional on Solaris
12627N/A- Bugzilla : 426538, bugster : 6537569
12627N/A* Wed Mar 21 2007 - damien.carbery@sun.com
12116N/A- Bump to 2.18.0.1.
12116N/A* Tue Mar 13 2007 - damien.carbery@sun.com
12116N/A- Bump to 2.18.0.
11936N/A* Mon Mar 05 2007 - damien.carbery@sun.com
11936N/A- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
11936N/A* Thu Feb 15 2007 - damien.carbery@sun.com
11914N/A- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
11219N/A Specify build user/group so that chown calls don't fail; disable building
11219N/A of aisleriot game (removing code from SUNWgnome-games.spec).
11086N/A* Tue Feb 13 2007 - damien.carbery@sun.com
11086N/A- Bump to 2.17.91.
10970N/A* Wed Jan 24 2007 - damien.carbery@sun.com
10970N/A- Bump to 2.17.90.1.
10878N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10878N/A- Bump to 2.17.90.
10702N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10702N/A- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
10702N/A* Wed Dec 20 2006 - damien.carbery@sun.com
10697N/A- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
10697N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10614N/A- Bump to 2.17.4.
10614N/A* Thu Dec 07 2006 - damien.carbery@sun.com
10614N/A- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
10386N/A Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
10386N/A Install python libs to vendor-packages dir and remove *.pyo files.
10373N/A* Fri Nov 24 2006 - damien.carbery@sun.com
10373N/A- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
10386N/A* Wed Nov 22 2006 - damien.carbery@sun.com
10362N/A- Bump to 2.17.1.
10362N/A* Thu Nov 09 2006 - damien.carbery@sun.com
10386N/A- Bump to 2.16.1.1.
10239N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.16.1.
10145N/A* Tue Sep 05 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.16.0.
10145N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.15.92.
10145N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.15.6.
10145N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.15.5.
10145N/A* Web Jul 21 2006 - dermot.mccluskey@sun.com
10145N/A- Bump to 2.15.4.
10145N/A* Mon Jun 26 2006 - laca@sun.com
10145N/A- remove patch menu-entry.diff since gnome-games is moving back to /usr
10145N/A* Fri Jun 23 2006 - brian.cameron@sun.com
10145N/A- Bump to 2.14.2.
10145N/A* Fri Apr 10 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.14.
10145N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.14.
10145N/A* Thu Feb 23 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.13.8.
10145N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.13.7.
10145N/A* Sat Jan 21 2006 - damien.carbery@sun.com
10145N/A- Remove upstream patch, 02-illegal-cast.
10145N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.13.5
10145N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.13.4.
10145N/A* Sat Jan 07 2006 - damien.carbery@sun.com
10145N/A- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
10145N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10145N/A- Bump to 2.13.3
10145N/A* Fri Dec 02 2005 - srirama.sharma@wipro.com
10145N/A- Added gnome-games-01-sfw-path.diff to use the absolute path of the
10145N/A executable in the .desktop file as usr/sfw/bin should not be
10145N/A included in $PATH.
10145N/A Fixes bug #6345489.
10145N/A* Tue Nov 29 2005 - laca.com
10145N/A- remove javahelp stuff
10145N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10145N/A- Bump to 2.12.2.
10145N/A* Wed Oct 12 2005 - damien.carbery@sun.com
10145N/A- Remove patch as offending struct is no longer empty.
10145N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10145N/A- Bump to 2.12.1
10145N/A* Sat Sep 17 2005 - glynn.foster@sun.com
10145N/A- Bump to 2.12.0
10145N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10145N/A- Bump to 2.11.5.
10145N/A* Fri Sep 02 2005 - damien.carbery@sun.com
10145N/A- Add patch to fix zero sized struct Solaris build error.
10145N/A* Wed Aug 24 2005 - damien.carbery@sun.com
10145N/A- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
10145N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10145N/A- Bump to 2.11.4.
10145N/A* Fri May 20 2005 - glynn.foster@sun.com
10145N/A- Bump to 2.10.1
10145N/A* Wed May 11 2005 - ciaran.mcdermott@sun.com
10145N/A- added gnome-games-05-g11n-desktop-fix.diff
10145N/A- to fix CR 6266891
16401N/A* Wed Apr 27 2005 - kieran.colfer@sun.com
19198N/A- added gnome-games-04-po-install-fixes.diff for CR 6243601
19515N/A* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected on
Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- removed sol from files
* Thu Sep 04 2004 - laslzo.kovacs@sun.com
- packaged sol
* Thu Aug 26 2004 - damien.carbery@sun.com
- Put scores files in %{_localstatedir}/lib.
* Wed Aug 25 2004 - damien.carbery@sun.com
- Add unpackaged files to %files.
* Mon Aug 23 2004 - niall.power@sun.com
- remove auto*-jds tool dependencies
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Tue Jun 1 2004 - glynn.foster@sun.com
- Fix up schema install
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - matt.keenan@sun.com
- Bump to 2.6.1
* Wed Apr 21 2004 - laca@sun.com
- disable javahelp conversion for stuff not built on Solaris
* Sun Apr 18 2004 - laca@sun.com
- enable javahelp conversion on Solaris
* Fri Apr 02 2004 - brian.cameron@sun.com
- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
configure line.
* Thu Apr 01 2004 - matt.keenan@sun.com
- javahelp conversion
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - glynn.foster@sun.com
- Use JDS autotools
* Tue Mar 23 2004 - glynn.foster@sun.com
- Bump to 2.6.0. Remove 2 potfile patches and
replace with a single one.
* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
- added gnome-games-03-g11n-potfiles.diff
* Fri Feb 06 2004 - <matt.keenan@sun.com>
- Bump up 2.5.5, remove intltool-merge patch
- re-engineered patch-01, as automake etc is commented out.
- This could be changed again if automake 1.7 was being used not 1.6 !!
* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
- add patch 03 for intltool-merge and dep. on intltool
* Fri Dec 29 2003 - <niall.power@sun.com>
- comment out libtool, aclocal etc. which
is causing build failure
* Fri Dec 29 2003 - <glynn.foster@sun.com>
- Bump to 2.5.3
* Wed Dec 17 2003 - <glynn.foster@sun.com>
- Bump to 2.5.2
* Fri Oct 31 2003 - <glynn.foster@sun.com>
- Remove the Sun Supported keyword from the desktop
files. We're removing the Extras menu.
* Wed Oct 22 2003 - <glynn.foster@sun.com>
- Add blackjack into the build
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to GNOME 2.4.0 version
- Removed freecell entries
- Moved gnome-games-03-menu-entry.diff patch to
gnome-games-01-menu-entry.diff
- Dropped gnome-games-04-glines-preferences.diff patch.
* Thu Aug 14 2003 - <laca@sun.com>
- remove *.so, *.a, *.la
* Wed Aug 06 2003 - <glynn.foster@sun.com>
- fix glines preference dialog
* Thu Jul 17 2003 - <glynn.foster@sun.com>
- remove more xbill stuff
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Tue Jul 08 2003 - glynn.foster@sun.com
- Add menu icon for freecell, and add aclocal, automake checks
* Tue May 13 2003 - ghee.teo@Sun.COM
- Created new spec file for gnome-games