gnome-games.spec revision 11136
18861N/A#
18861N/A# spec file for package gnome-games
18861N/A#
18861N/A# Copyright (c) 2005 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
20226N/A# package are under the same license as the package itself.
18861N/A#
18861N/A# Owner: gman
18861N/A#
18861N/AName: gnome-games
18861N/ALicense: GPL
18861N/AGroup: Amusements/Games
18861N/AVersion: 2.19.91.1
18861N/ARelease: 1
18861N/ADistribution: Java Desktop System
18861N/AVendor: Sun Microsystems, Inc.
18861N/ASummary: GNOME games
18861N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.19/%{name}-%{version}.tar.bz2
18861N/AURL: http://www.gnome.org
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ADocdir: %{_defaultdocdir}/%{name}
18861N/AAutoreqprov: on
18861N/APrereq: GConf
18861N/A
18861N/A%define python_version 2.4
18861N/A%define libgnomeui_version 2.2.0
18861N/A%define scrollkeeper_version 0.3.11
18861N/A
18861N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
19094N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
18861N/ABuildRequires: intltool
20238N/ARequires: libgnomeui >= %{libgnomeui_version}
20238N/A
20238N/A%description
20238N/AThe gnome-games package includes some small games that come with the
18861N/AGNOME desktop environment but can be used under any desktop.
18861N/AThe games are mostly puzzle or solitaire games.
18861N/A
20238N/A%prep
18861N/A%setup -q
18861N/A
19142N/A%build
19142N/A%ifos linux
19142N/Aif [ -x /usr/bin/getconf ]; then
19142N/A CPUS=`getconf _NPROCESSORS_ONLN`
19142N/Afi
19142N/A%else
19142N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20226N/A%endif
20238N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20238N/A CPUS=1
20238N/Afi
18993N/A
18993N/Aexport install_user=$LOGNAME
20254N/Aexport install_group=`groups | awk '{print $1}'`
18993N/A
19142N/Aaclocal $ACLOCAL_FLAGS -I m4
18861N/Aautomake -a -c -f
20259N/Aautoconf
20259N/A./configure --prefix=%{_prefix} \
20225N/A --sysconfdir=%{_sysconfdir} \
20259N/A --bindir=%{_bindir} \
20226N/A --libdir=%{_libdir} \
20226N/A --includedir=%{_includedir} \
20226N/A --libexecdir=%{_libexecdir} \
20225N/A --with-scores-user=$install_user \
20100N/A --with-scores-group=$install_group \
20100N/A --enable-omitgames=aisleriot
20100N/A
20100N/Amake -j $CPUS \
20100N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
20100N/A
20100N/A%install
20100N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
18861N/A%makeinstall localstatedir=%{_localstatedir}/lib \
18861N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
18861N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
18861N/A
18861N/A## things we just don't want in the package
18861N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
18861N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
18861N/A
18861N/A## install desktop files
18861N/A
18861N/A%find_lang %{name}
18861N/A
18861N/A#Copy zh_HK from zh_TW
18861N/A#Fixes bug 4930405
18861N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
18861N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
18861N/A
18861N/A%post
19896N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
18861N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
18861N/Afor S in $SCHEMAS; do
18861N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
18861N/Adone
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
18861N/A
18861N/A%files -f %{name}.lang
18861N/A%defattr(-, root, root)
18861N/A%doc AUTHORS COPYING ChangeLog
18861N/A
18861N/A# these are not setgid games
18861N/A%{_bindir}/games-server.py
18861N/A%{_bindir}/gnect
18861N/A%{_bindir}/blackjack
18861N/A
18861N/A%{_localstatedir}/lib
20165N/A
20165N/A# these are setgid games
20165N/A%attr(2551, root, games) %{_bindir}/gnomine
20165N/A%attr(2551, root, games) %{_bindir}/same-gnome
20165N/A%attr(2551, root, games) %{_bindir}/mahjongg
20165N/A%attr(2551, root, games) %{_bindir}/gtali
20165N/A%attr(2551, root, games) %{_bindir}/gnobots2
20165N/A%attr(2551, root, games) %{_bindir}/gataxx
18861N/A%attr(2551, root, games) %{_bindir}/gnotravex
18861N/A%attr(2551, root, games) %{_bindir}/gnotski
18861N/A%attr(2551, root, games) %{_bindir}/gnibbles
18861N/A%attr(2551, root, games) %{_bindir}/glines
18861N/A%attr(2551, root, games) %{_bindir}/iagno
18861N/A
18861N/A%{_datadir}/applications
18861N/A%{_datadir}/blackjack
18861N/A%{_datadir}/gnect
18861N/A%{_datadir}/gnibbles
18861N/A%{_datadir}/gnobots2
18861N/A%{_datadir}/gnome
18861N/A%{_datadir}/gnome-games
18861N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
18861N/A%{_datadir}/omf
18861N/A%{_datadir}/pixmaps
20165N/A%{_datadir}/sounds
20165N/A%{_sysconfdir}/gconf/schemas/*
20165N/A%config %{_sysconfdir}/sound/events/*
20165N/A
20165N/A%changelog
20165N/A* Wed Aug 29 2007 - damien.carbery@sun.com
20165N/A- Bump to 2.19.91.1.
20165N/A* Tue Aug 28 2007 - damien.carbery@sun.com
20165N/A- Bump to 2.19.91. Remove upstream patch, gnome-menus-05-iconv-solaris.
20165N/A* Thu Aug 16 2007 - damien.carbery@sun.com
20165N/A- Add patch gnome-menus-05-iconv-solaris to fix #467309. Modify
20165N/A intltool-merge.in to allow use of non-GNU iconv.
20165N/A* Wed Aug 15 2007 - damien.carbery@sun.com
20165N/A- Bump to 2.19.90.1.
20165N/A* Wed Aug 15 2007 - damien.carbery@sun.com
20165N/A- Bump to 2.19.90b. Remove upstream patch, 01-build-gnometris.
20165N/A* Mon Jul 30 2007 - damien.carbery@sun.com
20165N/A- Bump to 2.19.6. Remove upstream patches, 01-strrchr and 03-ggz-signed-char.
20165N/A Renumber remainder.
20165N/A* Tue Jun 19 2007 - damien.carbery@sun.com
20165N/A- Bump to 2.19.4. Remove upstream patches, 01-named-struct and 03-signed-char.
20165N/A* Mon Jun 11 2007 - damien.carbery@sun.com
20165N/A- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
20165N/A bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
18861N/A file (modified in patch3).
18861N/A* Fri Jun 08 2007 - damien.carbery@sun.com
18861N/A- Add patch, 03-signed-char, for #445556.
20225N/A* Wed Jun 06 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.19.3. Add patches to fix some build errors.
20225N/A* Fri May 18 2007 - matt.keenan@sun.com
20225N/A- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
20225N/A* Wed May 16 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.19.2.
20225N/A* Wed May 09 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.19.1.
20225N/A* Fri May 04 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.18.1.1.
20225N/A* Thu Apr 12 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.18.1.
20225N/A* Thu Apr 05 2007 - matt.keenan@sun.com
20225N/A- Remove glchess.desktop, until glchess is made functional on Solaris
20225N/A- Bugzilla : 426538, bugster : 6537569
20225N/A* Wed Mar 21 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.18.0.1.
20225N/A* Tue Mar 13 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.18.0.
20225N/A* Mon Mar 05 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
20225N/A* Thu Feb 15 2007 - damien.carbery@sun.com
20225N/A- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
20225N/A Specify build user/group so that chown calls don't fail; disable building
20225N/A of aisleriot game (removing code from SUNWgnome-games.spec).
20225N/A* Tue Feb 13 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.17.91.
18861N/A* Wed Jan 24 2007 - damien.carbery@sun.com
18861N/A- Bump to 2.17.90.1.
18861N/A* Mon Jan 22 2007 - damien.carbery@sun.com
18861N/A- Bump to 2.17.90.
20225N/A* Mon Jan 08 2007 - damien.carbery@sun.com
20225N/A- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
20225N/A* Wed Dec 20 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
20225N/A* Tue Dec 19 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.17.4.
20225N/A* Thu Dec 07 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
20225N/A Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
20225N/A Install python libs to vendor-packages dir and remove *.pyo files.
20225N/A* Fri Nov 24 2006 - damien.carbery@sun.com
20225N/A- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
20225N/A* Wed Nov 22 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.17.1.
20225N/A* Thu Nov 09 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.16.1.1.
20225N/A* Tue Oct 03 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.16.1.
20225N/A* Tue Sep 05 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.16.0.
20225N/A* Tue Aug 22 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.15.92.
20225N/A* Tue Aug 08 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.15.6.
20225N/A* Mon Jul 24 2006 - damien.carbery@sun.com
18861N/A- Bump to 2.15.5.
18861N/A* Web Jul 21 2006 - dermot.mccluskey@sun.com
18861N/A- Bump to 2.15.4.
20225N/A* Mon Jun 26 2006 - laca@sun.com
20225N/A- remove patch menu-entry.diff since gnome-games is moving back to /usr
20225N/A* Fri Jun 23 2006 - brian.cameron@sun.com
20225N/A- Bump to 2.14.2.
20225N/A* Fri Apr 10 2006 - damien.carbery@sun.com
20259N/A- Bump to 2.14.
18861N/A* Mon Mar 13 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.14.
20225N/A* Thu Feb 23 2006 - damien.carbery@sun.com
20225N/A- Bump to 2.13.8.
20238N/A* Mon Feb 13 2006 - damien.carbery@sun.com
20238N/A- Bump to 2.13.7.
20238N/A* Sat Jan 21 2006 - damien.carbery@sun.com
20238N/A- Remove upstream patch, 02-illegal-cast.
20238N/A* Tue Jan 17 2006 - damien.carbery@sun.com
20238N/A- Bump to 2.13.5
20238N/A* Sun Jan 15 2006 - damien.carbery@sun.com
20238N/A- Bump to 2.13.4.
20238N/A* Sat Jan 07 2006 - damien.carbery@sun.com
20238N/A- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
20238N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
20238N/A- Bump to 2.13.3
20225N/A* Fri Dec 02 2005 - srirama.sharma@wipro.com
20225N/A- Added gnome-games-01-sfw-path.diff to use the absolute path of the
20225N/A executable in the .desktop file as usr/sfw/bin should not be
20238N/A included in $PATH.
20238N/A Fixes bug #6345489.
20238N/A* Tue Nov 29 2005 - laca.com
20238N/A- remove javahelp stuff
20238N/A* Tue Nov 29 2005 - damien.carbery@sun.com
20238N/A- Bump to 2.12.2.
20225N/A* Wed Oct 12 2005 - damien.carbery@sun.com
20238N/A- Remove patch as offending struct is no longer empty.
20238N/A* Tue Oct 11 2005 - damien.carbery@sun.com
20238N/A- Bump to 2.12.1
20238N/A* Sat Sep 17 2005 - glynn.foster@sun.com
20238N/A- Bump to 2.12.0
20238N/A* Mon Sep 05 2005 - damien.carbery@sun.com
20238N/A- Bump to 2.11.5.
20238N/A* Fri Sep 02 2005 - damien.carbery@sun.com
20238N/A- Add patch to fix zero sized struct Solaris build error.
20238N/A* Wed Aug 24 2005 - damien.carbery@sun.com
20238N/A- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
20238N/A* Mon Aug 15 2005 - damien.carbery@sun.com
20238N/A- Bump to 2.11.4.
20238N/A* Fri May 20 2005 - glynn.foster@sun.com
20238N/A- Bump to 2.10.1
20238N/A* Wed May 11 2005 - ciaran.mcdermott@sun.com
20238N/A- added gnome-games-05-g11n-desktop-fix.diff
20238N/A- to fix CR 6266891
20238N/A* Wed Apr 27 2005 - kieran.colfer@sun.com
20238N/A- added gnome-games-04-po-install-fixes.diff for CR 6243601
20238N/A* Fri Nov 12 2004 - laca@sun.com
20238N/A- added --libdir and --bindir to configure opts so they can be redirected on
20238N/A Solaris
20238N/A* Mon Sep 20 2004 - dermot.mccluskey@sun.com
20238N/A- removed sol from files
20238N/A* Thu Sep 04 2004 - laslzo.kovacs@sun.com
20238N/A- packaged sol
20238N/A* Thu Aug 26 2004 - damien.carbery@sun.com
20238N/A- Put scores files in %{_localstatedir}/lib.
20238N/A* Wed Aug 25 2004 - damien.carbery@sun.com
20238N/A- Add unpackaged files to %files.
20238N/A* Mon Aug 23 2004 - niall.power@sun.com
20238N/A- remove auto*-jds tool dependencies
20238N/A* Thu Jul 08 2004 - damien.donlon@sun.com
20238N/A- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
20238N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
20238N/A- added "-j $CPUS" to make to speed up builds
20238N/A* Tue Jun 1 2004 - glynn.foster@sun.com
20238N/A- Fix up schema install
20238N/A* Wed May 12 2004 - damien.donlon@sun.com
20238N/A- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
20238N/A* Fri May 07 2004 - matt.keenan@sun.com
20238N/A- Bump to 2.6.1
20238N/A* Wed Apr 21 2004 - laca@sun.com
20238N/A- disable javahelp conversion for stuff not built on Solaris
20238N/A* Sun Apr 18 2004 - laca@sun.com
20225N/A- enable javahelp conversion on Solaris
20238N/A* Fri Apr 02 2004 - brian.cameron@sun.com
20238N/A- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
20238N/A configure line.
20238N/A* Thu Apr 01 2004 - matt.keenan@sun.com
20238N/A- javahelp conversion
20238N/A* Mon Mar 29 2004 - damien.donlon@sun.com
20238N/A- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
20238N/A* Wed Mar 24 2004 - glynn.foster@sun.com
20238N/A- Use JDS autotools
20238N/A* Tue Mar 23 2004 - glynn.foster@sun.com
20238N/A- Bump to 2.6.0. Remove 2 potfile patches and
20238N/A replace with a single one.
20225N/A* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
20225N/A- added gnome-games-03-g11n-potfiles.diff
20225N/A* Fri Feb 06 2004 - <matt.keenan@sun.com>
20225N/A- Bump up 2.5.5, remove intltool-merge patch
18861N/A- re-engineered patch-01, as automake etc is commented out.
18861N/A- This could be changed again if automake 1.7 was being used not 1.6 !!
18861N/A* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
18861N/A- add patch 03 for intltool-merge and dep. on intltool
18861N/A* Fri Dec 29 2003 - <niall.power@sun.com>
18861N/A- comment out libtool, aclocal etc. which
18861N/A is causing build failure
18861N/A* Fri Dec 29 2003 - <glynn.foster@sun.com>
18861N/A- Bump to 2.5.3
20259N/A* Wed Dec 17 2003 - <glynn.foster@sun.com>
20238N/A- Bump to 2.5.2
20238N/A* Fri Oct 31 2003 - <glynn.foster@sun.com>
20238N/A- Remove the Sun Supported keyword from the desktop
18861N/A files. We're removing the Extras menu.
20259N/A* Wed Oct 22 2003 - <glynn.foster@sun.com>
20259N/A- Add blackjack into the build
20238N/A* Tue Oct 21 2003 - <michael.twomey@sun.com>
20238N/A- Updated to GNOME 2.4.0 version
20238N/A- Removed freecell entries
20238N/A- Moved gnome-games-03-menu-entry.diff patch to
20238N/A gnome-games-01-menu-entry.diff
20238N/A- Dropped gnome-games-04-glines-preferences.diff patch.
20238N/A* Thu Aug 14 2003 - <laca@sun.com>
20225N/A- remove *.so, *.a, *.la
20225N/A* Wed Aug 06 2003 - <glynn.foster@sun.com>
20165N/A- fix glines preference dialog
20165N/A* Thu Jul 17 2003 - <glynn.foster@sun.com>
20165N/A- remove more xbill stuff
19094N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
19094N/A- add in sun po files
18861N/A* Tue Jul 08 2003 - glynn.foster@sun.com
18861N/A- Add menu icon for freecell, and add aclocal, automake checks
18861N/A* Tue May 13 2003 - ghee.teo@Sun.COM
18861N/A- Created new spec file for gnome-games
18861N/A
18861N/A