gnome-games.spec revision 11071
18345N/A#
18345N/A# spec file for package gnome-games
18345N/A#
18345N/A# Copyright (c) 2005 Sun Microsystems, Inc.
18345N/A# This file and all modifications and additions to the pristine
18345N/A# package are under the same license as the package itself.
18345N/A#
18345N/A# Owner: gman
18345N/A#
18632N/AName: gnome-games
18345N/ALicense: GPL
18345N/AGroup: Amusements/Games
18345N/AVersion: 2.19.90.1
18374N/ARelease: 1
18345N/ADistribution: Java Desktop System
18345N/AVendor: Sun Microsystems, Inc.
18345N/ASummary: GNOME games
18345N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.19/%{name}-%{version}.tar.bz2
18644N/AURL: http://www.gnome.org
18345N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18345N/ADocdir: %{_defaultdocdir}/%{name}
18345N/AAutoreqprov: on
18345N/APrereq: GConf
18345N/A
18345N/A%define python_version 2.4
18345N/A%define libgnomeui_version 2.2.0
18345N/A%define scrollkeeper_version 0.3.11
18345N/A
18345N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
18545N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
18545N/ABuildRequires: intltool
18545N/ARequires: libgnomeui >= %{libgnomeui_version}
18345N/A
18345N/A%description
18345N/AThe gnome-games package includes some small games that come with the
18345N/AGNOME desktop environment but can be used under any desktop.
18345N/AThe games are mostly puzzle or solitaire games.
18345N/A
18345N/A%prep
18345N/A%setup -q
18345N/A
18345N/A%build
18345N/A%ifos linux
18345N/Aif [ -x /usr/bin/getconf ]; then
18345N/A CPUS=`getconf _NPROCESSORS_ONLN`
18345N/Afi
18345N/A%else
18345N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18345N/A%endif
18345N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18345N/A CPUS=1
18345N/Afi
18345N/A
18345N/Aexport install_user=$LOGNAME
18345N/Aexport install_group=`groups | awk '{print $1}'`
18345N/A
18545N/Aaclocal $ACLOCAL_FLAGS -I m4
18345N/Aautomake -a -c -f
18345N/Aautoconf
18345N/A./configure --prefix=%{_prefix} \
18345N/A --sysconfdir=%{_sysconfdir} \
18345N/A --bindir=%{_bindir} \
18345N/A --libdir=%{_libdir} \
18345N/A --includedir=%{_includedir} \
18345N/A --libexecdir=%{_libexecdir} \
18345N/A --with-scores-user=$install_user \
18345N/A --with-scores-group=$install_group \
18345N/A --enable-omitgames=aisleriot
18345N/A
18345N/Amake -j $CPUS \
18345N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
18345N/A
18345N/A%install
18345N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
18345N/A%makeinstall localstatedir=%{_localstatedir}/lib \
18345N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
18345N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
18345N/A
18345N/A## things we just don't want in the package
18345N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
18345N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
18345N/A
18345N/A## install desktop files
18345N/A
18345N/A%find_lang %{name}
18345N/A
18345N/A#Copy zh_HK from zh_TW
18345N/A#Fixes bug 4930405
18345N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
18345N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
18345N/A
18345N/A%post
18345N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
18345N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
18345N/Afor S in $SCHEMAS; do
18345N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
18345N/Adone
18345N/A
18345N/A%clean
18345N/Arm -rf $RPM_BUILD_ROOT
18345N/A
18345N/A%files -f %{name}.lang
18345N/A%defattr(-, root, root)
18345N/A%doc AUTHORS COPYING ChangeLog
18345N/A
18345N/A# these are not setgid games
18345N/A%{_bindir}/games-server.py
18345N/A%{_bindir}/gnect
18345N/A%{_bindir}/blackjack
18345N/A
18345N/A%{_localstatedir}/lib
18345N/A
18345N/A# these are setgid games
18345N/A%attr(2551, root, games) %{_bindir}/gnomine
18345N/A%attr(2551, root, games) %{_bindir}/same-gnome
18345N/A%attr(2551, root, games) %{_bindir}/mahjongg
18345N/A%attr(2551, root, games) %{_bindir}/gtali
18345N/A%attr(2551, root, games) %{_bindir}/gnobots2
18345N/A%attr(2551, root, games) %{_bindir}/gataxx
18345N/A%attr(2551, root, games) %{_bindir}/gnotravex
18345N/A%attr(2551, root, games) %{_bindir}/gnotski
18345N/A%attr(2551, root, games) %{_bindir}/gnibbles
18345N/A%attr(2551, root, games) %{_bindir}/glines
18345N/A%attr(2551, root, games) %{_bindir}/iagno
18345N/A
18345N/A%{_datadir}/applications
18345N/A%{_datadir}/blackjack
18545N/A%{_datadir}/gnect
18545N/A%{_datadir}/gnibbles
18374N/A%{_datadir}/gnobots2
18374N/A%{_datadir}/gnome
18345N/A%{_datadir}/gnome-games
18345N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
%{_datadir}/omf
%{_datadir}/pixmaps
%{_datadir}/sounds
%{_sysconfdir}/gconf/schemas/*
%config %{_sysconfdir}/sound/events/*
%changelog
* Wed Aug 15 2007 - damien.carbery@sun.com
- Bump to 2.19.90.1.
* Wed Aug 15 2007 - damien.carbery@sun.com
- Bump to 2.19.90b. Remove upstream patch, 01-build-gnometris.
* Mon Jul 30 2007 - damien.carbery@sun.com
- Bump to 2.19.6. Remove upstream patches, 01-strrchr and 03-ggz-signed-char.
Renumber remainder.
* Tue Jun 19 2007 - damien.carbery@sun.com
- Bump to 2.19.4. Remove upstream patches, 01-named-struct and 03-signed-char.
* Mon Jun 11 2007 - damien.carbery@sun.com
- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
file (modified in patch3).
* Fri Jun 08 2007 - damien.carbery@sun.com
- Add patch, 03-signed-char, for #445556.
* Wed Jun 06 2007 - damien.carbery@sun.com
- Bump to 2.19.3. Add patches to fix some build errors.
* Fri May 18 2007 - matt.keenan@sun.com
- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
* Wed May 16 2007 - damien.carbery@sun.com
- Bump to 2.19.2.
* Wed May 09 2007 - damien.carbery@sun.com
- Bump to 2.19.1.
* Fri May 04 2007 - damien.carbery@sun.com
- Bump to 2.18.1.1.
* Thu Apr 12 2007 - damien.carbery@sun.com
- Bump to 2.18.1.
* Thu Apr 05 2007 - matt.keenan@sun.com
- Remove glchess.desktop, until glchess is made functional on Solaris
- Bugzilla : 426538, bugster : 6537569
* Wed Mar 21 2007 - damien.carbery@sun.com
- Bump to 2.18.0.1.
* Tue Mar 13 2007 - damien.carbery@sun.com
- Bump to 2.18.0.
* Mon Mar 05 2007 - damien.carbery@sun.com
- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
* Thu Feb 15 2007 - damien.carbery@sun.com
- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
Specify build user/group so that chown calls don't fail; disable building
of aisleriot game (removing code from SUNWgnome-games.spec).
* Tue Feb 13 2007 - damien.carbery@sun.com
- Bump to 2.17.91.
* Wed Jan 24 2007 - damien.carbery@sun.com
- Bump to 2.17.90.1.
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 2.17.90.
* Mon Jan 08 2007 - damien.carbery@sun.com
- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
* Wed Dec 20 2006 - damien.carbery@sun.com
- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
* Tue Dec 19 2006 - damien.carbery@sun.com
- Bump to 2.17.4.
* Thu Dec 07 2006 - damien.carbery@sun.com
- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
Install python libs to vendor-packages dir and remove *.pyo files.
* Fri Nov 24 2006 - damien.carbery@sun.com
- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
* Wed Nov 22 2006 - damien.carbery@sun.com
- Bump to 2.17.1.
* Thu Nov 09 2006 - damien.carbery@sun.com
- Bump to 2.16.1.1.
* Tue Oct 03 2006 - damien.carbery@sun.com
- Bump to 2.16.1.
* Tue Sep 05 2006 - damien.carbery@sun.com
- Bump to 2.16.0.
* Tue Aug 22 2006 - damien.carbery@sun.com
- Bump to 2.15.92.
* Tue Aug 08 2006 - damien.carbery@sun.com
- Bump to 2.15.6.
* Mon Jul 24 2006 - damien.carbery@sun.com
- Bump to 2.15.5.
* Web Jul 21 2006 - dermot.mccluskey@sun.com
- Bump to 2.15.4.
* Mon Jun 26 2006 - laca@sun.com
- remove patch menu-entry.diff since gnome-games is moving back to /usr
* Fri Jun 23 2006 - brian.cameron@sun.com
- Bump to 2.14.2.
* Fri Apr 10 2006 - damien.carbery@sun.com
- Bump to 2.14.
* Mon Mar 13 2006 - damien.carbery@sun.com
- Bump to 2.14.
* Thu Feb 23 2006 - damien.carbery@sun.com
- Bump to 2.13.8.
* Mon Feb 13 2006 - damien.carbery@sun.com
- Bump to 2.13.7.
* Sat Jan 21 2006 - damien.carbery@sun.com
- Remove upstream patch, 02-illegal-cast.
* Tue Jan 17 2006 - damien.carbery@sun.com
- Bump to 2.13.5
* Sun Jan 15 2006 - damien.carbery@sun.com
- Bump to 2.13.4.
* Sat Jan 07 2006 - damien.carbery@sun.com
- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 2.13.3
* Fri Dec 02 2005 - srirama.sharma@wipro.com
- Added gnome-games-01-sfw-path.diff to use the absolute path of the
executable in the .desktop file as usr/sfw/bin should not be
included in $PATH.
Fixes bug #6345489.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 2.12.2.
* Wed Oct 12 2005 - damien.carbery@sun.com
- Remove patch as offending struct is no longer empty.
* Tue Oct 11 2005 - damien.carbery@sun.com
- Bump to 2.12.1
* Sat Sep 17 2005 - glynn.foster@sun.com
- Bump to 2.12.0
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.11.5.
* Fri Sep 02 2005 - damien.carbery@sun.com
- Add patch to fix zero sized struct Solaris build error.
* Wed Aug 24 2005 - damien.carbery@sun.com
- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.11.4.
* Fri May 20 2005 - glynn.foster@sun.com
- Bump to 2.10.1
* Wed May 11 2005 - ciaran.mcdermott@sun.com
- added gnome-games-05-g11n-desktop-fix.diff
- to fix CR 6266891
* Wed Apr 27 2005 - kieran.colfer@sun.com
- added gnome-games-04-po-install-fixes.diff for CR 6243601
* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected on
Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- removed sol from files
* Thu Sep 04 2004 - laslzo.kovacs@sun.com
- packaged sol
* Thu Aug 26 2004 - damien.carbery@sun.com
- Put scores files in %{_localstatedir}/lib.
* Wed Aug 25 2004 - damien.carbery@sun.com
- Add unpackaged files to %files.
* Mon Aug 23 2004 - niall.power@sun.com
- remove auto*-jds tool dependencies
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Tue Jun 1 2004 - glynn.foster@sun.com
- Fix up schema install
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - matt.keenan@sun.com
- Bump to 2.6.1
* Wed Apr 21 2004 - laca@sun.com
- disable javahelp conversion for stuff not built on Solaris
* Sun Apr 18 2004 - laca@sun.com
- enable javahelp conversion on Solaris
* Fri Apr 02 2004 - brian.cameron@sun.com
- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
configure line.
* Thu Apr 01 2004 - matt.keenan@sun.com
- javahelp conversion
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - glynn.foster@sun.com
- Use JDS autotools
* Tue Mar 23 2004 - glynn.foster@sun.com
- Bump to 2.6.0. Remove 2 potfile patches and
replace with a single one.
* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
- added gnome-games-03-g11n-potfiles.diff
* Fri Feb 06 2004 - <matt.keenan@sun.com>
- Bump up 2.5.5, remove intltool-merge patch
- re-engineered patch-01, as automake etc is commented out.
- This could be changed again if automake 1.7 was being used not 1.6 !!
* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
- add patch 03 for intltool-merge and dep. on intltool
* Fri Dec 29 2003 - <niall.power@sun.com>
- comment out libtool, aclocal etc. which
is causing build failure
* Fri Dec 29 2003 - <glynn.foster@sun.com>
- Bump to 2.5.3
* Wed Dec 17 2003 - <glynn.foster@sun.com>
- Bump to 2.5.2
* Fri Oct 31 2003 - <glynn.foster@sun.com>
- Remove the Sun Supported keyword from the desktop
files. We're removing the Extras menu.
* Wed Oct 22 2003 - <glynn.foster@sun.com>
- Add blackjack into the build
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to GNOME 2.4.0 version
- Removed freecell entries
- Moved gnome-games-03-menu-entry.diff patch to
gnome-games-01-menu-entry.diff
- Dropped gnome-games-04-glines-preferences.diff patch.
* Thu Aug 14 2003 - <laca@sun.com>
- remove *.so, *.a, *.la
* Wed Aug 06 2003 - <glynn.foster@sun.com>
- fix glines preference dialog
* Thu Jul 17 2003 - <glynn.foster@sun.com>
- remove more xbill stuff
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Tue Jul 08 2003 - glynn.foster@sun.com
- Add menu icon for freecell, and add aclocal, automake checks
* Tue May 13 2003 - ghee.teo@Sun.COM
- Created new spec file for gnome-games