gnome-games.spec revision 10778
12258N/A#
12258N/A# spec file for package gnome-games
12258N/A#
12412N/A# Copyright (c) 2005 Sun Microsystems, Inc.
12258N/A# This file and all modifications and additions to the pristine
12258N/A# package are under the same license as the package itself.
12258N/A#
15894N/A# Owner: gman
12258N/A#
12258N/AName: gnome-games
15153N/ALicense: GPL
12258N/AGroup: Amusements/Games
15293N/AVersion: 2.19.3
12258N/ARelease: 1
16214N/ADistribution: Java Desktop System
12258N/AVendor: Sun Microsystems, Inc.
12258N/ASummary: GNOME games
12258N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.19/%{name}-%{version}.tar.bz2
12258N/A#owner:dcarbery date:2007-06-06 type:bug bugzilla:444802 state:upstream
12258N/APatch1: gnome-games-01-named-struct.diff
16214N/A#owner:dcarbery date:2007-06-06 type:bug bugzilla:444806
15153N/APatch2: gnome-games-02-strrchr.diff
15153N/A#owner:dcarbery date:2007-06-08 type:bug bugzilla:445556
12258N/APatch3: gnome-games-03-signed-char.diff
16130N/A#owner:dcarbery date:2007-06-11 type:bug bugzilla:446290
12517N/APatch4: gnome-games-04-build-gnometris.diff
16130N/AURL: http://www.gnome.org
15234N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
16130N/ADocdir: %{_defaultdocdir}/%{name}
14295N/AAutoreqprov: on
16130N/APrereq: GConf
15260N/A
16130N/A%define python_version 2.4
16130N/A%define libgnomeui_version 2.2.0
16130N/A%define scrollkeeper_version 0.3.11
16130N/A
16130N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
12258N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
12258N/ABuildRequires: intltool
12258N/ARequires: libgnomeui >= %{libgnomeui_version}
12258N/A
12258N/A%description
12258N/AThe gnome-games package includes some small games that come with the
12258N/AGNOME desktop environment but can be used under any desktop.
12258N/AThe games are mostly puzzle or solitaire games.
12258N/A
12258N/A%prep
12258N/A%setup -q
12258N/A%patch1 -p1
12258N/A%patch2 -p1
12258N/A%patch3 -p1
12258N/A%patch4 -p1
12258N/A
12258N/A%build
12258N/A%ifos linux
12258N/Aif [ -x /usr/bin/getconf ]; then
12258N/A CPUS=`getconf _NPROCESSORS_ONLN`
12258N/Afi
12258N/A%else
12258N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12258N/A%endif
12258N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
12258N/A CPUS=1
12258N/Afi
12258N/A
12258N/Aexport install_user=$LOGNAME
12258N/Aexport install_group=`groups | awk '{print $1}'`
12258N/A
12258N/Aaclocal $ACLOCAL_FLAGS -I m4
12258N/Aautomake -a -c -f
12258N/Aautoconf
12258N/A./configure --prefix=%{_prefix} \
12258N/A --sysconfdir=%{_sysconfdir} \
12258N/A --bindir=%{_bindir} \
15523N/A --libdir=%{_libdir} \
15153N/A --includedir=%{_includedir} \
15153N/A --libexecdir=%{_libexecdir} \
15153N/A --with-scores-user=$install_user \
13875N/A --with-scores-group=$install_group \
16130N/A --enable-omitgames=aisleriot
16130N/A
12258N/Amake -j $CPUS \
13708N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
16130N/A
16130N/A%install
16130N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
16130N/A%makeinstall localstatedir=%{_localstatedir}/lib \
12258N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
12258N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
12258N/A
12258N/A## things we just don't want in the package
12258N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
12258N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
12258N/A
12258N/A## install desktop files
12258N/A
12258N/A%find_lang %{name}
12258N/A
12258N/A#Copy zh_HK from zh_TW
12258N/A#Fixes bug 4930405
12258N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
12773N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
12773N/A
12773N/A%post
12258N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
12258N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
12258N/Afor S in $SCHEMAS; do
12258N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
12258N/Adone
12258N/A
12258N/A%clean
12258N/Arm -rf $RPM_BUILD_ROOT
12258N/A
12258N/A%files -f %{name}.lang
16080N/A%defattr(-, root, root)
12258N/A%doc AUTHORS COPYING ChangeLog
12258N/A
12258N/A# these are not setgid games
12258N/A%{_bindir}/games-server.py
12258N/A%{_bindir}/gnect
16214N/A%{_bindir}/blackjack
12258N/A
12258N/A%{_localstatedir}/lib
12258N/A
12258N/A# these are setgid games
12258N/A%attr(2551, root, games) %{_bindir}/gnomine
12258N/A%attr(2551, root, games) %{_bindir}/same-gnome
12258N/A%attr(2551, root, games) %{_bindir}/mahjongg
12258N/A%attr(2551, root, games) %{_bindir}/gtali
12258N/A%attr(2551, root, games) %{_bindir}/gnobots2
12258N/A%attr(2551, root, games) %{_bindir}/gataxx
12258N/A%attr(2551, root, games) %{_bindir}/gnotravex
12258N/A%attr(2551, root, games) %{_bindir}/gnotski
12258N/A%attr(2551, root, games) %{_bindir}/gnibbles
12258N/A%attr(2551, root, games) %{_bindir}/glines
12258N/A%attr(2551, root, games) %{_bindir}/iagno
12258N/A
12258N/A%{_datadir}/applications
12258N/A%{_datadir}/blackjack
12258N/A%{_datadir}/gnect
12258N/A%{_datadir}/gnibbles
12258N/A%{_datadir}/gnobots2
12258N/A%{_datadir}/gnome
12258N/A%{_datadir}/gnome-games
12258N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
12258N/A%{_datadir}/omf
12258N/A%{_datadir}/pixmaps
16080N/A%{_datadir}/sounds
16080N/A%{_sysconfdir}/gconf/schemas/*
16080N/A%config %{_sysconfdir}/sound/events/*
12258N/A
12258N/A%changelog
12258N/A* Mon Jun 11 2007 - damien.carbery@sun.com
12258N/A- Add patch 04-build-gnometris to fix build error in gnometris game. Filed
12258N/A bugzilla #446290. Also add some autofoo calls to incorporate updates ggz.m4
12258N/A file (modified in patch3).
12258N/A* Fri Jun 08 2007 - damien.carbery@sun.com
12258N/A- Add patch, 03-signed-char, for #445556.
12258N/A* Wed Jun 06 2007 - damien.carbery@sun.com
12258N/A- Bump to 2.19.3. Add patches to fix some build errors.
12258N/A* Fri May 18 2007 - matt.keenan@sun.com
16080N/A- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
16080N/A* Wed May 16 2007 - damien.carbery@sun.com
16080N/A- Bump to 2.19.2.
16080N/A* Wed May 09 2007 - damien.carbery@sun.com
15856N/A- Bump to 2.19.1.
15856N/A* Fri May 04 2007 - damien.carbery@sun.com
15856N/A- Bump to 2.18.1.1.
15856N/A* Thu Apr 12 2007 - damien.carbery@sun.com
15523N/A- Bump to 2.18.1.
15523N/A* Thu Apr 05 2007 - matt.keenan@sun.com
15153N/A- Remove glchess.desktop, until glchess is made functional on Solaris
15153N/A- Bugzilla : 426538, bugster : 6537569
14295N/A* Wed Mar 21 2007 - damien.carbery@sun.com
14295N/A- Bump to 2.18.0.1.
13851N/A* Tue Mar 13 2007 - damien.carbery@sun.com
13851N/A- Bump to 2.18.0.
12517N/A* Mon Mar 05 2007 - damien.carbery@sun.com
12517N/A- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
12517N/A* Thu Feb 15 2007 - damien.carbery@sun.com
12474N/A- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
12474N/A Specify build user/group so that chown calls don't fail; disable building
12457N/A of aisleriot game (removing code from SUNWgnome-games.spec).
12457N/A* Tue Feb 13 2007 - damien.carbery@sun.com
12258N/A- Bump to 2.17.91.
12258N/A* Wed Jan 24 2007 - damien.carbery@sun.com
12258N/A- Bump to 2.17.90.1.
12258N/A* Mon Jan 22 2007 - damien.carbery@sun.com
12258N/A- Bump to 2.17.90.
12258N/A* Mon Jan 08 2007 - damien.carbery@sun.com
12258N/A- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
12258N/A* Wed Dec 20 2006 - damien.carbery@sun.com
12258N/A- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
12258N/A* Tue Dec 19 2006 - damien.carbery@sun.com
12258N/A- Bump to 2.17.4.
12258N/A* Thu Dec 07 2006 - damien.carbery@sun.com
12258N/A- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
12258N/A Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
12258N/A Install python libs to vendor-packages dir and remove *.pyo files.
12258N/A* Fri Nov 24 2006 - damien.carbery@sun.com
12258N/A- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
* Wed Nov 22 2006 - damien.carbery@sun.com
- Bump to 2.17.1.
* Thu Nov 09 2006 - damien.carbery@sun.com
- Bump to 2.16.1.1.
* Tue Oct 03 2006 - damien.carbery@sun.com
- Bump to 2.16.1.
* Tue Sep 05 2006 - damien.carbery@sun.com
- Bump to 2.16.0.
* Tue Aug 22 2006 - damien.carbery@sun.com
- Bump to 2.15.92.
* Tue Aug 08 2006 - damien.carbery@sun.com
- Bump to 2.15.6.
* Mon Jul 24 2006 - damien.carbery@sun.com
- Bump to 2.15.5.
* Web Jul 21 2006 - dermot.mccluskey@sun.com
- Bump to 2.15.4.
* Mon Jun 26 2006 - laca@sun.com
- remove patch menu-entry.diff since gnome-games is moving back to /usr
* Fri Jun 23 2006 - brian.cameron@sun.com
- Bump to 2.14.2.
* Fri Apr 10 2006 - damien.carbery@sun.com
- Bump to 2.14.
* Mon Mar 13 2006 - damien.carbery@sun.com
- Bump to 2.14.
* Thu Feb 23 2006 - damien.carbery@sun.com
- Bump to 2.13.8.
* Mon Feb 13 2006 - damien.carbery@sun.com
- Bump to 2.13.7.
* Sat Jan 21 2006 - damien.carbery@sun.com
- Remove upstream patch, 02-illegal-cast.
* Tue Jan 17 2006 - damien.carbery@sun.com
- Bump to 2.13.5
* Sun Jan 15 2006 - damien.carbery@sun.com
- Bump to 2.13.4.
* Sat Jan 07 2006 - damien.carbery@sun.com
- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 2.13.3
* Fri Dec 02 2005 - srirama.sharma@wipro.com
- Added gnome-games-01-sfw-path.diff to use the absolute path of the
executable in the .desktop file as usr/sfw/bin should not be
included in $PATH.
Fixes bug #6345489.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 2.12.2.
* Wed Oct 12 2005 - damien.carbery@sun.com
- Remove patch as offending struct is no longer empty.
* Tue Oct 11 2005 - damien.carbery@sun.com
- Bump to 2.12.1
* Sat Sep 17 2005 - glynn.foster@sun.com
- Bump to 2.12.0
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.11.5.
* Fri Sep 02 2005 - damien.carbery@sun.com
- Add patch to fix zero sized struct Solaris build error.
* Wed Aug 24 2005 - damien.carbery@sun.com
- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.11.4.
* Fri May 20 2005 - glynn.foster@sun.com
- Bump to 2.10.1
* Wed May 11 2005 - ciaran.mcdermott@sun.com
- added gnome-games-05-g11n-desktop-fix.diff
- to fix CR 6266891
* Wed Apr 27 2005 - kieran.colfer@sun.com
- added gnome-games-04-po-install-fixes.diff for CR 6243601
* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected on
Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- removed sol from files
* Thu Sep 04 2004 - laslzo.kovacs@sun.com
- packaged sol
* Thu Aug 26 2004 - damien.carbery@sun.com
- Put scores files in %{_localstatedir}/lib.
* Wed Aug 25 2004 - damien.carbery@sun.com
- Add unpackaged files to %files.
* Mon Aug 23 2004 - niall.power@sun.com
- remove auto*-jds tool dependencies
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Tue Jun 1 2004 - glynn.foster@sun.com
- Fix up schema install
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
* Fri May 07 2004 - matt.keenan@sun.com
- Bump to 2.6.1
* Wed Apr 21 2004 - laca@sun.com
- disable javahelp conversion for stuff not built on Solaris
* Sun Apr 18 2004 - laca@sun.com
- enable javahelp conversion on Solaris
* Fri Apr 02 2004 - brian.cameron@sun.com
- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
configure line.
* Thu Apr 01 2004 - matt.keenan@sun.com
- javahelp conversion
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - glynn.foster@sun.com
- Use JDS autotools
* Tue Mar 23 2004 - glynn.foster@sun.com
- Bump to 2.6.0. Remove 2 potfile patches and
replace with a single one.
* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
- added gnome-games-03-g11n-potfiles.diff
* Fri Feb 06 2004 - <matt.keenan@sun.com>
- Bump up 2.5.5, remove intltool-merge patch
- re-engineered patch-01, as automake etc is commented out.
- This could be changed again if automake 1.7 was being used not 1.6 !!
* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
- add patch 03 for intltool-merge and dep. on intltool
* Fri Dec 29 2003 - <niall.power@sun.com>
- comment out libtool, aclocal etc. which
is causing build failure
* Fri Dec 29 2003 - <glynn.foster@sun.com>
- Bump to 2.5.3
* Wed Dec 17 2003 - <glynn.foster@sun.com>
- Bump to 2.5.2
* Fri Oct 31 2003 - <glynn.foster@sun.com>
- Remove the Sun Supported keyword from the desktop
files. We're removing the Extras menu.
* Wed Oct 22 2003 - <glynn.foster@sun.com>
- Add blackjack into the build
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to GNOME 2.4.0 version
- Removed freecell entries
- Moved gnome-games-03-menu-entry.diff patch to
gnome-games-01-menu-entry.diff
- Dropped gnome-games-04-glines-preferences.diff patch.
* Thu Aug 14 2003 - <laca@sun.com>
- remove *.so, *.a, *.la
* Wed Aug 06 2003 - <glynn.foster@sun.com>
- fix glines preference dialog
* Thu Jul 17 2003 - <glynn.foster@sun.com>
- remove more xbill stuff
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Tue Jul 08 2003 - glynn.foster@sun.com
- Add menu icon for freecell, and add aclocal, automake checks
* Tue May 13 2003 - ghee.teo@Sun.COM
- Created new spec file for gnome-games