gnome-games.spec revision 10666
10139N/A#
10139N/A# spec file for package gnome-games
10139N/A#
12144N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: gman
10139N/A#
17178N/AName: gnome-games
18603N/ALicense: GPL
17178N/AGroup: Amusements/Games
10139N/AVersion: 2.19.2
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18236N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: GNOME games
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.19/%{name}-%{version}.tar.bz2
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17401N/ADocdir: %{_defaultdocdir}/%{name}
13577N/AAutoreqprov: on
13034N/APrereq: GConf
17889N/A
10139N/A%define python_version 2.4
10139N/A%define libgnomeui_version 2.2.0
10139N/A%define scrollkeeper_version 0.3.11
10139N/A
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
10139N/ABuildRequires: intltool
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/A
10139N/A%description
10139N/AThe gnome-games package includes some small games that come with the
10139N/AGNOME desktop environment but can be used under any desktop.
10139N/AThe games are mostly puzzle or solitaire games.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
13034N/Afi
17889N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport install_user=$LOGNAME
10139N/Aexport install_group=`groups | awk '{print $1}'`
10139N/A
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --bindir=%{_bindir} \
17651N/A --libdir=%{_libdir} \
10139N/A --includedir=%{_includedir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --with-scores-user=$install_user \
12268N/A --with-scores-group=$install_group \
12268N/A --enable-omitgames=aisleriot
12268N/A
12271N/Amake -j $CPUS \
13768N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
10778N/A
13768N/A%install
15162N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
16039N/A%makeinstall localstatedir=%{_localstatedir}/lib \
16039N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
16039N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
16039N/A
15162N/A## things we just don't want in the package
10139N/Arm -rf $RPM_BUILD_ROOT/var/lib/scrollkeeper
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm {} ';'
10139N/A
10139N/A## install desktop files
13360N/A
10139N/A%find_lang %{name}
10139N/A
10139N/A#Copy zh_HK from zh_TW
12649N/A#Fixes bug 4930405
11370N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
12150N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
12108N/A
12108N/A%post
12500N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
12500N/ASCHEMAS="blackjack.schemas gataxx.schemas glines.schemas gnect.schemas gnibbles.schemas gnobots2.schemas gnomine.schemas gnotravex.schemas gtali.schemas iagno.schemas mahjongg.schemas same-gnome.schemas"
15162N/Afor S in $SCHEMAS; do
16885N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
16946N/Adone
16946N/A
17227N/A%clean
17227N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files -f %{name}.lang
17651N/A%defattr(-, root, root)
10139N/A%doc AUTHORS COPYING ChangeLog
10139N/A
10139N/A# these are not setgid games
10139N/A%{_bindir}/games-server.py
17651N/A%{_bindir}/gnect
10139N/A%{_bindir}/blackjack
10139N/A
10139N/A%{_localstatedir}/lib
10139N/A
10424N/A# these are setgid games
10139N/A%attr(2551, root, games) %{_bindir}/gnomine
10139N/A%attr(2551, root, games) %{_bindir}/same-gnome
10139N/A%attr(2551, root, games) %{_bindir}/mahjongg
10139N/A%attr(2551, root, games) %{_bindir}/gtali
10139N/A%attr(2551, root, games) %{_bindir}/gnobots2
10139N/A%attr(2551, root, games) %{_bindir}/gataxx
10139N/A%attr(2551, root, games) %{_bindir}/gnotravex
10139N/A%attr(2551, root, games) %{_bindir}/gnotski
10139N/A%attr(2551, root, games) %{_bindir}/gnibbles
10139N/A%attr(2551, root, games) %{_bindir}/glines
10139N/A%attr(2551, root, games) %{_bindir}/iagno
10139N/A
10139N/A%{_datadir}/applications
10139N/A%{_datadir}/blackjack
10139N/A%{_datadir}/gnect
10139N/A%{_datadir}/gnibbles
10139N/A%{_datadir}/gnobots2
10139N/A%{_datadir}/gnome
10139N/A%{_datadir}/gnome-games
10139N/A%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/A%{_datadir}/omf
10139N/A%{_datadir}/pixmaps
10139N/A%{_datadir}/sounds
10139N/A%{_sysconfdir}/gconf/schemas/*
10139N/A%config %{_sysconfdir}/sound/events/*
10139N/A
10139N/A%changelog
10139N/A* Fri May 18 2007 - matt.keenan@sun.com
10139N/A- Add glchess.desktop back in bugzilla 426538 now fixed in 2.19.1.1
10139N/A* Wed May 16 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.2.
10139N/A* Wed May 09 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.1.
10139N/A* Fri May 04 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.1.
10139N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.
10139N/A* Thu Apr 05 2007 - matt.keenan@sun.com
10139N/A- Remove glchess.desktop, until glchess is made functional on Solaris
10139N/A- Bugzilla : 426538, bugster : 6537569
10139N/A* Wed Mar 21 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.1.
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.
10139N/A* Mon Mar 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.92. Removed upstream patch, 01-grep-no-q.
10139N/A* Thu Feb 15 2007 - damien.carbery@sun.com
10139N/A- Add patch, 01-grep-no-q.diff, to remove '-q' from grep calls. Fixes 408331.
10139N/A Specify build user/group so that chown calls don't fail; disable building
10139N/A of aisleriot game (removing code from SUNWgnome-games.spec).
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.91.
10139N/A* Wed Jan 24 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.90.1.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.90.
10139N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.5. Remove upstream patch 01-ggz-function.
10139N/A* Wed Dec 20 2006 - damien.carbery@sun.com
18236N/A- Bump to 2.17.4.1. Add patch 01-ggz-function to fix #363444.
18236N/A* Tue Dec 19 2006 - damien.carbery@sun.com
17889N/A- Bump to 2.17.4.
17889N/A* Thu Dec 07 2006 - damien.carbery@sun.com
17651N/A- Bump to 2.17.3. Remove upstream patches, 01-array-init and 02-ggz-function.
17651N/A Remove obsolete 'rm' calls in %install (those files/dirs no longer installed).
17570N/A Install python libs to vendor-packages dir and remove *.pyo files.
17570N/A* Fri Nov 24 2006 - damien.carbery@sun.com
17401N/A- Add patches 01-array-init to fix 363438 and 02-ggz-function to fix 362444.
17401N/A* Wed Nov 22 2006 - damien.carbery@sun.com
17315N/A- Bump to 2.17.1.
17315N/A* Thu Nov 09 2006 - damien.carbery@sun.com
17227N/A- Bump to 2.16.1.1.
17227N/A* Tue Oct 03 2006 - damien.carbery@sun.com
17020N/A- Bump to 2.16.1.
17020N/A* Tue Sep 05 2006 - damien.carbery@sun.com
16947N/A- Bump to 2.16.0.
16947N/A* Tue Aug 22 2006 - damien.carbery@sun.com
16885N/A- Bump to 2.15.92.
16885N/A* Tue Aug 08 2006 - damien.carbery@sun.com
16626N/A- Bump to 2.15.6.
16626N/A* Mon Jul 24 2006 - damien.carbery@sun.com
16379N/A- Bump to 2.15.5.
16626N/A* Web Jul 21 2006 - dermot.mccluskey@sun.com
16160N/A- Bump to 2.15.4.
16160N/A* Mon Jun 26 2006 - laca@sun.com
16149N/A- remove patch menu-entry.diff since gnome-games is moving back to /usr
16626N/A* Fri Jun 23 2006 - brian.cameron@sun.com
16039N/A- Bump to 2.14.2.
16039N/A* Fri Apr 10 2006 - damien.carbery@sun.com
15882N/A- Bump to 2.14.
16626N/A* Mon Mar 13 2006 - damien.carbery@sun.com
15882N/A- Bump to 2.14.
16626N/A* Thu Feb 23 2006 - damien.carbery@sun.com
15753N/A- Bump to 2.13.8.
15753N/A* Mon Feb 13 2006 - damien.carbery@sun.com
15745N/A- Bump to 2.13.7.
16626N/A* Sat Jan 21 2006 - damien.carbery@sun.com
15745N/A- Remove upstream patch, 02-illegal-cast.
15745N/A* Tue Jan 17 2006 - damien.carbery@sun.com
15630N/A- Bump to 2.13.5
15630N/A* Sun Jan 15 2006 - damien.carbery@sun.com
15566N/A- Bump to 2.13.4.
15566N/A* Sat Jan 07 2006 - damien.carbery@sun.com
15566N/A- Add patch, 02-illegal_cast, to fix compilation errors; bugzilla 326024.
15448N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
16626N/A- Bump to 2.13.3
15162N/A* Fri Dec 02 2005 - srirama.sharma@wipro.com
15162N/A- Added gnome-games-01-sfw-path.diff to use the absolute path of the
14555N/A executable in the .desktop file as usr/sfw/bin should not be
14555N/A included in $PATH.
14265N/A Fixes bug #6345489.
14555N/A* Tue Nov 29 2005 - laca.com
13936N/A- remove javahelp stuff
13936N/A* Tue Nov 29 2005 - damien.carbery@sun.com
13766N/A- Bump to 2.12.2.
13768N/A* Wed Oct 12 2005 - damien.carbery@sun.com
13610N/A- Remove patch as offending struct is no longer empty.
13610N/A* Tue Oct 11 2005 - damien.carbery@sun.com
13424N/A- Bump to 2.12.1
13424N/A* Sat Sep 17 2005 - glynn.foster@sun.com
13360N/A- Bump to 2.12.0
13360N/A* Mon Sep 05 2005 - damien.carbery@sun.com
13314N/A- Bump to 2.11.5.
13314N/A* Fri Sep 02 2005 - damien.carbery@sun.com
13264N/A- Add patch to fix zero sized struct Solaris build error.
13264N/A* Wed Aug 24 2005 - damien.carbery@sun.com
13114N/A- Add patch to remove blank line 1 from same-gnome.xml (javahelp had prob).
13114N/A* Mon Aug 15 2005 - damien.carbery@sun.com
13034N/A- Bump to 2.11.4.
16626N/A* Fri May 20 2005 - glynn.foster@sun.com
12808N/A- Bump to 2.10.1
12809N/A* Wed May 11 2005 - ciaran.mcdermott@sun.com
12649N/A- added gnome-games-05-g11n-desktop-fix.diff
12649N/A- to fix CR 6266891
12649N/A* Wed Apr 27 2005 - kieran.colfer@sun.com
12586N/A- added gnome-games-04-po-install-fixes.diff for CR 6243601
12586N/A* Fri Nov 12 2004 - laca@sun.com
12500N/A- added --libdir and --bindir to configure opts so they can be redirected on
12500N/A Solaris
12500N/A* Mon Sep 20 2004 - dermot.mccluskey@sun.com
12467N/A- removed sol from files
12467N/A* Thu Sep 04 2004 - laslzo.kovacs@sun.com
12369N/A- packaged sol
12369N/A* Thu Aug 26 2004 - damien.carbery@sun.com
12287N/A- Put scores files in %{_localstatedir}/lib.
12287N/A* Wed Aug 25 2004 - damien.carbery@sun.com
12268N/A- Add unpackaged files to %files.
12268N/A* Mon Aug 23 2004 - niall.power@sun.com
12268N/A- remove auto*-jds tool dependencies
12268N/A* Thu Jul 08 2004 - damien.donlon@sun.com
12197N/A- Updated l10n content to gnome-games-l10n-po-1.2.tar.bz2
12197N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
12171N/A- added "-j $CPUS" to make to speed up builds
12171N/A* Tue Jun 1 2004 - glynn.foster@sun.com
12171N/A- Fix up schema install
12145N/A* Wed May 12 2004 - damien.donlon@sun.com
16626N/A- Updated l10n content to gnome-games-l10n-po-1.1.tar.bz2
12144N/A* Fri May 07 2004 - matt.keenan@sun.com
12144N/A- Bump to 2.6.1
12108N/A* Wed Apr 21 2004 - laca@sun.com
12108N/A- disable javahelp conversion for stuff not built on Solaris
12108N/A* Sun Apr 18 2004 - laca@sun.com
12071N/A- enable javahelp conversion on Solaris
12071N/A* Fri Apr 02 2004 - brian.cameron@sun.com
12022N/A- Added patch 03 to fix Solaris Makefile issue, and added libexecdir to
12022N/A configure line.
11922N/A* Thu Apr 01 2004 - matt.keenan@sun.com
11922N/A- javahelp conversion
11819N/A* Mon Mar 29 2004 - damien.donlon@sun.com
11819N/A- Updated l10n content to gnome-games-l10n-po-1.0.tar.bz2
11416N/A* Wed Mar 24 2004 - glynn.foster@sun.com
11416N/A- Use JDS autotools
11370N/A* Tue Mar 23 2004 - glynn.foster@sun.com
11370N/A- Bump to 2.6.0. Remove 2 potfile patches and
11370N/A replace with a single one.
11256N/A* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
11256N/A- added gnome-games-03-g11n-potfiles.diff
11172N/A* Fri Feb 06 2004 - <matt.keenan@sun.com>
11175N/A- Bump up 2.5.5, remove intltool-merge patch
11136N/A- re-engineered patch-01, as automake etc is commented out.
11136N/A- This could be changed again if automake 1.7 was being used not 1.6 !!
11123N/A* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
11123N/A- add patch 03 for intltool-merge and dep. on intltool
11083N/A* Fri Dec 29 2003 - <niall.power@sun.com>
11083N/A- comment out libtool, aclocal etc. which
11083N/A is causing build failure
11066N/A* Fri Dec 29 2003 - <glynn.foster@sun.com>
11071N/A- Bump to 2.5.3
11071N/A* Wed Dec 17 2003 - <glynn.foster@sun.com>
11066N/A- Bump to 2.5.2
10972N/A* Fri Oct 31 2003 - <glynn.foster@sun.com>
10972N/A- Remove the Sun Supported keyword from the desktop
10972N/A files. We're removing the Extras menu.
10820N/A* Wed Oct 22 2003 - <glynn.foster@sun.com>
10820N/A- Add blackjack into the build
10778N/A* Tue Oct 21 2003 - <michael.twomey@sun.com>
10778N/A- Updated to GNOME 2.4.0 version
10778N/A- Removed freecell entries
10778N/A- Moved gnome-games-03-menu-entry.diff patch to
10774N/A gnome-games-01-menu-entry.diff
10774N/A- Dropped gnome-games-04-glines-preferences.diff patch.
10748N/A* Thu Aug 14 2003 - <laca@sun.com>
10748N/A- remove *.so, *.a, *.la
10666N/A* Wed Aug 06 2003 - <glynn.foster@sun.com>
10666N/A- fix glines preference dialog
10650N/A* Thu Jul 17 2003 - <glynn.foster@sun.com>
10650N/A- remove more xbill stuff
10596N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10596N/A- add in sun po files
10580N/A* Tue Jul 08 2003 - glynn.foster@sun.com
10580N/A- Add menu icon for freecell, and add aclocal, automake checks
10473N/A* Tue May 13 2003 - ghee.teo@Sun.COM
10473N/A- Created new spec file for gnome-games
10424N/A
10424N/A