glib2.spec revision 22050
10710N/A#
10710N/A# spec file for package glib2
10710N/A#
10710N/A# Copyright (c) 2003, 2012, Oracle and/or its affiliates. All rights reserved.
10710N/A# This file and all modifications and additions to the pristine
10710N/A# package are under the same license as the package itself.
10710N/A#
10710N/A%define owner erwannc
10843N/A#
10843N/A
10710N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
10710N/A
10710N/AName: glib2
15590N/ALicense: LGPL v2
10710N/AGroup: System/Libraries
10710N/AVersion: 2.32.4
10710N/ARelease: 1
10710N/ADistribution: Java Desktop System
10710N/AVendor: Gnome Community
10710N/ASummary: Low level core compatibility library for GTK+ and GNOME
11925N/ASource: http://ftp.gnome.org/pub/GNOME/sources/glib/2.32/glib-%{version}.tar.xz
12773N/A
15153N/A# Patch default-path to not include "." because on Solaris we want to avoid
15153N/A# setting PATH to include the current working directory. This was an
12773N/A# ARC requirement. The GNOME community already decided to not change
10710N/A# this behavior (bugzilla bug 317945), but this change is safe. This
10881N/A# code only gets executed when the user's PATH is unset, which should
10710N/A# be never. Safer to avoid adding "." to PATH.
10881N/A#owner:yippi date:2005-08-14 type:feature
13952N/APatch1: glib-01-default-path.diff
13952N/A# owner:laca type:bug date:2005-10-13
10710N/APatch2: glib-02-gmodule-always-lazy.diff
10881N/A#owner:stephen date:2006-11-01 type:feature bugster:6393731
13303N/APatch3: glib-03-trusted-extensions.diff
10881N/A#owner:padraig date:2008-01-10 type:bug bugster:5105006
13303N/APatch4: glib-04-gio-trash-only-home.diff
11114N/A#owner:dcarbery date:2008-01-30 type:bug bugzilla:385132
13957N/APatch5: glib-05-ac-canonical-host.diff
13957N/A#owner:erwannc date:2011-04-11 type:feature (port)
10710N/APatch6: glib-06-solaris-port.diff
10710N/A#owner:dcarbery date:2008-05-21 type:bug bugzilla:528506
10710N/APatch7: glib-07-ss12-visibility.diff
10710N/A#owner:erwannc date:2008-09-17 type:bug bugzilla:551919
13079N/APatch8: glib-08-gsize.diff
10710N/A#owner:gheet date:2011-03-11 type:bug bugster:6956527
10710N/APatch9: glib-09-cleanup-libs.diff
10710N/A# date:2011-03-14 type:feature owner:yippi bugster:7013977
10710N/APatch10: glib-10-gio-rbac.diff
10710N/AURL: http://www.gtk.org
10710N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10710N/ADocdir: %{_defaultdocdir}/doc
10710N/AAutoReqProv: on
10710N/APrereq: /sbin/ldconfig
10710N/A
10710N/A%define pkgconfig_version 0.15.0
10710N/A%define gtk_doc_version 1.1
10710N/A%define intltool_version 0.34.1
10710N/A
10710N/ARequires: aaa_base
10710N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10710N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10710N/ABuildRequires: intltool >= %{intltool_version}
10710N/A
10710N/A%description
10710N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
10710N/Astructure handling for C, portability wrappers, and interfaces for such
10710N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
10710N/Aobject system
10710N/A
10710N/A%package devel
10710N/ASummary: GIMP Toolkit and GIMP Drawing Kit support library
10710N/AGroup: Development/Libraries
10710N/ARequires: %{name} = %{version}
10710N/A
13079N/A%description devel
13079N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
13079N/Astructure handling for C, portability wrappers, and interfaces for such
13079N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
10710N/Aobject system
10710N/A
10710N/A%prep
10710N/A%setup -q -n glib-%{version}
10710N/A%patch1 -p1
11114N/A%patch2 -p1
13957N/A%patch3 -p1
10710N/A%patch4 -p1
10710N/A%patch5 -p1
12831N/A%patch6 -p1
12831N/A%patch7 -p1
10710N/A%patch8 -p1
10710N/A%patch9 -p1
10710N/A%patch10 -p1
10710N/A
10710N/A%build
10710N/A%ifos linux
10710N/Aif [ -x /usr/bin/getconf ]; then
10710N/A CPUS=`getconf _NPROCESSORS_ONLN`
10710N/Afi
10710N/A%else
10710N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10710N/A%endif
10710N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
11149N/A CPUS=1
12773N/Afi
12773N/A
12773N/Aexport SED="/usr/gnu/bin/sed"
12773N/Aaclocal-1.11 $ACLOCAL_FLAGS
12773N/Alibtoolize --force --copy
10710N/Agtkdocize
10710N/Aautoheader
10710N/Aautomake-1.11 -a -c -f
10710N/Achmod a+x mkinstalldirs
10710N/Aautoconf
10710N/Aexport CFLAGS="%optflags"
10710N/Aexport LDFLAGS="%_ldflags -lsocket -lsecdb -lnsl"
10710N/A
10710N/A./configure --prefix=%{_prefix} \
10710N/A --mandir=%{_mandir} \
10710N/A --datadir=%{_datadir} \
10710N/A --libdir=%{_libdir} \
10710N/A --bindir=%{_bindir} \
10710N/A --sysconfdir=%{_sysconfdir} \
10710N/A --disable-fam \
10710N/A --disable-dtrace \
10710N/A --enable-shared \
12831N/A $GLIB_EXTRA_CONFIG_OPTIONS \
13282N/A %{gtk_doc_option}
13282N/A
13079N/Amake -j $CPUS
13079N/A
13466N/A%install
12831N/Aexport SED="/usr/gnu/bin/sed"
10710N/A
10710N/Amake DESTDIR=$RPM_BUILD_ROOT install
10710N/A#Copy zh_HK from zh_TW
10710N/A#Fixes bug 4930405
10710N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10710N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10710N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
12741N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
10710N/Arm -Rf $RPM_BUILD_ROOT%{_sysconfdir}
10710N/A
10710N/A%clean
12557N/Arm -rf $RPM_BUILD_ROOT
11867N/A
11867N/A%post
10881N/A/sbin/ldconfig
10881N/A
10881N/A%postun
11947N/A/sbin/ldconfig
12741N/A
12741N/A%files
10710N/A%defattr(-,root,root)
10710N/A%{_libdir}/lib*.so.*
10710N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10710N/A
10710N/A%files devel
10710N/A%defattr(-,root,root)
10710N/A%{_bindir}/*
10710N/A%{_libdir}/lib*.so
10710N/A%{_includedir}/glib-2.0/*
10710N/A%{_libdir}/glib-2.0/include/*.h
10710N/A%{_libdir}/pkgconfig/*.pc
10710N/A%{_datadir}/aclocal/*.m4
10710N/A%{_datadir}/glib-2.0/*
10710N/A%{_datadir}/gtk-doc/html/*
12831N/A%{_mandir}/man1/*
12831N/A%{_mandir}/man3/*
12831N/A
12831N/A%changelog
10710N/A* Sat Sep 15 2012 - brian.cameron@oracle.com
10710N/A- Bump to 2.32.4.
10710N/A* Thu May 17 2012 - brian.cameron@oracle.com
10710N/A- Bump to 2.32.3.
10710N/A* Fri Apr 27 2012 - brian.cameron@oracle.com
10710N/A- Bump to 2.32.1.
10710N/A* Wed Oct 19 2011 - brian.cameron@oracle.com
10710N/A- Bump to 2.30.1.
10710N/A* Fri Sep 30 2011 - brian.cameron@oracle.com
10710N/A- Bump to 2.30.0.
10710N/A* Tue Sep 13 2011 - brian.cameron@oracle.com
15590N/A- Bump to 2.29.90.
15590N/A* Thu Sep 08 2011 - brian.cameron@oracle.com
15590N/A- Bump to 2.29.18.
15255N/A* Sat Aug 06 2011 - brian.cameron@oracle.com
15255N/A- Bump to 2.29.14.
15255N/A* Tue Jul 05 2011 - brian.cameron@oracle.com
15232N/A- Bump to 2.29.10.
15232N/A* Mon Mar 14 2011 - brian.cameron@oracle.com
15232N/A- Add patch glib-14-gio-rbac.diff so desktop entries that need to be run with
14097N/A gksu or pfexec are run properly. Fixes bugster #7013977.
14097N/A* Thu Feb 17 2011 - lin.ma@oracle.com
14097N/A- Fixed 7007407, add new patch.
13957N/A* Wed Nov 17 2010 - dave.lin@oracle.com
13957N/A- Rolled back to previous version 2.25.1.
13957N/A* Thu Oct 21 2010 - brian.cameron@oracle.com
13952N/A- Bump to 2.26.0.
13952N/A- Add patch glib-12-python.diff so that /usr/bin/gtester-report uses Python
13952N/A 2.6.
13510N/A- Remove glib-10-gio-fen.diff and glib-11-gio-fen-assertion-on-root.diff,
13510N/A upstream.
13510N/A- Add glib-10-ellipsis-as-range to fix build issue where an ellipsis (...) is
13466N/A being used to define a range in a case block.
13466N/A- Add glib-11-major-minor-linking.diff. Comments out a couple of dodgy
13466N/A printf's.
13466N/A* Tue May 26 2010 - lin.ma@sun.com
13466N/A- Added glib-11-gio-fen-assertion-on-root.diff for bugzilla:6955199.
13466N/A* Tue Apr 20 2010 - christian.kelly@oracle.com
13303N/A- Bump to 2.25.1.
13303N/A* Tue Apr 06 2010 - lin.ma@sun.com
13466N/A- Added glib-10-gio-fen.diff for doo#10194
13282N/A* Mon Mar 29 2010 - christian.kelly@sun.com
13282N/A- Bump to 2.24.0.
13282N/A* Fri Mar 26 2010 - christian.kelly@sun.com
13079N/A- Bump to 2.23.6.
13079N/A* Thu Mar 11 2010 - christian.kelly@sun.com
12557N/A- Bump to 2.23.5.
12557N/A* Mon Feb 15 2010 - christian.kelly@sun.com
12557N/A- Bump to 2.23.3.
12543N/A* Tue Jan 26 2010 - christian.kelly@sun.com
12543N/A- Bump to 2.23.2.
12543N/A* Thu Oct 22 2009 - harry.fu@sun.com
12126N/A- Remove build option -D__STDC_ISO_10646__ due to doo # 11936.
12126N/A* Wed Oct 14 2009 - dave.lin@sun.com
12126N/A- Bump to 2.22.2
12042N/A* Wed Sep 23 2009 - dave.lin@sun.com
12042N/A- Bump to 2.22.0
12042N/A* Wed Sep 16 2009 - harry.fu@sun.com
11867N/A- Add build option -D__STDC_ISO_10646__ for correct collation.
11867N/A* Sun Sep 06 2009 - dave.lin@sun.com
11867N/A- Bump to 2.21.6
11847N/A* Tue Aug 25 2009 - christian.kelly@sun.com
11847N/A- Bump to 2.21.5.
11847N/A- Upstreamed patch -10-bad-return and -11-gio-fen-undef-function
11149N/A* Mon Jul 20 2009 - lin.ma@sun.com
11149N/A- Add a patch for doo#10117
11149N/A* Sun Jul 19 2009 - christian.kelly@sun.com
11114N/A- Bump to 2.21.4.
11114N/A* Tue Jul 14 2009 - chris.wang@sun.com
11149N/A- Change patch 8,9 owner to erwann
11114N/A* Tue Jun 16 2009 - christian.kelly@sun.com
11103N/A- Bump to 2.21.2.
11104N/A- Remove glib-11-gio-check-mountflag.diff and glib-10-display.diff.
11103N/A- Add glib-10-bad-return.diff.
11033N/A* Mon Jun 15 2009 - ghee.teo@sun.com
11033N/A- patched fix to 585360 for now. Performance fix.
11033N/A* Wed Apr 15 2009 - dave.lin@sun.com
10913N/A- Bump to 2.20.1
10913N/A* Sat Apr 04 2009 - dave.lin@sun.com
10913N/A- Removed the unnecessary option %option_with_gnu_iconv.
10761N/A* Fri Mar 13 2009 - dave.lin@sun.com
10761N/A- Bump to 2.20.0
10761N/A* Mon Mar 02 2009 - dave.lin@sun.com
10761N/A- Bump to 2.19.10
10710N/A* Mon Feb 23 2009 - chris.wang@sun.com
10710N/A- Add patch 09 to fix 64 application fail on check gsize issue
10710N/A* Wed Feb 18 2009 - dave.lin@sun.com
10710N/A- Bump to 2.19.8
10710N/A* Tue Feb 17 2009 - dave.lin@sun.com
10710N/A- Bump to 2.19.7
10710N/A* Fri Feb 13 2009 - dave.lin@sun.com
10710N/A- Bump to 2.19.6
10710N/A* Wed Jan 07 2000 - christian.kelly@sun.com
10710N/A- Bump to 2.19.4.
10710N/A- Remove patch9.
10710N/A* Mon Dec 15 2008 - chris.wang@sun.com
10710N/A- Add patch glib-09-sunpro_c.diff, define G_GNUC_INTERNAL to
10710N/A __attribute__(visibility("hidden")) in SS12
10710N/A* Wed Dec 03 2008 - dave.lin@sun.com
10710N/A- Bump to 2.19.2
10710N/A* Wed Dec 03 2008 - dave.lin@sun.com
10710N/A- Bump to 2.19.1
10710N/A* Wed Sep 17 2008 - chris.wang@sun.com
10710N/A- add patch 08-typedetect to fix defecto bug 3355 core dump from pidgin
10710N/A* Tue Sep 08 2008 - patrick.ale@gmail.com
10710N/A- Correct download URL
10710N/A* Wed Sep 03 2008 - christian.kelly@sun.com
10710N/A- Bump to 2.18.0.
10710N/A* Tue Aug 19 2008 - dave.lin@sun.com
10710N/A- Bump to 2.17.7
10710N/A- Removed the upstreamed patch glib-06-dont-show-zfs.diff
10710N/A* Fri Aug 15 2008 - padraig.obriain@sun.com
10710N/A- Update patch 06-dont-show-zfs to what has been accepted upstream.
10710N/A* Wed Aug 06 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.17.6.
10710N/A* Tue Jul 22 2008 - christian.kelly@sun.com
10710N/A- Bump to 2.17.4
10710N/A* Wed Jul 10 2008 - padraig.obriain@sun.com
10710N/A- Add patch 06-dont-show-zfs.
10710N/A* Thu Jul 03 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.17.3.
10710N/A* Fri Jun 13 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.17.2.
10710N/A* Thu May 29 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.17.0. Remove upstream patches, 06-gio-fen, 08-gio-set-name,
10710N/A 09-gio-fs-type. Renumber remainder.
10710N/A* Tue May 27 2008 - simon.zheng@sun.com
10710N/A- Rework 09-gio-fs-type.diff the same as upstream.
10710N/A* Wed Apr 08 2008 - damien.carbery@sun.com
10710N/A- Add patch ss12-visibility to fix bugzilla 528506. Sun Studio 12 compiler
10710N/A doesn't support aliases for variables. Disable this change until we switch to
10710N/A building with ss12.
10710N/A* Fri May 16 2008 - simon.zheng@sun.com
10710N/A- Add glib-09-gio-fs-type.diff to identify filesystem type on Solaris.
10710N/A* Thu Apr 10 2008 - padraig.obriain@sun.com
10710N/A- Rework glib-04-gio-trash-only-home.diff so that it applies
10710N/A* Wed Apr 08 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.16.3.
10710N/A* Wed Apr 09 2008 - padraig.obriain@sun.com
10710N/A- Added glib-08-gio-set-name.diff.
10710N/A* Thu Apr 03 2008 - padraig.obriain@sun.com
10710N/A- Added glib-07-gio-ignore-fs.diff.
10710N/A* Wed Apr 03 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.16.2.
10710N/A* Tue Mar 18 2008 - lin.ma@sun.com
10710N/A- Added glib-06-gio-fen.diff which is upstreamed and will be available
10710N/A Glib 2.18.0, so it will be removed at that time.
10710N/A* Tue Mar 11 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.16.1.
10710N/A* Tue Feb 26 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.15.6.
10710N/A* Wed Feb 13 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.15.5. Remove upstream patch 05-func. Comment out patch4 as it needs
10710N/A engineer rework. Rename patch6.
10710N/A* Tue Jan 29 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.15.4.
10710N/A* Tue Jan 22 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.15.3.
10710N/A* Mon Jan 07 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.15.2. Remove upstream patch, 04-sed-i. Rename remainder.
10710N/A* Thu Jan 10 2008 - padraig.obriain@sun.com
10710N/A- Add patch glib-05-gio-trash-only-home.diff, rework of gnome-vfs and
10710N/A nautilus patches.
10710N/A* Mon Jan 07 2008 - damien.carbery@sun.com
10710N/A- Bump to 2.15.1. Remove upstream patch, 04-void-return, rename remainder.
10710N/A* Fri Jan 04 2008 - ghee.teo@sun.com
10710N/A- Added --disable-fam as per damien.
10710N/A* Wed Dec 26 2007 - damien.carbery@sun.com
10710N/A- Add patch 05-sed-i to rework sed command for non-GNU sed that doesn't support
10710N/A -i option.
10710N/A* Tue Dec 25 2007 - damien.carbery@sun.com
10710N/A- Add patch 04-void-return. void functions returning values are breaking build.
10710N/A* Fri Dec 21 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.15.0.
10710N/A* Fri Dec 21 2007 - takao.fujiwara@sun.com
10710N/A- Remove glib-01-convert-utf8.diff Fixes 6294268
10710N/A* Tue Nov 27 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.14.4.
10710N/A* Wed Nov 07 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.14.3.
10710N/A* Fri Oct 19 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.14.2.
10710N/A* Tue Oct 2 2007 - laca@sun.com
10710N/A- when building with GNU iconv, hack glib-2.0.pc.in so that /usr/gnu/lib
10710N/A is automatically added to the library search path and RUNPATH
10710N/A* Sat Sep 29 2007 - laca@sun.com
10710N/A- remove --with-libiconv=native option as it appears to break the build
10710N/A on nevada
10710N/A* Fri Sep 28 2007 - laca@sun.com
10710N/A- add support for building with GNU libiconv
10710N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.14.1.
10710N/A* Sun Aug 05 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.14.0. Remove upstream patch, 05-gthread-cast.
10710N/A* Fri Jul 13 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.13.7. Add patch 05-gthread-cast from svn trunk.
10710N/A* Mon Jul 02 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.13.6.
10710N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.13.5.
10710N/A* Thu Jun 07 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.13.4.
10710N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.13.3.
10710N/A* Wed May 23 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.13.2. Remove upstream patch, 04-hidden. Renumber rest.
10710N/A* Fri May 11 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.13.1.
10710N/A* Wed May 02 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.12.12.
10710N/A* Thu Mar 15 2007 - laca@sun.com
10710N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
10710N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10710N/A- Removed adding ccdir to PATH
10710N/A* Fri Mar 09 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.12.11.
10710N/A* Thu Mar 08 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.12.10. Remove upstream patch, 04-msgfmt-c. Renumber remainder.
10710N/A* Sun Feb 4 2007 - laca@sun.com
10710N/A- remove patch ALL_LINGUAS.diff - no longer needed; reorder remaining
10710N/A* Wed Jan 17 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.12.9.
10710N/A* Mon Jan 15 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.12.8.
10710N/A* Fri Jan 05 2007 - damien.carbery@sun.com
10710N/A- Bump to 2.12.7.
10710N/A* Thu Dec 21 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.12.6.
10710N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.12.5. Remove upstream patches, 01-gettext-macro,
10710N/A 05-solaris-thread-flags, 09-use-fdwalk. Renumber remainder.
10710N/A* Fri Nov 3 2006 - laca@sun.com
10710N/A- use %gtk_doc_option in configure so that it can be disabled using
10710N/A --without-gtk-doc
10710N/A* Wed Nov 01 2006 - stephen.browne@sun.com
10710N/A- added patch glib-11-trusted-extensions.diff: covers bugster 639371
10710N/A* Mon Oct 02 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.12.4.
10710N/A* Mon Sep 25 2006 - padraig.obriain@sun.com
10710N/A- Add patch use-fdwalk for bugzilla 357585
10710N/A* Wed Aug 30 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.12.3.
10710N/A* Wed Aug 16 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.12.2.
10710N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.12.1.
10710N/A* Thu Jul 20 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.12.0.
10710N/A* Thu Jul 13 2006 - laca@sun.com
10710N/A- add patch ALL_LINGUAS.diff that removes the \n's from ALL_LINGUAS in
10710N/A AM_GLIB_GNU_GETTEXT
10710N/A* Thu May 25 2006 - brian.cameron@sun.com
10710N/A- Add patch glib-08-hidden.diff to make sure that the G_HAVE_GNUC_VISIBILITY
10710N/A macro is defined to "__hidden" if using the Sun Forte compiler. This
10710N/A makes sure that symbols that should be hidden are not exported when using
10710N/A our compiler. This resolves the GNOME 2.14 LSARC 2006/202 TCR regarding
10710N/A this issue.
10710N/A* Wed Apr 26 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.10.2.
10710N/A* Wed Mar 8 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.10.1.
10710N/A* Sun Feb 26 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.10.0.
10710N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.9.6.
10710N/A* Sun Feb 12 2006 - damien.carbery@sun.com
10710N/A- Call gettextize to fix infinite loop in configure.
10710N/A* Fri Jan 27 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.9.5
10710N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.9.3
10710N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10710N/A- Bump to 2.9.2.
10710N/A* Tue Dec 20 2005 - damien.carbery@sun.com
10710N/A- Bump to 2.9.1. Remove upstream patch 05-logname. Add intltool BuildRequires.
10710N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10710N/A- Bump to 2.8.4.
10710N/A* Mon Nov 28 2005 - laca@sun.com
10710N/A- prepare for building from CVS snapshots:
10710N/A- use a macro for Version
10710N/A- fix autotool order, add some more
10710N/A- cp mkinstalldirs so that we don't need to add even more autotool foo
10710N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10710N/A- Bump to 2.8.3
10710N/A* Tue Sep 27 2005 - glynn.foster@sun.com
10710N/A- Bump to 2.8.2
10710N/A* Mon Aug 15 2005 - glynn.foster@sun.com
10710N/A- Bump to 2.8.0
10710N/A* Wed Jun 15 2005 - matt.keenan@sun.com
10710N/A- Bump to 2.6.5
10710N/A- Remove patch glib-04-uninstalled-pc.diff
10710N/A* Fri May 06 2005 - brian.cameron@sun.com
10710N/A- Add patch 04 to add needed uninstalled.pc files to allow other
10710N/A base-libs libraries to build. This requires calling autoconf
10710N/A aclocal, etc.
10710N/A- Fix naming of patches since the patches were renamed but this
10710N/A spec file not updated.
10710N/A* Fri May 06 2005 - glynn.foster@sun.com
10710N/A- Bump to 2.6.4
10710N/A* Wed Nov 15 2004 - glynn.foster@sun.com
10710N/A- Bump to 2.4.8, since otherwise glib-gettextize doesn't create
10710N/A mkinstalldirs properly, and consequently it means I can't create
10710N/A tarballs from CVS sources. We also get a rake of nice bug fixes
10710N/A as a result.
10710N/A* Fri Nov 12 2004 - brian.cameron@sun.com
10710N/A- Modify the default path that glib sets (if the user does not have PATH
10710N/A set), so it does not include "." since ARC determined this is a
10710N/A security concern. When building on Sun, set it to just "/usr/bin"
10710N/A since "/bin" is a symlink to "/usr/bin". On Linux set it to
10710N/A "/bin:/usr/bin".
* Fri Oct 29 2004 - laca@sun.com
- use $CC64 for the 64-bit build if defined
* Wed Oct 05 2004 - Yong.Sun@Sun.COM
- Added glib-04-convert-utf8.diff to fix CR 5055972
* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
- Create 64bit libraries for Solaris
* Thu Sep 16 2004 - ciaran.mcdermott@sun.com
- Added glib-03-g11n-allinguas.diff to include hu lingua
* Wed Aug 18 2004 - brian.cameron@sun.com
- added --enable-gtk-doc
* Thu Aug 05 2004 - archana.shah@wipro.com
- Add patch to fix glib get SIGCHLD everytime
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to glib2-l10n-po-1.2.tar.bz2
* Thu Jul 08 2004 - stephen.browne@sun.com
- ported to rpm4/suse91
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Fri May 14 2004 - glynn.foster@sun.com
- Bump to 2.4.1
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to glib2-l10n-po-1.1.tar.bz2
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to glib2-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - <glynn.foster@sun.com>
- Bump to 2.4.0
* Wed Mar 10 2004 - <niall.power@sun.com>
- remove glib-02 patch (it wasn't being applied anyway).
- bump to 2.3.6
* Thu Feb 19 2004 - <damien.carbery@sun.com>
- Add patch for glib/gmessages.h to change '...' to '__VA_ARGS__' to build
on Solaris. May revisit to use '#ifdef __sun'
* Tue Feb 10 2004 - <matt.keenan@sun.com>
- Bump to 2.3.2, l10n to 0.7
* Mon Dec 15 2003 - <glynn.foster@sun.com>
- update to 2.3.1
* Sat Oct 04 2003 - <laca@sun.com>
- update to 2.2.3
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Fri Aug 01 2003 - <markmc@sun.com> 2.2.2-1
* Wed Jul 25 2003 - <niall.power@sun.com>
- add aaa_base dependency. Fixes postinstall script breakage
during OS install.
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Thu May 12 2003 - <ghee.teo@sun.com>
- Initial spec file for glib2