glib2.spec revision 12088
13284N/A#
13284N/A# spec file for package glib2
13284N/A#
17722N/A# Copyright 2007 Sun Microsystems, Inc.
13284N/A# This file and all modifications and additions to the pristine
13284N/A# package are under the same license as the package itself.
13284N/A#
13284N/A# Owner: erwannc
13284N/A#
13284N/AName: glib2
13284N/ALicense: LGPL
13284N/AGroup: System/Libraries
13284N/AVersion: 2.14.4
13284N/ARelease: 1
13284N/ADistribution: Java Desktop System
13284N/AVendor: Sun Microsystems, Inc.
13284N/ASummary: Low level core compatibility library for GTK+ and GNOME
13284N/ASource: http://ftp.gnome.org/pub/GNOME/sources/glib/2.14/glib-%{version}.tar.bz2
13284N/A
13284N/A# Note we patch default-path to not include "." because on Solaris
13284N/A# we are extra paranoid about not ever setting PATH to include the
13284N/A# current working directory. This was an ARC requirement.
13284N/A# The GNOME community already decided to not change this behavior
13284N/A# (refer to bugzilla bug 317945), but this change is safe. This
13284N/A# code only gets executed when the user's PATH is unset, which
13284N/A# should be never. Still safer to avoid adding "." to PATH.
13284N/A# Note the bug isn't referenced on the next line since it appears
13284N/A# as a "yellow" patch if we do, but this is a feature that ARC
13284N/A# requires so we really want it. Laca approved this idea.
13284N/A#owner:yippi date:2005-08-14 type:feature
13284N/APatch1: glib-01-default-path.diff
13284N/A# owner:laca type:bug date:2005-10-13
13284N/APatch2: glib-02-gmodule-always-lazy.diff
13284N/A#owner:stephen date:2006-11-01 type:feature bugster:6393731
13284N/APatch3: glib-03-trusted-extensions.diff
13284N/AURL: http://www.gtk.org
13284N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
13284N/ADocdir: %{_defaultdocdir}/doc
13284N/AAutoReqProv: on
13284N/APrereq: /sbin/ldconfig
13284N/A
13284N/A%define pkgconfig_version 0.15.0
13284N/A%define gtk_doc_version 1.1
13284N/A%define intltool_version 0.34.1
13284N/A
13284N/ARequires: aaa_base
13284N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
13284N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
13284N/ABuildRequires: intltool >= %{intltool_version}
13284N/A
13284N/A%description
13284N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
13284N/Astructure handling for C, portability wrappers, and interfaces for such
13284N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
13284N/Aobject system
13284N/A
13284N/A%package devel
13284N/ASummary: GIMP Toolkit and GIMP Drawing Kit support library
17722N/AGroup: Development/Libraries
13284N/ARequires: %{name} = %{version}
13284N/A
13284N/A%description devel
13284N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
13284N/Astructure handling for C, portability wrappers, and interfaces for such
13284N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
13284N/Aobject system
13284N/A
13284N/A%prep
13284N/A%setup -q -n glib-%{version}
13284N/A%patch1 -p1
13284N/A%patch2 -p1
13284N/A%patch3 -p1
13284N/A
13284N/A%if %option_with_gnu_iconv
13284N/A%if %opt_arch64
13284N/Aperl -pi -e 's,^Libs: ,Libs: -L/usr/gnu/lib/%{_arch64} -R/usr/gnu/lib/%{_arch64} ,' glib-2.0.pc.in
13284N/A%else
13284N/Aperl -pi -e 's,^Libs: ,Libs: -L/usr/gnu/lib -R/usr/gnu/lib ,' glib-2.0.pc.in
13284N/A%endif
13284N/Aperl -pi -e 's,^Cflags: ,Cflags: -I/usr/gnu/include ,' glib-2.0.pc.in
13284N/A%endif
13284N/A
13284N/A%build
13284N/A%ifos linux
13284N/Aif [ -x /usr/bin/getconf ]; then
13284N/A CPUS=`getconf _NPROCESSORS_ONLN`
13284N/Afi
13284N/A%else
13284N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
13284N/A%endif
13284N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
13284N/A CPUS=1
13284N/Afi
13284N/A
13284N/A%if %option_with_gnu_iconv
13284N/A%define libiconv_option --with-libiconv=gnu
13284N/A%else
13284N/A%define libiconv_option
13284N/A%endif
13284N/A
13284N/Aaclocal $ACLOCAL_FLAGS
13284N/Alibtoolize --force --copy
13284N/Agtkdocize
13284N/Aautoheader
13284N/Aautomake -a -c -f
13284N/Aautoconf
13284N/Aexport CFLAGS="%optflags"
17719N/Aexport LDFLAGS="%_ldflags"
13284N/A./configure --prefix=%{_prefix} \
13284N/A --mandir=%{_mandir} \
13284N/A --datadir=%{_datadir} \
13284N/A --libdir=%{_libdir} \
13284N/A --bindir=%{_bindir} \
13284N/A --sysconfdir=%{_sysconfdir} \
13284N/A %{gtk_doc_option} %{libiconv_option}
13284N/A
13284N/Amake -j $CPUS
13284N/A
13284N/A%install
13284N/A
13284N/Amake DESTDIR=$RPM_BUILD_ROOT install
13284N/A#Copy zh_HK from zh_TW
13284N/A#Fixes bug 4930405
13284N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
13284N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
13284N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
13284N/A
13284N/A%clean
13284N/Arm -rf $RPM_BUILD_ROOT
13284N/A
13284N/A%post
13284N/A/sbin/ldconfig
13284N/A
13284N/A%postun
13284N/A/sbin/ldconfig
13284N/A
13284N/A%files
13284N/A%defattr(-,root,root)
13284N/A%{_libdir}/lib*.so.*
13284N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
13284N/A
13284N/A%files devel
13284N/A%defattr(-,root,root)
13284N/A%{_bindir}/*
13284N/A%{_libdir}/lib*.so
13284N/A%{_includedir}/glib-2.0/*
13284N/A%{_libdir}/glib-2.0/include/*.h
13284N/A%{_libdir}/pkgconfig/*.pc
13284N/A%{_datadir}/aclocal/*.m4
13284N/A%{_datadir}/glib-2.0/*
17719N/A%{_datadir}/gtk-doc/html/*
13284N/A%{_mandir}/man1/*
13284N/A%{_mandir}/man3/*
13284N/A
13284N/A%changelog
13284N/A* Fri Dec 21 2007 - takao.fujiwara@sun.com
13284N/A- Remove glib-01-convert-utf8.diff Fixes 6294268
13284N/A* Tue Nov 27 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.14.4.
13284N/A* Wed Nov 07 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.14.3.
13284N/A* Fri Oct 19 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.14.2.
13284N/A* Tue Oct 2 2007 - laca@sun.com
13284N/A- when building with GNU iconv, hack glib-2.0.pc.in so that /usr/gnu/lib
13284N/A is automatically added to the library search path and RUNPATH
13284N/A* Sat Sep 29 2007 - laca@sun.com
13284N/A- remove --with-libiconv=native option as it appears to break the build
13284N/A on nevada
13284N/A* Fri Sep 28 2007 - laca@sun.com
13284N/A- add support for building with GNU libiconv
13284N/A* Tue Sep 18 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.14.1.
17719N/A* Sun Aug 05 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.14.0. Remove upstream patch, 05-gthread-cast.
13284N/A* Fri Jul 13 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.13.7. Add patch 05-gthread-cast from svn trunk.
13284N/A* Mon Jul 02 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.13.6.
13284N/A* Tue Jun 19 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.13.5.
13284N/A* Thu Jun 07 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.13.4.
13284N/A* Wed Jun 06 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.13.3.
13284N/A* Wed May 23 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.13.2. Remove upstream patch, 04-hidden. Renumber rest.
13284N/A* Fri May 11 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.13.1.
13284N/A* Wed May 02 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.12.12.
13284N/A* Thu Mar 15 2007 - laca@sun.com
13284N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
13284N/A* Wed Mar 15 2007 - dougs@truemail.co.th
13284N/A- Removed adding ccdir to PATH
13284N/A* Fri Mar 09 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.12.11.
13284N/A* Thu Mar 08 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.12.10. Remove upstream patch, 04-msgfmt-c. Renumber remainder.
13284N/A* Sun Feb 4 2007 - laca@sun.com
13284N/A- remove patch ALL_LINGUAS.diff - no longer needed; reorder remaining
13284N/A* Wed Jan 17 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.12.9.
17719N/A* Mon Jan 15 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.12.8.
13284N/A* Fri Jan 05 2007 - damien.carbery@sun.com
13284N/A- Bump to 2.12.7.
13284N/A* Thu Dec 21 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.12.6.
13284N/A* Tue Dec 19 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.12.5. Remove upstream patches, 01-gettext-macro,
13284N/A 05-solaris-thread-flags, 09-use-fdwalk. Renumber remainder.
13284N/A* Fri Nov 3 2006 - laca@sun.com
13284N/A- use %gtk_doc_option in configure so that it can be disabled using
13284N/A --without-gtk-doc
13284N/A* Wed Nov 01 2006 - stephen.browne@sun.com
13284N/A- added patch glib-11-trusted-extensions.diff: covers bugster 639371
13284N/A* Mon Oct 02 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.12.4.
13284N/A* Mon Sep 25 2006 - padraig.obriain@sun.com
13284N/A- Add patch use-fdwalk for bugzilla 357585
13284N/A* Wed Aug 30 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.12.3.
13284N/A* Wed Aug 16 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.12.2.
13284N/A* Mon Jul 24 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.12.1.
13284N/A* Thu Jul 20 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.12.0.
13284N/A* Thu Jul 13 2006 - laca@sun.com
13284N/A- add patch ALL_LINGUAS.diff that removes the \n's from ALL_LINGUAS in
13284N/A AM_GLIB_GNU_GETTEXT
13284N/A* Thu May 25 2006 - brian.cameron@sun.com
13284N/A- Add patch glib-08-hidden.diff to make sure that the G_HAVE_GNUC_VISIBILITY
13284N/A macro is defined to "__hidden" if using the Sun Forte compiler. This
13284N/A makes sure that symbols that should be hidden are not exported when using
13284N/A our compiler. This resolves the GNOME 2.14 LSARC 2006/202 TCR regarding
13284N/A this issue.
13284N/A* Wed Apr 26 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.10.2.
13284N/A* Wed Mar 8 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.10.1.
13284N/A* Sun Feb 26 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.10.0.
13284N/A* Mon Feb 13 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.9.6.
13284N/A* Sun Feb 12 2006 - damien.carbery@sun.com
13284N/A- Call gettextize to fix infinite loop in configure.
13284N/A* Fri Jan 27 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.9.5
13284N/A* Tue Jan 17 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.9.3
13284N/A* Sun Jan 15 2006 - damien.carbery@sun.com
13284N/A- Bump to 2.9.2.
13284N/A* Tue Dec 20 2005 - damien.carbery@sun.com
13284N/A- Bump to 2.9.1. Remove upstream patch 05-logname. Add intltool BuildRequires.
13284N/A* Tue Nov 29 2005 - damien.carbery@sun.com
13284N/A- Bump to 2.8.4.
13284N/A* Mon Nov 28 2005 - laca@sun.com
13284N/A- prepare for building from CVS snapshots:
13284N/A- use a macro for Version
13284N/A- fix autotool order, add some more
13284N/A- cp mkinstalldirs so that we don't need to add even more autotool foo
13284N/A* Tue Oct 11 2005 - damien.carbery@sun.com
13284N/A- Bump to 2.8.3
13284N/A* Tue Sep 27 2005 - glynn.foster@sun.com
13284N/A- Bump to 2.8.2
13284N/A* Mon Aug 15 2005 - glynn.foster@sun.com
13284N/A- Bump to 2.8.0
13284N/A* Wed Jun 15 2005 - matt.keenan@sun.com
13284N/A- Bump to 2.6.5
13284N/A- Remove patch glib-04-uninstalled-pc.diff
13284N/A* Fri May 06 2005 - brian.cameron@sun.com
13284N/A- Add patch 04 to add needed uninstalled.pc files to allow other
13284N/A base-libs libraries to build. This requires calling autoconf
13284N/A aclocal, etc.
13284N/A- Fix naming of patches since the patches were renamed but this
13284N/A spec file not updated.
13284N/A* Fri May 06 2005 - glynn.foster@sun.com
13284N/A- Bump to 2.6.4
13284N/A* Wed Nov 15 2004 - glynn.foster@sun.com
13284N/A- Bump to 2.4.8, since otherwise glib-gettextize doesn't create
13284N/A mkinstalldirs properly, and consequently it means I can't create
13284N/A tarballs from CVS sources. We also get a rake of nice bug fixes
13284N/A as a result.
13284N/A* Fri Nov 12 2004 - brian.cameron@sun.com
13284N/A- Modify the default path that glib sets (if the user does not have PATH
13284N/A set), so it does not include "." since ARC determined this is a
13284N/A security concern. When building on Sun, set it to just "/usr/bin"
13284N/A since "/bin" is a symlink to "/usr/bin". On Linux set it to
13284N/A "/bin:/usr/bin".
13284N/A* Fri Oct 29 2004 - laca@sun.com
13284N/A- use $CC64 for the 64-bit build if defined
13284N/A* Wed Oct 05 2004 - Yong.Sun@Sun.COM
13284N/A- Added glib-04-convert-utf8.diff to fix CR 5055972
13284N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
13284N/A- Create 64bit libraries for Solaris
13284N/A* Thu Sep 16 2004 - ciaran.mcdermott@sun.com
13284N/A- Added glib-03-g11n-allinguas.diff to include hu lingua
13284N/A* Wed Aug 18 2004 - brian.cameron@sun.com
13284N/A- added --enable-gtk-doc
13284N/A* Thu Aug 05 2004 - archana.shah@wipro.com
13284N/A- Add patch to fix glib get SIGCHLD everytime
13284N/A* Thu Jul 08 2004 - damien.donlon@sun.com
13284N/A- Updated l10n content to glib2-l10n-po-1.2.tar.bz2
13284N/A* Thu Jul 08 2004 - stephen.browne@sun.com
13284N/A- ported to rpm4/suse91
13284N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
13284N/A- added "-j $CPUS" to make to speed up builds
13284N/A* Fri May 14 2004 - glynn.foster@sun.com
13284N/A- Bump to 2.4.1
13284N/A* Wed May 12 2004 - damien.donlon@sun.com
13284N/A- Updated l10n content to glib2-l10n-po-1.1.tar.bz2
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to glib2-l10n-po-1.0.tar.bz2
* Wed Mar 24 2004 - <glynn.foster@sun.com>
- Bump to 2.4.0
* Wed Mar 10 2004 - <niall.power@sun.com>
- remove glib-02 patch (it wasn't being applied anyway).
- bump to 2.3.6
* Thu Feb 19 2004 - <damien.carbery@sun.com>
- Add patch for glib/gmessages.h to change '...' to '__VA_ARGS__' to build
on Solaris. May revisit to use '#ifdef __sun'
* Tue Feb 10 2004 - <matt.keenan@sun.com>
- Bump to 2.3.2, l10n to 0.7
* Mon Dec 15 2003 - <glynn.foster@sun.com>
- update to 2.3.1
* Sat Oct 04 2003 - <laca@sun.com>
- update to 2.2.3
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Fri Aug 01 2003 - <markmc@sun.com> 2.2.2-1
* Wed Jul 25 2003 - <niall.power@sun.com>
- add aaa_base dependency. Fixes postinstall script breakage
during OS install.
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Thu May 12 2003 - <ghee.teo@sun.com>
- Initial spec file for glib2