glib2.spec revision 11314
10139N/A#
10139N/A# spec file for package glib2
10139N/A#
12147N/A# Copyright 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: erwannc
10139N/A#
10139N/AName: glib2
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries
12812N/AVersion: 2.14.1
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Low level core compatibility library for GTK+ and GNOME
12584N/ASource: http://ftp.gnome.org/pub/GNOME/sources/glib/2.14/glib-%{version}.tar.bz2
10139N/A
10139N/A#owner:erwannc date:2004-10-05 type:bug bugster:5055972 bugzilla:466760
10139N/APatch1: glib-01-convert-utf8.diff
10139N/A# Note we patch default-path to not include "." because on Solaris
10139N/A# we are extra paranoid about not ever setting PATH to include the
10139N/A# current working directory. This was an ARC requirement.
10139N/A# The GNOME community already decided to not change this behavior
10139N/A# (refer to bugzilla bug 317945), but this change is safe. This
10491N/A# code only gets executed when the user's PATH is unset, which
10491N/A# should be never. Still safer to avoid adding "." to PATH.
10491N/A# Note the bug isn't referenced on the next line since it appears
10491N/A# as a "yellow" patch if we do, but this is a feature that ARC
12088N/A# requires so we really want it. Laca approved this idea.
10139N/A#owner:yippi date:2005-08-14 type:feature
12088N/APatch2: glib-02-default-path.diff
10139N/A# owner:laca type:bug date:2005-10-13
12088N/APatch3: glib-03-gmodule-always-lazy.diff
12176N/A#owner:stephen date:2006-11-01 type:feature bugster:6393731
12196N/APatch4: glib-04-trusted-extensions.diff
12306N/AURL: http://www.gtk.org
12368N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12619N/ADocdir: %{_defaultdocdir}/doc
12619N/AAutoReqProv: on
12765N/APrereq: /sbin/ldconfig
12765N/A
12811N/A%define pkgconfig_version 0.15.0
12811N/A%define gtk_doc_version 1.1
10139N/A%define intltool_version 0.34.1
10139N/A
10139N/ARequires: aaa_base
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: intltool >= %{intltool_version}
10139N/A
10139N/A%description
10139N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
10139N/Astructure handling for C, portability wrappers, and interfaces for such
10139N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
10139N/Aobject system
10139N/A
10139N/A%package devel
10139N/ASummary: GIMP Toolkit and GIMP Drawing Kit support library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
10139N/Astructure handling for C, portability wrappers, and interfaces for such
10139N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
10139N/Aobject system
10139N/A
10139N/A%prep
10139N/A%setup -q -n glib-%{version}
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
12368N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12288N/A%endif
12619N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
12765N/A CPUS=1
12811N/Afi
10139N/A
11330N/A%if %option_with_gnu_iconv
11330N/A%define libiconv_option --with-libiconv=gnu
11330N/A%else
11330N/A%define libiconv_option --with-libiconv=native
11330N/A%endif
11330N/A
11330N/Aaclocal $ACLOCAL_FLAGS
11330N/Alibtoolize --force --copy
11330N/Agtkdocize
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A %{gtk_doc_option} %{libiconv_option}
11314N/A
11314N/Amake -j $CPUS
11314N/A
11320N/A%install
11314N/A
11314N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10318N/A%clean
10318N/Arm -rf $RPM_BUILD_ROOT
10318N/A
10318N/A%post
10318N/A/sbin/ldconfig
10318N/A
10318N/A%postun
10139N/A/sbin/ldconfig
12140N/A
11314N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%{_bindir}/*
10139N/A%{_libdir}/lib*.so
10139N/A%{_includedir}/glib-2.0/*
10139N/A%{_libdir}/glib-2.0/include/*.h
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/glib-2.0/*
10139N/A%{_datadir}/gtk-doc/html/*
10139N/A%{_mandir}/man1/*
10139N/A%{_mandir}/man3/*
10139N/A
10139N/A%changelog
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- add support for building with GNU libiconv
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.14.1.
10139N/A* Sun Aug 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.14.0. Remove upstream patch, 05-gthread-cast.
10139N/A* Fri Jul 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.13.7. Add patch 05-gthread-cast from svn trunk.
10139N/A* Mon Jul 02 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.13.6.
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.13.5.
10139N/A* Thu Jun 07 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.13.4.
10139N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.13.3.
10139N/A* Wed May 23 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.13.2. Remove upstream patch, 04-hidden. Renumber rest.
10139N/A* Fri May 11 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.13.1.
10139N/A* Wed May 02 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.12.12.
12812N/A* Thu Mar 15 2007 - laca@sun.com
12812N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
12811N/A* Wed Mar 15 2007 - dougs@truemail.co.th
12811N/A- Removed adding ccdir to PATH
12765N/A* Fri Mar 09 2007 - damien.carbery@sun.com
12765N/A- Bump to 2.12.11.
12746N/A* Thu Mar 08 2007 - damien.carbery@sun.com
12746N/A- Bump to 2.12.10. Remove upstream patch, 04-msgfmt-c. Renumber remainder.
12619N/A* Sun Feb 4 2007 - laca@sun.com
12619N/A- remove patch ALL_LINGUAS.diff - no longer needed; reorder remaining
12619N/A* Wed Jan 17 2007 - damien.carbery@sun.com
12584N/A- Bump to 2.12.9.
12584N/A* Mon Jan 15 2007 - damien.carbery@sun.com
12468N/A- Bump to 2.12.8.
12468N/A* Fri Jan 05 2007 - damien.carbery@sun.com
12368N/A- Bump to 2.12.7.
12368N/A* Thu Dec 21 2006 - damien.carbery@sun.com
12368N/A- Bump to 2.12.6.
12287N/A* Tue Dec 19 2006 - damien.carbery@sun.com
12287N/A- Bump to 2.12.5. Remove upstream patches, 01-gettext-macro,
12246N/A 05-solaris-thread-flags, 09-use-fdwalk. Renumber remainder.
12246N/A* Fri Nov 3 2006 - laca@sun.com
12196N/A- use %gtk_doc_option in configure so that it can be disabled using
12196N/A --without-gtk-doc
12765N/A* Wed Nov 01 2006 - stephen.browne@sun.com
12176N/A- added patch glib-11-trusted-extensions.diff: covers bugster 639371
12176N/A* Mon Oct 02 2006 - damien.carbery@sun.com
12147N/A- Bump to 2.12.4.
12152N/A* Mon Sep 25 2006 - padraig.obriain@sun.com
12140N/A- Add patch use-fdwalk for bugzilla 357585
12140N/A* Wed Aug 30 2006 - damien.carbery@sun.com
12095N/A- Bump to 2.12.3.
12096N/A* Wed Aug 16 2006 - damien.carbery@sun.com
12096N/A- Bump to 2.12.2.
12093N/A* Mon Jul 24 2006 - damien.carbery@sun.com
12093N/A- Bump to 2.12.1.
12092N/A* Thu Jul 20 2006 - damien.carbery@sun.com
12092N/A- Bump to 2.12.0.
12088N/A* Thu Jul 13 2006 - laca@sun.com
12088N/A- add patch ALL_LINGUAS.diff that removes the \n's from ALL_LINGUAS in
11989N/A AM_GLIB_GNU_GETTEXT
11989N/A* Thu May 25 2006 - brian.cameron@sun.com
11884N/A- Add patch glib-08-hidden.diff to make sure that the G_HAVE_GNUC_VISIBILITY
11884N/A macro is defined to "__hidden" if using the Sun Forte compiler. This
11416N/A makes sure that symbols that should be hidden are not exported when using
11416N/A our compiler. This resolves the GNOME 2.14 LSARC 2006/202 TCR regarding
11330N/A this issue.
11330N/A* Wed Apr 26 2006 - damien.carbery@sun.com
11330N/A- Bump to 2.10.2.
11320N/A* Wed Mar 8 2006 - damien.carbery@sun.com
11320N/A- Bump to 2.10.1.
11320N/A* Sun Feb 26 2006 - damien.carbery@sun.com
11314N/A- Bump to 2.10.0.
11314N/A* Mon Feb 13 2006 - damien.carbery@sun.com
11251N/A- Bump to 2.9.6.
11251N/A* Sun Feb 12 2006 - damien.carbery@sun.com
11015N/A- Call gettextize to fix infinite loop in configure.
11015N/A* Fri Jan 27 2006 - damien.carbery@sun.com
10935N/A- Bump to 2.9.5
10935N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10889N/A- Bump to 2.9.3
10889N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10821N/A- Bump to 2.9.2.
10821N/A* Tue Dec 20 2005 - damien.carbery@sun.com
10754N/A- Bump to 2.9.1. Remove upstream patch 05-logname. Add intltool BuildRequires.
10754N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10746N/A- Bump to 2.8.4.
10746N/A* Mon Nov 28 2005 - laca@sun.com
10681N/A- prepare for building from CVS snapshots:
10681N/A- use a macro for Version
10622N/A- fix autotool order, add some more
10622N/A- cp mkinstalldirs so that we don't need to add even more autotool foo
10560N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10560N/A- Bump to 2.8.3
10318N/A* Tue Sep 27 2005 - glynn.foster@sun.com
10318N/A- Bump to 2.8.2
10307N/A* Mon Aug 15 2005 - glynn.foster@sun.com
10307N/A- Bump to 2.8.0
10253N/A* Wed Jun 15 2005 - matt.keenan@sun.com
10253N/A- Bump to 2.6.5
10242N/A- Remove patch glib-04-uninstalled-pc.diff
10242N/A* Fri May 06 2005 - brian.cameron@sun.com
10139N/A- Add patch 04 to add needed uninstalled.pc files to allow other
10139N/A base-libs libraries to build. This requires calling autoconf
10139N/A aclocal, etc.
10139N/A- Fix naming of patches since the patches were renamed but this
10139N/A spec file not updated.
10139N/A* Fri May 06 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.6.4
10139N/A* Wed Nov 15 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.8, since otherwise glib-gettextize doesn't create
10139N/A mkinstalldirs properly, and consequently it means I can't create
10139N/A tarballs from CVS sources. We also get a rake of nice bug fixes
10139N/A as a result.
10139N/A* Fri Nov 12 2004 - brian.cameron@sun.com
10139N/A- Modify the default path that glib sets (if the user does not have PATH
10139N/A set), so it does not include "." since ARC determined this is a
10139N/A security concern. When building on Sun, set it to just "/usr/bin"
10139N/A since "/bin" is a symlink to "/usr/bin". On Linux set it to
10139N/A "/bin:/usr/bin".
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- use $CC64 for the 64-bit build if defined
10139N/A* Wed Oct 05 2004 - Yong.Sun@Sun.COM
10139N/A- Added glib-04-convert-utf8.diff to fix CR 5055972
10139N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10139N/A- Create 64bit libraries for Solaris
10139N/A* Thu Sep 16 2004 - ciaran.mcdermott@sun.com
10139N/A- Added glib-03-g11n-allinguas.diff to include hu lingua
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- added --enable-gtk-doc
10139N/A* Thu Aug 05 2004 - archana.shah@wipro.com
10139N/A- Add patch to fix glib get SIGCHLD everytime
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to glib2-l10n-po-1.2.tar.bz2
10139N/A* Thu Jul 08 2004 - stephen.browne@sun.com
10139N/A- ported to rpm4/suse91
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Fri May 14 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.1
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to glib2-l10n-po-1.1.tar.bz2
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to glib2-l10n-po-1.0.tar.bz2
10139N/A* Wed Mar 24 2004 - <glynn.foster@sun.com>
10139N/A- Bump to 2.4.0
10139N/A* Wed Mar 10 2004 - <niall.power@sun.com>
10139N/A- remove glib-02 patch (it wasn't being applied anyway).
10139N/A- bump to 2.3.6
10139N/A* Thu Feb 19 2004 - <damien.carbery@sun.com>
10139N/A- Add patch for glib/gmessages.h to change '...' to '__VA_ARGS__' to build
10139N/A on Solaris. May revisit to use '#ifdef __sun'
10139N/A* Tue Feb 10 2004 - <matt.keenan@sun.com>
10139N/A- Bump to 2.3.2, l10n to 0.7
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- update to 2.3.1
10139N/A* Sat Oct 04 2003 - <laca@sun.com>
10139N/A- update to 2.2.3
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Aug 01 2003 - <markmc@sun.com> 2.2.2-1
10139N/A* Wed Jul 25 2003 - <niall.power@sun.com>
10139N/A- add aaa_base dependency. Fixes postinstall script breakage
10139N/A during OS install.
10139N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10139N/A- add in sun po files
10139N/A* Thu May 12 2003 - <ghee.teo@sun.com>
10139N/A- Initial spec file for glib2
10139N/A