20903N/A#
10139N/A# spec file for package glib2
10139N/A#
20903N/A# Copyright (c) 2003, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner erwannc
10139N/A#
17177N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17177N/A
10139N/AName: glib2
19112N/ALicense: LGPL v2
10139N/AGroup: System/Libraries
22050N/AVersion: 2.32.4
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: Gnome Community
10139N/ASummary: Low level core compatibility library for GTK+ and GNOME
20903N/ASource: http://ftp.gnome.org/pub/GNOME/sources/glib/2.32/glib-%{version}.tar.xz
10139N/A
16360N/A# Patch default-path to not include "." because on Solaris we want to avoid
16428N/A# setting PATH to include the current working directory. This was an
16428N/A# ARC requirement. The GNOME community already decided to not change
16428N/A# this behavior (bugzilla bug 317945), but this change is safe. This
16428N/A# code only gets executed when the user's PATH is unset, which should
16428N/A# be never. Safer to avoid adding "." to PATH.
10491N/A#owner:yippi date:2005-08-14 type:feature
12088N/APatch1: glib-01-default-path.diff
10139N/A# owner:laca type:bug date:2005-10-13
12088N/APatch2: glib-02-gmodule-always-lazy.diff
10139N/A#owner:stephen date:2006-11-01 type:feature bugster:6393731
12088N/APatch3: glib-03-trusted-extensions.diff
12176N/A#owner:padraig date:2008-01-10 type:bug bugster:5105006
12196N/APatch4: glib-04-gio-trash-only-home.diff
12306N/A#owner:dcarbery date:2008-01-30 type:bug bugzilla:385132
12368N/APatch5: glib-05-ac-canonical-host.diff
20216N/A#owner:erwannc date:2011-04-11 type:feature (port)
20216N/APatch6: glib-06-solaris-port.diff
13088N/A#owner:dcarbery date:2008-05-21 type:bug bugzilla:528506
13278N/APatch7: glib-07-ss12-visibility.diff
16768N/A#owner:erwannc date:2008-09-17 type:bug bugzilla:551919
20216N/APatch8: glib-08-gsize.diff
20118N/A#owner:gheet date:2011-03-11 type:bug bugster:6956527
20824N/APatch9: glib-09-cleanup-libs.diff
20127N/A# date:2011-03-14 type:feature owner:yippi bugster:7013977
20216N/APatch10: glib-10-gio-rbac.diff
10139N/AURL: http://www.gtk.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoReqProv: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define pkgconfig_version 0.15.0
10139N/A%define gtk_doc_version 1.1
10139N/A%define intltool_version 0.34.1
10139N/A
10139N/ARequires: aaa_base
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: intltool >= %{intltool_version}
10139N/A
10139N/A%description
10139N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
10139N/Astructure handling for C, portability wrappers, and interfaces for such
10139N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
10139N/Aobject system
10139N/A
10139N/A%package devel
10139N/ASummary: GIMP Toolkit and GIMP Drawing Kit support library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AGlib is the base compatibility library for GTK+ and GNOME. It provides data
10139N/Astructure handling for C, portability wrappers, and interfaces for such
10139N/Aruntime functionality as an event loop, threads, dynamic laoding, and an
10139N/Aobject system
10139N/A
10139N/A%prep
10139N/A%setup -q -n glib-%{version}
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
12819N/A%patch4 -p1
12288N/A%patch5 -p1
20216N/A%patch6 -p1
15377N/A%patch7 -p1
14363N/A%patch8 -p1
15959N/A%patch9 -p1
18549N/A%patch10 -p1
20824N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
20778N/Aexport SED="/usr/gnu/bin/sed"
20790N/Aaclocal-1.11 $ACLOCAL_FLAGS
10139N/Alibtoolize --force --copy
10139N/Agtkdocize
10139N/Aautoheader
20790N/Aautomake-1.11 -a -c -f
20216N/Achmod a+x mkinstalldirs
10139N/Aautoconf
18138N/Aexport CFLAGS="%optflags"
20127N/Aexport LDFLAGS="%_ldflags -lsocket -lsecdb -lnsl"
20903N/A
10318N/A./configure --prefix=%{_prefix} \
10318N/A --mandir=%{_mandir} \
10318N/A --datadir=%{_datadir} \
10318N/A --libdir=%{_libdir} \
10318N/A --bindir=%{_bindir} \
10139N/A --sysconfdir=%{_sysconfdir} \
12140N/A --disable-fam \
20216N/A --disable-dtrace \
20841N/A --enable-shared \
20903N/A $GLIB_EXTRA_CONFIG_OPTIONS \
16309N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
20790N/Aexport SED="/usr/gnu/bin/sed"
10139N/A
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
20903N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
20903N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
20216N/Arm -Rf $RPM_BUILD_ROOT%{_sysconfdir}
17379N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%{_bindir}/*
10139N/A%{_libdir}/lib*.so
10139N/A%{_includedir}/glib-2.0/*
10139N/A%{_libdir}/glib-2.0/include/*.h
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/aclocal/*.m4
10139N/A%{_datadir}/glib-2.0/*
10139N/A%{_datadir}/gtk-doc/html/*
10139N/A%{_mandir}/man1/*
10139N/A%{_mandir}/man3/*
10139N/A
10139N/A%changelog
22050N/A* Sat Sep 15 2012 - brian.cameron@oracle.com
22050N/A- Bump to 2.32.4.
20916N/A* Thu May 17 2012 - brian.cameron@oracle.com
20916N/A- Bump to 2.32.3.
20903N/A* Fri Apr 27 2012 - brian.cameron@oracle.com
20903N/A- Bump to 2.32.1.
20862N/A* Wed Oct 19 2011 - brian.cameron@oracle.com
20862N/A- Bump to 2.30.1.
20841N/A* Fri Sep 30 2011 - brian.cameron@oracle.com
20841N/A- Bump to 2.30.0.
20832N/A* Tue Sep 13 2011 - brian.cameron@oracle.com
20832N/A- Bump to 2.29.90.
20831N/A* Thu Sep 08 2011 - brian.cameron@oracle.com
20831N/A- Bump to 2.29.18.
20824N/A* Sat Aug 06 2011 - brian.cameron@oracle.com
20824N/A- Bump to 2.29.14.
20778N/A* Tue Jul 05 2011 - brian.cameron@oracle.com
20778N/A- Bump to 2.29.10.
20127N/A* Mon Mar 14 2011 - brian.cameron@oracle.com
20127N/A- Add patch glib-14-gio-rbac.diff so desktop entries that need to be run with
20127N/A gksu or pfexec are run properly. Fixes bugster #7013977.
20039N/A* Thu Feb 17 2011 - lin.ma@oracle.com
20039N/A- Fixed 7007407, add new patch.
19123N/A* Wed Nov 17 2010 - dave.lin@oracle.com
19123N/A- Rolled back to previous version 2.25.1.
19088N/A* Thu Oct 21 2010 - brian.cameron@oracle.com
19088N/A- Bump to 2.26.0.
19088N/A- Add patch glib-12-python.diff so that /usr/bin/gtester-report uses Python
19088N/A 2.6.
19088N/A- Remove glib-10-gio-fen.diff and glib-11-gio-fen-assertion-on-root.diff,
19088N/A upstream.
19088N/A- Add glib-10-ellipsis-as-range to fix build issue where an ellipsis (...) is
19088N/A being used to define a range in a case block.
19088N/A- Add glib-11-major-minor-linking.diff. Comments out a couple of dodgy
19088N/A printf's.
18786N/A* Tue May 26 2010 - lin.ma@sun.com
18786N/A- Added glib-11-gio-fen-assertion-on-root.diff for bugzilla:6955199.
18623N/A* Tue Apr 20 2010 - christian.kelly@oracle.com
18623N/A- Bump to 2.25.1.
18549N/A* Tue Apr 06 2010 - lin.ma@sun.com
18549N/A- Added glib-10-gio-fen.diff for doo#10194
18521N/A* Mon Mar 29 2010 - christian.kelly@sun.com
18521N/A- Bump to 2.24.0.
18511N/A* Fri Mar 26 2010 - christian.kelly@sun.com
18511N/A- Bump to 2.23.6.
18436N/A* Thu Mar 11 2010 - christian.kelly@sun.com
18436N/A- Bump to 2.23.5.
18303N/A* Mon Feb 15 2010 - christian.kelly@sun.com
18303N/A- Bump to 2.23.3.
18195N/A* Tue Jan 26 2010 - christian.kelly@sun.com
18195N/A- Bump to 2.23.2.
17605N/A* Thu Oct 22 2009 - harry.fu@sun.com
17605N/A- Remove build option -D__STDC_ISO_10646__ due to doo # 11936.
17496N/A* Wed Oct 14 2009 - dave.lin@sun.com
17496N/A- Bump to 2.22.2
17379N/A* Wed Sep 23 2009 - dave.lin@sun.com
17379N/A- Bump to 2.22.0
17320N/A* Wed Sep 16 2009 - harry.fu@sun.com
17320N/A- Add build option -D__STDC_ISO_10646__ for correct collation.
17234N/A* Sun Sep 06 2009 - dave.lin@sun.com
17234N/A- Bump to 2.21.6
17091N/A* Tue Aug 25 2009 - christian.kelly@sun.com
17091N/A- Bump to 2.21.5.
17091N/A- Upstreamed patch -10-bad-return and -11-gio-fen-undef-function
16821N/A* Mon Jul 20 2009 - lin.ma@sun.com
16821N/A- Add a patch for doo#10117
16802N/A* Sun Jul 19 2009 - christian.kelly@sun.com
16802N/A- Bump to 2.21.4.
16802N/A* Tue Jul 14 2009 - chris.wang@sun.com
16768N/A- Change patch 8,9 owner to erwann
16667N/A* Tue Jun 16 2009 - christian.kelly@sun.com
16667N/A- Bump to 2.21.2.
16667N/A- Remove glib-11-gio-check-mountflag.diff and glib-10-display.diff.
16667N/A- Add glib-10-bad-return.diff.
16653N/A* Mon Jun 15 2009 - ghee.teo@sun.com
16653N/A- patched fix to 585360 for now. Performance fix.
16367N/A* Wed Apr 15 2009 - dave.lin@sun.com
16367N/A- Bump to 2.20.1
16309N/A* Sat Apr 04 2009 - dave.lin@sun.com
16309N/A- Removed the unnecessary option %option_with_gnu_iconv.
16134N/A* Fri Mar 13 2009 - dave.lin@sun.com
16134N/A- Bump to 2.20.0
16030N/A* Mon Mar 02 2009 - dave.lin@sun.com
16030N/A- Bump to 2.19.10
15959N/A* Mon Feb 23 2009 - chris.wang@sun.com
15959N/A- Add patch 09 to fix 64 application fail on check gsize issue
15880N/A* Wed Feb 18 2009 - dave.lin@sun.com
15880N/A- Bump to 2.19.8
15860N/A* Tue Feb 17 2009 - dave.lin@sun.com
15860N/A- Bump to 2.19.7
15838N/A* Fri Feb 13 2009 - dave.lin@sun.com
15838N/A- Bump to 2.19.6
15613N/A* Wed Jan 07 2000 - christian.kelly@sun.com
15613N/A- Bump to 2.19.4.
15613N/A- Remove patch9.
15521N/A* Mon Dec 15 2008 - chris.wang@sun.com
15521N/A- Add patch glib-09-sunpro_c.diff, define G_GNUC_INTERNAL to
15521N/A __attribute__(visibility("hidden")) in SS12
15448N/A* Wed Dec 03 2008 - dave.lin@sun.com
15448N/A- Bump to 2.19.2
15448N/A* Wed Dec 03 2008 - dave.lin@sun.com
15448N/A- Bump to 2.19.1
14363N/A* Wed Sep 17 2008 - chris.wang@sun.com
14363N/A- add patch 08-typedetect to fix defecto bug 3355 core dump from pidgin
14196N/A* Tue Sep 08 2008 - patrick.ale@gmail.com
14196N/A- Correct download URL
14136N/A* Wed Sep 03 2008 - christian.kelly@sun.com
14136N/A- Bump to 2.18.0.
13910N/A* Tue Aug 19 2008 - dave.lin@sun.com
13910N/A- Bump to 2.17.7
13910N/A- Removed the upstreamed patch glib-06-dont-show-zfs.diff
13876N/A* Fri Aug 15 2008 - padraig.obriain@sun.com
13876N/A- Update patch 06-dont-show-zfs to what has been accepted upstream.
13791N/A* Wed Aug 06 2008 - damien.carbery@sun.com
13791N/A- Bump to 2.17.6.
13620N/A* Tue Jul 22 2008 - christian.kelly@sun.com
13620N/A- Bump to 2.17.4
13519N/A* Wed Jul 10 2008 - padraig.obriain@sun.com
13519N/A- Add patch 06-dont-show-zfs.
13497N/A* Thu Jul 03 2008 - damien.carbery@sun.com
13497N/A- Bump to 2.17.3.
13400N/A* Fri Jun 13 2008 - damien.carbery@sun.com
13400N/A- Bump to 2.17.2.
13278N/A* Thu May 29 2008 - damien.carbery@sun.com
13278N/A- Bump to 2.17.0. Remove upstream patches, 06-gio-fen, 08-gio-set-name,
13278N/A 09-gio-fs-type. Renumber remainder.
13109N/A* Tue May 27 2008 - simon.zheng@sun.com
13109N/A- Rework 09-gio-fs-type.diff the same as upstream.
13088N/A* Wed Apr 08 2008 - damien.carbery@sun.com
13088N/A- Add patch ss12-visibility to fix bugzilla 528506. Sun Studio 12 compiler
13088N/A doesn't support aliases for variables. Disable this change until we switch to
13088N/A building with ss12.
13055N/A* Fri May 16 2008 - simon.zheng@sun.com
13055N/A- Add glib-09-gio-fs-type.diff to identify filesystem type on Solaris.
12819N/A* Thu Apr 10 2008 - padraig.obriain@sun.com
12819N/A- Rework glib-04-gio-trash-only-home.diff so that it applies
12812N/A* Wed Apr 08 2008 - damien.carbery@sun.com
12812N/A- Bump to 2.16.3.
12811N/A* Wed Apr 09 2008 - padraig.obriain@sun.com
12811N/A- Added glib-08-gio-set-name.diff.
12765N/A* Thu Apr 03 2008 - padraig.obriain@sun.com
12765N/A- Added glib-07-gio-ignore-fs.diff.
12746N/A* Wed Apr 03 2008 - damien.carbery@sun.com
12746N/A- Bump to 2.16.2.
12619N/A* Tue Mar 18 2008 - lin.ma@sun.com
12619N/A- Added glib-06-gio-fen.diff which is upstreamed and will be available
12619N/A Glib 2.18.0, so it will be removed at that time.
12584N/A* Tue Mar 11 2008 - damien.carbery@sun.com
12584N/A- Bump to 2.16.1.
12468N/A* Tue Feb 26 2008 - damien.carbery@sun.com
12468N/A- Bump to 2.15.6.
12368N/A* Wed Feb 13 2008 - damien.carbery@sun.com
12368N/A- Bump to 2.15.5. Remove upstream patch 05-func. Comment out patch4 as it needs
12368N/A engineer rework. Rename patch6.
12287N/A* Tue Jan 29 2008 - damien.carbery@sun.com
12287N/A- Bump to 2.15.4.
12246N/A* Tue Jan 22 2008 - damien.carbery@sun.com
12246N/A- Bump to 2.15.3.
12196N/A* Mon Jan 07 2008 - damien.carbery@sun.com
12196N/A- Bump to 2.15.2. Remove upstream patch, 04-sed-i. Rename remainder.
12765N/A* Thu Jan 10 2008 - padraig.obriain@sun.com
12176N/A- Add patch glib-05-gio-trash-only-home.diff, rework of gnome-vfs and
12176N/A nautilus patches.
12147N/A* Mon Jan 07 2008 - damien.carbery@sun.com
12152N/A- Bump to 2.15.1. Remove upstream patch, 04-void-return, rename remainder.
12140N/A* Fri Jan 04 2008 - ghee.teo@sun.com
12140N/A- Added --disable-fam as per damien.
12095N/A* Wed Dec 26 2007 - damien.carbery@sun.com
12096N/A- Add patch 05-sed-i to rework sed command for non-GNU sed that doesn't support
12096N/A -i option.
12093N/A* Tue Dec 25 2007 - damien.carbery@sun.com
12093N/A- Add patch 04-void-return. void functions returning values are breaking build.
12092N/A* Fri Dec 21 2007 - damien.carbery@sun.com
12092N/A- Bump to 2.15.0.
12088N/A* Fri Dec 21 2007 - takao.fujiwara@sun.com
12088N/A- Remove glib-01-convert-utf8.diff Fixes 6294268
11989N/A* Tue Nov 27 2007 - damien.carbery@sun.com
11989N/A- Bump to 2.14.4.
11884N/A* Wed Nov 07 2007 - damien.carbery@sun.com
11884N/A- Bump to 2.14.3.
11416N/A* Fri Oct 19 2007 - damien.carbery@sun.com
11416N/A- Bump to 2.14.2.
11330N/A* Tue Oct 2 2007 - laca@sun.com
11330N/A- when building with GNU iconv, hack glib-2.0.pc.in so that /usr/gnu/lib
11330N/A is automatically added to the library search path and RUNPATH
11320N/A* Sat Sep 29 2007 - laca@sun.com
11320N/A- remove --with-libiconv=native option as it appears to break the build
11320N/A on nevada
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- add support for building with GNU libiconv
11251N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11251N/A- Bump to 2.14.1.
11015N/A* Sun Aug 05 2007 - damien.carbery@sun.com
11015N/A- Bump to 2.14.0. Remove upstream patch, 05-gthread-cast.
10935N/A* Fri Jul 13 2007 - damien.carbery@sun.com
10935N/A- Bump to 2.13.7. Add patch 05-gthread-cast from svn trunk.
10889N/A* Mon Jul 02 2007 - damien.carbery@sun.com
10889N/A- Bump to 2.13.6.
10821N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10821N/A- Bump to 2.13.5.
10754N/A* Thu Jun 07 2007 - damien.carbery@sun.com
10754N/A- Bump to 2.13.4.
10746N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10746N/A- Bump to 2.13.3.
10681N/A* Wed May 23 2007 - damien.carbery@sun.com
10681N/A- Bump to 2.13.2. Remove upstream patch, 04-hidden. Renumber rest.
10622N/A* Fri May 11 2007 - damien.carbery@sun.com
10622N/A- Bump to 2.13.1.
10560N/A* Wed May 02 2007 - damien.carbery@sun.com
10560N/A- Bump to 2.12.12.
10318N/A* Thu Mar 15 2007 - laca@sun.com
10318N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
10307N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10307N/A- Removed adding ccdir to PATH
10253N/A* Fri Mar 09 2007 - damien.carbery@sun.com
10253N/A- Bump to 2.12.11.
10242N/A* Thu Mar 08 2007 - damien.carbery@sun.com
10242N/A- Bump to 2.12.10. Remove upstream patch, 04-msgfmt-c. Renumber remainder.
10139N/A* Sun Feb 4 2007 - laca@sun.com
10139N/A- remove patch ALL_LINGUAS.diff - no longer needed; reorder remaining
10139N/A* Wed Jan 17 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.12.9.
10139N/A* Mon Jan 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.12.8.
10139N/A* Fri Jan 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.12.7.
10139N/A* Thu Dec 21 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.12.6.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.12.5. Remove upstream patches, 01-gettext-macro,
10139N/A 05-solaris-thread-flags, 09-use-fdwalk. Renumber remainder.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Wed Nov 01 2006 - stephen.browne@sun.com
10139N/A- added patch glib-11-trusted-extensions.diff: covers bugster 639371
10139N/A* Mon Oct 02 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.12.4.
10139N/A* Mon Sep 25 2006 - padraig.obriain@sun.com
10139N/A- Add patch use-fdwalk for bugzilla 357585
10139N/A* Wed Aug 30 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.12.3.
10139N/A* Wed Aug 16 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.12.2.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.12.1.
10139N/A* Thu Jul 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.12.0.
10139N/A* Thu Jul 13 2006 - laca@sun.com
10139N/A- add patch ALL_LINGUAS.diff that removes the \n's from ALL_LINGUAS in
10139N/A AM_GLIB_GNU_GETTEXT
10139N/A* Thu May 25 2006 - brian.cameron@sun.com
10139N/A- Add patch glib-08-hidden.diff to make sure that the G_HAVE_GNUC_VISIBILITY
10139N/A macro is defined to "__hidden" if using the Sun Forte compiler. This
10139N/A makes sure that symbols that should be hidden are not exported when using
10139N/A our compiler. This resolves the GNOME 2.14 LSARC 2006/202 TCR regarding
10139N/A this issue.
10139N/A* Wed Apr 26 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.2.
10139N/A* Wed Mar 8 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.1.
10139N/A* Sun Feb 26 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.0.
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.6.
10139N/A* Sun Feb 12 2006 - damien.carbery@sun.com
10139N/A- Call gettextize to fix infinite loop in configure.
10139N/A* Fri Jan 27 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.5
10139N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.3
10139N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.2.
10139N/A* Tue Dec 20 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.9.1. Remove upstream patch 05-logname. Add intltool BuildRequires.
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.8.4.
10139N/A* Mon Nov 28 2005 - laca@sun.com
10139N/A- prepare for building from CVS snapshots:
10139N/A- use a macro for Version
10139N/A- fix autotool order, add some more
10139N/A- cp mkinstalldirs so that we don't need to add even more autotool foo
10139N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.8.3
10139N/A* Tue Sep 27 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.8.2
10139N/A* Mon Aug 15 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.8.0
10139N/A* Wed Jun 15 2005 - matt.keenan@sun.com
10139N/A- Bump to 2.6.5
10139N/A- Remove patch glib-04-uninstalled-pc.diff
10139N/A* Fri May 06 2005 - brian.cameron@sun.com
10139N/A- Add patch 04 to add needed uninstalled.pc files to allow other
10139N/A base-libs libraries to build. This requires calling autoconf
10139N/A aclocal, etc.
10139N/A- Fix naming of patches since the patches were renamed but this
10139N/A spec file not updated.
10139N/A* Fri May 06 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.6.4
10139N/A* Wed Nov 15 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.8, since otherwise glib-gettextize doesn't create
10139N/A mkinstalldirs properly, and consequently it means I can't create
10139N/A tarballs from CVS sources. We also get a rake of nice bug fixes
10139N/A as a result.
10139N/A* Fri Nov 12 2004 - brian.cameron@sun.com
10139N/A- Modify the default path that glib sets (if the user does not have PATH
10139N/A set), so it does not include "." since ARC determined this is a
10139N/A security concern. When building on Sun, set it to just "/usr/bin"
10139N/A since "/bin" is a symlink to "/usr/bin". On Linux set it to
10139N/A "/bin:/usr/bin".
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- use $CC64 for the 64-bit build if defined
10139N/A* Wed Oct 05 2004 - Yong.Sun@Sun.COM
10139N/A- Added glib-04-convert-utf8.diff to fix CR 5055972
10139N/A* Sat Oct 2 2004 - Joseph.Townsend@Sun.COM
10139N/A- Create 64bit libraries for Solaris
10139N/A* Thu Sep 16 2004 - ciaran.mcdermott@sun.com
10139N/A- Added glib-03-g11n-allinguas.diff to include hu lingua
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- added --enable-gtk-doc
10139N/A* Thu Aug 05 2004 - archana.shah@wipro.com
10139N/A- Add patch to fix glib get SIGCHLD everytime
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to glib2-l10n-po-1.2.tar.bz2
10139N/A* Thu Jul 08 2004 - stephen.browne@sun.com
10139N/A- ported to rpm4/suse91
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Fri May 14 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.4.1
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to glib2-l10n-po-1.1.tar.bz2
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to glib2-l10n-po-1.0.tar.bz2
10139N/A* Wed Mar 24 2004 - <glynn.foster@sun.com>
10139N/A- Bump to 2.4.0
10139N/A* Wed Mar 10 2004 - <niall.power@sun.com>
10139N/A- remove glib-02 patch (it wasn't being applied anyway).
10139N/A- bump to 2.3.6
10139N/A* Thu Feb 19 2004 - <damien.carbery@sun.com>
10139N/A- Add patch for glib/gmessages.h to change '...' to '__VA_ARGS__' to build
10139N/A on Solaris. May revisit to use '#ifdef __sun'
10139N/A* Tue Feb 10 2004 - <matt.keenan@sun.com>
10139N/A- Bump to 2.3.2, l10n to 0.7
10139N/A* Mon Dec 15 2003 - <glynn.foster@sun.com>
10139N/A- update to 2.3.1
10139N/A* Sat Oct 04 2003 - <laca@sun.com>
10139N/A- update to 2.2.3
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- move lib*.so to -devel, remove *.a, *.la
10139N/A* Fri Aug 01 2003 - <markmc@sun.com> 2.2.2-1
10139N/A* Wed Jul 25 2003 - <niall.power@sun.com>
10139N/A- add aaa_base dependency. Fixes postinstall script breakage
10139N/A during OS install.
10139N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10139N/A- add in sun po files
10139N/A* Thu May 12 2003 - <ghee.teo@sun.com>
10139N/A- Initial spec file for glib2