gedit-plugins.spec revision 18326
#
# spec file for package: gedit-plugins
#
# Copyright (c) 2010 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner jouby
#
Name: gedit-plugins
Summary: Plugins for gedit
Version: 2.28.0
Release: 1
License: GPLv2
Url: http://live.gnome.org/Gedit/Plugins
Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
#Group: Accessories
BuildRoot: %{_tmppath}/%{name}-%{version}-build
#SUNW_Basedir: /
#SUNW_Copyright: %{name}.copyright
#%include default-depend.inc
%description
Plugins for gedit including: bracketcompletion charmap codecomment colorpicker
drawspaces joinlines sessionsaver showtabbar smartspaces terminal
%prep
rm -rf %name-%version
%setup -q -n %name-%version
%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
export CFLAGS="%optflags"
export LDFLAGS="%{_ldflags}"
./configure --prefix=%{_prefix} \
--bindir=%{_bindir} \
--mandir=%{_mandir} \
--infodir=%{_infodir} \
--sysconfdir=%{_sysconfdir} \
--disable-scrollkeeper
make -j$CPUS
%install
rm -rf $RPM_BUILD_ROOT
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm -f $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/*.pyo
rm -f $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/*/*.pyo
%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gedit-show-tabbar-plugin.schemas"
for S in $SCHEMAS; do
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done
%clean
rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Feb 23 2010 - yuntong.jin@sun.com
- Initial this base spec