gdm.spec revision 12797
10139N/A#
10139N/A# spec file for package gdm
10139N/A#
12147N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: yippi
10139N/A#
10139N/A%include l10n.inc
10139N/AName: gdm
10139N/ALicense: GPL
16367N/AGroup: System/GUI/GNOME
10139N/A#### DO NOT BUMP MODULE TO 2.21.x AS IT IS BEING REWRITTEN AND WILL BREAK ARC.
10139N/AVersion: 2.20.5
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
16134N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: The GNOME 2.x Display Manager
16360N/ASource: http://ftp.gnome.org/pub/GNOME/sources/gdm/2.20/gdm-%{version}.tar.bz2
16428N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
16428N/A%if %build_l10n
16428N/ASource2: l10n-configure.sh
16428N/A%endif
16428N/A%if %option_with_sun_branding
10491N/A#owner:yippi date:2004-11-24 type:branding
12088N/APatch1: gdm-01-sun-branding.diff
10139N/A%endif
12088N/A%if %option_with_indiana_branding
10139N/A#owner:yippi date:2007-10-05 type:branding
12088N/APatch1: gdm-01-indiana-branding.diff
12176N/A%endif
12196N/A#owner:yippi date:2007-08-02 type:feature bugzilla:457871
12306N/APatch2: gdm-02-showlocale.diff
12368N/A#owner:fujiwara date:2008-02-29 type:feature
13088N/APatch3: gdm-03-locale-support.diff
13278N/AURL: www.gnome.org
14363N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
14363N/ADocdir: %{_defaultdocdir}
15959N/AAutoreqprov: on
15959N/APrereq: /usr/sbin/groupadd
10139N/APrereq: /usr/sbin/useradd
10139N/APrereq: /sbin/nologin
10139N/APrereq: sed
10139N/APrereq: coreutils
10139N/A
10139N/A%define pango_version 1.4.0
10139N/A%define gtk2_version 2.4.0
10139N/A%define libglade_version 2.3.6
10139N/A%define libgnomeui_version 2.6.0
10139N/A%define libgnomecanvas_version 2.6.0
10139N/A%define librsvg_version 2.5.0
10139N/A%define libxml2_version 2.6.7
10139N/A%define scrollkeeper_version 0.3.14
10139N/A%define pam_version 0.77
10139N/A%define gail_version 1.6.3
10139N/A%define XFree86_version 4.3.99
10139N/A%define usermode_version 1.68
10139N/A%define openssl_version 0.9.7d
10139N/A
10139N/A%define dsp_mgr_file /etc/sysconfig/displaymanager
10139N/A%define xdm_rc_file /etc/init.d/xdm
10139N/A
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: sun-gdm-themes
10139N/ARequires: libglade >= %{libglade_version}
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: libgnomecanvas >= %{libgnomecanvas_version}
10139N/ARequires: librsvg >= %{librsvg_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: pam >= %{pam_version}
10139N/ARequires: usermode >= %{usermode_version}
10139N/ARequires: openssl >= %{openssl_version}
10139N/A
10139N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
10139N/ABuildRequires: pango-devel >= %{pango_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
12819N/ABuildRequires: libglade-devel >= %{libglade_version}
12288N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
15377N/ABuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
14363N/ABuildRequires: librsvg-devel >= %{librsvg_version}
15959N/ABuildRequires: libxml2-devel >= %{libxml2_version}
10139N/ABuildRequires: pam-devel >= %{pam_version}
10139N/ABuildRequires: XFree86-devel >= %{XFree86_version}
10139N/ABuildRequires: gail-devel >= %{gail_version}
10139N/ABuildRequires: usermode >= %{usermode_version}
10139N/ABuildRequires: openssl-devel >= %{openssl_version}
10139N/A
10139N/A%description
10139N/AThis version of GDM, the GNOME Display manager is based on
10139N/AGTK2 and suited for the GNOME Desktop Environment. GDM is a
10139N/Aflexible X-Window Display Manager that allows to set many
10139N/Aoptions, usable for remote login, and provides a good looking
10139N/Agraphical interface.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10139N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
10318N/A%if %option_with_sun_branding
10318N/A%patch1 -p1
10318N/A%endif
10318N/A%if %option_with_indiana_branding
10318N/A%patch1 -p1
10318N/A%endif
10318N/A%patch2 -p1
10139N/A%patch3 -p1
12140N/A
16309N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport CFLAGS="$RPM_OPT_FLAGS"
10139N/Aautoheader
10139N/Aautoconf
10139N/A
10139N/AENABLE_CONSOLE_HELPER=
10139N/A%ifos linux
10139N/AENABLE_CONSOLE_HELPER="--enable-console-helper"
10139N/A%endif
10139N/A
10139N/ABINDIR_CONFIG=""
10139N/ACTRUN_CONFIG=""
10139N/A%ifos solaris
10139N/ABINDIR_CONFIG="--with-post-path=/usr/openwin/bin"
10139N/ACTRUN_CONFIG="--with-ctrun"
10139N/A%endif
10139N/A
10139N/Alibtoolize --force
10139N/Aglib-gettextize -c -f
10139N/Aintltoolize --copy --force --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE2 --enable-copyright
10139N/A%endif
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoconf
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/A./configure \
16367N/A --prefix=%{_prefix} \
16367N/A --sysconfdir=%{_sysconfdir}/X11 \
16309N/A --localstatedir=%{_localstatedir}/lib \
16309N/A --mandir=%{_mandir} \
16134N/A --with-pam-prefix=%{_sysconfdir} \
16134N/A --libexecdir=%{_libexecdir} \
16030N/A --with-prefetch \
16030N/A --with-console-kit=no \
15959N/A --disable-scrollkeeper \
15959N/A --enable-ipv6=yes $ENABLE_CONSOLE_HELPER $BINDIR_CONFIG $CTRUN_CONFIG
15880N/Amake -j $CPUS
15880N/A
15860N/A%install
15860N/Amake install DESTDIR=$RPM_BUILD_ROOT
15838N/A#
15838N/A# Remove gdmflexiserver.desktop until Virtual Termainals are supported
15613N/A# on Solaris. Continue shipping gdmflexiserver-xnest.desktop since
15613N/A# running GDM in a Xnest window does work.
15613N/A#
15521N/A%ifos solaris
15521N/Arm -f $RPM_BUILD_ROOT%{_datadir}/applications/gdmflexiserver.desktop
15521N/A%endif
15448N/A
15448N/A%if %option_without_dt
15448N/Arm $RPM_BUILD_ROOT%{_datadir}/xsessions/CDE.desktop
15448N/A%endif
14363N/A
14363N/A# Clean up unpackaged files
14196N/A#
14196N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.a
14136N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
14136N/Arm -rf $RPM_BUILD_ROOT%{_localstatedir}/lib/scrollkeeper
13910N/A
13910N/A%clean
13910N/Arm -rf $RPM_BUILD_ROOT
13876N/A
13876N/A%pre
13791N/A/usr/sbin/groupadd -r -g 50 gdm
13791N/A/usr/sbin/useradd -r -o -g gdm -u 50 -s /sbin/nologin \
13620N/A-c "Gnome Display Manager daemon" -d /var/lib/gdm gdm 2> /dev/null || :
13620N/A
13519N/A
13519N/A%post
13497N/Aif [ -f %{dsp_mgr_file} ]; then
13497N/A sed -e 's/^DISPLAYMANAGER=.*/DISPLAYMANAGER="gdm"/' %{dsp_mgr_file} > /tmp/displaymanager.$$
13400N/A
13400N/A if [ $? -eq 0 ]; then
13278N/A mv /tmp/displaymanager.$$ %{dsp_mgr_file}
13278N/A fi
13278N/Afi
13109N/A
13109N/Aif [ -f %{xdm_rc_file} ]; then
13088N/A sed -e 's#^\( *gdm.*DISPLAYMANAGER=\)\(.*\)#\1/usr/bin/gdm ;;#' %{xdm_rc_file} > /tmp/xdm.$$
13088N/A
13088N/A if [ $? -eq 0 ]; then
13088N/A mv /tmp/xdm.$$ %{xdm_rc_file}
13055N/A chmod 755 %{xdm_rc_file}
13055N/A fi
12819N/Afi
12819N/A
12812N/A
12812N/A%files
12811N/A%config %attr(-,gdm,gdm) %{_sysconfdir}/X11/gdm
12811N/A%config %attr(-,root,root) %{_sysconfdir}/X11/dm
12765N/A%{_datadir}/locale/*/LC_MESSAGES/gdm*.mo
12765N/A%{_sbindir}/*
12746N/A%{_bindir}/*
12746N/A%{_libdir}/gtk-2.0/modules/*.so
12619N/A%{_libexecdir}/*
12619N/A%{_datadir}/gdm
12619N/A%{_datadir}/pixmaps/*.png
12584N/A%{_datadir}/pixmaps/faces/*.jpg
12584N/A%{_datadir}/pixmaps/faces/*.png
12468N/A%{_datadir}/icons
12468N/A%{_datadir}/gnome/help/*
12368N/A%{_datadir}/xsessions/*
12368N/A%{_mandir}/man1/*
12368N/A%{_datadir}/omf/*
12287N/A%attr(-,gdm,gdm) /var/lib/gdm
12287N/A%config /etc/pam.d/*
12246N/A%config /etc/security/*
12246N/A
12196N/A%changelog
12196N/A* Mon Apr 07 2008 - brian.cameron@sun.com
12765N/A- Bump to 2.20.5.
12176N/A* Mon Mar 10 2008 - brian.cameron@sun.com
12176N/A- Bump to 2.20.4.
12147N/A* Fri Feb 29 2008 - takao.fujiwara@sun.com
12152N/A- Add gdm-03-locale-support.diff
12140N/A* Mon Jan 07 2008 - brian.cameron@sun.com
12140N/A- Bump to 2.20.3 and remove upstream patch.
12095N/A* Tue Nov 27 2007 - brian.cameron@sun.com
12096N/A- Remove upstream gdm-03-sockaddr-len.diff patch and added new
12096N/A gdm-03-xdmcp-close.diff patch needed for XDMCP to work properly.
12093N/A* Tue Nov 27 2007 - damien.carbery@sun.com
12093N/A- Bump to 2.20.2.
12092N/A* Thu Nov 08 2007 - brian.cameron@sun.com
12092N/A- Add patch gdm-03-sockaddr-len.diff to fix XDMCP so it works.
12088N/A* Fri Oct 19 2007 - damien.carbery@sun.com
12088N/A- Bump to 2.20.1.
11989N/A* Fri Oct 5 2007 - laca@sun.com
11989N/A- use separate branding patches for nevada and indiana
11884N/A- delete CDE.desktop when --without-dt is used
11884N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11416N/A- Bump to 2.20.0.
11416N/A* Thu Sep 06 2007 - damien.carbery@sun.com
11330N/A- Bump to 2.19.8.
11330N/A* Tue Aug 28 2007 - damien.carbery@sun.com
11330N/A- Bump to 2.19.7.
11320N/A* Wed Aug 15 2007 - brian.cameron@sun.com
11320N/A- Bump to 2.19.6. Remove upstream patch.
11320N/A* Thu Aug 02 2007 - brian.cameron@sun.com
11314N/A- Add patch gdm-02-showlocale.diff to address bugzilla bug #457871.
11314N/A* Tue Jul 31 2007 - damien.carbery@sun.com
11251N/A- Bump to 2.19.5. Remove upstream patch, 02-g11n-memory-handle.
11251N/A* Fri Jul 13 2007 - takao.fujiwara@sun.com
11015N/A- Added gdm-02-g11n-memory-handle.diff for memory handling.
11015N/A* Tue Jul 10 2007 - damien.carbery@sun.com
10935N/A- Bump to 2.19.4. Remove upstream patch, 02-vtsupport.
10935N/A* Thu Jun 21 2007 - brian.cameron@sun.com
10889N/A- Add patch for better utmpx processing and for VT support when it goes
10889N/A into Nevada.
10821N/A* Mon Jun 18 2007 - damien.carbery@sun.com
10821N/A- Bump to 2.19.3. Remove upstream patch, 02-xnestperms.
10754N/A* Mon Jun 11 2007 - brian.cameron@sun.com
10754N/A- Add patch to fix GDM so it doesn't modify device permissions if logging
10746N/A into a xnest session.
10746N/A* Mon Jun 4 2007 - brian.cameron@sun.com
10681N/A- Bump to 2.19.2. Remove upstream patch gdm-02-no-gdm-in-cde-menu.diff.
10681N/A* Thu Jue 1 2007 - simon.zheng@sun.com
10622N/A- Point download path to 2.19.
10622N/A* Mon May 14 2007 - brian.cameron@sun.com
10560N/A* Merge patch gdm-03-nossh-in-xsession.diff with gdm-01-branding.diff
10560N/A since this is really a branding change.
10318N/A* Mon May 14 2007 - brian.cameron@sun.com
10318N/A- Bump to 2.19.1.
10307N/A* Fri May 11 2007 - brian.cameron@sun.com
10307N/A- Add --with-ctrun flag since I udpated the patch to require this
10253N/A argument. This way people who want to build GDM on Solaris without
10253N/A SVC can do so. Also added new gdm-05-nossh-in-xsession.diff patch.
10242N/A* Thu May 10 2007 - brian.cameron@sun.com
10242N/A- Bump to 2.19.0
10139N/A* Thu Apr 12 2007 - brian.cameron@sun.com
10139N/A- Fix upstream bug where if you fail to enter the proper root password
10139N/A after asking to run "Configure GDM" from the login menu, it asks for
10139N/A the password again. If you type it in properly, then it starts a
10139N/A session as the root user. This patch fixes this problem.
10139N/A* Tue Apr 10 2007 - brian.cameron@sun.com
10139N/A- Backout patch gdm-06-languages.diff since the patch doesn't work
10139N/A properly. Code needs to be backported from gdm SVN head, and I'll add
10139N/A back the patch later if we decide we need this in GNOME 2.18.
10139N/A* Mon Apr 09 2007 - brian.cameron@sun.com
10139N/A- Bump to 2.18.1.
10139N/A* Wed Mar 21 2007 - brian.cameron@sun.com
10139N/A- Add gdm-10-desktop.diff to fix Catagory in gdmsetup and gdmphotosetup
10139N/A desktop file.
10139N/A* Tue Mar 13 2007 - brian.cameron@sun.com
10139N/A- Add gdm-07-xephyr.diff and gdm-08-nodbus.diff patches. Both are
10139N/A upstream.
10139N/A* Mon Mar 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.
10139N/A* Fri May 09 2007 - brian.cameron@sun.com
10139N/A- Add patch gdm-07-fixdesktop.diff to move GDM desktop entries into
10139N/A control center. Add patch gdm-08-fixxnest.diff to fix GDM to send
10139N/A the right fontpath to the Xsun Xnest program. Add patch
10139N/A gdm-09-no-gdm-in-cdu-menu.diff to ensure that GDM desktop menu
10139N/A choices only appear if using GDM. If not using GDM these programs
10139N/A are non-functional.
10139N/A* Fri Mar 02 2007 - brian.cameron@sun.com
10139N/A- Bump to 2.17.8
10139N/A* Wed Feb 28 2007 - brian.cameron@sun.com
10139N/A- Add patch to fix bugster bug #4877721 and bugzilla bug #108820.
10139N/A This patch won't go into GDM until 2.19, but we want this patch
10139N/A to go into 2.18 for Solaris.
10139N/A* Tue Feb 15 2007 - brian.cameron@sun.com
10139N/A- Remove sessionexit patch due to patch review comments.
10139N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
10139N/A- Add l10n tarball.
10139N/A* Tue Feb 13 2007 - brian.cameron@sun.com
10139N/A- Bump to 2.17.7 and add sessionexit patch to fix bugster bug
10139N/A 6228488.
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.6.
10139N/A* Mon Jan 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.5. Remove upstream patch, 07-fixdialogs.
10139N/A* Sun Dec 17 2006 - laca@sun.com
10139N/A- delete upstream patch fixsecurity.diff
10139N/A- renumber remaining patch
10139N/A* Fri Dec 15 2006 - brian.cameron@sun.com
10139N/A- Patch from CVS head to fix dialog boxes so that they display text.
10139N/A* Thu Dec 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.4.
10139N/A* Wed Dec 06 2006 - brian.cameron@sun.com
10139N/A- Remove Linux specific gdm-01-branding-defaults-linux.diff and
10139N/A gdm-03-pam-security-setup.diff. Add patch comments.
10139N/A* Tue Dec 05 2006 - brian.cameron@sun.com
10139N/A- Add patch gdm-08-fixsecurity.diff to fix a security vulnerability found
10139N/A in gdmchooser.
10139N/A* Tue Dec 05 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.3. Remove upstream patches, 07-linguas, 10-fixsessionname,
10139N/A 09-gdmsetup-launch-menu-tooltip and 11-defaultdesc: Renumber remainder.
10139N/A* Thu Nov 27 2006 - brian.cameron@sun.com
10139N/A- Patch to fix setting the sesison name for gnome.desktop.
10139N/A Define better name for default.desktop and turn off console kit support
10139N/A since it doesn't work on Solaris yet.
10139N/A* Thu Nov 23 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patchs, 09-sun-branding-patch and 10-fixfocus. Renumber
10139N/A remainder.
10139N/A* Mon Nov 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.2.
10139N/A* Wed Nov 15 2006 - calum.benson@sun.com
10139N/A- Modify tooltip to match latest UI spec.
10139N/A* Tue Oct 31 2006 - brian.cameron@sun.com
10139N/A- Add patch to fix focus problem, fixed in CVS head.
10139N/A* Tue Oct 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.2.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.1. Remove upstream patch, gdm-10-fixcrash.diff.
10139N/A* Sat Sep 23 2006 - brian.cameron@sun.com
10139N/A- Add patch to fix crashing.
10139N/A* Tue Sep 05 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.0.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.10.
10139N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.9.
10139N/A* Tue Aug 01 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.8.
10139N/A* Fri Jul 28 2006 - dermot.mccluskey@sun.com
10139N/A- Fix minor typo.
10139N/A* Wed Jul 26 2006 - brian.cameron@sun.com
10139N/A- No longer set --with-at-bindir when calling configure since gok and
10139N/A gnopernicus are now in the standard /usr/bin location, not /usr/sfw/bin.
10139N/A* Wed Jul 26 2006 - brian.cameron@sun.com
10139N/A- Remove patches 7 and 11, merged into CVS head. Also remove
10139N/A gdmflexiserver.desktop from Solaris builds since we do not support
10139N/A Virtual Terminals. Running this menu choice causes the session to
10139N/A hang on Solaris, so we shouldn't put it in the menus.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.7.
10139N/A* Fri Jun 16 2006 - brian.cameron@sun.com
10139N/A- Fix focus so it returns to entry field after session, language, restart,
10139N/A suspend, and shutdown dialogs are used from options button.
10139N/A* Mon Jun 12 2006 - brian.cameron@sun.com
10139N/A- Bumped to 2.14.9. This fixes automatic login, which was broken, and
10139N/A corrects a number of warnings that were causing core dumping issues.
10139N/A* Wed Jun 07 2006 - brian.cameron@sun.com
10139N/A- Bumped to 2.14.8. Removed patches no longer needed. This fixes a serious
10139N/A security issue where a user can access the gdmsetup GUI with their user
10139N/A password if the face browser is enabled (off by default on Solaris).
10139N/A* Tue Jun 06 2006 - brian.cameron@sun.com
10139N/A- Added patch gdm-12-fixflexiserver.diff to fix a core dumping problem.
10139N/A Modified gdm-01-branding-defaults-solaris.diff to better integrate with
10139N/A ctrun and updated the gdm.xml SVC manifest so that core dumps do not
10139N/A cause GDM to restart. Removed gdm-05-fix-a11y-crash.diff since it didn't
10139N/A work as a fix.
10139N/A* Mon May 23 2006 - brian.cameron@sun.com
10139N/A- Bump to 2.14.7.
10139N/A* Fri May 19 2006 - glynn.foster@sun.com
10139N/A- Don't show the login photo dialog in the menus - removed according to
10139N/A the UI spec, and the functionality should really be apart of the
10139N/A 'Personal Information' dialog.
10139N/A* Fri May 12 2006 - brian.cameron@sun.com
10139N/A- Added patch gdm-12-fixconfig.diff to fix a problem that prevents users
10139N/A from disabiling the failsafe session in the menu.
10139N/A* Fri May 12 2006 - brian.cameron@sun.com
10139N/A- Updated to 2.14.6 which has the new features included in the patch
10139N/A added in the previous comment. Replace the patch with a much smaller
10139N/A patch that just adds the "startagain" feature. This is much more
10139N/A maintainable. Also added a patch to update the Lanugage display
10139N/A provided by Peter Nugent.
10139N/A* Thu May 11 2006 - brian.cameron@sun.com
10139N/A- Add patch to add per-display configuration needed by SunRay.
10139N/A This patch also adds the updated Cancel button, the pam-error-logo,
10139N/A and real GTK+ buttons needed by Coolstart branding. These changes
10139N/A all copied from GDM CVS head.
10139N/A* Tue May 09 2006 - brian.cameron@sun.com
10139N/A- Remove two patches that have been integrated into GDM, and add the
10139N/A avoidchown patch so that building this package works if you are a
10139N/A running as non-root.
10139N/A* Wed May 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.5.
* Wed Apr 26 2006 - damien.carbery@sun.com
- Bump to 2.14.4.
* Tue Apr 25 2006 - damien.carbery@sun.com
- Bump to 2.14.3.
* Tue Apr 18 2006 - damien.carbery@sun.com
- Bump to 2.14.2.
* Thu Apr 13 2006 - damien.carbery@sun.com
- Remove upstream patches, 10-libvicious-dir and 11-fixaudit.
* Tue Apr 11 2006 - damien.carbery@sun.com
- Bump to 2.14.1.
* Tue Mar 14 2006 - damien.carbery@sun.com
- Bump to 2.14.0.
* Mon Mar 13 2006 - brian.cameron@sun.com
- Add patch 11 to fix auditing logic. This patch can go away when the
GDM 2.14.1 comes out.
* Fri Mar 3 2006 - damien.carbery@sun.com
- Bump to 2.13.0.10.
* Tue Feb 28 2006 - damien.carbery@sun.com
- Bump to 2.13.0.9.
- Remove upstream patch, 11-fixcore.
* Thu Feb 16 2006 - brian.cameron@sun.com
- Add patch 11 to fix core dumping issue in gdmsetup. This fix is in
CVS head so it can go away when we update to the next version of GDM.
* Tue Feb 14 2006 - damien.carbery@sun.com
- Bump to 2.13.0.8.
* Tue Jan 31 2006 - damien.carbery@sun.com
- Bump to 2.13.0.7.
* Thu Jan 19 2006 - brian.cameron@sun.com
- Bump to 2.13.0.6.
* Mon Jan 16 2006 - damien.carbery@sun.com
- Move sfw reference (a Solaris specific dir) to SUNWgnome-display-mgr.spec.
* Mon Jan 16 2006 - padraig.obriain@sun.com
- Bump to 2.13.0.5; dd --with-prefetch and add /usr/sfw/include to CFILES to
find <tcpd.h>
* Sun Jan 15 2006 - damien.carbery@sun.com
- Bump to 2.13.0.4
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 2.13.0.3
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 2.8.0.7.
* Thu Oct 13 2005 - damien.carbery@sun.com
- Added patch, 10-libvicious-dir, to remove dir in vicious-extensions
Makefile.am, as it caused build to fail.
* Tue Oct 11 2005 - damien.carbery@sun.com
- Bump to 2.0.8.5
* Wed Sep 21 2005 - brian.cameron@sun.com
- Bump to 2.8.0.4
* Wed Sep 07 2005 - damien.carbery@sun.com
- Remove capplets dir from %files. Contents moved in 2.8.0.3.
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.8.0.3.
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 2.8.0.1.
* Wed Aug 03 2005 - laca@sun.com
- remove upstream patch xnext-remote-session.diff
* Thu Jul 14 2005 - damien.carbery@sun.com
- Add unpackaged files to %files (pixmaps/faces and gnome/capplets).
* Wed Jul 13 2005 - brian.cameron@sun.com
- Upgraded to 2.8.0.1
* Fri Jun 10 2005 - matt.keenan@sun.com
- Re-applied patch 01 linux branding
- Added patch 04/05 to build
* Tue May 10 2005 - leena.gunda@wipro.com
- Added patch gdm-45-xnest-remote-session.diff to allow remote login
using XDMCP chooser in nested window. Fixes bug #6245415.
* Tue Apr 19 2005 - bill.haneman@sun.com
- Reinstated xevie-enabling patch on Linux, via gdm-44-linux-xevie.diff.
* Fri Apr 1 2005 - brian.cameron@sun.com
- Add patch 43 so that we set the Xserver on Solaris to
/usr/X11/bin/Xserver instead of /usr/X11/bin/X as per ARQ
request. Also now put /usr/openwin/bin in the user default
patch here instead of in SUNWdtlogin-integration.spec.
* Thu Mar 17 2005 - brian.cameron@sun.com
- Add patch 42 to allow configure to specify the full path to the
a11y AT programs used in the gesture listener configuration files.
Patch in gdm CVS head.
* Thu Mar 10 2005 - Chookij.Vanatham@Sun.COM
- Fix gdm to fork user's session with "system locale" if "Default" option
at the language menu being selected. [CR Id: 5032088]
* Thu Mar 03 2005 - brian.cameron@sun.com
- Fix XDMCP logic so that it works when an IPv4 address requests a
connection and IPV6 is enabled in GDM. Patch40 fixes this.
* Tue Mar 01 2005 - dermot.mccluskey@sun.com
- remove patch 40 (XEVIE) - break new X server
* Fri Feb 25 2005 - brian.cameron@sun.com
- Added patch 40 to turn on XEVIE on Linux by default for the
standard server to meet a11y requirements. Fixes bug 6226645.
* Thu Feb 24 2005 - brian.cameron@sun.com
- Added branding patch 39 to change the GNOME string to "Java Desktop
System" in a number of places in the c-code.
* Tue Feb 22 2005 - brian.cameron@sun.com
- Backed out patch 39/40 since ARC determined that these flags should
not be set by default after initially indicating it was okay.
* Mon Feb 14 2005 - brian.cameron@sun.com
- Added patch 39/40 to support setting the Xserver with needed
a11y Xserver flags. Fixes CR 6226645.
* Tue Feb 08 2005 - brian.cameron@sun.com
- Removed --with-post-path argument since /usr/dt/bin and
/usr/openwin/bin are added also by the /usr/dt/config/Xinitrc.jds.
No need to have them in the PATH twice. Also we do not
need to add /usr/demo/jds/bin since all the *.desktop files
have full-paths defined.
* Mon Feb 07 2005 - brian.cameron@sun.com
- Added patch-38 to more cleanly set the default PATH. This replaces
patches gdm-15-default.path.diff and gdm-16-reboot-shutdown-option.diff.
The new patch sets more sensible definitions for Halt, Reboot, Shutdown
commands on Solaris. Also updated gdm-18-help.diff so it forwards
the user to the right subsection when running gdmsetup help.
* Fri Jan 21 2005 - brian.cameron@sun.com
- Now only apply patch 37 when building on Linux. Modified patch 37 to
include needed changes for Solaris.
* Tue Jan 18 2005 - brian.cameron@sun.com
- Added patch gdm-37-branding.diff to fix branding issue in gnome.desktop
file. Also updated gdm-21-fix-a11y-crash.diff patch so it works on
JDS Linux.
* Fri Jan 14 2005 - kazuhiko.maekawa@sun.com
- Updated l10n help tarball for cinnabar-linux
* Thu Dec 30 2004 - Chookij.Vanatham@Sun.COM
- #6213083 - Add note that legacy locales are NOT SUPPORTED for linux platform.
* Wed Dec 22 2004 - leena.gunda@wipro.com
- Added gdm-35-flexi-xdmcp-option.diff to make XDMCP chooser work in
flexiserver. Fixes bug #4992853.
* Fri Nov 26 2004 - leena.gunda@wipro.com
- Added gdm-34-xsession-use-ksh.diff to execute Xsession script using
ksh on Solaris. Fixes stopper bug #6199960.
* Wed Nov 24 2004 - Chookij.Vanatham@Sun.COM
- #6196675 - all single byte locales removed.
* Thu Nov 18 2004 - hidetoshi.tajima@sun.com
- #5081827 - run /usr/dt/config/Xsession.jds instead of gnome-session
for gnome session vid gdm. Solaris only.
* Wed Nov 17 2004 - matt.keenan@sun.com
- #6195855 Install correct man page
* Wed Nov 10 2004 - Chookij.Vanatham@Sun.COM
- Added gdm-31-current-locale.diff to fix bug#5100351
* Wed Nov 10 2004 - leena.gunda@wipro.com
- Remove gdm-26-start-gnome-volcheck.diff as gnome-volcheck is now
started by gnome-session.
* Mon Nov 09 2004 - alvaro.lopez@sun.com
- Added new patch 31. It fixes #6182860: IPv6 logic is broken for New
Login in a Nested Window, so the enable-ipv6 parameter of configure
is "yes" again.
* Mon Nov 01 2004 - hidetoshi.tajima@sun.com
- Modify gdm-07-set-lc-messages-to-lang.diff. set LANG from RC_LANG
in /etc/sysconfig/language when it is NULL. (CR 6188663)
* Fri Oct 29 2004 - damien.carbery@sun.com
- Add gdm-30-xorg-conf.diff to fix 6185918. configure.in checks for Xorg
binary before looking for X (Xsun) binary.
* Thu Oct 28 2004 - matt.keenan@sun.com
- Added gdm-binary.1.gz, gdm.1.gz, gdmXnest.1.gz, gdmXnestchooser.1.gz,
gdmchooser.1.gz, gdmflexiserver.1.gz, gdmgreeter.1.gz, gdmlogin.1.gz,
gdmphotosetup.1.gz, gdmsetup.1.gz, gdmthemetester.1.gz, gdm-restart.1m.gz,
gdm-safe-restart.1m.gz, gdm-stop.1m.gz, gdmconfig.1m.gz man pages
* Thu Oct 28 2004 - kazuhiko.maekawa@sun.com
- Updated l10n help tarball and added pt_BR
* Fri Oct 22 2004 - alvaro.lopez@sun.com
- "Source" entry updated
* Thu Oct 21 2004 - brian.cameron@sun.com
- Removed ipv6 support (--enable-ipv6=no) since this is breaking
gdm's ability to "login in a nested window". Created bug 6182860
so that issue gets fixed.
* Wed Oct 20 2004 - leena.gunda@wipro.com
- Added patch gdm-27-alt-meta-mapping.diff to restore 'Alt' and 'Meta'
mappings on sparc Solaris. Fixes bug 6173594.
* Wed Oct 20 2004 - leena.gunda@wipro.com
- Added patch gdm-26-start-gnome-volcheck.diff to start gnome-volcheck
if Xserver is local. Fixes bug #5107205.
* Fri Oct 15 2004 - brian.cameron@sun.com
- Correct GreenLine integration. The problem with disabling core dumps
in the GreenLine XML file is that this causes GreenLine to ignore
core dumps for all programs, including gdm. Now using patch 25
we use ctrun to specify that only programs launched from gdm's
Xsession script (the user's session) are run in a separate GreenLine
contract that ignores core dumps. This way if gdm itself core dumps,
GreenLine will correctly default back to the console login.
* Thu Oct 14 2004 - brian.cameron@sun.com
- Added patch gdm-24-sanitize-conf.diff to clean up language in
gdm.conf file. Fixes bug 5097046.
* Wed Oct 06 2004 - balamurali.viswanathan@wipro.com
- Add patch gdm-22-xserver-location.diff to set GDM_XSERVER_LOCATION
with the x server type. Fixes bug #6174802
* Wed Oct 06 2004 - padraig.obriain@sun.com
- Added patch gdm-21-fix-a11y-crash.diff to remove
/var/tmp/orbit-gdm/bonobo-activation-server-ior. Fixes bug #5103715.
* Tue Oct 05 2004 - balamurali.viswanathan@wipro.com
- Modified patch gdm-15-default-path.diff to add
/usr/openwin/bin to the path. Fixes bug #5106790
* Mon Oct 04 2004 - yuriy.kuznetsov@sun.com
- Added gdm-20-g11n-i18n-button.diff to fix bug#5109970
* Wed Sep 29 2004 - <hidetoshi.tajima@sun.com>
- updated gdm-03-locale-alias.diff to remove non-UTF-8
locale entries from Traditional Chinese (big5 and big5hkscs)
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- Added chmod xdm in post-install script
* Fri Sep 17 2004 - bill.haneman@sun.com
- Added patch gdm-20-gdmwm-struts.diff, to fix bugzilla
#143634.
* Thu Sep 16 2004 - dermot.mccluskey@sun.com
- Added post install script to set gdm as displaymanager
* Wed Sep 15 2004 - archana.shah@wipro.com
- Patch added gdm-19-add-acroread-path.diff
Fixes bug# 5087934
* Thu Aug 26 2004 - vinay.mandyakoppal@wipro.com
- Patch gdm-18-help.diff provide help link.
* Thu Aug 26 2004 - bill.haneman@sun.com
- Updated patch gdm-10-a11y-gestures.diff.
* Tue Aug 24 2004 - brian.cameron@sun.com
- Enabling ipv6.
* Tue Aug 24 2004 - glynn.foster@sun.com
- Add back icons
* Tue Aug 24 2004 - laszlo.kovacs@sun.com
- removed some icons
* Thu Aug 19 2004 - damien.carbery@sun.com
- Integrate updated docs tarball from eugene.oconnor@sun.com.
* Fri Aug 13 2004 - bill.haneman@sun.com
- Update patch gdm-10-a11y-gestures.diff. Fixes bug #5067111.
* Thu Jul 29 2004 - bill.haneman@sun.com
- use version 2.6.0.3 (fix for bugzilla 144920 and related GOK problem)
- remove patches gdm-08-gdmtranslate.diff and gdm-09-fix-which.diff,
since they are included in 2.6.0.3.
* Thu Jul 22 2004 - vinay.mandyakoppal@wipro.com
- add patch to remove reboot/shutdown option on Solaris box
* Thu Jul 22 2004 - leena.gunda@wipro.com
- add patch gdm-15-default-path.diff to add /usr/dt/bin and /usr/sfw/bin
to PATH for Solaris.
* Wed Jul 14 2004 - niall.power@sun.com
- add patch from Johan to invoke jds registration on first login
* Thu Jul 08 2004 - arvind.samptur@wipro.com
- add patch to pass X server options instead of hardcoding
it in the gdm.conf.in
* Wed Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Wed Jun 23 2004 - damien.carbery@sun.com
- Update a11y-gestures patch to add HAVE_XINPUT to acconfig.h.
Remove xdmcp-enable patch (10) for app security reasons and move 13 to 10.
* Thu Jun 10 2004 - damien.carbery@sun.com
- Add patch 12 to add 'docs/C/figures' directory to the build.
* Mon May 31 2004 - niall.power@sun.com
- bump to 2.6.0.2
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gdm-l10n-po-1.1.tar.bz2
* Sun Apr 18 2004 - laca@sun.com
- enable javahelp conversion on Solaris
* Thu Apr 08 2004 - <niall.power@sun.com>
- bumped to 2.6.0.0 and updated dependencies
* Sat Apr 03 2004 - Chookij.Vanatham@Sun.COM
- added gdm-11-g11n-truncated-username.diff to fix 4955151
* Thu Apr 01 2004 - matt.keenan@sun.com
- javahelp conversion
* Wed Mar 31 2004 - <hidetoshi.tajima@sun.com>
- updated gdm-03-locale-alias.diff to fix 4884887
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to gdm-l10n-po-1.0.tar.bz2
* Tue Mar 23 2004 - <glynn.foster@sun.com>
- Remove photo setup from %files since we didn't want it part of the
menus by default [$datadir/gnome/capplets/..]
* Mon Mar 22 2004 - <laca@sun.com>
- simplify %build
* Fri Mar 19 2004 - <damien.carbery@sun.com>
- Move autoheader and autoconf out of the platform specific section because
it is common to both platforms.
* Fri Mar 19 2004 - <damien.carbery@sun.com>
- Change '\' to ';' so autoheader and autoconf run separately.
* Thu Mar 18 2004 - <brian.cameron@sun.com>
- Add patch 8 that fixes gdmtranslate so it compiles with -g, add
patch 9 to fix scripts so that they don't call which (since which
doesn't work on Solaris without an associated TTY), and add patch
10 to turn on XDMCP support by default.
* Tue Mar 09 2004 - <niall.power@sun.com>
- bump to 2.5.90.2
* Mon Mar 01 2004 - <laca@sun.com>
- s$/usr/share$%{_datadir}$
* Thu Feb 26 2004 - <damien.carbery@sun.com>
- Fix small typos in description and change tar commmand to bzcat/tar.
- Remove --enable-console-helper on Solaris.
* Fri Feb 06 2004 - <matt.keenan@sun.com>
- Bump to 2.5.90.0, add docs, and ported QS patches
* Wed Jan 07 2004 - <niall.power@sun.com>
- Update to 2.4.4.7 for gnome-2.5.x
- Regenerated gdm-07-enable-tcp-by-default.diff
* Fri Oct 31 2003 - <glynn.foster@sun.com>
- Remove the Sun Supported menu entry patch, and reorder.
* Tue Oct 14 2003 - <markmc@sun.com> 2.4.4.3-2
- Add patch from Toshi to normalize the locale environment
variables to be the same as LANG if they are unset.
* Fri Oct 10 2003 - <niall.power@sun.com> 2.4.4.3
- Update to 2.4.4.3 for gnome-2.4
* Wed Oct 01 2003 - <michael.twomey@sun.com> 2.4.2.101-14
- Add patch from Chookij to fix bug 4901817 (ja_JP.eucJP name)
* Thu Sep 18 2003 - <markmc@sun.com> 2.4.2.101-12
- Add patch from Leena to set AlwaysRestartServer to true.
* Thu Aug 21 2003 - <markmc@sun.com> 2.4.2.101-1
- Upgrade to 2.4.2.101
* Mon Aug 18 2003 - <markmc@sun.com> 2.4.2.99-7
- Set DisallowTCP to false by default.
* Fri Aug 08 2003 - <michael.twomey@sun.com> 2.4.2.99-3
- Updated locale.alias patch with a fix for zh_HK and a tweak
for ja_JP.sjis (now ja_JP.SJIS). Fixing bug 4899317.
- Added a dependancy on openssl-devel. My build failed because
it was missing. I've also added openssl for good measure.
* Thu Aug 07 2003 - <michael.twomey@sun.com> 2.4.2.99-2
- Patched /etc/X11/gdm/Xsession so ~/.xim or /etc/skel/.xim is sourced which
ensures that XIM input methods are started.
* Fri Aug 01 2003 - <markmc@sun.com> 2.4.2.99-1
- Upgrade to 2.4.2.99.
* Fri Aug 01 2003 - <glynn.foster@sun.com>
- Add supported menu category.
* Sun Jul 27 2003 - <markmc@sun.com>
- Update to 2.4.2.98
- Remove POTFILES.in patch. Seems to be in new tarball.
* Tue Jul 22 2003 - <michael.twomey@sun.com>
- Added a patch to update the POTFILES.in.
* Mon Jul 21 2003 - <glynn.foster@sun.com>
- Changed category of gdmsetup.desktop, so it appears in
the system menu again.
* Mon Jul 21 2003 - <michael.twomey@sun.com>
- Added zh_HK (Hong Kong Chinese) to the available languages.
* Fri Jul 18 2003 - <michael.twomey@sun.com>
- Patched locale.alias to include more Asian locale codeset
variants as requested by the Asian teams.
* Thu Jul 17 2003 - <markmc@sun.com>
- Fixed up the PAM configuration files.
- Removed the sysconfig/displaymanager hack
* Thu Jul 17 2003 - <niall.power@sun.com>
- update to version 2.4.2.97, release 0
- removed patches gdm-04-setlocale.diff and
gdm-05-potfiles_in.diff, which are integrated upstream
- Changed sysconfdir to /etc/X11 so that new common sessions
configuration directory (/etc/X11/dm/Sessions) can be shared
with kdm etc.
- New common sessions dir /etc/X11/dm added to %files
* Fri Jul 11 2003 - <niall.power@sun.com>
- added setlocal patch - No more Welsh :) (or Czech!)
* Tue Jul 08 2003 - <niall.power@sun.com>
- Remove .desktop capplets from %files since photo setup
is gone.
* Mon Jul 07 2003 - <glynn.foster@sun.com>
- Remove the photo setup .desktop menu item from the
Settings menu.
* Tue Jul 01 2003 - <glynn.foster@sun.com>
- Move the pam and branding stuff to patches, and not
dirty copy hacks ;)
* Tue Jul 01 2003 - <glynn.foster@sun.com>
- Make gdm now depend on sun-gdm-themes which is a new
package, replacing the old one.
* Fri Jun 30 2003 - <glynn.foster@sun.com>
- Make gdm now depend on Sundt-gdm-theme. This may be
crack that we shouldn't do, but until I figure out
how things work, let's go with it.
* Fri Jun 30 2003 - <glynn.foster@sun.com>
- New tarball, bump version and reset release. Remove
the old greeter theme, since we probably don't want
it installed anyway
* Fri May 02 2003 - <niall.power@sun.com>
- Initial Sun release.