evolution-data-server.spec revision 10917
10139N/A# spec file for package evolution-data-server
10139N/A#
12219N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: jefftsai
10139N/A#
10139N/AName: evolution-data-server
15291N/ALicense: GPL
10139N/AGroup: System/Libraries/GNOME
15275N/AVersion: 1.11.5
10139N/ARelease: 2
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Backend Library for Evolution
14464N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.11/%{name}-%{version}.tar.bz2
10794N/A%if %build_l10n
10794N/ASource1: l10n-configure.sh
12773N/A%endif
12773N/A# date:2006-09-28 owner:sh162551 type:branding
12773N/APatch1: evolution-data-server-01-libexec.diff
10794N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/evolution-data-server
10815N/AAutoreqprov: on
14188N/APrereq: /sbin/ldconfig
14188N/A
10139N/A%define api_version 1.2
10139N/A%define base_version 1.6
10139N/A
10139N/A%define libbonobo_version 2.4.2
10139N/A%define gnome_vfs_version 2.4
10139N/A%define libgnome_version 2.4
10139N/A%define GConf_version 2.4
10139N/A%define libsoup_version 2.2.3
10139N/A%define gtk_doc_version 1.1
10139N/A%define openldap2_version 2.1.4
10139N/A
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: gnome-vfs >= %{gnome_vfs_version}
10139N/ARequires: libgnome >= %{libgnome_version}
10139N/ARequires: GConf >= %{GConf_version}
10139N/ARequires: libsoup >= %{libsoup_version}
10139N/ARequires: openldap2-client >= %{openldap2_version}
10139N/A
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
10139N/ABuildRequires: libgnome-devel >= %{libgnome_version}
10139N/ABuildRequires: GConf-devel >= %{GConf_version}
10139N/ABuildRequires: libsoup-devel >= %{libsoup_version}
10139N/ABuildRequires: openldap2-devel >= %{openldap2_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: bison
10139N/ABuildRequires: heimdal-devel
10139N/A
10139N/A%description
10139N/Aevolution-data-server is the backend library for Evolution, providing
10139N/Asupport for calendar and addressbook.
10139N/A
10139N/A%package devel
10139N/ASummary: Development Backend Library for Evolution
10139N/AGroup: Development/Libraries/GNOME
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
10139N/ABuildRequires: libgnome-devel >= %{libgnome_version}
10139N/ABuildRequires: GConf-devel >= %{GConf_version}
10139N/ABuildRequires: openldap2-devel >= %{openldap2_version}
10139N/ABuildRequires: libsoup-devel >= %{libsoup_version}
10139N/A
10139N/A%description devel
10139N/Aevolution-data-server is the backend library for Evolution, providing
10139N/Asupport for calendar and addressbook.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10139N/A# bugster 6558756
10139N/Ash -x %SOURCE1 --disable-gnu-extensions --disable-sun-linguas
10139N/A%endif
10794N/A%patch1 -p0
10794N/A
12754N/A%build
10794N/A
11087N/A%ifos linux
14188N/A%define ldap_option --with-openldap=%{_prefix}
13621N/A%define krb5_option --with-krb5=%{_prefix}
10139N/A%define nss_libs %{_libdir}/firefox
10139N/A%define nspr_libs %{_libdir}/firefox
10139N/A%define nss_includes %{_includedir}/firefox/nss
10139N/A%define nspr_includes %{_includedir}/firefox/nspr
10139N/A%else
10139N/A%define ldap_option --with-sunldap=%{_prefix}
10139N/A%if %is_s10
10139N/A%define krb5_option --without-krb5
10139N/A%else
10139N/A%define krb5_option --with-krb5=%{_prefix}
10139N/A%endif
10139N/A%define nss_libs %{_libdir}/mps
10139N/A%define nspr_libs %{_libdir}/mps
10139N/A%define nss_includes %{_includedir}/mps
10139N/A%define nspr_includes %{_includedir}/mps
10139N/A%endif
10139N/A
10139N/Aexport LDFLAGS="$LDFLAGS -L%{nss_libs} -R%{nss_libs} -L%{nspr_libs} -R%{nspr_libs}"
10139N/Aexport CFLAGS="$CFLAGS $RPM_OPT_FLAGS -I%{nss_includes} -I%{nspr_includes}"
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS
11338N/Alibtoolize --force
11338N/Aglib-gettextize --force --copy
11338N/Aintltoolize --force --automake
11338N/Aautoheader
11338N/Aautomake -a -f -c --gnu
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --enable-nss=yes \
10139N/A --enable-smime=yes \
10139N/A --enable-nntp=yes \
10139N/A --with-nss-includes=%{nss_includes} \
12773N/A --with-nss-libs=%{nss_libs} \
12773N/A --with-nspr-includes=%{nspr_includes} \
12773N/A --with-nspr-libs=%{nspr_libs} \
12773N/A %ldap_option \
12773N/A --with-krb4=%{_prefix} \
10139N/A %krb5_option \
10139N/A %gtk_doc_option \
10139N/A %bdb_option
10139N/A
10139N/Amake
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
11338N/A/sbin/ldconfig
11338N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%doc AUTHORS COPYING ChangeLog NEWS README
10139N/A%{_libdir}/*.so.*
10139N/A%{_libdir}/evolution-data-server-%{api_version}/extensions/*.so
10139N/A%{_libdir}/evolution-data-server-%{api_version}/camel-providers/*.so
10139N/A%{_libdir}/evolution-data-server-%{api_version}/camel-providers/*urls
10139N/A%{_libdir}/bonobo/servers/*
10139N/A%{_libexecdir}/*
10139N/A%{_datadir}/evolution-data-server-%{base_version}/*
10139N/A%{_datadir}/pixmaps/evolution-data-server-%{base_version}/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A
10139N/A%files devel
10139N/A%defattr (-, root, root)
10139N/A%{_libdir}/*.so
10139N/A%{_includedir}/evolution-data-server-%{base_version}/*
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_datadir}/gtk-doc/*
10139N/A%{_datadir}/idl/*
10139N/A
10139N/A%changelog
10139N/A* Tue Jul 10 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.11.5.
10139N/A* Mon Jun 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.11.4. Remove upstream patch, 01-kerberos.
10139N/A* Wed Jun 13 2007 - takao.fujiwara@sun.com
10139N/A- Add l10n-configure.sh to remove GNU extension from de.po, et.po, hu.po,
10139N/A it.po and ja.po
10139N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.11.3.
10139N/A* Tue May 15 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.11.2.
10139N/A* Thu May 10 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.11.1.
10139N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.10.1. Remove upstream patch 03-libbdb.
10139N/A* Wed Apr 04 2007 - simon.zheng@sun.com
15291N/A- Add patch evolution-data-server-03-libbdb.diff,
15291N/A to fix bugster bug #6538754.
15275N/A* Tue Mar 13 2007 - simon.zheng@sun.com
15275N/A- Bump to 1.10.0.
14464N/A* Tue Feb 28 2007 - simon.zheng@sun.com
14464N/A- Bump to 1.9.92.
14185N/A* Mon Feb 12 2007 - damien.carbery@sun.com
14185N/A- Bump to 1.9.91. Remove upstream patch, 03-mail-header.
14188N/A* Fri Feb 09 2007 - jeff.cai@sun.com
14123N/A- Add patch, 03-mail-header, to fix #400841.
14123N/A* Sun Jan 28 2007 - laca@sun.com
14123N/A- disable krb5 support on s10
14038N/A* Wed Jan 24 2007 - damien.carbery@sun.com
14038N/A- Bump to 1.9.6.1. Remove upstream patch, 03-gnome-keyring.
13925N/A* Tue Jan 23 2007 - damien.carbery@sun.com
13925N/A- Add patch, 03-gnome-keyring, to fix build error, #399706.
13925N/A* Mon Jan 22 2007 - damien.carbery@sun.com
13761N/A- Bump to 1.9.6.
13767N/A* Tue Jan 09 2007 - jeff.cai@sun.com
13767N/A- Bump to 1.9.5.
13767N/A- Remove build patch for bug 387397.
13767N/A* Wed Dec 20 2006 - jeff.cai@sun.com
13767N/A- Add bugzilla bug number for patch 3.
13761N/A* Tue Dec 19 2006 - jeff.cai@sun.com
13754N/A- Add patch evolution-data-server-03-exchange-account.diff
13754N/A to resolve building broken on Solaris.
13692N/A* Tue Dec 19 2006 - jeff.cai@sun.com
13692N/A- Bump to 1.9.4.
13639N/A* Wed Dec 13 2006 - jeff.cai@sun.com
13639N/A- Change patch comments.
13639N/A* Tue Dec 05 2006 - damien.carbery@sun.com
13639N/A- Bump to 1.9.3.
13639N/A* Tue Nov 28 2006 - jeff.cai@sun.com
13621N/A- Bump to 1.9.2 and remove patch:
13621N/A evolution-data-server-03-mail-rlimit.diff
13621N/A* Mon Nov 27 2006 - damien.carbery@sun.com
13499N/A- Bump to 1.8.2.
13499N/A* Fri Nov 3 2006 - laca@sun.com
13498N/A- use %gtk_doc_option in configure so that it can be disabled using
13498N/A --without-gtk-doc
13416N/A* Mon Nov 04 2006 - irene.huang@sun.com
13416N/A- Change owner to be opensolaris account.
13313N/A* Mon Oct 23 2006 - irene.huang@sun.com
13313N/A- moved evolution-data-server-01-kerberos.diff
13299N/A and evolution-data-server-02-libexec.diff and
13299N/A evolution-data-server-03-mail-rlimit.diff from
13274N/A Solaris/patches
13274N/A* Mon Oct 02 2006 - damien.carbery@sun.com
13261N/A- Bump to 1.8.1.
13261N/A* Mon Sep 04 2006 - damien.carbery@sun.com
13103N/A- Bump to 1.8.0.
13103N/A- Remove upstream patch, 01-attachment.
12988N/A* Tue Aug 21 2006 - jedy.wang@sun.com
12988N/A- Add one patch, 01-attachment.diff, for 6461581.
12933N/A* Tue Aug 08 2006 - damien.carbery@sun.com
12933N/A- Bump to 1.7.91.
12933N/A* Wed Jul 26 2006 - halton.huo@sun.com
12571N/A- Use system BerkeleyDB.
12571N/A* Wed Jul 26 2006 - jeff.cai@sun.com
12466N/A- Bump to 1.7.90.1
12466N/A Remove patches/evolution-data-server-01-libebook-files.diff.
12413N/A* Tue Jul 25 2006 - damien.carbery@sun.com
12413N/A- Add patch to include files missing from tarball (but in cvs).
12413N/A* Mon Jul 24 2006 - damien.carbery@sun.com
12401N/A- Bump to 1.7.90
12401N/A* Fri Jul 21 2006 - jeff.cai@sun.com
12387N/A- Bump to 1.7.4
12387N/A* Tue May 30 2006 - halton.huo@sun.com
12370N/A- Bump to 1.6.2.
12370N/A* Wed Apr 26 2006 - halton.huo@sun.com
12287N/A- Use JES's NSS/NSPR(/usr/lib/mps) instead of that provided by
12287N/A mozilla or firefox, to fix bug #6418049.
12227N/A* Thu Apr 13 2006 - halton.huo@sun.com
12227N/A- Firefox move from /usr/sfw to /usr.
12219N/A* Mon Apr 10 2006 - damien.carbery@sun.com
12219N/A- Bump to 1.6.1.
12071N/A* Tue Apr 04 2006 - halton.huo@sun.com
12071N/A- Remove .a/.la files in linux spec.
12022N/A* Thu Mar 30 2006 - halton.huo@sun.com
12022N/A- Alter "remove *.a/*.la files part" to SUNWevolution-data-server.spec
11922N/A* Mon Mar 13 2006 - damien.carbery@sun.com
11922N/A- Bump to 1.6.0.
11819N/A* Tue Feb 28 2006 - halton.huo@sun.com
11821N/A- Bump to 1.5.92.
11416N/A* Tue Feb 14 2006 - damien.carbery@sun.com
11418N/A- Bump to 1.5.91.
11338N/A* Mon Jan 30 2006 - damien.carbery@sun.com
11338N/A- Bump to 1.5.90.
11253N/A* Thu Jan 19 2006 - halton.huo@sun.com
11253N/A- Bump to 1.5.5.
11172N/A* Wed Jan 04 2006 - halton.huo@sun.com
11172N/A- Bump to 1.5.4.
11118N/A* Wed Dec 21 2005 - halton.huo@sun.com
11118N/A- Correct Source filed.
11087N/A- Remove upstreamed patch evolution-data-server-6341837.diff.
11087N/A- Remove upstreamed patch evolution-data-server-6359639.diff.
11087N/A* Fri Dec 19 2005 - damien.carbery@sun.com
11073N/A- Bump to 1.5.3.
11067N/A- Bump to 1.4.2.1.
11067N/A* Fri Dec 09 2005 - dave.lin@sun.com
11060N/A- Add the patch evolution-data-server-6359639.diff
11060N/A* Fri Dec 02 2005 - dave.lin@sun.com
11025N/A- Bump to 1.4.2.1.
11025N/A- Add the patch evolution-data-server-6341837.diff
11025N/A* Thu Dec 01 2005 - damien.carbery@sun.com
10986N/A- Remove upstream patch, patches/evolution-data-server-01-6340601.diff.
10988N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10980N/A- Bump to 1.4.2.
10980N/A* Wed Nov 23 2005 - halton.huo@sun.com
10917N/A- Add patch evolution-data-server-01-6340601.diff.
10917N/A* Fri Oct 21 2005 - halton.huo@sun.com
10815N/A- Use firefox nss/nspr lib instead of mozilla's.
10815N/A* Wed Oct 12 2005 - halton.huo@sun.com
10794N/A- change --with-ldap to --with-sunldap.
10794N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10794N/A- Bump to 1.4.1.1.
10742N/A* Mon Oct 10 2005 - halton.huo@sun.com
10742N/A- Bump to 1.4.1.
10640N/A- Move obsolete patches:
10640N/A evolution-data-server-01-libgobject.diff,
10613N/A evolution-data-server-02-pretty_function.diff.
10613N/A- Move upstreamed patches:
10473N/A evolution-data-server-03-lock-helper.diff.
10474N/A* Thu Sep 15 2005 - halton.huo@sun.com
10406N/A- Add define krb5_option, disable Kerberos 5 on Solaris.
10406N/A* Thu Sep 8 2005 - halton.huo@sun.com
10406N/A- Add krb5_prefix define and enable Kerberos 5.
10283N/A- Fix CFLAGS problem.
10283N/A* Wed Sep 7 2005 - halton.huo@sun.com
10139N/A- Bump to 1.4.0.
10139N/A* Tue Sep 6 2005 - damien.carbery@sun.com
10139N/A- Call configure instead of autogen.sh because autogen.sh not in 1.3.8 tarball.
10139N/A Remove some ver nums from %files because there is no consistency.
10139N/A Remove patch3 and reorder.
10139N/A* Tue Sep 6 2005 - halton.huo@sun.com
10139N/A- Move patch evolution-data-server-04-ldap-ssl.diff and Source1
10139N/A evolution-data-server-ldap-ssl-patch.tar to SUNWgnutls.spec.
10139N/A* Fri Sep 2 2005 - halton.huo@sun.com
10139N/A- Add option --enable-nntp=yes to support news groups.
10139N/A- Use SUN LDAP on solaris with %ldap_option.
10139N/A- Add Source1 Patch4 to support SUN LDAP
10139N/A- Use ./autogen.sh to replace libtoolize aclocal automake autoconf ./configure
10139N/A steps, because we need build code that checked out from community HEAD.
10139N/A- Temporarily disable Kerberos for header files are not installed on Nevada.
10139N/A* Tue Aug 30 2005 - damien.carbery@sun.com
10139N/A- Redefine major_version to 1.2 so that %files section can use while patch 03
10139N/A redefines it to 1.2.
10139N/A* Tue Aug 30 2005 - glynn.foster@sun.com
10139N/A- Bump to 1.3.8
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 1.3.7.
10139N/A* Thu Jul 28 2005 - damien.carbery@sun.com
10139N/A- Rename --with-openldap configure option to --with-ldap as a result of Jerry's
10139N/A patch from Jul 27. Also remove '%ifos' code around this option.
10139N/A* Wed Jul 27 2005 - damien.carbery@sun.com
10139N/A- Add patch from Jerry Pu (Shi.Pu@sun.com) to support LDAP on Solaris.
10139N/A* Thu Jul 14 2005 - damien.carbery@sun.com
10139N/A- Add 5 patches to build on Solaris.
10139N/A* Wed Jun 15 2005 - matt.keenan@sun.com
10139N/A- Bump to 1.2.3
10139N/A* Tue May 10 2005 - glynn.foster@sun.com
10139N/A- Bump to 1.2.2
10139N/A* Tue Nov 23 2004 - glynn.foster@sun.com
10139N/A- Bump to 1.0.2
10139N/A* Thu Jun 17 2004 - niall.power@sun.com
10139N/A- rpm4´ified
10139N/A* Thu Jun 17 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.0.94.1
10139N/A* Tue Jun 08 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.0.94
10139N/A* Fri May 21 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.0.93
10139N/A* Tue Apr 20 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.0.92
10139N/A* Mon Apr 19 2004 - glynn.foster@sun.com
10139N/A- Initial spec file for evolution-data-server 0.0.91
10139N/A