evolution-data-server.spec revision 10139
10139N/A# spec file for package evolution-data-server
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
15469N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: jefftsai
10139N/A#
10139N/AName: evolution-data-server
16128N/ALicense: GPL
16128N/AGroup: System/Libraries/GNOME
16128N/AVersion: 1.9.92
17181N/ARelease: 2
17181N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Backend Library for Evolution
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/1.9/%{name}-%{version}.tar.bz2
10139N/A# date:2006-05-28 bugzilla:344728 owner:sh162551 type:bug
15461N/APatch1: evolution-data-server-01-kerberos.diff
10139N/A# date:2006-09-28 owner:sh162551 type:branding
10139N/APatch2: evolution-data-server-02-libexec.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/evolution-data-server
15461N/AAutoreqprov: on
16176N/APrereq: /sbin/ldconfig
16176N/A
10139N/A%define api_version 1.2
10139N/A%define base_version 1.6
10139N/A
10139N/A%define libbonobo_version 2.4.2
10139N/A%define gnome_vfs_version 2.4
10139N/A%define libgnome_version 2.4
10139N/A%define GConf_version 2.4
10139N/A%define libsoup_version 2.2.3
10139N/A%define gtk_doc_version 1.1
10139N/A%define openldap2_version 2.1.4
10139N/A
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: gnome-vfs >= %{gnome_vfs_version}
10139N/ARequires: libgnome >= %{libgnome_version}
10139N/ARequires: GConf >= %{GConf_version}
10139N/ARequires: libsoup >= %{libsoup_version}
10139N/ARequires: openldap2-client >= %{openldap2_version}
10139N/A
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
16176N/ABuildRequires: libgnome-devel >= %{libgnome_version}
10139N/ABuildRequires: GConf-devel >= %{GConf_version}
10139N/ABuildRequires: libsoup-devel >= %{libsoup_version}
10139N/ABuildRequires: openldap2-devel >= %{openldap2_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: bison
10139N/ABuildRequires: heimdal-devel
10139N/A
10139N/A%description
10139N/Aevolution-data-server is the backend library for Evolution, providing
10139N/Asupport for calendar and addressbook.
10139N/A
10139N/A%package devel
10139N/ASummary: Development Backend Library for Evolution
10139N/AGroup: Development/Libraries/GNOME
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
16128N/ABuildRequires: libgnome-devel >= %{libgnome_version}
10139N/ABuildRequires: GConf-devel >= %{GConf_version}
15469N/ABuildRequires: openldap2-devel >= %{openldap2_version}
10139N/ABuildRequires: libsoup-devel >= %{libsoup_version}
10139N/A
10139N/A%description devel
10139N/Aevolution-data-server is the backend library for Evolution, providing
10139N/Asupport for calendar and addressbook.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p0
10139N/A%patch2 -p0
10139N/A
10139N/A%build
10139N/A
10139N/A%ifos linux
10139N/A%define ldap_option --with-openldap=%{_prefix}
10139N/A%define krb5_option --with-krb5=%{_prefix}
10139N/A%define nss_libs %{_libdir}/firefox
10139N/A%define nspr_libs %{_libdir}/firefox
10139N/A%define nss_includes %{_includedir}/firefox/nss
10139N/A%define nspr_includes %{_includedir}/firefox/nspr
10139N/A%else
10139N/A%define ldap_option --with-sunldap=%{_prefix}
10139N/A%if %is_s10
10139N/A%define krb5_option --without-krb5
16176N/A%else
16176N/A%define krb5_option --with-krb5=%{_prefix}
16128N/A%endif
16128N/A%define nss_libs %{_libdir}/mps
15469N/A%define nspr_libs %{_libdir}/mps
15469N/A%define nss_includes %{_includedir}/mps
15461N/A%define nspr_includes %{_includedir}/mps
15461N/A%endif
12722N/A
12722N/Aexport LDFLAGS="$LDFLAGS -L%{nss_libs} -R%{nss_libs} -L%{nspr_libs} -R%{nspr_libs}"
12634N/Aexport CFLAGS="$CFLAGS $RPM_OPT_FLAGS -I%{nss_includes} -I%{nspr_includes}"
12634N/A
11333N/Aaclocal $ACLOCAL_FLAGS
11333N/Alibtoolize --force
10139N/Aglib-gettextize --force --copy
10139N/Aintltoolize --force --automake
10139N/Aautoheader
10139N/Aautomake -a -f -c --gnu
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --enable-nss=yes \
10139N/A --enable-smime=yes \
10139N/A --enable-nntp=yes \
10139N/A --with-nss-includes=%{nss_includes} \
10139N/A --with-nss-libs=%{nss_libs} \
10139N/A --with-nspr-includes=%{nspr_includes} \
10139N/A --with-nspr-libs=%{nspr_libs} \
10139N/A %ldap_option \
10139N/A --with-krb4=%{_prefix} \
10139N/A %krb5_option \
10139N/A %gtk_doc_option \
10139N/A %bdb_option
10139N/A
10139N/Amake
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%post
/sbin/ldconfig
%postun
/sbin/ldconfig
%files
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_libdir}/*.so.*
%{_libdir}/evolution-data-server-%{api_version}/extensions/*.so
%{_libdir}/evolution-data-server-%{api_version}/camel-providers/*.so
%{_libdir}/evolution-data-server-%{api_version}/camel-providers/*urls
%{_libdir}/bonobo/servers/*
%{_libexecdir}/*
%{_datadir}/evolution-data-server-%{base_version}/*
%{_datadir}/pixmaps/evolution-data-server-%{base_version}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%files devel
%defattr (-, root, root)
%{_libdir}/*.so
%{_includedir}/evolution-data-server-%{base_version}/*
%{_libdir}/pkgconfig/*.pc
%{_datadir}/gtk-doc/*
%{_datadir}/idl/*
%changelog
* Tue Feb 28 2007 - simon.zheng@sun.com
- Bump to 1.9.92.
* Mon Feb 12 2007 - damien.carbery@sun.com
- Bump to 1.9.91. Remove upstream patch, 03-mail-header.
* Fri Feb 09 2007 - jeff.cai@sun.com
- Add patch, 03-mail-header, to fix #400841.
* Sun Jan 28 2007 - laca@sun.com
- disable krb5 support on s10
* Wed Jan 24 2007 - damien.carbery@sun.com
- Bump to 1.9.6.1. Remove upstream patch, 03-gnome-keyring.
* Tue Jan 23 2007 - damien.carbery@sun.com
- Add patch, 03-gnome-keyring, to fix build error, #399706.
* Mon Jan 22 2007 - damien.carbery@sun.com
- Bump to 1.9.6.
* Tue Jan 09 2007 - jeff.cai@sun.com
- Bump to 1.9.5.
- Remove build patch for bug 387397.
* Wed Dec 20 2006 - jeff.cai@sun.com
- Add bugzilla bug number for patch 3.
* Tue Dec 19 2006 - jeff.cai@sun.com
- Add patch evolution-data-server-03-exchange-account.diff
to resolve building broken on Solaris.
* Tue Dec 19 2006 - jeff.cai@sun.com
- Bump to 1.9.4.
* Wed Dec 13 2006 - jeff.cai@sun.com
- Change patch comments.
* Tue Dec 05 2006 - damien.carbery@sun.com
- Bump to 1.9.3.
* Tue Nov 28 2006 - jeff.cai@sun.com
- Bump to 1.9.2 and remove patch:
evolution-data-server-03-mail-rlimit.diff
* Mon Nov 27 2006 - damien.carbery@sun.com
- Bump to 1.8.2.
* Fri Nov 3 2006 - laca@sun.com
- use %gtk_doc_option in configure so that it can be disabled using
--without-gtk-doc
* Mon Nov 04 2006 - irene.huang@sun.com
- Change owner to be opensolaris account.
* Mon Oct 23 2006 - irene.huang@sun.com
- moved evolution-data-server-01-kerberos.diff
and evolution-data-server-02-libexec.diff and
evolution-data-server-03-mail-rlimit.diff from
Solaris/patches
* Mon Oct 02 2006 - damien.carbery@sun.com
- Bump to 1.8.1.
* Mon Sep 04 2006 - damien.carbery@sun.com
- Bump to 1.8.0.
- Remove upstream patch, 01-attachment.
* Tue Aug 21 2006 - jedy.wang@sun.com
- Add one patch, 01-attachment.diff, for 6461581.
* Tue Aug 08 2006 - damien.carbery@sun.com
- Bump to 1.7.91.
* Wed Jul 26 2006 - halton.huo@sun.com
- Use system BerkeleyDB.
* Wed Jul 26 2006 - jeff.cai@sun.com
- Bump to 1.7.90.1
Remove patches/evolution-data-server-01-libebook-files.diff.
* Tue Jul 25 2006 - damien.carbery@sun.com
- Add patch to include files missing from tarball (but in cvs).
* Mon Jul 24 2006 - damien.carbery@sun.com
- Bump to 1.7.90
* Fri Jul 21 2006 - jeff.cai@sun.com
- Bump to 1.7.4
* Tue May 30 2006 - halton.huo@sun.com
- Bump to 1.6.2.
* Wed Apr 26 2006 - halton.huo@sun.com
- Use JES's NSS/NSPR(/usr/lib/mps) instead of that provided by
mozilla or firefox, to fix bug #6418049.
* Thu Apr 13 2006 - halton.huo@sun.com
- Firefox move from /usr/sfw to /usr.
* Mon Apr 10 2006 - damien.carbery@sun.com
- Bump to 1.6.1.
* Tue Apr 04 2006 - halton.huo@sun.com
- Remove .a/.la files in linux spec.
* Thu Mar 30 2006 - halton.huo@sun.com
- Alter "remove *.a/*.la files part" to SUNWevolution-data-server.spec
* Mon Mar 13 2006 - damien.carbery@sun.com
- Bump to 1.6.0.
* Tue Feb 28 2006 - halton.huo@sun.com
- Bump to 1.5.92.
* Tue Feb 14 2006 - damien.carbery@sun.com
- Bump to 1.5.91.
* Mon Jan 30 2006 - damien.carbery@sun.com
- Bump to 1.5.90.
* Thu Jan 19 2006 - halton.huo@sun.com
- Bump to 1.5.5.
* Wed Jan 04 2006 - halton.huo@sun.com
- Bump to 1.5.4.
* Wed Dec 21 2005 - halton.huo@sun.com
- Correct Source filed.
- Remove upstreamed patch evolution-data-server-6341837.diff.
- Remove upstreamed patch evolution-data-server-6359639.diff.
* Fri Dec 19 2005 - damien.carbery@sun.com
- Bump to 1.5.3.
- Bump to 1.4.2.1.
* Fri Dec 09 2005 - dave.lin@sun.com
- Add the patch evolution-data-server-6359639.diff
* Fri Dec 02 2005 - dave.lin@sun.com
- Bump to 1.4.2.1.
- Add the patch evolution-data-server-6341837.diff
* Thu Dec 01 2005 - damien.carbery@sun.com
- Remove upstream patch, patches/evolution-data-server-01-6340601.diff.
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 1.4.2.
* Wed Nov 23 2005 - halton.huo@sun.com
- Add patch evolution-data-server-01-6340601.diff.
* Fri Oct 21 2005 - halton.huo@sun.com
- Use firefox nss/nspr lib instead of mozilla's.
* Wed Oct 12 2005 - halton.huo@sun.com
- change --with-ldap to --with-sunldap.
* Tue Oct 11 2005 - damien.carbery@sun.com
- Bump to 1.4.1.1.
* Mon Oct 10 2005 - halton.huo@sun.com
- Bump to 1.4.1.
- Move obsolete patches:
evolution-data-server-01-libgobject.diff,
evolution-data-server-02-pretty_function.diff.
- Move upstreamed patches:
evolution-data-server-03-lock-helper.diff.
* Thu Sep 15 2005 - halton.huo@sun.com
- Add define krb5_option, disable Kerberos 5 on Solaris.
* Thu Sep 8 2005 - halton.huo@sun.com
- Add krb5_prefix define and enable Kerberos 5.
- Fix CFLAGS problem.
* Wed Sep 7 2005 - halton.huo@sun.com
- Bump to 1.4.0.
* Tue Sep 6 2005 - damien.carbery@sun.com
- Call configure instead of autogen.sh because autogen.sh not in 1.3.8 tarball.
Remove some ver nums from %files because there is no consistency.
Remove patch3 and reorder.
* Tue Sep 6 2005 - halton.huo@sun.com
- Move patch evolution-data-server-04-ldap-ssl.diff and Source1
evolution-data-server-ldap-ssl-patch.tar to SUNWgnutls.spec.
* Fri Sep 2 2005 - halton.huo@sun.com
- Add option --enable-nntp=yes to support news groups.
- Use SUN LDAP on solaris with %ldap_option.
- Add Source1 Patch4 to support SUN LDAP
- Use ./autogen.sh to replace libtoolize aclocal automake autoconf ./configure
steps, because we need build code that checked out from community HEAD.
- Temporarily disable Kerberos for header files are not installed on Nevada.
* Tue Aug 30 2005 - damien.carbery@sun.com
- Redefine major_version to 1.2 so that %files section can use while patch 03
redefines it to 1.2.
* Tue Aug 30 2005 - glynn.foster@sun.com
- Bump to 1.3.8
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 1.3.7.
* Thu Jul 28 2005 - damien.carbery@sun.com
- Rename --with-openldap configure option to --with-ldap as a result of Jerry's
patch from Jul 27. Also remove '%ifos' code around this option.
* Wed Jul 27 2005 - damien.carbery@sun.com
- Add patch from Jerry Pu (Shi.Pu@sun.com) to support LDAP on Solaris.
* Thu Jul 14 2005 - damien.carbery@sun.com
- Add 5 patches to build on Solaris.
* Wed Jun 15 2005 - matt.keenan@sun.com
- Bump to 1.2.3
* Tue May 10 2005 - glynn.foster@sun.com
- Bump to 1.2.2
* Tue Nov 23 2004 - glynn.foster@sun.com
- Bump to 1.0.2
* Thu Jun 17 2004 - niall.power@sun.com
- rpm4´ified
* Thu Jun 17 2004 - glynn.foster@sun.com
- Bump to 0.0.94.1
* Tue Jun 08 2004 - glynn.foster@sun.com
- Bump to 0.0.94
* Fri May 21 2004 - glynn.foster@sun.com
- Bump to 0.0.93
* Tue Apr 20 2004 - glynn.foster@sun.com
- Bump to 0.0.92
* Mon Apr 19 2004 - glynn.foster@sun.com
- Initial spec file for evolution-data-server 0.0.91