evince.spec revision 17570
10139N/A#
10139N/A# spec file for package evince
10139N/A#
12208N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
12352N/A#
10139N/A%define owner dkenny
10139N/A#
10139N/A
10139N/A%define OSR gnome.org:0
15742N/A
10139N/A%include l10n.inc
10139N/AName: evince
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
15564N/A# poppler should be bumped at the same time - evince depends on poppler.
10139N/A# WARNING: Do NOT bump to 2.23.x version as other dependencies (e.g libgs and libspectre needed first)
10139N/AVersion: 2.28.1
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Document viewer
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/evince/2.28/%{name}-%{version}.tar.bz2
10139N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
13064N/A%if %build_l10n
10243N/ASource2: l10n-configure.sh
14082N/A%endif
14082N/A# date:2006-06-06 type:branding owner:gman
14550N/APatch1: evince-01-menu-entry.diff
14550N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/A
10139N/A%define gtk2_version 2.6.0
10139N/A%define libgnomeui_version 2.6.0
11393N/A%define dbus_version 0.33
10139N/A%define poppler_version 0.4.0
10139N/A%define libgnomeprintui_version 2.5.1
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: dbus >= %{dbus_version}
10139N/ARequires: poppler >= %{poppler_version}
10139N/ARequires: libgnomeprintui >= %{libgnomeprintui_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: dbus-devel >= %{dbus_version}
10139N/ABuildRequires: poppler-devel >= %{poppler_version}
10139N/ABuildRequires: libgnomeprintui-devel >= %{libgnomeprintui_version}
10139N/A
10139N/A%description
10139N/AEvince is a document viewer capable of displaying multiple and single page document formats like PDF and Postscript.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10139N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
10139N/A%patch1 -p1
10139N/A
10139N/A# Remove DOS line end chars. Fixes #395105.
10139N/Ados2unix -ascii po/be.po po/be.po
10139N/A
10243N/A%build
14082N/A%ifos linux
14550N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/Aexport PKG_CONFIG_TOP_BUILD_DIR=${PWD}
10139N/A
10139N/Alibtoolize --force
10139N/Aintltoolize --force --copy --automake
12805N/A
12805N/A%if %build_l10n
12805N/Abash -x %SOURCE2 --enable-copyright
12805N/A%endif
12805N/A
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS -I/usr/include/libxml2" \
10139N/A ./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --libexecdir=%{_libexecdir} \
15742N/A --sysconfdir=%{_sysconfdir} \
15742N/A --disable-comics \
15742N/A --enable-thumbnailer \
10139N/A --mandir=%{_mandir}
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
11393N/Arm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0/*.a
11393N/Arm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-2.0/*.la
11393N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="evince.schemas evince-thumbnailer.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_bindir}/*
10139N/A%{_libdir}/nautilus/extensions-2.0/*.so*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/evince/*
10139N/A%{_datadir}/gnome/help/*
10139N/A%{_datadir}/omf/*
10139N/A%{_sysconfdir}/gconf/schemas/*
10139N/A
10139N/A%changelog
10139N/A* Tue Oct 20 2009 - dave.lin@sun.com
10139N/A- Bump to 2.28.1
10139N/A* Wed Sep 23 2009 - dave.lin@sun.com
10139N/A- Bump to 2.28.0
10139N/A- Sun Aug 20 2009 - darren.kenny@sun.com
10139N/A- Bump to 2.27.90 and remove upstreamed patches.
10139N/A* Mon Sep 22 2008 - darren.kenny@sun.com
10139N/A- Add patch evince-03-remember-page-size.diff, which is a backport of the
10139N/A 2.26 fix to remember page size (A4, US Letter, etc) - bugzilla:525185.
10139N/A* Mon Sep 22 2008 - darren.kenny@sun.com
10139N/A- Re-introduce patch evince-02-static-enum.diff to make GEnum types be "static const".
10139N/A fixing bug#6724495 since we've reverted back to GNOME 2.22 version.
10139N/A* Fri Aug 15 2008 - darren.kenny@sun.com
10139N/A- Reverting back to evince 2.22 due to no libspectre or libgs.so on Solaris
10139N/A yet. When these appear I will bump evince again.
10139N/A* Thu Aug 07 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.6.
10139N/A* Wed Jul 23 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.5. Remove upstream patch 02-static-enum.
10139N/A* Mon Jul 14 2008 - darren.kenny@sun.com
15742N/A- Add patch evince-03-static-enum.diff to make GEnum types be "static const".
15742N/A fixing bug#6724495, logged upstream bug#542924
15742N/A* Sat Jun 21 2008 - patrick.ale@gmail.com
15742N/A- Change download URI to fetch from 2.23 branch (URI correction)
15564N/A* Fri Jun 20 2008 - darren.kenny@sun.com
15564N/A- Remove unnecessary patch for sfw since gs is now in /usr/bin.
14550N/A* Thu May 29 2008 - damien.carbery@sun.com
14550N/A- Bump to 2.22.2.
14550N/A* Wed Apr 09 2008 - damien.carbery@sun.com
14550N/A- Bump to 2.22.1.1.
14378N/A* Tue Mar 11 2008 - damien.carbery@sun.com
14378N/A- Bump to 2.22.0.
14378N/A* Tue Feb 12 2008 - damien.carbery@sun.com
14173N/A- Bump to 2.21.91.
14173N/A* Tue Jan 29 2008 - damien.carbery@sun.com
14082N/A- Bump to 2.21.90. Remove upstream patch 03-nautilus-dir.
14082N/A* Fri Jan 11 2008 - damien.carbery@sun.com
14082N/A- Add patch 03-nautilus-dir to determine nautilus extension dir via pkgconfig.
13917N/A* Fri Dec 07 2007 - ghee.teo@sun.com
13917N/A- added --disable-comics to configure option as it failed on Solaris.
13769N/A* Tue Dec 04 2007 - damien.carbery@sun.com
13769N/A- Bump to 2.21.1.
13769N/A* Tue Nov 27 2007 - damien.carbery@sun.com
13415N/A- Bump to 2.20.2. Remove upstream patch, 03-zero-pages-up.
13415N/A* Mon Nov 19 2007 - darren.kenny@sun.com
13415N/A- Add a new patch, evince-03-zero-pages-up.diff, to fix bug#6631614
13259N/A* Fri Oct 19 2007 - damien.carbery@sun.com
13264N/A- Bump to 2.20.1.
13264N/A* Tue Sep 18 2007 - damien.carbery@sun.com
13264N/A- Bump to 2.20.0.
13259N/A* Thu Aug 30 2007 - damien.carbery@sun.com
13259N/A- Add intltoolize call to update intltool scripts.
12813N/A* Tue Aug 28 2007 - damien.carbery@sun.com
12813N/A- Bump to 2.19.4.
12813N/A* Tue Jul 31 2007 - damien.carbery@sun.com
12805N/A- Bump to 0.9.3.
12805N/A* Tue Jul 10 2007 - damien.carbery@sun.com
12805N/A- Bump to 0.9.2.
12805N/A* Tue Jun 19 2007 - damien.carbery@sun.com
12805N/A- Bump to 0.9.1.
12571N/A* Tue May 15 2007 - damien.carbery@sun.com
12571N/A- Bump to 0.9.0.
12571N/A* Thu May 10 2007 - darren.kenny@sun.com
12467N/A- Add bug#6553312 ref for gs-sfw patch.
12467N/A* Thu Apr 19 2007 - laca@sun.com
12467N/A- add -ascii option to dos2unix so that utf8 strings are not messed up
12360N/A* Thu Apr 12 2007 - damien.carbery@sun.com
12360N/A- Bump to 0.8.1.
12360N/A* Tue Mar 13 2007 - damien.carbery@sun.com
12316N/A- Bump to 0.8.0.
12316N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
12316N/A- Add l10n tarball.
12316N/A* Tue Feb 13 2007 - damien.carbery@sun.com
12208N/A- Bump to 0.7.2.
12208N/A* Wed Jan 10 2006 - damien.carbery@sun.com
12208N/A- Bump to 0.7.1. Remove upstream patch, 03-lc-measurement. Add code to dos2unix
12022N/A po/be.po to fix #395105.
12022N/A* Wed Jan 10 2007 - damien.carbery@sun.com
12022N/A- Add dir to CFLAGS so that libxml headers can be found.
11912N/A* Wed Dec 20 2006 - damien.carbery@sun.com
11912N/A- Add patch, 03-lc-measurement, to fix #387887. Patch written by Glynn.
11912N/A* Tue Dec 19 2006 - damien.carbery@sun.com
11393N/A- Bump to 0.7.0.
11393N/A* Tue Oct 10 2006 - damien.carbery@sun.com
11393N/A- Bump to 0.6.1.
11393N/A* Tue Sep 05 2006 - brian.cameron@sun.com
11393N/A- Bump to 0.6.0.
11393N/A* Tue Aug 08 2006 - brian.cameron@sun.com
11252N/A- Bump to 0.5.5.
11252N/A* Wed Jul 20 2006 - dermot.mccluskey@sun.com
11252N/A- Bump to 0.5.4.
11169N/A And remove patch 03 (upstream)
11169N/A* Thu Jun 15 2006 - ghee.teo@sun.com
11169N/A- Fixed 6437235 stop evince from crashing on PAPI print backend.
10986N/A* Fri Jun 02 2006 - glynn.foster@sun.com
10986N/A- Bump to 0.5.3
10986N/A* Fri Apr 28 2006 - glynn.foster@sun.com
10972N/A- Add patch to install into Office submenu
10972N/A with 'Evince Document Viewer'.
10972N/A* Tue Mar 14 2006 - damien.carbery@sun.com
10961N/A- Bump to 0.5.2.
10961N/A* Fri Jan 20 2006 - damien.carbery@sun.com
10961N/A- Bump to 0.5.0.
10265N/A* Tue Nov 08 2005 - glynn.foster@sun.com
10265N/A- Show the .desktop file entry for the moment.
10265N/A* Fri Sep 30 2005 - brian.cameron@sun.com
10180N/A- Bump to 0.4.0
10180N/A* Wed Aug 24 2005 - damien.carbery@sun.com
10180N/A- Add libgnomeprintui dependency.
10139N/A* Tue Aug 16 2005 - glynn.foster@sun.com
10139N/A- New spec file for evince
10139N/A