evince.spec revision 10504
18861N/A#
18861N/A# spec file for package evince
18861N/A#
18861N/A# Copyright (c) 2005 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A# Owner: dkenny
18861N/A#
18861N/A%include l10n.inc
18861N/AName: evince
18861N/ALicense: GPL
18861N/AGroup: System/GUI/GNOME
18861N/A# poppler should be bumped at the same time - evince depends on poppler.
18861N/AVersion: 0.8.1
18861N/ARelease: 1
18861N/ADistribution: Java Desktop System
18861N/AVendor: Sun Microsystems, Inc.
18861N/ASummary: Document viewer
18861N/ASource: http://ftp.gnome.org/pub/GNOME/sources/evince/0.8/%{name}-%{version}.tar.bz2
18861N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
18861N/A# date:2006-06-06 type:branding owner:gman
18970N/APatch1: evince-01-menu-entry.diff
20818N/A# date:2006-05-29 type:bug owner:dkenny bugster:6430428,6431474
18861N/APatch2: evince-02-gs-sfw.diff
18861N/AURL: http://www.gnome.org
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ADocdir: %{_defaultdocdir}/%{name}
18861N/AAutoreqprov: on
18861N/A
18861N/A%define gtk2_version 2.6.0
19142N/A%define libgnomeui_version 2.6.0
19997N/A%define dbus_version 0.33
18861N/A%define poppler_version 0.4.0
18861N/A%define libgnomeprintui_version 2.5.1
18861N/A
18861N/ARequires: gtk2 >= %{gtk2_version}
18861N/ARequires: libgnomeui >= %{libgnomeui_version}
18861N/ARequires: dbus >= %{dbus_version}
18861N/ARequires: poppler >= %{poppler_version}
18861N/ARequires: libgnomeprintui >= %{libgnomeprintui_version}
18861N/ABuildRequires: gtk2-devel >= %{gtk2_version}
18861N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
18861N/ABuildRequires: dbus-devel >= %{dbus_version}
18861N/ABuildRequires: poppler-devel >= %{poppler_version}
18861N/ABuildRequires: libgnomeprintui-devel >= %{libgnomeprintui_version}
18861N/A
19142N/A%description
18861N/AEvince is a document viewer capable of displaying multiple and single page document formats like PDF and Postscript.
18861N/A
18861N/A%prep
19126N/A%setup -q
18861N/A%if %build_l10n
19126N/Abzcat %SOURCE1 | tar xf -
18861N/Acd po-sun; make; cd ..
19142N/A%endif
18861N/A%patch1 -p1
18861N/A%patch2 -p1
18861N/A
18861N/A# Remove DOS line end chars. Fixes #395105.
18861N/Ados2unix -ascii po/be.po po/be.po
18861N/A
18861N/A%build
18861N/A%ifos linux
18861N/Aif [ -x /usr/bin/getconf ]; then
18861N/A CPUS=`getconf _NPROCESSORS_ONLN`
18861N/Afi
18861N/A%else
18861N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18861N/A%endif
18861N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18861N/A CPUS=1
18861N/Afi
18861N/A
18861N/Alibtoolize --force
19898N/Aaclocal $ACLOCAL_FLAGS
19898N/Aautomake -a -c -f
19911N/Aautoconf
19911N/ACFLAGS="$RPM_OPT_FLAGS -I/usr/include/libxml2" \
18880N/A ./configure \
18861N/A --prefix=%{_prefix} \
18861N/A --libexecdir=%{_libexecdir} \
18861N/A --sysconfdir=%{_sysconfdir} \
18861N/A --mandir=%{_mandir}
18861N/Amake -j $CPUS
18861N/A
18861N/A%install
18861N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.a
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/*.la
18861N/A
18861N/A%post
18861N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
18861N/ASCHEMAS="evince.schemas evince-thumbnailer.schemas"
18861N/Afor S in $SCHEMAS; do
18861N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
18861N/Adone
18861N/A
18861N/A%clean
18861N/Arm -rf $RPM_BUILD_ROOT
19142N/A
19142N/A%files
19142N/A%defattr (-, root, root)
18861N/A%{_bindir}/*
18861N/A%{_libdir}/nautilus/extensions-1.0/*.so*
18861N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
18861N/A%{_datadir}/applications/*
18861N/A%{_datadir}/evince/*
18861N/A%{_datadir}/gnome/help/*
18861N/A%{_datadir}/omf/*
18861N/A%{_sysconfdir}/gconf/schemas/*
18861N/A
18861N/A%changelog
18861N/A* Thu Apr 19 2007 - laca@sun.com
18861N/A- add -ascii option to dos2unix so that utf8 strings are not messed up
18861N/A* Thu Apr 12 2007 - damien.carbery@sun.com
18861N/A- Bump to 0.8.1.
18861N/A* Tue Mar 13 2007 - damien.carbery@sun.com
18861N/A- Bump to 0.8.0.
18861N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
18861N/A- Add l10n tarball.
18861N/A* Tue Feb 13 2007 - damien.carbery@sun.com
18861N/A- Bump to 0.7.2.
18861N/A* Wed Jan 10 2006 - damien.carbery@sun.com
18861N/A- Bump to 0.7.1. Remove upstream patch, 03-lc-measurement. Add code to dos2unix
18861N/A po/be.po to fix #395105.
18861N/A* Wed Jan 10 2007 - damien.carbery@sun.com
18861N/A- Add dir to CFLAGS so that libxml headers can be found.
18861N/A* Wed Dec 20 2006 - damien.carbery@sun.com
18861N/A- Add patch, 03-lc-measurement, to fix #387887. Patch written by Glynn.
18861N/A* Tue Dec 19 2006 - damien.carbery@sun.com
18861N/A- Bump to 0.7.0.
18861N/A* Tue Oct 10 2006 - damien.carbery@sun.com
18861N/A- Bump to 0.6.1.
18861N/A* Tue Sep 05 2006 - brian.cameron@sun.com
18861N/A- Bump to 0.6.0.
18861N/A* Tue Aug 08 2006 - brian.cameron@sun.com
18861N/A- Bump to 0.5.5.
18861N/A* Wed Jul 20 2006 - dermot.mccluskey@sun.com
18861N/A- Bump to 0.5.4.
18861N/A And remove patch 03 (upstream)
18861N/A* Thu Jun 15 2006 - ghee.teo@sun.com
18861N/A- Fixed 6437235 stop evince from crashing on PAPI print backend.
18861N/A* Fri Jun 02 2006 - glynn.foster@sun.com
18861N/A- Bump to 0.5.3
18861N/A* Fri Apr 28 2006 - glynn.foster@sun.com
18861N/A- Add patch to install into Office submenu
18861N/A with 'Evince Document Viewer'.
18861N/A* Tue Mar 14 2006 - damien.carbery@sun.com
18861N/A- Bump to 0.5.2.
18861N/A* Fri Jan 20 2006 - damien.carbery@sun.com
18861N/A- Bump to 0.5.0.
18880N/A* Tue Nov 08 2005 - glynn.foster@sun.com
18880N/A- Show the .desktop file entry for the moment.
19898N/A* Fri Sep 30 2005 - brian.cameron@sun.com
19911N/A- Bump to 0.4.0
19898N/A* Wed Aug 24 2005 - damien.carbery@sun.com
19911N/A- Add libgnomeprintui dependency.
20818N/A* Tue Aug 16 2005 - glynn.foster@sun.com
20818N/A- New spec file for evince
20818N/A