eog.spec revision 10616
10145N/A#
10145N/A# spec file for package eog
10145N/A#
10145N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10145N/A# This file and all modifications and additions to the pristine
12242N/A# package are under the same license as the package itself.
10145N/A#
10145N/A# Owner: rickju
10145N/A#
17834N/A%include l10n.inc
10145N/AName: eog
10145N/ALicense: GPL
10145N/AGroup: System/GUI/GNOME
10145N/AVersion: 2.19.1
10145N/ARelease: 1
10145N/ADistribution: Java Desktop System
10145N/AVendor: Sun Microsystems, Inc.
10145N/ASummary: Eye Of GNOME Image Viewer
10145N/ASource: http://ftp.gnome.org/pub/GNOME/sources/eog/2.19/eog-%{version}.tar.bz2
10145N/A%if %build_l10n
16334N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
10145N/A%endif
16334N/A# date:2006-06-06 owner:gman type:branding
16334N/APatch1: eog-01-menu-entry.diff
16334N/A# date:2007-05-10 owner:dcarbery type:branding
10145N/APatch2: eog-02-sys-time.diff
10145N/AURL: http://www.gnome.org
10145N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20055N/ADocdir: %{_defaultdocdir}/doc
20055N/AAutoreqprov: on
10145N/A
10145N/A%define libgnomeui_version 2.5.90
10145N/A%define libgnomeprintui_version 2.6.0
10145N/A%define scrollkeeper_version 0.3.12
10145N/A%define eel_version 2.5.90
12689N/A
19140N/ARequires: libgnomeui >= %{libgnomeui_version}
10145N/ARequires: libgnomeprintui >= %{libgnomeprintui_version}
20857N/ARequires: eel > %{eel_version}
10145N/APrereq: GConf
20239N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
20239N/ABuildRequires: libgnomeprintui-devel >= %{libgnomeprintui_version}
16334N/ABuildRequires: eel-devel >= %{eel_version}
16728N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
16728N/ABuildRequires: intltool
16728N/A
16728N/A%description
16728N/AThe "Eye of GNOME" is a very fast picture viewer, which can either be used as a
20352N/Aplugin for Nautilus, or as a standalone application. This version of EOG is
20352N/Acompiled for the GNOME 2.0 Desktop platform.
10145N/A
10145N/A%prep
10145N/A%setup -q
20055N/A%if %build_l10n
10145N/Abzcat %SOURCE1 | tar xf -
10145N/Acd po-sun; make; cd ..
10145N/A%endif
20857N/A%patch1 -p1
10145N/A%patch2 -p1
10145N/A
10145N/Afor po in po/*.po; do
10145N/A dos2unix -ascii $po $po
10145N/Adone
10145N/A
10145N/A
10145N/A%build
10145N/A%ifos linux
10145N/Aif [ -3 /usr/bin/getconf ]; then
10145N/A CPUS=`getconf _NPROCESSORS_ONLN`
10145N/Afi
10145N/A%else
10145N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10145N/A%endif
10145N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10145N/A CPUS=1
10145N/Afi
12230N/A
16334N/Agnome-doc-common
16334N/Alibtoolize --force
16334N/Aglib-gettextize -f
10145N/Aintltoolize --force --copy
16334N/Aaclocal $ACLOCAL_FLAGS
12594N/Aautomake -a -c -f
12230N/Aautoconf
12952N/A
12952N/ACFLAGS="$RPM_OPT_FLAGS" \
12952N/A./configure --prefix=%{_prefix} \
12952N/A --sysconfdir=%{_sysconfdir} \
12952N/A --libexecdir=%{_libexecdir} \
12952N/A --without-lcms
12952N/Amake -j $CPUS
12952N/A
12952N/A%install
12952N/Arm -rf $RPM_BUILD_ROOT
12952N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
12952N/Amake DESTDIR=$RPM_BUILD_ROOT install
12952N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
12952N/A#Copy zh_HK from zh_TW
12952N/A#Fixes bug 4930405
12952N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
12952N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
12952N/Achmod 644 $RPM_BUILD_ROOT%{_datadir}/gnome/help/eog/*/*.xml
12952N/A
12952N/A
12952N/A%clean
12952N/Arm -rf $RPM_BUILD_ROOT
12952N/A
12952N/A%post
12952N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
12952N/ASCHEMAS="eog.schemas"
12952N/Afor S in $SCHEMAS; do
12952N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
12952N/Adone
13257N/A
13100N/A%files
13100N/A%defattr (-, root, root)
12952N/A%{_bindir}/*
12952N/A%{_sysconfdir}/gconf/schemas/eog.schemas
12952N/A%{_datadir}/applications/eog.desktop
12952N/A%{_datadir}/eog/*
13257N/A%{_datadir}/gnome/help/*
13100N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
13100N/A%{_datadir}/omf/eog/*
12952N/A%{_datadir}/pixmaps/*
12952N/A%{_datadir}/man/man1/*
12230N/A%{_prefix}/var/scrollkeeper
12230N/A
12230N/A%changelog
12952N/A* Thu May 10 2007 - damien.carbery@sun.com
12952N/A- Bump to 2.19.1. Add patch, 02-sys-time, to fix build issue where sys/time.h
12952N/A not included unless included at top of source file.
12952N/A* Thu Apr 29 2007 - rick.ju@sun.com
12952N/A- remove the upstreamed patch eog-01-full-screen-show.diff
12952N/A* Thu Apr 12 2007 - damien.carbery@sun.com
12952N/A- Bump to 2.18.1.
12952N/A* Wed Apr 04 2007 - darren.kenny@sun.com
12952N/A- Wrapped Source1 in a %if %build_l10n
12952N/A* Tue Mar 13 2007 - damien.carbery@sun.com
12952N/A- Bump to 2.18.0.1.
12952N/A* Mon Mar 12 2007 - damien.carbery@sun.com
12952N/A- Bump to 2.18.0.
12952N/A* Tue Mar 06 2005 - damien.carbery@sun.com
12952N/A- Bump to 2.17.92.
12952N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
12952N/A- Add l10n tarball.
12952N/A* Tue Feb 13 2007 - damien.carbery@sun.com
12952N/A- Bump to 2.17.91.
12952N/A* Tue Feb 06 2007 - matt.keenan@sun.com
12952N/A- Remove patch eog-02-jpeg.diff, linker patch no longer needed
12952N/A* Tue Jan 23 2007 - damien.carbery@sun.com
12952N/A- Bump to 2.17.90.
12952N/A* Tue Jan 09 2007 - damien.carbery@sun.com
12952N/A- Bump to 2.17.4.
12952N/A* Tue Dec 19 2006 - damien.carbery@sun.com
12952N/A- Bump to 2.17.3.
12952N/A* Tue Dec 05 2006 - damien.carbery@sun.com
12594N/A- Bump to 2.17.2.
12952N/A* Mon Nov 20 2006 - damien.carbery@sun.com
12952N/A- Bump to 2.17.1.
12952N/A* Fri Oct 20 2006 - damien.carbery@sun.com
12594N/A- Bump to 2.16.1.1.
12594N/A* Mon Oct 02 2006 - damien.carbery@sun.com
12594N/A- Bump to 2.16.1.
12952N/A* Mon Sep 04 2006 - damien.carbery@sun.com
12952N/A- Bump to 2.16.0.1.
12952N/A* Mon Sep 04 2006 - damien.carbery@sun.com
12594N/A- Bump to 2.16.0.
12594N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.15.92.
10145N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.15.91.
10145N/A* Thu Jul 27 2006 - damien.carbery@sun.com
10145N/A- Add dos2unix call to fix po files.
10145N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.15.90.
10145N/A* Fri Jul 21 2006 - laca@sun.com
10145N/A- add --without-lcms to avoid accidentally picking up liblcms (part of
10145N/A spec-files-extra), fixes 6425540
10145N/A* Web Jul 19 2006 - dermot.mccluskey@sun.com
10145N/A- Bump to 2.15.4.
10145N/A* Tue Apr 11 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.14.1.
10145N/A* Tue Mar 14 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.14.0.
10145N/A* Sun Mar 5 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.13.92.
10145N/A* Wed Feb 15 2006 - damien.carbery@sun.com
10145N/A- Bump to 2.13.91.
16334N/A* Thu Jan 19 2006 - damien.carbery@sun.com
16334N/A- Running glib-gettextize is a better fix than patching the Makefile to
16334N/A not go into the po directory. This fixes infinite loop also.
16334N/A* Wed Jan 18 2006 - damien.carbery@sun.com
16334N/A- Add intltoolize call.
16334N/A* Tue Jan 17 2006 - glynn.foster@sun.com
16334N/A- Bump to 2.13.5
16334N/A* Sun Jan 15 2006 - damien.carbery@sun.com
16334N/A- Bump to 2.13.4
16334N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
16334N/A- Bump to 2.13.3
16334N/A* Tue Nov 29 2005 - laca.com
16334N/A- remove javahelp stuff
16334N/A* Tue Nov 29 2005 - damien.carbery@sun.com
16334N/A- Bump to 2.12.2.
16334N/A* Tue Oct 11 2005 - damien.carbery@sun.com
16334N/A- Bump to 2.12.1
16334N/A* Mon Oct 03 2005 - damien.carbery@sun.com
16334N/A- Add patch to link with X11 to build on Solaris. Bugzilla 317828.
16334N/A* Sat Sep 17 2005 - glynn.foster@sun.com
16334N/A- Bump to 2.12.0
16334N/A* Mon Sep 05 2005 - damien.carbery@sun.com
16334N/A- Bump to 2.11.92.
16334N/A* Mon Aug 15 2005 - damien.carbery@sun.com
16334N/A- Bump to 2.11.90.
16334N/A* Thu Aug 04 2005 - laca@sun.com
16334N/A- removed patch image-save-as.diff, fix now in gnome-vfs
16334N/A* Thu Jun 23 2005 - arvind.samptur@wipro.com
16334N/A- Fix files getting deleted when doing a save as. Fixes #6288517
16334N/A* Thu May 19 2005 - glynn.foster@sun.com
16334N/A- Bump to 2.10.0
16334N/A* Fri May 05 2005 - kieran.colfer@sun.com
16334N/A- updating l10n po tarball to 1.15. Fixing CR 6265841
16334N/A* Mon Mar 21 2005 - srirama.sharma@wipro.com
16334N/A- Added eog-06-full-screen-show.diff to see that gtk_grab_add is
16334N/A done only when no other widget holds the grab.
16334N/A Fixes bug #6238888.
16334N/A* Mon Mar 07 2005 - damien.carbery@sun.com
16334N/A* 6233036: Add Source6 to specify Linux version of docs tarball.
10145N/A* Thu Mar 03 2005 - srirama.sharma@wipro.com
10145N/A- Added eog-05-multihead-functionality.diff to
10145N/A make eog functional on a multihead system.
10145N/A Fixes bug #4893502.
10145N/A* Tue Feb 22 2005 - damien.carbery@sun.com
10145N/A* Correct name of docs tarball.
10145N/A* Mon Feb 21 2005 - damien.carbery@sun.com
10145N/A- Correct commit of Jan 25 to update docs tarball to 0.4.
10145N/A* Tue Feb 08 2005 - srirama.sharma@wipro.com
16728N/A- Updated eog-02-print-preview.diff to see that the print-preview window
16728N/A does not diminish in size when invoked multiple times. Fixes bug #6221186.
16531N/A* Tue Jan 25 2005 - damien.carbery@sun.com
16531N/A- Update docs with Linux specific tarball from maeve.anslow@sun.com.
16334N/A* Fri Jan 14 2005 - kazuhiko.maekawa@sun.com
16334N/A- Updated l10n help tarball for cinnabar-linux
16334N/A* Wed Dec 22 2004 - takao.fujiwara@sun.com
13257N/A- Added eog-04-g11n-i18n-ui.diff to localize eog printer dialog.
13257N/A Fix bug 6174164
13100N/A* Wed Aug 25 2004 - Kazuhiko.Maekawa@sun.com
13100N/A- Added l10n help contents with patch
13100N/A* Mon Aug 16 2004 - shirley.woo@sun.com
12952N/A- Updated /usr/share/gnome/help/eog/*/*.xml to 0644 for Solaris integration
12748N/A* Thu Aug 05 2004 - damien.carbery@sun.com
12748N/A- Incorporate new docs tarball from breda.mccolgan@sun.com.
12594N/A* Thu Jul 08 2004 - damien.donlon@sun.com
12594N/A- Updated l10n content to eog-l10n-po-1.2.tar.bz2
12242N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
12242N/A- added "-j $CPUS" to make to speed up builds
12230N/A* Thu Jun 10 2004 - vijaykumar.patwari@wipro.com
12230N/A- Added patch for print preview.
10145N/A* Fri May 28 2004 - damien.carbery@sun.com
10145N/A- Incorporate new docs tarball from breda.mccolgan@sun.com.
10145N/A* Thu May 13 2004 - narayana.pattipati@wipro.com
10145N/A- Added patch eog-01-image-collection-viewer.diff to provide viewer_label
10145N/A for Image Collection Viewer. Fixes bugtraq bug#5043908. Also the changes
10145N/A have been committed to community CVS HEAD on May 12 2004
10145N/A (bugzilla bug#142347)
10145N/A* Wed May 12 2004 - damien.donlon@sun.com
10145N/A- Updated l10n content to eog-l10n-po-1.1.tar.bz2
10145N/A* Fri May 07 2004 - matt.keenan@sun.com
10145N/A- Bump to 2.6.1
10145N/A* Sun Apr 18 2004 - laca@sun.com
10145N/A- enable javahelp conversion on Solaris
10145N/A* Fri Apr 09 2004 - brian.cameron@sun.com
10145N/A- Change the way the build directory is cleaned so that eog and
10145N/A gthumb can be built into the same Solaris package.
10145N/A* Tue Apr 06 2004 - glynn.foster@sun.com
10145N/A- Bump to 2.6.0
10145N/A* Thu Apr 01 2004 - matt.keenan@sun.com
10145N/A- Javahelp conversion
10145N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10145N/A- Updated l10n content to eog-l10n-po-1.0.tar.bz2
10145N/A* Mon Mar 01 2004 - <laca@sun.com>
10145N/A- add $ACLOCAL_FLAGS to aclocal args
10145N/A* Fri Feb 06 2004 - <matt.keenan@sun.com>
10145N/A- Bump tarball to 2.5.4 because of intltool (OrigTree) Failures
10145N/A- Remove patch1 and patch2 no longer needed
10145N/A- bump l10n release
10145N/A* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
10145N/A- add patch 02 for intltool-merge and dep. on intltool
10145N/A* Wed Dec 17 2003 - <glynn.foster@sun.com>
10145N/A- Bump to 2.5.1
10145N/A* Fri Oct 31 2003 - <glynn.foster@sun.com>
10145N/A- Remove potfiles patch [not needed] and Sun Support
10145N/A keyword patch, since we're no longer using the Extras
10145N/A menu.
10145N/A- Update to 2.4.0
10145N/A* Fri Oct 10 2003 - <laca@sun.com>
10145N/A- Update to 2.4.0
10145N/A* Fri Sep 26 2003 - <laca@sun.com>
10145N/A- Integrate Sun docs
10145N/A* Fri Aug 07 2003 - <glynn.foster@sun.com>
10145N/A- Add mnemonics to some menu items.
19150N/A* Fri Aug 01 2003 - <glynn.foster@sun.com>
19467N/A- Add recent files support
* Wed Jul 30 2003 - <glynn.foster@sun.com>
- New tarball
* Mon Jul 28 2003 - <glynn.foster@sun.com>
- Change menu entry.
* Wed Jul 09 2003 - <michael.twomey@sun.com>
- add in sun po files
* Wed Jul 02 2003 - glynn.foster@sun.com
- Fix up the install of the glade file to stop things
crashing
* Wed May 14 2003 - Stephen.Browne@sun.com
- initial release