eog.spec revision 10474
10139N/A#
10139N/A# spec file for package eog
10139N/A#
12217N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
16722N/A# Owner: rickju
10139N/A#
10139N/A%include l10n.inc
10139N/AName: eog
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
17019N/AVersion: 2.18.1
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Eye Of GNOME Image Viewer
16164N/ASource: http://ftp.gnome.org/pub/GNOME/sources/eog/2.18/eog-%{version}.tar.bz2
10411N/A%if %build_l10n
10142N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
12773N/A%endif
12773N/A# date:2005-03-21 owner:rickju type:bug bugster:6238888
12773N/APatch1: eog-01-full-screen-show.diff
10411N/A# date:2006-06-06 owner:gman type:branding
10139N/APatch2: eog-02-menu-entry.diff
10548N/AURL: http://www.gnome.org
15880N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15880N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/A
10139N/A%define libgnomeui_version 2.5.90
10139N/A%define libgnomeprintui_version 2.6.0
10139N/A%define scrollkeeper_version 0.3.12
10139N/A%define eel_version 2.5.90
10139N/A
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: libgnomeprintui >= %{libgnomeprintui_version}
10139N/ARequires: eel > %{eel_version}
10139N/APrereq: GConf
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: libgnomeprintui-devel >= %{libgnomeprintui_version}
10139N/ABuildRequires: eel-devel >= %{eel_version}
10139N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
10139N/ABuildRequires: intltool
10139N/A
10139N/A%description
10139N/AThe "Eye of GNOME" is a very fast picture viewer, which can either be used as a
10139N/Aplugin for Nautilus, or as a standalone application. This version of EOG is
10139N/Acompiled for the GNOME 2.0 Desktop platform.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10139N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
10142N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A
10139N/Afor po in po/*.po; do
15880N/A dos2unix -ascii $po $po
10139N/Adone
10139N/A
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -3 /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Agnome-doc-common
10139N/Alibtoolize --force
10139N/Aglib-gettextize -f
10139N/Aintltoolize --force --copy
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautomake -a -c -f
10139N/Aautoconf
12773N/A
12773N/ACFLAGS="$RPM_OPT_FLAGS" \
12773N/A./configure --prefix=%{_prefix} \
12773N/A --sysconfdir=%{_sysconfdir} \
12773N/A --libexecdir=%{_libexecdir} \
10139N/A --without-lcms
16174N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A#Copy zh_HK from zh_TW
11965N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/Achmod 644 $RPM_BUILD_ROOT%{_datadir}/gnome/help/eog/*/*.xml
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="eog.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_bindir}/*
10139N/A%{_sysconfdir}/gconf/schemas/eog.schemas
10139N/A%{_datadir}/applications/eog.desktop
10139N/A%{_datadir}/eog/*
10139N/A%{_datadir}/gnome/help/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/omf/eog/*
10139N/A%{_datadir}/pixmaps/*
10139N/A%{_datadir}/man/man1/*
10139N/A%{_prefix}/var/scrollkeeper
10139N/A
10139N/A%changelog
10139N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.
10139N/A* Wed Apr 04 2007 - darren.kenny@sun.com
10139N/A- Wrapped Source1 in a %if %build_l10n
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.1.
10139N/A* Mon Mar 12 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.
10139N/A* Tue Mar 06 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.17.92.
17019N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
17019N/A- Add l10n tarball.
16932N/A* Tue Feb 13 2007 - damien.carbery@sun.com
16932N/A- Bump to 2.17.91.
16810N/A* Tue Feb 06 2007 - matt.keenan@sun.com
16810N/A- Remove patch eog-02-jpeg.diff, linker patch no longer needed
16752N/A* Tue Jan 23 2007 - damien.carbery@sun.com
16752N/A- Bump to 2.17.90.
16626N/A* Tue Jan 09 2007 - damien.carbery@sun.com
16626N/A- Bump to 2.17.4.
16379N/A* Tue Dec 19 2006 - damien.carbery@sun.com
16626N/A- Bump to 2.17.3.
16164N/A* Tue Dec 05 2006 - damien.carbery@sun.com
16626N/A- Bump to 2.17.2.
16164N/A* Mon Nov 20 2006 - damien.carbery@sun.com
16149N/A- Bump to 2.17.1.
16626N/A* Fri Oct 20 2006 - damien.carbery@sun.com
16044N/A- Bump to 2.16.1.1.
16626N/A* Mon Oct 02 2006 - damien.carbery@sun.com
15880N/A- Bump to 2.16.1.
16626N/A* Mon Sep 04 2006 - damien.carbery@sun.com
15880N/A- Bump to 2.16.0.1.
15448N/A* Mon Sep 04 2006 - damien.carbery@sun.com
16626N/A- Bump to 2.16.0.
14482N/A* Tue Aug 22 2006 - damien.carbery@sun.com
14482N/A- Bump to 2.15.92.
14203N/A* Tue Aug 08 2006 - damien.carbery@sun.com
14203N/A- Bump to 2.15.91.
14117N/A* Thu Jul 27 2006 - damien.carbery@sun.com
14117N/A- Add dos2unix call to fix po files.
13958N/A* Mon Jul 24 2006 - damien.carbery@sun.com
16626N/A- Bump to 2.15.90.
13777N/A* Fri Jul 21 2006 - laca@sun.com
13777N/A- add --without-lcms to avoid accidentally picking up liblcms (part of
13619N/A spec-files-extra), fixes 6425540
13619N/A* Web Jul 19 2006 - dermot.mccluskey@sun.com
13431N/A- Bump to 2.15.4.
13431N/A* Tue Apr 11 2006 - damien.carbery@sun.com
13380N/A- Bump to 2.14.1.
13380N/A* Tue Mar 14 2006 - damien.carbery@sun.com
13322N/A- Bump to 2.14.0.
13322N/A* Sun Mar 5 2006 - damien.carbery@sun.com
13260N/A- Bump to 2.13.92.
13260N/A* Wed Feb 15 2006 - damien.carbery@sun.com
13113N/A- Bump to 2.13.91.
13113N/A* Thu Jan 19 2006 - damien.carbery@sun.com
12813N/A- Running glib-gettextize is a better fix than patching the Makefile to
12813N/A not go into the po directory. This fixes infinite loop also.
12571N/A* Wed Jan 18 2006 - damien.carbery@sun.com
12571N/A- Add intltoolize call.
12467N/A* Tue Jan 17 2006 - glynn.foster@sun.com
12467N/A- Bump to 2.13.5
12418N/A* Sun Jan 15 2006 - damien.carbery@sun.com
12418N/A- Bump to 2.13.4
12418N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
12369N/A- Bump to 2.13.3
12369N/A* Tue Nov 29 2005 - laca.com
12217N/A- remove javahelp stuff
12217N/A* Tue Nov 29 2005 - damien.carbery@sun.com
12072N/A- Bump to 2.12.2.
12072N/A* Tue Oct 11 2005 - damien.carbery@sun.com
12072N/A- Bump to 2.12.1
12022N/A* Mon Oct 03 2005 - damien.carbery@sun.com
11975N/A- Add patch to link with X11 to build on Solaris. Bugzilla 317828.
11975N/A* Sat Sep 17 2005 - glynn.foster@sun.com
11819N/A- Bump to 2.12.0
11819N/A* Mon Sep 05 2005 - damien.carbery@sun.com
11416N/A- Bump to 2.11.92.
11416N/A* Mon Aug 15 2005 - damien.carbery@sun.com
11253N/A- Bump to 2.11.90.
11253N/A* Thu Aug 04 2005 - laca@sun.com
11185N/A- removed patch image-save-as.diff, fix now in gnome-vfs
11185N/A* Thu Jun 23 2005 - arvind.samptur@wipro.com
11123N/A- Fix files getting deleted when doing a save as. Fixes #6288517
11123N/A* Thu May 19 2005 - glynn.foster@sun.com
11070N/A- Bump to 2.10.0
11070N/A* Fri May 05 2005 - kieran.colfer@sun.com
10917N/A- updating l10n po tarball to 1.15. Fixing CR 6265841
10917N/A* Mon Mar 21 2005 - srirama.sharma@wipro.com
10746N/A- Added eog-06-full-screen-show.diff to see that gtk_grab_add is
10746N/A done only when no other widget holds the grab.
10651N/A Fixes bug #6238888.
10651N/A* Mon Mar 07 2005 - damien.carbery@sun.com
10603N/A* 6233036: Add Source6 to specify Linux version of docs tarball.
10616N/A* Thu Mar 03 2005 - srirama.sharma@wipro.com
10616N/A- Added eog-05-multihead-functionality.diff to
10548N/A make eog functional on a multihead system.
16626N/A Fixes bug #4893502.
10474N/A* Tue Feb 22 2005 - damien.carbery@sun.com
10474N/A* Correct name of docs tarball.
10413N/A* Mon Feb 21 2005 - damien.carbery@sun.com
10413N/A- Correct commit of Jan 25 to update docs tarball to 0.4.
10285N/A* Tue Feb 08 2005 - srirama.sharma@wipro.com
10285N/A- Updated eog-02-print-preview.diff to see that the print-preview window
10261N/A does not diminish in size when invoked multiple times. Fixes bug #6221186.
10261N/A* Tue Jan 25 2005 - damien.carbery@sun.com
10199N/A- Update docs with Linux specific tarball from maeve.anslow@sun.com.
10199N/A* Fri Jan 14 2005 - kazuhiko.maekawa@sun.com
10139N/A- Updated l10n help tarball for cinnabar-linux
10139N/A* Wed Dec 22 2004 - takao.fujiwara@sun.com
10139N/A- Added eog-04-g11n-i18n-ui.diff to localize eog printer dialog.
10139N/A Fix bug 6174164
10139N/A* Wed Aug 25 2004 - Kazuhiko.Maekawa@sun.com
10139N/A- Added l10n help contents with patch
10139N/A* Mon Aug 16 2004 - shirley.woo@sun.com
10139N/A- Updated /usr/share/gnome/help/eog/*/*.xml to 0644 for Solaris integration
10139N/A* Thu Aug 05 2004 - damien.carbery@sun.com
10139N/A- Incorporate new docs tarball from breda.mccolgan@sun.com.
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to eog-l10n-po-1.2.tar.bz2
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Thu Jun 10 2004 - vijaykumar.patwari@wipro.com
10139N/A- Added patch for print preview.
10139N/A* Fri May 28 2004 - damien.carbery@sun.com
10139N/A- Incorporate new docs tarball from breda.mccolgan@sun.com.
10139N/A* Thu May 13 2004 - narayana.pattipati@wipro.com
10139N/A- Added patch eog-01-image-collection-viewer.diff to provide viewer_label
10139N/A for Image Collection Viewer. Fixes bugtraq bug#5043908. Also the changes
10139N/A have been committed to community CVS HEAD on May 12 2004
10139N/A (bugzilla bug#142347)
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to eog-l10n-po-1.1.tar.bz2
10139N/A* Fri May 07 2004 - matt.keenan@sun.com
10139N/A- Bump to 2.6.1
10139N/A* Sun Apr 18 2004 - laca@sun.com
10139N/A- enable javahelp conversion on Solaris
10139N/A* Fri Apr 09 2004 - brian.cameron@sun.com
10139N/A- Change the way the build directory is cleaned so that eog and
10139N/A gthumb can be built into the same Solaris package.
10139N/A* Tue Apr 06 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.6.0
16626N/A* Thu Apr 01 2004 - matt.keenan@sun.com
10139N/A- Javahelp conversion
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to eog-l10n-po-1.0.tar.bz2
10139N/A* Mon Mar 01 2004 - <laca@sun.com>
10139N/A- add $ACLOCAL_FLAGS to aclocal args
10139N/A* Fri Feb 06 2004 - <matt.keenan@sun.com>
10139N/A- Bump tarball to 2.5.4 because of intltool (OrigTree) Failures
10139N/A- Remove patch1 and patch2 no longer needed
10139N/A- bump l10n release
10139N/A* Thu Jan 29 2004 - <dermot.mccluskey@sun.com>
10139N/A- add patch 02 for intltool-merge and dep. on intltool
10139N/A* Wed Dec 17 2003 - <glynn.foster@sun.com>
10139N/A- Bump to 2.5.1
10139N/A* Fri Oct 31 2003 - <glynn.foster@sun.com>
10139N/A- Remove potfiles patch [not needed] and Sun Support
10139N/A keyword patch, since we're no longer using the Extras
16626N/A menu.
10139N/A- Update to 2.4.0
16626N/A* Fri Oct 10 2003 - <laca@sun.com>
10139N/A- Update to 2.4.0
16626N/A* Fri Sep 26 2003 - <laca@sun.com>
10139N/A- Integrate Sun docs
10139N/A* Fri Aug 07 2003 - <glynn.foster@sun.com>
10139N/A- Add mnemonics to some menu items.
10139N/A* Fri Aug 01 2003 - <glynn.foster@sun.com>
10139N/A- Add recent files support
16626N/A* Wed Jul 30 2003 - <glynn.foster@sun.com>
10139N/A- New tarball
10139N/A* Mon Jul 28 2003 - <glynn.foster@sun.com>
10139N/A- Change menu entry.
16626N/A* Wed Jul 09 2003 - <michael.twomey@sun.com>
10139N/A- add in sun po files
10139N/A* Wed Jul 02 2003 - glynn.foster@sun.com
10139N/A- Fix up the install of the glade file to stop things
10139N/A crashing
10139N/A* Wed May 14 2003 - Stephen.Browne@sun.com
16626N/A- initial release
10139N/A