eog-plugins.spec revision 18650
18319N/A#
18337N/A# base spec file for package eog-plugins
18319N/A#
18319N/A# Copyright (c) 2010 Sun Microsystems, Inc.
18319N/A# This file and all modifications and additions to the pristine
18319N/A# package are under the same license as the package itself.
18319N/A#
18319N/A%define owner jouby
18632N/A
18644N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
18632N/A
18319N/A#
18319N/A
18319N/AName: eog-plugins
18319N/ALicense: GPLv2
18319N/AGroup: System/GUI/GNOME
18319N/AVersion: 2.29.5
18319N/ARelease: 1
18615N/AVendor: Gnome Community
18337N/ASummary: Eog plugins
18319N/ASource: http://ftp.gnome.org/pub/GNOME/sources/eog-plugins/2.29/eog-plugins-%{version}.tar.bz2
18319N/A
18319N/AURL: http://live.gnome.org/EyeOfGnome/Plugins
18319N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18319N/ADocdir: %{_defaultdocdir}/doc
18319N/AAutoreqprov: on
18319N/A
18319N/A
18319N/A%description
18337N/Aplugins of package eog ("Eye of GNOME")
18319N/A
18319N/A%prep
18319N/A%setup -q
18650N/A#%if %build_l10n
18650N/A#bzcat %SOURCE1 | tar xf -
18650N/A#cd po-sun; make; cd ..
18650N/A#%endif
18319N/A
18650N/A#for po in po/*.po; do
18650N/A# dos2unix -ascii $po $po
18650N/A#done
18319N/A
18319N/A%build
18319N/A%ifos linux
18319N/Aif [ -3 /usr/bin/getconf ]; then
18319N/A CPUS=`getconf _NPROCESSORS_ONLN`
18319N/Afi
18319N/A%else
18319N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18319N/A%endif
18319N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18319N/A CPUS=1
18319N/Afi
18319N/A
18319N/Agnome-doc-common
18319N/Alibtoolize --force
18319N/Aglib-gettextize -f
18319N/Aintltoolize --force --copy
18319N/A
18319N/A
18319N/Aaclocal $ACLOCAL_FLAGS
18319N/Aautomake -a -c -f
18319N/Aautoconf
18319N/A
18319N/ACFLAGS="$RPM_OPT_FLAGS -g" \
18319N/A./configure --prefix=%{_prefix} \
18319N/A --sysconfdir=%{_sysconfdir} \
18319N/A --libexecdir=%{_libexecdir} \
18319N/A --disable-scrollkeeper \
18319N/A --without-lcms \
18555N/A --with-plugins=champlain,exif-display,fit-to-width,pythonconsole,slideshowshuffle,send-by-mail
18319N/A
18319N/Amake -j $CPUS
18319N/A
18319N/A%install
18319N/Arm -rf $RPM_BUILD_ROOT
18319N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
18319N/Amake DESTDIR=$RPM_BUILD_ROOT install
18319N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
18319N/A
18319N/A
18319N/A%clean
18319N/Arm -rf $RPM_BUILD_ROOT
18319N/A
18319N/A%changelog
18650N/A* Thu Apr 22 2010 - christian.kelly@oracle.com
18650N/A- Comment out l10n stuff. Seems to be missing.
18650N/A* Wen Api 07 2010 - yuntong.jin@sun.com
18555N/A- Add send-by-mail plugin
18650N/A* Tue Jan 19 2010 - yuntong.jin@sun.com
18319N/A- Init