ekiga.spec revision 18826
16060N/A#
16060N/A# spec file for package ekiga
16060N/A#
16060N/A# Copyright 2007 Sun Microsystems, Inc.
16060N/A# This file and all modifications and additions to the pristine
16060N/A# package are under the same license as the package itself.
16060N/A#
16060N/A%define owner hawklu
16060N/A#
16060N/A
16060N/A%define OSR 10431:3.0
16060N/A
16060N/A%include l10n.inc
16060N/AName: ekiga
16060N/ALicense: GPLv2
16060N/AGroup: X11/GNOME/Applications
16060N/AVersion: 3.2.7
16060N/ARelease: 1
16060N/AVendor: www.ekiga.org
16060N/ADistribution: Java Desktop System
16060N/ASummary: A GNOME based H.323/SIP video conferencing application
16060N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ekiga/3.2/%{name}-%{version}.tar.gz
16060N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
16060N/ASource3: http://downloads.sourceforge.net/sourceforge/boost/boost_1_39_0.tar.bz2
16060N/A
16060N/A# owner:gman date:2006-06-02 type:branding
16060N/A# change the menu entry according to the UI spec
16060N/APatch1: ekiga-01-menu-entry.diff
16060N/A
16060N/A# owner:elaine date:2008-11-11 type:branding
16060N/APatch2: ekiga-02-openldap-location.diff
16060N/A
16060N/A# owner:elaine date:2009-07-13 type:branding
16060N/A# Once Boost integrateed please remove this patch
16060N/Apatch3: ekiga-03-boost-header.diff
16060N/A
16060N/A
16060N/AURL: http://www.ekiga.org
16060N/ABuildRoot: %{_tmppath}/%{name}-root
16060N/ADocdir: %{_docdir}/%{name}
16060N/AAutoreqprov: on
16060N/A
16060N/A# The following version definitions probably are out of date, need update
16060N/A%define GConf_version 2.4.0.1
16060N/A%define gtk2_version 2.3.1
16060N/A%define openldap2_devel_version 2.1.4
16060N/A%define intltool_version 0.27
16060N/A%define libgnomeui_version 2.4.0.1
16060N/A%define des_version 4.04
16060N/A%define heimdal_version 0.4
16060N/A%define cyrus_sasl_version 1.5.27
16060N/A%define openssl_version 0.9.6
16060N/A%define flex_version 2.5.4
16060N/A%define slang_version 1.4.5
16060N/A%define pam_version 0.76
16060N/A%define db_version 4.0.14
16060N/A%define gdbm_version 1.8.0
16060N/A%define howl_version 1.0.0
16060N/A
16060N/ARequires: ptlib >= %{ptlib_version}
16060N/ARequires: opal >= %{opal_version}
16060N/ARequires: GConf >= %{GConf_version}
16060N/ARequires: libgnomeui >= %{libgnomeui_version}
16060N/ARequires: howl >= %{howl_version}
16060N/ARequires: evolution-data-server
16060N/ABuildRequires: gtk2-devel >= %{gtk2_version}
16060N/ABuildRequires: GConf-devel >= %{GConf_version}
16060N/ABuildRequires: openh323-devel >= %{openh323_version}
16060N/ABuildRequires: ptlib-devel >= %{ptlib_version}
16060N/ABuildRequires: intltool >= %{intltool_version}
16060N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
16060N/ABuildRequires: des >= %{des_version}
16060N/ABuildRequires: heimdal-devel >= %{heimdal_version}
16060N/ABuildRequires: cyrus-sasl-devel >= %{cyrus_sasl_version}
16060N/ABuildRequires: openssl-devel >= %{openssl_version}
16060N/ABuildRequires: openldap2-devel >= %{openldap2_devel_version}
16060N/ABuildRequires: flex >= %{flex_version}
16060N/ABuildRequires: slang-devel >= %{slang_version}
16060N/ABuildRequires: pam-devel >= %{pam_version}
16060N/ABuildRequires: db-devel >= %{db_version}
16060N/ABuildRequires: gdbm-devel >= %{gdbm_version}
16060N/ABuildRequires: howl-devel >= %{howl_version}
16060N/ABuildRequires: evolution-data-server-devel
16060N/APrereq: GConf
16060N/A
16060N/A%description
16060N/AEkiga is a free Voice over IP phone allowing you to do free calls over
16060N/Athe Internet. Ekiga is the first Open Source application to support
16060N/Aboth H.323 and SIP, as well as audio and video. Ekiga was formerly known
16060N/Aas GnomeMeeting.
16060N/A
16060N/A%prep
16060N/A%setup -q -n %{name}-%{version}
16060N/A%if %build_l10n
16060N/Abzcat %SOURCE2 | tar xf -
16060N/Acd po-sun; make; cd ..
16060N/A%endif
16060N/A#Once boost integrated pls remove the below 2 lines
16060N/Abzcat %SOURCE3 | tar xf -
16060N/Amv boost_1_39_0/boost boost
16060N/Acp %{opal_dir}/include/opal.h %{opal_dir}/include/opal/
16060N/A%patch1 -p1
16060N/A%patch2 -p1
16060N/A%patch3 -p1
16060N/A
16060N/A%build
16060N/A%ifos linux
16060N/Aif [ -x /usr/bin/getconf ]; then
16060N/A CPUS=`getconf _NPROCESSORS_ONLN`
16060N/Afi
16060N/A%else
16060N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
16060N/A%endif
16060N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
16060N/A CPUS=1
16060N/Afi
16060N/A
16060N/Aexport CFLAGS="%optflags -DSOLARIS -D__inline=inline"
16060N/Aexport CXXFLAGS="%cxx_optflags -DSOLARIS -D__inline=inline -I%{ptlib_dir}/include"
16060N/Aexport LDFLAGS="%_ldflags"
16060N/A#export XGETTEXT=`which xgettext`
16060N/A
16060N/Aexport CONFIG_SHELL=/bin/bash
16060N/A
16060N/A%{?ekiga_libdir:export LDFLAGS="$LDFLAGS -R%{ekiga_libdir}"}
16060N/A./configure --prefix=%{_prefix} \
16060N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
16060N/A --bindir=%{_bindir} \
16060N/A --datadir=%{_datadir} \
16060N/A --includedir=%{_includedir} \
16060N/A --mandir=%{_mandir} \
16060N/A --sysconfdir=%{_sysconfdir} \
16060N/A --disable-ldap \
16060N/A --disable-notify \
16060N/A --enable-xv
16060N/Agmake -j $CPUS
16060N/A
16060N/A%install
16060N/AGCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
16060N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
16060N/Agmake install DESTDIR=$RPM_BUILD_ROOT
16060N/A
16060N/Arm -f $RPM_BUILD_ROOT%{_bindir}/*config*
16060N/Arm -f $RPM_BUILD_ROOT%{_bindir}/ekiga-helper
16060N/Arm -rf $RPM_BUILD_ROOT%{_includedir}
16060N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}
16060N/A
16060N/A%clean
16060N/Arm -rf $RPM_BUILD_ROOT
16060N/A
16060N/A%post
16060N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
16060N/ASCHEMAS="ekiga.schemas"
16060N/Afor S in $SCHEMAS; do
16060N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
16060N/Adone
16060N/A
16060N/A%files
16060N/A%defattr(-,root,root)
16060N/A%dir %{_datadir}/ekiga/xdap
16060N/A%dir %{_datadir}/sounds/ekiga
16060N/A%{_bindir}/ekiga*
16060N/A%{_datadir}/locale/*/LC_MESSAGES/ekiga.mo
16060N/A%{_datadir}/applications/ekiga.desktop
16060N/A%{_datadir}/sounds/ekiga/*
16060N/A%{_datadir}/pixmaps/ekiga*
16060N/A%{_libdir}/bonobo/servers/ekiga.server
16060N/A%{_datadir}/ekiga/xdap/*
16060N/A%{_sysconfdir}/gconf/schemas/ekiga.schemas
16060N/A%{_datadir}/gnome/*
16060N/A%{_datadir}/omf/*
16060N/A%{_mandir}/man1/*
16060N/A
16060N/A
16060N/A%changelog
16060N/A* Fri Jun 04 2010 - brian.lu@sun.com
16060N/A- Bump to 3.2.7
16060N/A* Tue May 25 2010 - brian.lu@sun.com
16060N/A- Add --disable-notify to fix the bug d.o.o 11247
16060N/A* Fri Apr 23 2010 - christian.kelly@oracle.com
16060N/A- Set CONFIG_SHELL until I get the build systems upgraded to CBE 1.7.
16060N/A* Thu Jan 07 2009 - brian.lu@sun.com
16060N/A- Change the owner to hawklu
16060N/A* Fri Sep 25 2009 - brian.lu@sun.com
16060N/A- Add option --disable-ldap
16060N/A* Wed Sep 23 2009 - dave.lin@sun.com
16060N/A- Bump to 3.2.6
16060N/A* Tue Jul 14 2009 - elaine.xiong@sun.com
16060N/A- Bump to 3.2.5. Remove upstream patches. Add Boost as build dependency
16060N/A and related patch.
16060N/A* Thu Apr 16 2009 - takao.fujiwara@sun.com
16060N/A- Add patch ekiga-05-check-spaces.diff. bugzilla:578359
16060N/A* Mon Mar 23 2009 - elaine.xiong@sun.com
16060N/A- Remove ekiga-helper to fix man page problem.
16060N/A* Thu Nov 20 2008 - elaine.xiong@sun.com
16060N/A- Bump to 3.0.1.
16060N/A* Fri Nov 14 2008 - elaine.xiong@sun.com
16060N/A- Bump to 3.0.0. Add new patches and remove obsolete patches.
16060N/A- Update build options for new version.
16060N/A* Wed Sep 03 2008 - elaine.xiong@sun.com
16060N/A- Add note to not bump to 2.9.90 as it's actually 3.0 beta1 and not ready for
16060N/A Solaris.
16060N/A* Mon Jul 21 2008 - elaine.xiong@sun.com
16060N/A- Add bugID.
16060N/A* Mon Mar 10 2008 - damien.carbery@sun.com
16060N/A- Bump to 2.0.12.
16060N/A* Wed Mar 05 2008 - elaine.xiong@sun.com
16060N/A- Add ekiga-06-rm-evcard.diff to fix bugster#6665230.
16060N/A But this patch will not be compatible with Ekiga 3.0.
16060N/A* Sun Dec 23 2007 - patrick.ale@gmail.com
16060N/A- Set the XGETTEXT variable based on `which xgettext`
16060N/A Since we use JDS-CBE this should be /opt/jdsbld/bin/xgettext
16060N/A Ekiga will FAIL when /usr/bin/xgettext (NON-GNU version) is used.
16060N/A* Fri Nov 02 2007 - elaine.xiong@sun.com
16060N/A- Enable Avahi support.
16060N/A* Tue Sep 18 2007 - damien.carbery@sun.com
16060N/A- Bump to 2.0.11. Remove upstream patch, 06-loopback.
16060N/A* Thu Aug 30 2007 - elaine.xiong@sun.com
16060N/A- Disable DBUS component due to weak support.
16060N/A* Thu Jun 28 2007 - elaine.xiong@sun.com
16060N/A- Explicitly enable the DBUS component.
16060N/A* Sun Jun 03 2007 - elaine.xiong@sun.com
16060N/A- Add patch ekiga-06-loopback.diff to fix bugzilla439873
16060N/A* Wed Apr 25 2007 - elaine.xiong@sun.com
16060N/A- Update owner name for ekiga-04-performance-tuning.diff
16060N/A* Thu Apr 19 2007 - elaine.xiong@sun.com
16060N/A- Bump to 2.0.9.
16060N/A* Tue Apr 17 2007 - elaine.xiong@sun.com
16060N/A- move the -Lpath that could specify the /usr/lib/ as the search directory
16060N/A when link time.
16060N/A* Thu Apr 5 2007 - laca@sun.com
16060N/A- move libsdl, pwlib and opal to their own separate spec files
16060N/A* Fri Mar 23 2007 - elaine.xiong@sun.com
16060N/A- Add patch ekiga-23-opal-illege-payloadtype.diff to fix bugster6537448
16060N/A already upstream. Refer to
16060N/A http://openh323.cvs.sourceforge.net/openh323/opal/src/h323/h323.cxx?r1=2.143&r2=2.144
16060N/A* Mon Mar 20 2007 - damien.carbery@sun.com
16060N/A- Point at ftp.gnome.org for ekiga bz2 tarball. ekiga.org only has gz tarball.
16060N/A* Mon Mar 12 2007 - damien.carbery@sun.com
16060N/A- Bump to 2.0.7; bump pwlib to 1.10.5 & bump opal to 2.2.6. Remove upstream
16060N/A patch, 21-pwlib-v4l2-enable, renumber remainder.
16060N/A* Sun Mar 11 2007 - elaine.xiong@sun.com
16060N/A- Add patch ekiga-22-ekiga-performance-tuning.diff
16060N/A ekiga-23-pwlib-performance-tuning.diff
16060N/A Both of them for ekiga performance tuning with video support.
16060N/A Will upstream them or part of them to community if tuning is done.
16060N/A* Wed Feb 14 2007 - elaine.xiong@sun.com
16060N/A- Add patch ekiga-21-pwlib-enable-v4l2.diff to fix bugzilla407820
16060N/A Meantime enable V4L2 plugin in ekiga.spec
16060N/A* Wed Feb 14 2007 - damien.carbery@sun.com
16060N/A- Bump to 2.0.5; bump pwlib to 1.10.4 & bump opal to 2.2.5.
16060N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
16060N/A- Add l10n tarball.
16060N/A* Mon Jan 29 2007 - elaine.xiong@sun.com
16060N/A- Cancel parallel job option for ekiga(including sdl, pwlib, opal) build.
16060N/A To temporily solve the potential problems caused by parallel.
16060N/A Will be fixed ASAP.
16060N/A* Sat Jan 27 2007 - elaine.xiong@sun.com
16060N/A- Bump ekiga to 2.0.4 shrink patches and spec file for build failure
16060N/A* Wed Jan 24 2007 - damien.carbery@sun.com
16060N/A- Bump pwlib to 1.10.3, opal to 2.2.4. Remove upstream patches,
16060N/A 08-pwlib-disconnect, 09-pwlib-unset-port, 13-opal-bz356696,
16060N/A 15-opal-invalidarrayindex, 16-pwlib-video. Add patch 20-opal-break to fix
16060N/A build error (sourceforge: 1643652).
16060N/A* Mon Jan 22 2007 - damien.carbery@sun.com
16060N/A- Bump to 2.0.4.
16060N/A* Thu Jan 04 2007 - elaine.xiong@sun.com
16060N/A- Add patch ekiga-19-freeze-accessibility.diff. Workes around bugzilla 329454.
16060N/A* Thu Dec 28 2006 - dave.lin@sun.com
16060N/A- change the patch type to branding for some patches in patch comments
16060N/A* Wed Nov 29 2006 - damien.carbery@sun.com
16060N/A- Fix typo in name of patch 18: s/18-opal-sunray/18-sunray/
16060N/A* Mon Nov 27 2006 - brian.lu@sun.com
16060N/A- Add patch ekiga-18-sunray-port-conflict.diff. Fixes bugzilla 367516.
16060N/A* Mon Nov 20 2006 - davelin@sun.com
16060N/A- Add patch comment
16060N/A* Thu Nov 02 2006 - davelin@sun.com
16060N/A- Bump version to 2.0.3
16060N/A- Sync patches those have been upstreamed in ekiga community trunk
16060N/A- ekiga-10-pwlib-bz356696.diff, ekiga-13-opal-bz356696.diff(better fix
16060N/A for bugzilla356696)
16060N/A- ekiga-15-opal-invalidarrayindex.diff(bugzilla367482)
16060N/A- ekiga-16-pwlib-video.diff(bugzilla367516)
16060N/A- ekiga-17-opal-rtp.diff(CR#6483823, CR#6483831, which caused revert to
16060N/A 2.0.2 in b52b)
16060N/A* Wed Oct 25 2006 - davelin@sun.com
16060N/A- Roll back to the previous version 2.0.2 since following critical bug
16060N/A was found in 2.0.3 CR#6483823(and another P2 bug CR#6483831)
16060N/A* Tue Oct 17 2006 - dave.lin@sun.com
16060N/A- Bump version to 2.0.3
16060N/A- Add patch ekiga-pwlib-09-unset-port.diff to fix bug CR#6476679
16060N/A- Add patch ekiga-10-pwlib-bz356696.diff to fix bug gnome bugzilla #356696
16060N/A* Mon Oct 09 2006 - dave.lin@sun.com
16060N/A- Add patch ekiga-08-pwlib-disconnect-crash.diff to fix bug CR#6470530
16060N/A* Fri Sep 15 2006 - dermot.mccluskey@sun.com
16060N/A- Fixed erroneous comments in %defines
16060N/A* Wed Sep 06 2006 - damien.carbery@sun.com
16060N/A- Bump pwlib to 1.10.2, opal to 2.2.3.
16060N/A* Mon Sep 04 2006 - damien.carbery@sun.com
16060N/A- Bump to 2.0.3.
16060N/A* Mon Sep 04 2006 - damien.carbery@sun.com
16060N/A- Bump libsdl to 1.2.11.
16060N/A* Tue Aug 08 2006 - damien.carbery@sun.com
16060N/A- Change 'cd dir*' to use '%{version}'.
16060N/A* Mon Jul 10 2006 - dave.lin@sun.com
16060N/A- change to use Ekiga 2.0.2 release
16060N/A* Fri Jun 16 2006 - dave.lin@sun.com
16060N/A- add GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 to make sure not
16060N/A install the directory based %gconf.xml files based on the
16060N/A instruction in gconf.txt
16060N/A* Wed Jun 07 2006 - damien.carbery@sun.com
16060N/A- chdir into ekiga dir before applying ekiga patches.
16060N/A* Fri Jun 02 2006 - glynn.foster@sun.com
16060N/A- Add patch for change the menu entry according to the UI spec.
16060N/A* Mon May 15 2006 - dave.lin@sun.com
16060N/A- Add patch ekiga-08-multi-decla.diff to fix multiple declaration
16060N/A error.
16060N/A* Fri Apr 14 2006 - <dave.lin@sun.com>
16060N/A- Initial release for ekiga
16060N/A