ekiga.spec revision 17396
10139N/A#
10139N/A# spec file for package ekiga
10139N/A#
10430N/A# Copyright 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner elaine
10139N/A#
10139N/A%include l10n.inc
10139N/AName: ekiga
10139N/ALicense: GPL
10139N/AGroup: X11/GNOME/Applications
17396N/AVersion: 3.2.6
10139N/ARelease: 1
10139N/AVendor: Sun Microsystems, Inc.
10139N/ADistribution: Java Desktop System
10139N/ASummary: A GNOME based H.323/SIP video conferencing application
16772N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ekiga/3.2/%{name}-%{version}.tar.gz
10430N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
16772N/ASource3: http://downloads.sourceforge.net/sourceforge/boost/boost_1_39_0.tar.bz2
10139N/A
10139N/A# owner:gman date:2006-06-02 type:branding
10139N/A# change the menu entry according to the UI spec
10430N/APatch1: ekiga-01-menu-entry.diff
10139N/A
15354N/A# owner:elaine date:2008-11-11 type:branding
16772N/APatch2: ekiga-02-openldap-location.diff
10139N/A
16772N/A# owner:elaine date:2009-07-13 type:branding
16772N/A# Once Boost integrateed please remove this patch
16772N/Apatch3: ekiga-03-boost-header.diff
10353N/A
16385N/A
10139N/AURL: http://www.ekiga.org
10139N/ABuildRoot: %{_tmppath}/%{name}-root
10139N/ADocdir: %{_docdir}/%{name}
10139N/AAutoreqprov: on
10139N/A
10139N/A# The following version definitions probably are out of date, need update
10139N/A%define GConf_version 2.4.0.1
10139N/A%define gtk2_version 2.3.1
10139N/A%define openldap2_devel_version 2.1.4
10139N/A%define intltool_version 0.27
10139N/A%define libgnomeui_version 2.4.0.1
10139N/A%define des_version 4.04
10139N/A%define heimdal_version 0.4
10139N/A%define cyrus_sasl_version 1.5.27
10139N/A%define openssl_version 0.9.6
10139N/A%define flex_version 2.5.4
10139N/A%define slang_version 1.4.5
10139N/A%define pam_version 0.76
10139N/A%define db_version 4.0.14
10139N/A%define gdbm_version 1.8.0
10139N/A%define howl_version 1.0.0
10139N/A
15354N/ARequires: ptlib >= %{ptlib_version}
10139N/ARequires: opal >= %{opal_version}
10139N/ARequires: GConf >= %{GConf_version}
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: howl >= %{howl_version}
10139N/ARequires: evolution-data-server
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: GConf-devel >= %{GConf_version}
10139N/ABuildRequires: openh323-devel >= %{openh323_version}
15354N/ABuildRequires: ptlib-devel >= %{ptlib_version}
10139N/ABuildRequires: intltool >= %{intltool_version}
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: des >= %{des_version}
10139N/ABuildRequires: heimdal-devel >= %{heimdal_version}
10139N/ABuildRequires: cyrus-sasl-devel >= %{cyrus_sasl_version}
10139N/ABuildRequires: openssl-devel >= %{openssl_version}
10139N/ABuildRequires: openldap2-devel >= %{openldap2_devel_version}
10139N/ABuildRequires: flex >= %{flex_version}
10139N/ABuildRequires: slang-devel >= %{slang_version}
10139N/ABuildRequires: pam-devel >= %{pam_version}
10139N/ABuildRequires: db-devel >= %{db_version}
10139N/ABuildRequires: gdbm-devel >= %{gdbm_version}
10139N/ABuildRequires: howl-devel >= %{howl_version}
10139N/ABuildRequires: evolution-data-server-devel
10139N/APrereq: GConf
10139N/A
10139N/A%description
10139N/AEkiga is a free Voice over IP phone allowing you to do free calls over
10139N/Athe Internet. Ekiga is the first Open Source application to support
10139N/Aboth H.323 and SIP, as well as audio and video. Ekiga was formerly known
10139N/Aas GnomeMeeting.
10139N/A
10139N/A%prep
10430N/A%setup -q -n %{name}-%{version}
10139N/A%if %build_l10n
10430N/Abzcat %SOURCE2 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
16772N/A#Once boost integrated pls remove the below 2 lines
16772N/Abzcat %SOURCE3 | tar xf -
16772N/Amv boost_1_39_0/boost boost
16772N/Acp %{opal_dir}/include/opal.h %{opal_dir}/include/opal/
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
15354N/Aexport CFLAGS="%optflags -DSOLARIS -D__inline=inline"
15354N/Aexport CXXFLAGS="%cxx_optflags -DSOLARIS -D__inline=inline -I%{ptlib_dir}/include"
10430N/Aexport LDFLAGS="%_ldflags"
15354N/A#export XGETTEXT=`which xgettext`
12090N/A
10495N/A%{?ekiga_libdir:export LDFLAGS="$LDFLAGS -R%{ekiga_libdir}"}
16772N/A#aclocal
15354N/Aautoconf
15354N/A./configure --prefix=%{_prefix} \
10430N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
10139N/A --bindir=%{_bindir} \
10139N/A --datadir=%{_datadir} \
10139N/A --includedir=%{_includedir} \
10139N/A --mandir=%{_mandir} \
10139N/A --sysconfdir=%{_sysconfdir} \
15354N/A %{?ptlib_opt} %{?opal_opt} \
15354N/A --enable-xv
15354N/Agmake -j $CPUS
10139N/A
10139N/A%install
10139N/AGCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
15354N/Agmake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/Arm -f $RPM_BUILD_ROOT%{_bindir}/*config*
16223N/Arm -f $RPM_BUILD_ROOT%{_bindir}/ekiga-helper
10139N/Arm -rf $RPM_BUILD_ROOT%{_includedir}
10430N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="ekiga.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%dir %{_datadir}/ekiga/xdap
10139N/A%dir %{_datadir}/sounds/ekiga
10139N/A%{_bindir}/ekiga*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/ekiga.mo
10139N/A%{_datadir}/applications/ekiga.desktop
10139N/A%{_datadir}/sounds/ekiga/*
10139N/A%{_datadir}/pixmaps/ekiga*
10139N/A%{_libdir}/bonobo/servers/ekiga.server
10139N/A%{_datadir}/ekiga/xdap/*
10139N/A%{_sysconfdir}/gconf/schemas/ekiga.schemas
10139N/A%{_datadir}/gnome/*
10139N/A%{_datadir}/omf/*
10139N/A%{_mandir}/man1/*
10139N/A
10139N/A
10139N/A%changelog
17396N/A* Wed Sep 23 2009 - dave.lin@sun.com
17396N/A- Bump to 3.2.6
16772N/A* Tue Jul 14 2009 - elaine.xiong@sun.com
16772N/A- Bump to 3.2.5. Remove upstream patches. Add Boost as build dependency
16772N/A and related patch.
16385N/A* Thu Apr 16 2009 - takao.fujiwara@sun.com
16385N/A- Add patch ekiga-05-check-spaces.diff. bugzilla:578359
16223N/A* Mon Mar 23 2009 - elaine.xiong@sun.com
16223N/A- Remove ekiga-helper to fix man page problem.
15386N/A* Thu Nov 20 2008 - elaine.xiong@sun.com
15386N/A- Bump to 3.0.1.
15354N/A* Fri Nov 14 2008 - elaine.xiong@sun.com
15354N/A- Bump to 3.0.0. Add new patches and remove obsolete patches.
15354N/A- Update build options for new version.
14121N/A* Wed Sep 03 2008 - elaine.xiong@sun.com
14121N/A- Add note to not bump to 2.9.90 as it's actually 3.0 beta1 and not ready for
14121N/A Solaris.
13607N/A* Mon Jul 21 2008 - elaine.xiong@sun.com
13607N/A- Add bugID.
12573N/A* Mon Mar 10 2008 - damien.carbery@sun.com
12573N/A- Bump to 2.0.12.
12536N/A* Wed Mar 05 2008 - elaine.xiong@sun.com
12536N/A- Add ekiga-06-rm-evcard.diff to fix bugster#6665230.
12536N/A But this patch will not be compatible with Ekiga 3.0.
12090N/A* Sun Dec 23 2007 - patrick.ale@gmail.com
12090N/A- Set the XGETTEXT variable based on `which xgettext`
12090N/A Since we use JDS-CBE this should be /opt/jdsbld/bin/xgettext
12090N/A Ekiga will FAIL when /usr/bin/xgettext (NON-GNU version) is used.
11853N/A* Fri Nov 02 2007 - elaine.xiong@sun.com
11853N/A- Enable Avahi support.
11246N/A* Tue Sep 18 2007 - damien.carbery@sun.com
11246N/A- Bump to 2.0.11. Remove upstream patch, 06-loopback.
11148N/A* Thu Aug 30 2007 - elaine.xiong@sun.com
11148N/A- Disable DBUS component due to weak support.
10879N/A* Thu Jun 28 2007 - elaine.xiong@sun.com
10879N/A- Explicitly enable the DBUS component.
10720N/A* Sun Jun 03 2007 - elaine.xiong@sun.com
10720N/A- Add patch ekiga-06-loopback.diff to fix bugzilla439873
10527N/A* Wed Apr 25 2007 - elaine.xiong@sun.com
10527N/A- Update owner name for ekiga-04-performance-tuning.diff
10500N/A* Thu Apr 19 2007 - elaine.xiong@sun.com
10500N/A- Bump to 2.0.9.
10495N/A* Tue Apr 17 2007 - elaine.xiong@sun.com
10495N/A- move the -Lpath that could specify the /usr/lib/ as the search directory
10495N/A when link time.
10430N/A* Thu Apr 5 2007 - laca@sun.com
10430N/A- move libsdl, pwlib and opal to their own separate spec files
10353N/A* Fri Mar 23 2007 - elaine.xiong@sun.com
10353N/A- Add patch ekiga-23-opal-illege-payloadtype.diff to fix bugster6537448
10353N/A already upstream. Refer to
10353N/A http://openh323.cvs.sourceforge.net/openh323/opal/src/h323/h323.cxx?r1=2.143&r2=2.144
10334N/A* Mon Mar 20 2007 - damien.carbery@sun.com
10334N/A- Point at ftp.gnome.org for ekiga bz2 tarball. ekiga.org only has gz tarball.
10261N/A* Mon Mar 12 2007 - damien.carbery@sun.com
10261N/A- Bump to 2.0.7; bump pwlib to 1.10.5 & bump opal to 2.2.6. Remove upstream
10261N/A patch, 21-pwlib-v4l2-enable, renumber remainder.
10257N/A* Sun Mar 11 2007 - elaine.xiong@sun.com
10257N/A- Add patch ekiga-22-ekiga-performance-tuning.diff
10257N/A ekiga-23-pwlib-performance-tuning.diff
10257N/A Both of them for ekiga performance tuning with video support.
10257N/A Will upstream them or part of them to community if tuning is done.
10139N/A* Wed Feb 14 2007 - elaine.xiong@sun.com
10139N/A- Add patch ekiga-21-pwlib-enable-v4l2.diff to fix bugzilla407820
10139N/A Meantime enable V4L2 plugin in ekiga.spec
10139N/A* Wed Feb 14 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.0.5; bump pwlib to 1.10.4 & bump opal to 2.2.5.
10139N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
10139N/A- Add l10n tarball.
10139N/A* Mon Jan 29 2007 - elaine.xiong@sun.com
10139N/A- Cancel parallel job option for ekiga(including sdl, pwlib, opal) build.
10139N/A To temporily solve the potential problems caused by parallel.
10139N/A Will be fixed ASAP.
10139N/A* Sat Jan 27 2007 - elaine.xiong@sun.com
10139N/A- Bump ekiga to 2.0.4 shrink patches and spec file for build failure
10139N/A* Wed Jan 24 2007 - damien.carbery@sun.com
10139N/A- Bump pwlib to 1.10.3, opal to 2.2.4. Remove upstream patches,
10139N/A 08-pwlib-disconnect, 09-pwlib-unset-port, 13-opal-bz356696,
10139N/A 15-opal-invalidarrayindex, 16-pwlib-video. Add patch 20-opal-break to fix
10139N/A build error (sourceforge: 1643652).
10139N/A* Mon Jan 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.0.4.
10139N/A* Thu Jan 04 2007 - elaine.xiong@sun.com
10139N/A- Add patch ekiga-19-freeze-accessibility.diff. Workes around bugzilla 329454.
10139N/A* Thu Dec 28 2006 - dave.lin@sun.com
10139N/A- change the patch type to branding for some patches in patch comments
10139N/A* Wed Nov 29 2006 - damien.carbery@sun.com
10139N/A- Fix typo in name of patch 18: s/18-opal-sunray/18-sunray/
10139N/A* Mon Nov 27 2006 - brian.lu@sun.com
10139N/A- Add patch ekiga-18-sunray-port-conflict.diff. Fixes bugzilla 367516.
10139N/A* Mon Nov 20 2006 - davelin@sun.com
10139N/A- Add patch comment
10139N/A* Thu Nov 02 2006 - davelin@sun.com
10139N/A- Bump version to 2.0.3
10139N/A- Sync patches those have been upstreamed in ekiga community trunk
10139N/A- ekiga-10-pwlib-bz356696.diff, ekiga-13-opal-bz356696.diff(better fix
10139N/A for bugzilla356696)
10139N/A- ekiga-15-opal-invalidarrayindex.diff(bugzilla367482)
10139N/A- ekiga-16-pwlib-video.diff(bugzilla367516)
10139N/A- ekiga-17-opal-rtp.diff(CR#6483823, CR#6483831, which caused revert to
10139N/A 2.0.2 in b52b)
10139N/A* Wed Oct 25 2006 - davelin@sun.com
10139N/A- Roll back to the previous version 2.0.2 since following critical bug
10139N/A was found in 2.0.3 CR#6483823(and another P2 bug CR#6483831)
10139N/A* Tue Oct 17 2006 - dave.lin@sun.com
10139N/A- Bump version to 2.0.3
10139N/A- Add patch ekiga-pwlib-09-unset-port.diff to fix bug CR#6476679
10139N/A- Add patch ekiga-10-pwlib-bz356696.diff to fix bug gnome bugzilla #356696
10139N/A* Mon Oct 09 2006 - dave.lin@sun.com
10139N/A- Add patch ekiga-08-pwlib-disconnect-crash.diff to fix bug CR#6470530
10139N/A* Fri Sep 15 2006 - dermot.mccluskey@sun.com
10139N/A- Fixed erroneous comments in %defines
10139N/A* Wed Sep 06 2006 - damien.carbery@sun.com
10139N/A- Bump pwlib to 1.10.2, opal to 2.2.3.
10139N/A* Mon Sep 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.0.3.
10139N/A* Mon Sep 04 2006 - damien.carbery@sun.com
10139N/A- Bump libsdl to 1.2.11.
10139N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10139N/A- Change 'cd dir*' to use '%{version}'.
10139N/A* Mon Jul 10 2006 - dave.lin@sun.com
10139N/A- change to use Ekiga 2.0.2 release
10139N/A* Fri Jun 16 2006 - dave.lin@sun.com
10139N/A- add GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 to make sure not
10139N/A install the directory based %gconf.xml files based on the
10139N/A instruction in gconf.txt
10139N/A* Wed Jun 07 2006 - damien.carbery@sun.com
10139N/A- chdir into ekiga dir before applying ekiga patches.
10139N/A* Fri Jun 02 2006 - glynn.foster@sun.com
10139N/A- Add patch for change the menu entry according to the UI spec.
10139N/A* Mon May 15 2006 - dave.lin@sun.com
10139N/A- Add patch ekiga-08-multi-decla.diff to fix multiple declaration
10139N/A error.
10139N/A* Fri Apr 14 2006 - <dave.lin@sun.com>
10139N/A- Initial release for ekiga