devhelp.spec revision 14184
10139N/A#
10139N/A# spec file for package devhelp.spec
10139N/A#
12153N/A# Copyright (c) 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A#
10139N/AName: devhelp
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
10139N/AVersion: 0.20
13312N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: API documentation browser for GNOME
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/devhelp/0.20/devhelp-%{version}.tar.bz2
13312N/A
12773N/A# Build with Firefox3 when "--with-ff3" is specified
12773N/A%if %option_with_ff3
12773N/A#date:2008-05-08 owner:evan type:bug bugzilla:499050
11389N/APatch1: devhelp-01-using-firefox3-gecko.diff
11248N/A%endif
11963N/A#date:2008-08-15 owner:jedy type:branding
11412N/APatch2: devhelp-02-menu-entry.diff
12916N/A
13312N/AURL: http://developer.imendio.com/projects/devhelp
12916N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%define gtk2_version 2.5.3
10139N/A%define gnome_vfs_version 2.6.0
10139N/A%define libgnomeui_version 2.6.0
10139N/A%define libbonobo_version 2.6.0
10139N/A%define libxslt_version 1.1.14
10139N/A%define libglade_version 2.5.1
10139N/A%define libxml2_version 2.6.5
10139N/A%define mozilla_version 1.7
10139N/A%define libwnck_version 2.16.0
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: gnome-vfs >= %{gnome_vfs_version}
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: libxslt >= %{libxslt_version}
10139N/ARequires: libglade >= %{libglade_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: mozilla >= %{mozilla_version}
10139N/ARequires: libwnck >= %{libwnck_version}
10139N/A
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: libglade-devel >= %{libglade_version}
10139N/ABuildRequires: libxslt-devel >= %{libxslt_version}
10139N/ABuildRequires: mozilla-devel >= %{mozilla_version}
10139N/ABuildRequires: libwnck-devel >= %{libwnck_version}
10139N/A
10139N/A%description
10139N/ADevhelp is an API documentation browser for GNOME 2. It works natively with gtk-doc (the API reference framework developed for GTK+ and used throughout GNOME for API documentation).
10139N/A
10139N/A%package devel
10139N/ASummary: Library to embed Devhelp in other applications
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/ARequires: %name
10139N/ARequires: SUNWgnome-base-libs-devel
10139N/A
10139N/A%description devel
10139N/ALibrary of Devhelp for embedding into other applications.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %option_with_ff3
10139N/A#%patch1 -p1
10139N/A%endif
10139N/A%patch2 -p1
10139N/A
11248N/A%build
11412N/A%ifos linux
13312N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aglib-gettextize -f
10139N/Aintltoolize --force --copy
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
12773N/A
12773N/A./configure --prefix=%{_prefix} --mandir=%{_mandir} \
12773N/A --libdir=%{_libdir} \
12773N/A --libexecdir=%{_libexecdir} \
12773N/A --sysconfdir=%{_sysconfdir} --disable-gtk-doc
10139N/Amake -j$CPUS
10139N/A
10139N/A%install
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
13059N/A%doc AUTHORS ChangeLog COPYING NEWS README TODO
10139N/A%config %{_sysconfdir}/gconf/schemas/devhelp.schemas
10139N/A%{_bindir}/devhelp*
10139N/A%{_datadir}/applications/devhelp.desktop
10139N/A%{_datadir}/devhelp/
10139N/A%{_datadir}/mime-info/devhelp.*
10139N/A%{_datadir}/pixmaps/devhelp.png
10139N/A%{_libdir}/libdevhelp-1.so.*
10139N/A
10139N/A%files devel
12252N/A%defattr(-, root, root)
12252N/A%{_includedir}/devhelp-1.0/
12252N/A%{_libdir}/libdevhelp-1.so
12252N/A%{_libdir}/pkgconfig/libdevhelp-1.0.pc
12252N/A
12252N/A%changelog
12252N/A* Tue Sep 09 2008 - simon.zheng@sun.com
12252N/A- Bump to 0.20.
10139N/A
10139N/A* Fri Aug 22 2008 - jedy.wang@sun.com
10139N/A- rename desktop.diff to menu-entry.diff.
10139N/A
10139N/A* Thu Aug 21 2008 - jedy.wang@sun.com
10139N/A- remove option_with_indiana_branding
10139N/A
10139N/A* Fir Aug 14 2008 - jedy.wang@sun.com
10139N/A- add 02-desktop.diff.
10139N/A
10139N/A* Mon May 26 2008 - evan.yan@sun.com
10139N/A- add option "--with-ff3" to enable building with Firefox3
10139N/A
10139N/A* Mon May 26 2008 - damien.carbery@sun.com
10139N/A- Bump to 0.19.1.
13312N/A
13312N/A* Fri May 16 2008 - damien.carbery@sun.com
13312N/A- Comment out Evan's patch, 01-using-firefox3-gecko, so that we build against
13312N/A firefox 2 because FF3 is not stable enough to be the default browser in
13059N/A Nevada.
13059N/A
13059N/A* Thu May 08 2008 - evan.yan@sun.com
13059N/A- Add patch devhelp-01-using-firefox3-gecko.diff:
12923N/A build devhelp with firefox3 package
12916N/A- Add running auto tools
12916N/A
12916N/A* Fri Feb 08 2008 - damien.carbery@sun.com
12813N/A- Bump to 0.19.
12813N/A
12813N/A* Wed Jan 30 2008 - damien.carbery@sun.com
12625N/A- Bump to 0.18.
12625N/A
12625N/A* Mon Jan 08 2008 - damien.carbery@sun.com
12571N/A- Bump to 0.17.
12571N/A
12571N/A* Sun Dec 16 2007 - patrick.ale@gmail.com
12288N/A- Change the way version is defined so pkgtool plays
12295N/A nicely with minor versions [due to HTTP 404 upon fetching]
12288N/A
12252N/A* Mon Oct 08 2007 - damien.carbery@sun.com
12252N/A- Bump to 0.16.1.
12252N/A
12252N/A* Tue Sep 11 2007 - damien.carbery@sun.com
12153N/A- Bump to 0.16.
12153N/A
12024N/A* Tue Jun 19 2007 - simon.zheng@sun.com
12024N/A- Bump to 0.15. Remove upstream patch, 01-va-args.
12024N/A
12022N/A* Thu May 17 2007 - simon.zheng@sun.com
12022N/A- Bump to 0.14. Add patch 01-va-args to fix 439054.
12022N/A
11412N/A* Fri Mar 14 2007 - simon.zheng@sun.com
11412N/A- Initial version created, which stems from extra-spec-file
11412N/A created by li.ma@sun.com on sourceforge.net svn repository.
11240N/A