devhelp.spec revision 13541
10292N/A#
10292N/A# spec file for package devhelp.spec
10292N/A#
10292N/A# Copyright (c) 2007 Sun Microsystems, Inc.
10292N/A# This file and all modifications and additions to the pristine
10292N/A# package are under the same license as the package itself.
10292N/A#
10292N/A#
10292N/AName: devhelp
10292N/ALicense: GPL
10292N/AGroup: System/GUI/GNOME
13098N/AVersion: 0.19.1
10292N/ARelease: 1
10292N/ADistribution: Java Desktop System
10292N/AVendor: Sun Microsystems, Inc.
10292N/ASummary: API documentation browser for GNOME
13098N/ASource: http://ftp.gnome.org/pub/GNOME/sources/devhelp/0.19/devhelp-%{version}.tar.bz2
13011N/A
13108N/A# Build with Firefox3 when "--with-ff3" is specified
13108N/A%if %option_with_ff3
13541N/A#date:2008-05-08 owner:evan type:bug bugzilla:499050
13108N/APatch1: devhelp-01-using-firefox3-gecko.diff
13108N/A%endif
13011N/A
10292N/AURL: http://developer.imendio.com/projects/devhelp
10292N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10292N/A
10292N/A%define gtk2_version 2.5.3
10292N/A%define gnome_vfs_version 2.6.0
10292N/A%define libgnomeui_version 2.6.0
10292N/A%define libbonobo_version 2.6.0
10292N/A%define libxslt_version 1.1.14
10292N/A%define libglade_version 2.5.1
10292N/A%define libxml2_version 2.6.5
10292N/A%define mozilla_version 1.7
10292N/A%define libwnck_version 2.16.0
10292N/A
10292N/ARequires: gtk2 >= %{gtk2_version}
10292N/ARequires: gnome-vfs >= %{gnome_vfs_version}
10292N/ARequires: libgnomeui >= %{libgnomeui_version}
10292N/ARequires: libbonobo >= %{libbonobo_version}
10292N/ARequires: libxslt >= %{libxslt_version}
10292N/ARequires: libglade >= %{libglade_version}
10292N/ARequires: libxml2 >= %{libxml2_version}
10292N/ARequires: mozilla >= %{mozilla_version}
10292N/ARequires: libwnck >= %{libwnck_version}
10292N/A
10292N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10292N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
10292N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10292N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10292N/ABuildRequires: libglade-devel >= %{libglade_version}
10292N/ABuildRequires: libxslt-devel >= %{libxslt_version}
10292N/ABuildRequires: mozilla-devel >= %{mozilla_version}
10292N/ABuildRequires: libwnck-devel >= %{libwnck_version}
10292N/A
10292N/A%description
10292N/ADevhelp is an API documentation browser for GNOME 2. It works natively with gtk-doc (the API reference framework developed for GTK+ and used throughout GNOME for API documentation).
10292N/A
10292N/A%package devel
10292N/ASummary: Library to embed Devhelp in other applications
10292N/ASUNW_BaseDir: %{_basedir}
10292N/A%include default-depend.inc
10292N/ARequires: %name
10292N/ARequires: SUNWgnome-base-libs-devel
10292N/A
10292N/A%description devel
10292N/ALibrary of Devhelp for embedding into other applications.
10292N/A
10292N/A%prep
10292N/A%setup -q
13108N/A%if %option_with_ff3
13108N/A%patch1 -p1
13108N/A%endif
10292N/A
10292N/A%build
10292N/A%ifos linux
10292N/Aif [ -x /usr/bin/getconf ]; then
10292N/A CPUS=`getconf _NPROCESSORS_ONLN`
10292N/Afi
10292N/A%else
10292N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10292N/A%endif
10292N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10292N/A CPUS=1
10292N/Afi
10292N/A
13011N/Alibtoolize --force
13011N/Aglib-gettextize -f
13011N/Aintltoolize --force --copy
13011N/Aaclocal $ACLOCAL_FLAGS
13011N/Aautoheader
13011N/Aautomake -a -c -f
13011N/Aautoconf
13011N/A
10292N/A./configure --prefix=%{_prefix} --mandir=%{_mandir} \
10292N/A --libdir=%{_libdir} \
10292N/A --libexecdir=%{_libexecdir} \
10292N/A --sysconfdir=%{_sysconfdir} --disable-gtk-doc
10292N/Amake -j$CPUS
10292N/A
10292N/A%install
10292N/Arm -rf $RPM_BUILD_ROOT
10292N/Amake install DESTDIR=$RPM_BUILD_ROOT
10292N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10292N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10292N/A
10292N/A
10292N/A%clean
10292N/Arm -rf $RPM_BUILD_ROOT
10292N/A
10292N/A%files
10292N/A%defattr(-, root, root)
10292N/A%doc AUTHORS ChangeLog COPYING NEWS README TODO
10292N/A%config %{_sysconfdir}/gconf/schemas/devhelp.schemas
10292N/A%{_bindir}/devhelp*
10292N/A%{_datadir}/applications/devhelp.desktop
10292N/A%{_datadir}/devhelp/
10292N/A%{_datadir}/mime-info/devhelp.*
10292N/A%{_datadir}/pixmaps/devhelp.png
10292N/A%{_libdir}/libdevhelp-1.so.*
10292N/A
10292N/A%files devel
10292N/A%defattr(-, root, root)
10292N/A%{_includedir}/devhelp-1.0/
10292N/A%{_libdir}/libdevhelp-1.so
10292N/A%{_libdir}/pkgconfig/libdevhelp-1.0.pc
10292N/A
10292N/A%changelog
13108N/A* Mon May 26 2008 - evan.yan@sun.com
13108N/A- add option "--with-ff3" to enable building with Firefox3
13108N/A
13098N/A* Mon May 26 2008 - damien.carbery@sun.com
13098N/A- Bump to 0.19.1.
13094N/A
13059N/A* Fri May 16 2008 - damien.carbery@sun.com
13059N/A- Comment out Evan's patch, 01-using-firefox3-gecko, so that we build against
13059N/A firefox 2 because FF3 is not stable enough to be the default browser in
13059N/A Nevada.
13059N/A
13011N/A* Thu May 08 2008 - evan.yan@sun.com
13011N/A- Add patch devhelp-01-using-firefox3-gecko.diff:
13011N/A build devhelp with firefox3 package
13011N/A- Add running auto tools
13011N/A
12351N/A* Fri Feb 08 2008 - damien.carbery@sun.com
12351N/A- Bump to 0.19.
12351N/A
12305N/A* Wed Jan 30 2008 - damien.carbery@sun.com
12305N/A- Bump to 0.18.
12305N/A
12147N/A* Mon Jan 08 2008 - damien.carbery@sun.com
12147N/A- Bump to 0.17.
12147N/A
12066N/A* Sun Dec 16 2007 - patrick.ale@gmail.com
12066N/A- Change the way version is defined so pkgtool plays
12066N/A nicely with minor versions [due to HTTP 404 upon fetching]
12066N/A
11364N/A* Mon Oct 08 2007 - damien.carbery@sun.com
11364N/A- Bump to 0.16.1.
11364N/A
11230N/A* Tue Sep 11 2007 - damien.carbery@sun.com
11230N/A- Bump to 0.16.
11230N/A
10821N/A* Tue Jun 19 2007 - simon.zheng@sun.com
10821N/A- Bump to 0.15. Remove upstream patch, 01-va-args.
10821N/A
10659N/A* Thu May 17 2007 - simon.zheng@sun.com
10659N/A- Bump to 0.14. Add patch 01-va-args to fix 439054.
10659N/A
10292N/A* Fri Mar 14 2007 - simon.zheng@sun.com
10292N/A- Initial version created, which stems from extra-spec-file
10292N/A created by li.ma@sun.com on sourceforge.net svn repository.