devhelp.spec revision 10292
#
# spec file for package devhelp.spec
#
# Copyright (c) 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
#
Name: devhelp
License: GPL
Group: System/GUI/GNOME
Version: 0.13
Release: 1
Distribution: Java Desktop System
Vendor: Sun Microsystems, Inc.
Summary: API documentation browser for GNOME
Source: http://ftp.gnome.org/pub/GNOME/sources/devhelp/%{version}/devhelp-%{version}.tar.bz2
URL: http://developer.imendio.com/projects/devhelp
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%define gtk2_version 2.5.3
%define gnome_vfs_version 2.6.0
%define libgnomeui_version 2.6.0
%define libbonobo_version 2.6.0
%define libxslt_version 1.1.14
%define libglade_version 2.5.1
%define libxml2_version 2.6.5
%define mozilla_version 1.7
%define libwnck_version 2.16.0
Requires: gtk2 >= %{gtk2_version}
Requires: gnome-vfs >= %{gnome_vfs_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: libbonobo >= %{libbonobo_version}
Requires: libxslt >= %{libxslt_version}
Requires: libglade >= %{libglade_version}
Requires: libxml2 >= %{libxml2_version}
Requires: mozilla >= %{mozilla_version}
Requires: libwnck >= %{libwnck_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: libxslt-devel >= %{libxslt_version}
BuildRequires: mozilla-devel >= %{mozilla_version}
BuildRequires: libwnck-devel >= %{libwnck_version}
%description
Devhelp is an API documentation browser for GNOME 2. It works natively with gtk-doc (the API reference framework developed for GTK+ and used throughout GNOME for API documentation).
%package devel
Summary: Library to embed Devhelp in other applications
SUNW_BaseDir: %{_basedir}
%include default-depend.inc
Requires: %name
Requires: SUNWgnome-base-libs-devel
%description devel
Library of Devhelp for embedding into other applications.
%prep
%setup -q
%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
./configure --prefix=%{_prefix} --mandir=%{_mandir} \
--libdir=%{_libdir} \
--libexecdir=%{_libexecdir} \
--sysconfdir=%{_sysconfdir} --disable-gtk-doc
make -j$CPUS
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING NEWS README TODO
%config %{_sysconfdir}/gconf/schemas/devhelp.schemas
%{_bindir}/devhelp*
%{_datadir}/applications/devhelp.desktop
%{_datadir}/devhelp/
%{_datadir}/mime-info/devhelp.*
%{_datadir}/pixmaps/devhelp.png
%{_libdir}/libdevhelp-1.so.*
%files devel
%defattr(-, root, root)
%{_includedir}/devhelp-1.0/
%{_libdir}/libdevhelp-1.so
%{_libdir}/pkgconfig/libdevhelp-1.0.pc
%changelog
* Fri Mar 14 2007 - simon.zheng@sun.com
- Initial version created, which stems from extra-spec-file
created by li.ma@sun.com on sourceforge.net svn repository.