dbus.spec revision 20358
10139N/A#
10139N/A# spec file for package dbus
10139N/A#
12197N/A# Copyright (c) 2005, 2011, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17822N/A%define owner yippi
10139N/A# bugdb: bugzilla.freedesktop.org
17177N/A#
17177N/A
17177N/A%define OSR 12712:1.2.16
10139N/A
10139N/AName: dbus
10139N/ALicense: GPL v2, AFL v2.1
10139N/AGroup: System/Libraries
18532N/AVersion: 1.2.28
14538N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: freedesktop.org
10139N/ASummary: Simple IPC library based on messages
18532N/ASource: http://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.gz
10142N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
10139N/A#owner:yippi date:2007-09-06 type:feature
10139N/A# System services are disabled by default in Solaris configuration since
10139N/A# they are not yet supported on Solaris.
10139N/APatch1: dbus-01-nosystemservice.diff
10139N/A# date:2010-08-16 owner:padraig type:bug doo:16787
10139N/APatch2: dbus-02-closefrom.diff
10139N/A# date:2010-10-20 owner:yippi type:bug bugster:6993687
10139N/APatch3: dbus-03-consoleuser.diff
10139N/A#owner:gheet date:2011-03-11 type:bug bugster:6956527
10139N/APatch4: dbus-04-cleanup-libs.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define glib2_version 2.6.4
10139N/A%define libxml2_version 2.6.19
10139N/ABuildRequires: glib2-devel >= %glib2_version
10139N/ABuildRequires: libxml2-devel >= %libxml2_version
10139N/A# FIXME: get python rpm: BuildRequires: python >= %python_version
10139N/ARequires: glib2 >= %glib2_version
10139N/ARequires: libxml2 >= %libxml2_version
10139N/A
10139N/A%description
10139N/AD-Bus is a message bus system, a simple way for applications to talk to one
10139N/Aanother.
10139N/AD-Bus supplies both a system daemon (for events such as "new hardware device
17401N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10139N/Ageneral IPC needs among user applications). Also, the message bus is built on
10142N/Atop of a general one-to-one message passing framework, which can be used by
10139N/Aany two apps to communicate directly (without going through the message bus
10139N/Adaemon).
10139N/A
10139N/A%package devel
10139N/ASummary: Simple IPC library based on messages
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AD-Bus is a message bus system, a simple way for applications to talk to one
10139N/Aanother.
10139N/A
10139N/AD-Bus supplies both a system daemon (for events such as "new hardware device
10139N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10139N/Ageneral IPC needs among user applications). Also, the message bus is built on
10139N/Atop of a general one-to-one message passing framework, which can be used by
15696N/Aany two apps to communicate directly (without going through the message bus
13423N/Adaemon).
13423N/A
12583N/A%prep
12583N/A%setup -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize -f
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags -D_REENTRANT"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/Aexport PKG_CONFIG_PATH="%{_libdir}/pkgconfig"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
10139N/A --with-dbus-daemondir=%{_basedir}/lib \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --disable-static
10139N/Amake -j $CPUS \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10139N/Acd ../%{name}-%{version}
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10139N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
18532N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
18532N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
18443N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
18443N/A# Disable system services.
17855N/Arm $RPM_BUILD_ROOT%{_libexecdir}/dbus-daemon-launch-helper
17855N/A
17570N/A%post
17570N/A/sbin/ldconfig
17401N/A
17401N/A%postun
17401N/A/sbin/ldconfig
17124N/A
17124N/A%clean
16747N/Arm -rf $RPM_BUILD_ROOT
16747N/A
16625N/A%files
16625N/A%defattr(-, root, root)
16379N/A%config %{_sysconfdir}/dbus-1/session.conf
16625N/A%config %{_sysconfdir}/dbus-1/system.conf
16160N/A%{_bindir}/*
16625N/A%{_libdir}/libdbus*.so*
15947N/A%{_datadir}/man/*
15947N/A%{_datadir}/dbus-1/*
15866N/A
16625N/A%files devel
15696N/A%defattr(-, root, root)
15696N/A%{_libdir}/*.so
14538N/A%{_includedir}/dbus-1.0/*
14538N/A%{_libdir}/dbus-1.0/*
14085N/A%{_libdir}/pkgconfig/*
14085N/A%{_libdir}/python?.?/vendor-packages/*
13773N/A
13773N/A%changelog
13420N/A* Fri Jun 10 2011 - brian.cameron@oracle.com
13423N/A- Bump to 1.2.28.
12583N/A* Tue Dec 21 2010 - brian.cameron@oracle.com
12583N/A- Bump to 1.2.26.
12571N/A* Wed Oct 20 2010 - brian.cameron@oracle.com
12571N/A- Add patch dbus-03-consoleuser.diff to fix bugster:6963885.
12307N/A* Mon Aug 16 2010 - padraig.obriain@oracle.com
12307N/A- Add dbus-02-closefrom.diff rto fix doo 16787.
12197N/A* Tue Mar 23 2010 - brian.cameron@sun.com
12197N/A- Bump to 1.2.24. Remove upstream patch dbus-02-fixcompile.diff.
12072N/A* Wed Feb 03 2010 - brian.cameron@sun.com
12072N/A- Bump to 1.2.20. Remove upstream patch dbus-02-getpwnam.diff. Add new patch
12022N/A dbus-02-fixcompile.diff needed to build.
12022N/A* Wed Jul 15 2009 - brian.cameron@sun.com
11262N/A- Bump to 1.2.16. Add patch dbus-02-getpwnam.diff to fix compile issue.
11262N/A* Thu Jan 08 2009 - brian.cameron@sun.com
10285N/A- Bump to 1.2.12.
10285N/A* Wed Dec 10 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.8
10139N/A* Mon Dec 08 2008 - dave.lin@sun.com
10139N/A- Bump to 1.2.6.
10139N/A* Thu Oct 09 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.4.
10139N/A D-Bus if it fails to connect the first time.
10139N/A* Thu Aug 07 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.3. Remove upstream dbus-02-getauditsessiondata.diff patch.
10139N/A* Wed May 07 2008 - simon.zheng@sun.com
10139N/A- Add patch 02-getauditsessiondata.diff to add a interface
10139N/A "GetAdtAuditSessionData", getting audit data from socket connection.
10139N/A* Sun Apr 06 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.1
10139N/A* Wed Feb 27 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.1.20
10139N/A* Thu Jan 17 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.1.4.
10139N/A* Thu Jan 17 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.1.3. Remove upstream patches.
10139N/A* Wed Nov 07 2007 - padraig.obriain@sun.com
10139N/A- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
10139N/A See bugster 6615221.
10139N/A* Fri Oct 12 1007 - laca@sun.com
10139N/A- delete some env variable settings forgotten in the previous commit
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- convert to new style multi-ISA build
10139N/A* Thu Sep 06 2007 - brian.cameron@sun.com
10139N/A- Add patch dbus-04-nosystemservice.diff and do not ship
10139N/A dbus-daemon-launch-helper to disable D-Bus system services completely.
10139N/A Nothing in Solaris currently needs the D-Bus system service. The Linux
10139N/A solution specifies that --with-dbus-user is "messagebus". The idea is
10139N/A that the system daemon runs as this user and uses the root setgid
10139N/A script dbus-daemon-launch-helper to gain privilege when needed. It is
10139N/A likely that Sun would instead want to use a more secure least-privilege
10139N/A RBAC style solution for doing this, if we ever need to add this feature
10139N/A back.
10139N/A* Mon Aug 06 2007 - brian.cameron@sun.com
10139N/A- Bump to 0.74. Update patches.
10139N/A* Fri Jun 08 2007 - brian.cameron@sun.com
10139N/A- Remove dbus-01-dbus-launch.diff since it is no longer needed now
10139N/A that we've reworked the SUNWdtlogin-integration package to call
10139N/A dbus-launch from /usr/dt/config/Xsession.jds instead of Xinitrc.jds.
10139N/A* Sun Apr 1 2007 - laca@sun.com
10139N/A- add missing aclocal calls
10139N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10139N/A- Removed CC64 and CC32. They are not needed anymore
10139N/A* Sun Feb 25 2007 - dougs@truemail.co.th
10139N/A- updated to include 64-bit build RFE: #6480511
10139N/A- patch to stop Sun Studio compiling GCC asm specific code
10139N/A* Wed Dec 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.0.2.
10139N/A* Thu Nov 27 2006 - brian.cameron@sun.com
10139N/A- Minor cleanup. Remove python build dependancy since now python bindings
10139N/A are built in separate module.
10139N/A* Thu Nov 23 2006 - damien.carbery@sun.com
10139N/A- Removed upstream patches, 01, 02, 04, 05 and 06. Renumber remainder.
10139N/A* Wed Nov 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.0.1.
10139N/A* Fri Nov 17 2006 - ghee.teo@sun.com
10139N/A- Added patch dbus-06-proxy-change-owner-crash.diff. This patch is only
10139N/A for 0.6x release of dbus, when dbus 1.0 is incorporated, this patch
10139N/A can be dropped.
10139N/A* Fri Oct 13 2006 - damien.carbery@sun.com
10139N/A- Delete .a and .la files.
10139N/A* Wed Aug 30 2006 - damien.carbery@sun.com
10139N/A- Add --datadir to configure call so that path in session.conf is expanded.
10139N/A* Thu Aug 03 2006 - padraig.obriain@sun.com
10139N/A- Updated dbus-03-dbus-launch.diff to avoid chewing idle CPU.
10139N/A* Wed Aug 02 2006 - brian.cameron@sun.com
10139N/A- Rewrote libexec patch based on Havoc's comments. Now pass in
10139N/A --with-daemondir to set daemon location.
10139N/A* Fri Jul 28 2006 - laca@sun.com
10139N/A- add patch priv.spec (from Artem Kachitchkine), makes dbus run as user
10139N/A 'daemon' and also with least privileges
10139N/A* Fri Jul 21 2006 - brian.cameron@sun.com
10139N/A- Add patch to move dbus-daemon to /usr/lib, required by ARC.
10139N/A* Tue May 02 2006 - laca@sun.com
10139N/A- add patch console.diff that allows D-Bus to authenticate console user
10139N/A* Sun Feb 26 2006 - laca@sun.com
10139N/A- Bump to 0.61.
10139N/A- move python stuff to vendor-packages, remove .pyo and *.la
10139N/A* Thu Jan 19 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 01-auth-external. Renumber remaining.
10139N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.60.
10139N/A* Tue Oct 25 2005 - damien.carbery@sun.com
10139N/A- Remove patch3 as an include dir under _libdir is okay. Bump to 0.50. Disable
10139N/A python bindings as they fail. Bug 4878 files at freedesktop.org.
10139N/A* Fri Oct 21 2005 - damien.carbery@sun.com
10139N/A- Add patches to build on Solaris.
10139N/A* Tue Aug 30 2005 - glynn.foster@sun.com
10139N/A- Create the dbus-1 services directory
10139N/A* Tue Aug 16 2005 - damien.carbery@sun.com
15696N/A- Add python >= 2.4 dependency. Reformat description text.
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 0.35.2.
* Mon Jun 20 2005 - matt.keenan@sun.com
- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball
* Thu Jun 09 2005 - laca@sun.com
- add buildrequires glib2, libxml2
* Thu May 12 2005 - glynn.foster@sun.com
- Initial spec file for dbus.