dbus.spec revision 19019
10139N/A#
10139N/A# spec file for package dbus
10139N/A#
10139N/A# Copyright (c) 2005, 2010, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner yippi
10139N/A# bugdb: bugzilla.freedesktop.org
17178N/A#
17178N/A
17178N/A%define OSR 12712:1.2.16
10139N/A
10139N/AName: dbus
10139N/ALicense: GPL v2, AFL v2.1
17152N/AGroup: System/Libraries
10139N/AVersion: 1.2.24
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: freedesktop.org
16908N/ASummary: Simple IPC library based on messages
10139N/ASource: http://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.gz
10139N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
10139N/A#owner:yippi date:2007-09-06 type:feature
10139N/A# System services are disabled by default in Solaris configuration since
10139N/A# they are not yet supported on Solaris.
10139N/APatch1: dbus-01-nosystemservice.diff
10139N/A# date:2010-08-16 owner:padraig type:bug doo:16787
10139N/APatch2: dbus-02-closefrom.diff
10139N/A# date:2010-10-19 owner:yippi type:bug bugster:6963885
10139N/APatch3: dbus-03-consoleuser.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define glib2_version 2.6.4
10139N/A%define libxml2_version 2.6.19
10139N/ABuildRequires: glib2-devel >= %glib2_version
10139N/ABuildRequires: libxml2-devel >= %libxml2_version
10139N/A# FIXME: get python rpm: BuildRequires: python >= %python_version
10139N/ARequires: glib2 >= %glib2_version
10139N/ARequires: libxml2 >= %libxml2_version
10139N/A
10139N/A%description
10139N/AD-Bus is a message bus system, a simple way for applications to talk to one
10139N/Aanother.
10139N/AD-Bus supplies both a system daemon (for events such as "new hardware device
10139N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10139N/Ageneral IPC needs among user applications). Also, the message bus is built on
10139N/Atop of a general one-to-one message passing framework, which can be used by
10139N/Aany two apps to communicate directly (without going through the message bus
10139N/Adaemon).
10139N/A
10139N/A%package devel
10139N/ASummary: Simple IPC library based on messages
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AD-Bus is a message bus system, a simple way for applications to talk to one
10139N/Aanother.
11108N/A
10139N/AD-Bus supplies both a system daemon (for events such as "new hardware device
12582N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10139N/Ageneral IPC needs among user applications). Also, the message bus is built on
10139N/Atop of a general one-to-one message passing framework, which can be used by
11108N/Aany two apps to communicate directly (without going through the message bus
10139N/Adaemon).
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
11108N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize -f
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoheader
10139N/Aautomake -a -c -f
17152N/Aautoconf
17152N/Aexport CFLAGS="%optflags -D_REENTRANT"
16908N/Aexport LDFLAGS="%_ldflags"
16908N/Aexport PKG_CONFIG_PATH="%{_libdir}/pkgconfig"
16779N/A./configure --prefix=%{_prefix} \
16779N/A --includedir=%{_includedir} \
16695N/A --sysconfdir=%{_sysconfdir} \
16695N/A --libdir=%{_libdir} \
16367N/A --libexecdir=%{_libexecdir} \
16367N/A --bindir=%{_bindir} \
16160N/A --localstatedir=%{_localstatedir} \
16160N/A --with-dbus-user=root \
16030N/A --with-dbus-daemondir=%{_basedir}/lib \
16030N/A --mandir=%{_mandir} \
15784N/A --datadir=%{_datadir} \
15784N/A --disable-static
14198N/Amake -j $CPUS \
14198N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
14198N/Acd ../%{name}-%{version}
14059N/A
14059N/A%install
14059N/Amake DESTDIR=$RPM_BUILD_ROOT install \
12612N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
12612N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
12612N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
12609N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
12609N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
12582N/A# Disable system services.
12582N/Arm $RPM_BUILD_ROOT%{_libexecdir}/dbus-daemon-launch-helper
12573N/A
12573N/A%post
12371N/A/sbin/ldconfig
12371N/A
11268N/A%postun
11268N/A/sbin/ldconfig
11256N/A
11256N/A%clean
11214N/Arm -rf $RPM_BUILD_ROOT
11108N/A
11108N/A%files
11108N/A%defattr(-, root, root)
11108N/A%config %{_sysconfdir}/dbus-1/session.conf
11094N/A%config %{_sysconfdir}/dbus-1/system.conf
11103N/A%{_bindir}/*
11103N/A%{_libdir}/libdbus*.so*
11103N/A%{_datadir}/man/*
11094N/A%{_datadir}/dbus-1/*
10979N/A
10979N/A%files devel
10454N/A%defattr(-, root, root)
10454N/A%{_libdir}/*.so
10280N/A%{_includedir}/dbus-1.0/*
10283N/A%{_libdir}/dbus-1.0/*
10283N/A%{_libdir}/pkgconfig/*
10280N/A%{_libdir}/python?.?/vendor-packages/*
10139N/A
10139N/A%changelog
10139N/A* Mon Aug 16 2010 - padraig.obriain@oracle.com
10139N/A- Add dbus-02-closefrom.diff rto fix doo 16787.
10139N/A* Tue Mar 23 2010 - brian.cameron@sun.com
10139N/A- Bump to 1.2.24. Remove upstream patch dbus-02-fixcompile.diff.
10139N/A* Wed Feb 03 2010 - brian.cameron@sun.com
10139N/A- Bump to 1.2.20. Remove upstream patch dbus-02-getpwnam.diff. Add new patch
10139N/A dbus-02-fixcompile.diff needed to build.
10139N/A* Wed Jul 15 2009 - brian.cameron@sun.com
10139N/A- Bump to 1.2.16. Add patch dbus-02-getpwnam.diff to fix compile issue.
10139N/A* Thu Jan 08 2009 - brian.cameron@sun.com
10139N/A- Bump to 1.2.12.
10139N/A* Wed Dec 10 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.8
10139N/A* Mon Dec 08 2008 - dave.lin@sun.com
10139N/A- Bump to 1.2.6.
10139N/A* Thu Oct 09 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.4.
10139N/A D-Bus if it fails to connect the first time.
10139N/A* Thu Aug 07 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.3. Remove upstream dbus-02-getauditsessiondata.diff patch.
10139N/A* Wed May 07 2008 - simon.zheng@sun.com
10139N/A- Add patch 02-getauditsessiondata.diff to add a interface
10139N/A "GetAdtAuditSessionData", getting audit data from socket connection.
10139N/A* Sun Apr 06 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.2.1
10139N/A* Wed Feb 27 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.1.20
10139N/A* Thu Jan 17 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.1.4.
10139N/A* Thu Jan 17 2008 - brian.cameron@sun.com
10139N/A- Bump to 1.1.3. Remove upstream patches.
10139N/A* Wed Nov 07 2007 - padraig.obriain@sun.com
10139N/A- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
10139N/A See bugster 6615221.
10139N/A* Fri Oct 12 1007 - laca@sun.com
10139N/A- delete some env variable settings forgotten in the previous commit
10139N/A* Fri Sep 28 2007 - laca@sun.com
10139N/A- convert to new style multi-ISA build
10139N/A* Thu Sep 06 2007 - brian.cameron@sun.com
10139N/A- Add patch dbus-04-nosystemservice.diff and do not ship
10139N/A dbus-daemon-launch-helper to disable D-Bus system services completely.
Nothing in Solaris currently needs the D-Bus system service. The Linux
solution specifies that --with-dbus-user is "messagebus". The idea is
that the system daemon runs as this user and uses the root setgid
script dbus-daemon-launch-helper to gain privilege when needed. It is
likely that Sun would instead want to use a more secure least-privilege
RBAC style solution for doing this, if we ever need to add this feature
back.
* Mon Aug 06 2007 - brian.cameron@sun.com
- Bump to 0.74. Update patches.
* Fri Jun 08 2007 - brian.cameron@sun.com
- Remove dbus-01-dbus-launch.diff since it is no longer needed now
that we've reworked the SUNWdtlogin-integration package to call
dbus-launch from /usr/dt/config/Xsession.jds instead of Xinitrc.jds.
* Sun Apr 1 2007 - laca@sun.com
- add missing aclocal calls
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sun Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
- patch to stop Sun Studio compiling GCC asm specific code
* Wed Dec 13 2006 - damien.carbery@sun.com
- Bump to 1.0.2.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Minor cleanup. Remove python build dependancy since now python bindings
are built in separate module.
* Thu Nov 23 2006 - damien.carbery@sun.com
- Removed upstream patches, 01, 02, 04, 05 and 06. Renumber remainder.
* Wed Nov 22 2006 - damien.carbery@sun.com
- Bump to 1.0.1.
* Fri Nov 17 2006 - ghee.teo@sun.com
- Added patch dbus-06-proxy-change-owner-crash.diff. This patch is only
for 0.6x release of dbus, when dbus 1.0 is incorporated, this patch
can be dropped.
* Fri Oct 13 2006 - damien.carbery@sun.com
- Delete .a and .la files.
* Wed Aug 30 2006 - damien.carbery@sun.com
- Add --datadir to configure call so that path in session.conf is expanded.
* Thu Aug 03 2006 - padraig.obriain@sun.com
- Updated dbus-03-dbus-launch.diff to avoid chewing idle CPU.
* Wed Aug 02 2006 - brian.cameron@sun.com
- Rewrote libexec patch based on Havoc's comments. Now pass in
--with-daemondir to set daemon location.
* Fri Jul 28 2006 - laca@sun.com
- add patch priv.spec (from Artem Kachitchkine), makes dbus run as user
'daemon' and also with least privileges
* Fri Jul 21 2006 - brian.cameron@sun.com
- Add patch to move dbus-daemon to /usr/lib, required by ARC.
* Tue May 02 2006 - laca@sun.com
- add patch console.diff that allows D-Bus to authenticate console user
* Sun Feb 26 2006 - laca@sun.com
- Bump to 0.61.
- move python stuff to vendor-packages, remove .pyo and *.la
* Thu Jan 19 2006 - damien.carbery@sun.com
- Remove upstream patch, 01-auth-external. Renumber remaining.
* Tue Jan 17 2006 - damien.carbery@sun.com
- Bump to 0.60.
* Tue Oct 25 2005 - damien.carbery@sun.com
- Remove patch3 as an include dir under _libdir is okay. Bump to 0.50. Disable
python bindings as they fail. Bug 4878 files at freedesktop.org.
* Fri Oct 21 2005 - damien.carbery@sun.com
- Add patches to build on Solaris.
* Tue Aug 30 2005 - glynn.foster@sun.com
- Create the dbus-1 services directory
* Tue Aug 16 2005 - damien.carbery@sun.com
- Add python >= 2.4 dependency. Reformat description text.
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 0.35.2.
* Mon Jun 20 2005 - matt.keenan@sun.com
- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball
* Thu Jun 09 2005 - laca@sun.com
- add buildrequires glib2, libxml2
* Thu May 12 2005 - glynn.foster@sun.com
- Initial spec file for dbus.