dbus.spec revision 15503
10430N/A#
10430N/A# spec file for package dbus
10430N/A#
10430N/A# Copyright 2008 Sun Microsystems, Inc.
10430N/A# This file and all modifications and additions to the pristine
10430N/A# package are under the same license as the package itself.
10430N/A#
15354N/A# Owner: yippi
10430N/A# bugdb: bugzilla.freedesktop.org
10430N/A#
10430N/AName: dbus
10430N/ALicense: GPL v2, AFL v2.1
15386N/AGroup: System/Libraries
10430N/AVersion: 1.2.8
10430N/ARelease: 1
10430N/ADistribution: Java Desktop System
10430N/AVendor: Sun Microsystems, Inc.
15386N/ASummary: Simple IPC library based on messages
10430N/ASource: http://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.gz
10430N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
10430N/A#owner:yippi date:2007-09-06 type:feature
10430N/APatch1: dbus-01-nosystemservice.diff
10430N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15354N/ADocdir: %{_defaultdocdir}/doc
15354N/AAutoreqprov: on
15354N/APrereq: /sbin/ldconfig
15354N/A
10430N/A%define glib2_version 2.6.4
10430N/A%define libxml2_version 2.6.19
15354N/ABuildRequires: glib2-devel >= %glib2_version
15354N/ABuildRequires: libxml2-devel >= %libxml2_version
10430N/A# FIXME: get python rpm: BuildRequires: python >= %python_version
15354N/ARequires: glib2 >= %glib2_version
15354N/ARequires: libxml2 >= %libxml2_version
15354N/A
10433N/A%description
10430N/AD-Bus is a message bus system, a simple way for applications to talk to one
10430N/Aanother.
10430N/AD-Bus supplies both a system daemon (for events such as "new hardware device
10430N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10430N/Ageneral IPC needs among user applications). Also, the message bus is built on
15354N/Atop of a general one-to-one message passing framework, which can be used by
10430N/Aany two apps to communicate directly (without going through the message bus
10430N/Adaemon).
10430N/A
10430N/A%package devel
10430N/ASummary: Simple IPC library based on messages
10430N/AGroup: Development/Libraries
10430N/ARequires: %{name} = %{version}
10430N/A
10430N/A%description devel
10430N/AD-Bus is a message bus system, a simple way for applications to talk to one
10430N/Aanother.
10430N/A
10430N/AD-Bus supplies both a system daemon (for events such as "new hardware device
10430N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10430N/Ageneral IPC needs among user applications). Also, the message bus is built on
10430N/Atop of a general one-to-one message passing framework, which can be used by
10430N/Aany two apps to communicate directly (without going through the message bus
15354N/Adaemon).
10430N/A
10430N/A%prep
15354N/A%setup -q
10430N/A%patch1 -p1
10430N/A
10430N/A%build
10430N/A%ifos linux
10430N/Aif [ -x /usr/bin/getconf ]; then
10430N/A CPUS=`getconf _NPROCESSORS_ONLN`
10430N/Afi
10430N/A%else
10430N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10430N/A%endif
10430N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10430N/A CPUS=1
10430N/Afi
10430N/A
15354N/Aaclocal $ACLOCAL_FLAGS
10430N/Aautoheader
10495N/Aautomake -a -c -f
15354N/Aautoconf
15354N/Aexport CFLAGS="%optflags -D_REENTRANT"
15354N/Aexport LDFLAGS="%_ldflags"
15354N/Aexport PKG_CONFIG_PATH="%{_libdir}/pkgconfig"
15354N/A./configure --prefix=%{_prefix} \
15354N/A --includedir=%{_includedir} \
15354N/A --sysconfdir=%{_sysconfdir} \
10430N/A --libdir=%{_libdir} \
10430N/A --libexecdir=%{_libexecdir} \
10430N/A --bindir=%{_bindir} \
10430N/A --localstatedir=%{_localstatedir} \
10430N/A --with-dbus-user=root \
10662N/A --with-dbus-daemondir=%{_basedir}/lib \
10662N/A --mandir=%{_mandir} \
10430N/A --datadir=%{_datadir} \
10430N/A --disable-static
10430N/Amake -j $CPUS \
10430N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10430N/Acd ../%{name}-%{version}
10430N/A
10430N/A%install
10430N/Amake DESTDIR=$RPM_BUILD_ROOT install \
10430N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10430N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
10430N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
10430N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
10430N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
10430N/A# Disable system services.
10430N/Arm $RPM_BUILD_ROOT%{_libexecdir}/dbus-daemon-launch-helper
10430N/A
10430N/A%post
10430N/A/sbin/ldconfig
10430N/A
10430N/A%postun
15386N/A/sbin/ldconfig
15386N/A
15354N/A%clean
15354N/Arm -rf $RPM_BUILD_ROOT
15354N/A
14121N/A%files
14121N/A%defattr(-, root, root)
12090N/A%config %{_sysconfdir}/dbus-1/session.conf
12090N/A%config %{_sysconfdir}/dbus-1/system.conf
11853N/A%{_bindir}/*
11853N/A%{_libdir}/libdbus*.so*
11246N/A%{_datadir}/man/*
11246N/A%{_datadir}/dbus-1/*
10662N/A
10662N/A%files devel
10527N/A%defattr(-, root, root)
10527N/A%{_libdir}/*.so
10500N/A%{_includedir}/dbus-1.0/*
10500N/A%{_libdir}/dbus-1.0/*
10495N/A%{_libdir}/pkgconfig/*
10495N/A%{_libdir}/python?.?/vendor-packages/*
10495N/A
10433N/A%changelog
10433N/A* Wed Dec 10 2008 - brian.cameron@sun.com
10433N/A- Bump to 1.2.8
10433N/A* Mon Dec 08 2008 - dave.lin@sun.com
10433N/A- Bump to 1.2.6.
10430N/A* Thu Oct 09 2008 - brian.cameron@sun.com
10430N/A- Bump to 1.2.4.
D-Bus if it fails to connect the first time.
* Thu Aug 07 2008 - brian.cameron@sun.com
- Bump to 1.2.3. Remove upstream dbus-02-getauditsessiondata.diff patch.
* Wed May 07 2008 - simon.zheng@sun.com
- Add patch 02-getauditsessiondata.diff to add a interface
"GetAdtAuditSessionData", getting audit data from socket connection.
* Sun Apr 06 2008 - brian.cameron@sun.com
- Bump to 1.2.1
* Wed Feb 27 2008 - brian.cameron@sun.com
- Bump to 1.1.20
* Thu Jan 17 2008 - brian.cameron@sun.com
- Bump to 1.1.4.
* Thu Jan 17 2008 - brian.cameron@sun.com
- Bump to 1.1.3. Remove upstream patches.
* Wed Nov 07 2007 - padraig.obriain@sun.com
- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
See bugster 6615221.
* Fri Oct 12 1007 - laca@sun.com
- delete some env variable settings forgotten in the previous commit
* Fri Sep 28 2007 - laca@sun.com
- convert to new style multi-ISA build
* Thu Sep 06 2007 - brian.cameron@sun.com
- Add patch dbus-04-nosystemservice.diff and do not ship
dbus-daemon-launch-helper to disable D-Bus system services completely.
Nothing in Solaris currently needs the D-Bus system service. The Linux
solution specifies that --with-dbus-user is "messagebus". The idea is
that the system daemon runs as this user and uses the root setgid
script dbus-daemon-launch-helper to gain privilege when needed. It is
likely that Sun would instead want to use a more secure least-privilege
RBAC style solution for doing this, if we ever need to add this feature
back.
* Mon Aug 06 2007 - brian.cameron@sun.com
- Bump to 0.74. Update patches.
* Fri Jun 08 2007 - brian.cameron@sun.com
- Remove dbus-01-dbus-launch.diff since it is no longer needed now
that we've reworked the SUNWdtlogin-integration package to call
dbus-launch from /usr/dt/config/Xsession.jds instead of Xinitrc.jds.
* Sun Apr 1 2007 - laca@sun.com
- add missing aclocal calls
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sun Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
- patch to stop Sun Studio compiling GCC asm specific code
* Wed Dec 13 2006 - damien.carbery@sun.com
- Bump to 1.0.2.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Minor cleanup. Remove python build dependancy since now python bindings
are built in separate module.
* Thu Nov 23 2006 - damien.carbery@sun.com
- Removed upstream patches, 01, 02, 04, 05 and 06. Renumber remainder.
* Wed Nov 22 2006 - damien.carbery@sun.com
- Bump to 1.0.1.
* Fri Nov 17 2006 - ghee.teo@sun.com
- Added patch dbus-06-proxy-change-owner-crash.diff. This patch is only
for 0.6x release of dbus, when dbus 1.0 is incorporated, this patch
can be dropped.
* Fri Oct 13 2006 - damien.carbery@sun.com
- Delete .a and .la files.
* Wed Aug 30 2006 - damien.carbery@sun.com
- Add --datadir to configure call so that path in session.conf is expanded.
* Thu Aug 03 2006 - padraig.obriain@sun.com
- Updated dbus-03-dbus-launch.diff to avoid chewing idle CPU.
* Wed Aug 02 2006 - brian.cameron@sun.com
- Rewrote libexec patch based on Havoc's comments. Now pass in
--with-daemondir to set daemon location.
* Fri Jul 28 2006 - laca@sun.com
- add patch priv.spec (from Artem Kachitchkine), makes dbus run as user
'daemon' and also with least privileges
* Fri Jul 21 2006 - brian.cameron@sun.com
- Add patch to move dbus-daemon to /usr/lib, required by ARC.
* Tue May 02 2006 - laca@sun.com
- add patch console.diff that allows D-Bus to authenticate console user
* Sun Feb 26 2006 - laca@sun.com
- Bump to 0.61.
- move python stuff to vendor-packages, remove .pyo and *.la
* Thu Jan 19 2006 - damien.carbery@sun.com
- Remove upstream patch, 01-auth-external. Renumber remaining.
* Tue Jan 17 2006 - damien.carbery@sun.com
- Bump to 0.60.
* Tue Oct 25 2005 - damien.carbery@sun.com
- Remove patch3 as an include dir under _libdir is okay. Bump to 0.50. Disable
python bindings as they fail. Bug 4878 files at freedesktop.org.
* Fri Oct 21 2005 - damien.carbery@sun.com
- Add patches to build on Solaris.
* Tue Aug 30 2005 - glynn.foster@sun.com
- Create the dbus-1 services directory
* Tue Aug 16 2005 - damien.carbery@sun.com
- Add python >= 2.4 dependency. Reformat description text.
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 0.35.2.
* Mon Jun 20 2005 - matt.keenan@sun.com
- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball
* Thu Jun 09 2005 - laca@sun.com
- add buildrequires glib2, libxml2
* Thu May 12 2005 - glynn.foster@sun.com
- Initial spec file for dbus.