dbus.spec revision 12786
0N/A#
196N/A# spec file for package dbus
0N/A#
0N/A# Copyright 2008 Sun Microsystems, Inc.
0N/A# This file and all modifications and additions to the pristine
0N/A# package are under the same license as the package itself.
0N/A#
0N/A# Owner: yippi
0N/A# bugdb: bugzilla.freedesktop.org
0N/A#
0N/AName: dbus
0N/ALicense: GPL/AFL
0N/AGroup: System/Libraries
0N/AVersion: 1.2.1
0N/ARelease: 1
0N/ADistribution: Java Desktop System
0N/AVendor: Sun Microsystems, Inc.
0N/ASummary: Simple IPC library based on messages
0N/ASource: http://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.gz
0N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
0N/A#owner:yippi date:2007-09-06 type:feature
0N/APatch1: dbus-01-nosystemservice.diff
0N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
0N/ADocdir: %{_defaultdocdir}/doc
0N/AAutoreqprov: on
0N/APrereq: /sbin/ldconfig
0N/A
0N/A%define glib2_version 2.6.4
0N/A%define libxml2_version 2.6.19
0N/ABuildRequires: glib2-devel >= %glib2_version
0N/ABuildRequires: libxml2-devel >= %libxml2_version
0N/A# FIXME: get python rpm: BuildRequires: python >= %python_version
0N/ARequires: glib2 >= %glib2_version
0N/ARequires: libxml2 >= %libxml2_version
0N/A
0N/A%description
0N/AD-Bus is a message bus system, a simple way for applications to talk to one
0N/Aanother.
0N/AD-Bus supplies both a system daemon (for events such as "new hardware device
0N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
0N/Ageneral IPC needs among user applications). Also, the message bus is built on
0N/Atop of a general one-to-one message passing framework, which can be used by
0N/Aany two apps to communicate directly (without going through the message bus
0N/Adaemon).
0N/A
0N/A%package devel
0N/ASummary: Simple IPC library based on messages
0N/AGroup: Development/Libraries
0N/ARequires: %{name} = %{version}
0N/A
0N/A%description devel
0N/AD-Bus is a message bus system, a simple way for applications to talk to one
0N/Aanother.
0N/A
0N/AD-Bus supplies both a system daemon (for events such as "new hardware device
0N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
0N/Ageneral IPC needs among user applications). Also, the message bus is built on
0N/Atop of a general one-to-one message passing framework, which can be used by
0N/Aany two apps to communicate directly (without going through the message bus
0N/Adaemon).
0N/A
113N/A%prep
0N/A%setup -q
0N/A%patch1 -p1
0N/A
0N/A%build
0N/A%ifos linux
0N/Aif [ -x /usr/bin/getconf ]; then
0N/A CPUS=`getconf _NPROCESSORS_ONLN`
0N/Afi
0N/A%else
0N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
0N/A%endif
0N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
0N/A CPUS=1
0N/Afi
0N/A
0N/Aaclocal $ACLOCAL_FLAGS
0N/Aautoconf
0N/Aautomake -a -c -f
0N/Aexport CFLAGS="%optflags -D_REENTRANT"
0N/Aexport LDFLAGS="%_ldflags"
0N/Aexport PKG_CONFIG_PATH="%{_libdir}/pkgconfig"
0N/A./configure --prefix=%{_prefix} \
0N/A --includedir=%{_includedir} \
0N/A --sysconfdir=%{_sysconfdir} \
0N/A --libdir=%{_libdir} \
0N/A --libexecdir=%{_libexecdir} \
0N/A --bindir=%{_bindir} \
0N/A --localstatedir=%{_localstatedir} \
0N/A --with-dbus-user=root \
0N/A --with-dbus-daemondir=%{_basedir}/lib \
0N/A --mandir=%{_mandir} \
0N/A --datadir=%{_datadir} \
0N/A --disable-static
0N/Amake -j $CPUS \
0N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
0N/Acd ../%{name}-%{version}
0N/A
0N/A%install
0N/Amake DESTDIR=$RPM_BUILD_ROOT install \
0N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
0N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
0N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
0N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
0N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
0N/A# Disable system services.
0N/Arm $RPM_BUILD_ROOT%{_libexecdir}/dbus-daemon-launch-helper
0N/A
0N/A%post
0N/A/sbin/ldconfig
0N/A
0N/A%postun
0N/A/sbin/ldconfig
0N/A
0N/A%clean
0N/Arm -rf $RPM_BUILD_ROOT
0N/A
0N/A%files
0N/A%defattr(-, root, root)
0N/A%config %{_sysconfdir}/dbus-1/session.conf
0N/A%config %{_sysconfdir}/dbus-1/system.conf
0N/A%{_bindir}/*
0N/A%{_libdir}/libdbus*.so*
0N/A%{_datadir}/man/*
0N/A%{_datadir}/dbus-1/*
0N/A
0N/A%files devel
0N/A%defattr(-, root, root)
0N/A%{_libdir}/*.so
0N/A%{_includedir}/dbus-1.0/*
0N/A%{_libdir}/dbus-1.0/*
0N/A%{_libdir}/pkgconfig/*
0N/A%{_libdir}/python?.?/vendor-packages/*
0N/A
0N/A%changelog
0N/A* Sun Apr 06 2008 - brian.Cameron@sun.com
0N/A- Bump to 1.2.1
0N/A* Wed Feb 27 2008 - brian.Cameron@sun.com
0N/A- Bump to 1.1.20
0N/A* Thu Jan 17 2008 - brian.cameron@sun.com
0N/A- Bump to 1.1.4.
0N/A* Thu Jan 17 2008 - brian.cameron@sun.com
0N/A- Bump to 1.1.3. Remove upstream patches.
0N/A* Wed Nov 07 2007 - padraig.obriain@sun.com
0N/A- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
0N/A See bugster 6615221.
0N/A* Fri Oct 12 1007 - laca@sun.com
0N/A- delete some env variable settings forgotten in the previous commit
0N/A* Fri Sep 28 2007 - laca@sun.com
0N/A- convert to new style multi-ISA build
0N/A* Thu Sep 06 2007 - brian.cameron@sun.com
0N/A- Add patch dbus-04-nosystemservice.diff and do not ship
0N/A dbus-daemon-launch-helper to disable D-Bus system services completely.
0N/A Nothing in Solaris currently needs the D-Bus system service. The Linux
0N/A solution specifies that --with-dbus-user is "messagebus". The idea is
0N/A that the system daemon runs as this user and uses the root setgid
0N/A script dbus-daemon-launch-helper to gain privilege when needed. It is
0N/A likely that Sun would instead want to use a more secure least-privilege
0N/A RBAC style solution for doing this, if we ever need to add this feature
0N/A back.
0N/A* Mon Aug 06 2007 - brian.cameron@sun.com
0N/A- Bump to 0.74. Update patches.
0N/A* Fri Jun 08 2007 - brian.cameron@sun.com
0N/A- Remove dbus-01-dbus-launch.diff since it is no longer needed now
0N/A that we've reworked the SUNWdtlogin-integration package to call
0N/A dbus-launch from /usr/dt/config/Xsession.jds instead of Xinitrc.jds.
0N/A* Sun Apr 1 2007 - laca@sun.com
0N/A- add missing aclocal calls
0N/A* Wed Mar 15 2007 - dougs@truemail.co.th
0N/A- Removed CC64 and CC32. They are not needed anymore
0N/A* Sun Feb 25 2007 - dougs@truemail.co.th
0N/A- updated to include 64-bit build RFE: #6480511
0N/A- patch to stop Sun Studio compiling GCC asm specific code
0N/A* Wed Dec 13 2006 - damien.carbery@sun.com
0N/A- Bump to 1.0.2.
0N/A* Thu Nov 27 2006 - brian.cameron@sun.com
0N/A- Minor cleanup. Remove python build dependancy since now python bindings
0N/A are built in separate module.
0N/A* Thu Nov 23 2006 - damien.carbery@sun.com
0N/A- Removed upstream patches, 01, 02, 04, 05 and 06. Renumber remainder.
0N/A* Wed Nov 22 2006 - damien.carbery@sun.com
0N/A- Bump to 1.0.1.
0N/A* Fri Nov 17 2006 - ghee.teo@sun.com
0N/A- Added patch dbus-06-proxy-change-owner-crash.diff. This patch is only
0N/A for 0.6x release of dbus, when dbus 1.0 is incorporated, this patch
0N/A can be dropped.
0N/A* Fri Oct 13 2006 - damien.carbery@sun.com
0N/A- Delete .a and .la files.
0N/A* Wed Aug 30 2006 - damien.carbery@sun.com
0N/A- Add --datadir to configure call so that path in session.conf is expanded.
0N/A* Thu Aug 03 2006 - padraig.obriain@sun.com
0N/A- Updated dbus-03-dbus-launch.diff to avoid chewing idle CPU.
0N/A* Wed Aug 02 2006 - brian.cameron@sun.com
0N/A- Rewrote libexec patch based on Havoc's comments. Now pass in
0N/A --with-daemondir to set daemon location.
0N/A* Fri Jul 28 2006 - laca@sun.com
0N/A- add patch priv.spec (from Artem Kachitchkine), makes dbus run as user
0N/A 'daemon' and also with least privileges
0N/A* Fri Jul 21 2006 - brian.cameron@sun.com
0N/A- Add patch to move dbus-daemon to /usr/lib, required by ARC.
0N/A* Tue May 02 2006 - laca@sun.com
0N/A- add patch console.diff that allows D-Bus to authenticate console user
0N/A* Sun Feb 26 2006 - laca@sun.com
0N/A- Bump to 0.61.
0N/A- move python stuff to vendor-packages, remove .pyo and *.la
0N/A* Thu Jan 19 2006 - damien.carbery@sun.com
0N/A- Remove upstream patch, 01-auth-external. Renumber remaining.
0N/A* Tue Jan 17 2006 - damien.carbery@sun.com
0N/A- Bump to 0.60.
0N/A* Tue Oct 25 2005 - damien.carbery@sun.com
0N/A- Remove patch3 as an include dir under _libdir is okay. Bump to 0.50. Disable
0N/A python bindings as they fail. Bug 4878 files at freedesktop.org.
0N/A* Fri Oct 21 2005 - damien.carbery@sun.com
0N/A- Add patches to build on Solaris.
0N/A* Tue Aug 30 2005 - glynn.foster@sun.com
0N/A- Create the dbus-1 services directory
0N/A* Tue Aug 16 2005 - damien.carbery@sun.com
0N/A- Add python >= 2.4 dependency. Reformat description text.
0N/A* Mon Aug 15 2005 - damien.carbery@sun.com
0N/A- Bump to 0.35.2.
0N/A* Mon Jun 20 2005 - matt.keenan@sun.com
0N/A- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball
0N/A* Thu Jun 09 2005 - laca@sun.com
0N/A- add buildrequires glib2, libxml2
0N/A* Thu May 12 2005 - glynn.foster@sun.com
0N/A- Initial spec file for dbus.
0N/A