dbus.spec revision 10307
10139N/A#
10139N/A# spec file for package dbus
10139N/A#
12119N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A# bugdb: bugzilla.freedesktop.org
17180N/A#
18603N/AName: dbus
17180N/ALicense: GPL/AFL
10139N/AGroup: System/Libraries
10139N/AVersion: 1.0.2
19112N/ARelease: 2
10139N/ADistribution: Java Desktop System
18580N/AVendor: Sun Microsystems, Inc.
14538N/ASummary: Simple IPC library based on messages
10139N/ASource: http://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.gz
18616N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
10139N/A#owner:yippi date:2006-11-23 type:bug bugzilla:8391
18543N/APatch1: dbus-01-dbus-launch.diff
12559N/A#owner:drdoug type:bug date:2007-02-23 bugzilla:10080
12773N/APatch2: dbus-02-have-atomic.diff
12773N/A#owner:yippi date:2007-03-02 type:bug bugzilla:10153
12773N/APatch3: dbus-03-daemondir.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
14166N/AAutoreqprov: on
16459N/APrereq: /sbin/ldconfig
10139N/A
16459N/A%define glib2_version 2.6.4
10139N/A%define libxml2_version 2.6.19
16459N/ABuildRequires: glib2-devel >= %glib2_version
16768N/ABuildRequires: libxml2-devel >= %libxml2_version
16459N/A# FIXME: get python rpm: BuildRequires: python >= %python_version
15261N/ARequires: glib2 >= %glib2_version
16459N/ARequires: libxml2 >= %libxml2_version
16488N/A
16488N/A%description
17546N/AD-Bus is a message bus system, a simple way for applications to talk to one
17546N/Aanother.
20307N/AD-Bus supplies both a system daemon (for events such as "new hardware device
17999N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
18274N/Ageneral IPC needs among user applications). Also, the message bus is built on
19017N/Atop of a general one-to-one message passing framework, which can be used by
19017N/Aany two apps to communicate directly (without going through the message bus
19017N/Adaemon).
20175N/A
20175N/A%package devel
19017N/ASummary: Simple IPC library based on messages
10420N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AD-Bus is a message bus system, a simple way for applications to talk to one
10139N/Aanother.
10139N/A
10139N/AD-Bus supplies both a system daemon (for events such as "new hardware device
10139N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10139N/Ageneral IPC needs among user applications). Also, the message bus is built on
10139N/Atop of a general one-to-one message passing framework, which can be used by
10139N/Aany two apps to communicate directly (without going through the message bus
10139N/Adaemon).
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%ifos solaris
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%ifarch amd64 sparcv9
10139N/Acd ..
10139N/Acp -pr %{name}-%{version} %{name}-%{version}-64
10139N/A%endif
10139N/A%endif
10142N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
14166N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
16488N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
17546N/A CPUS=1
17999N/Afi
18274N/A
19017N/A%ifos solaris
20175N/A%ifarch amd64 sparcv9
13019N/Aexport CFLAGS="${CFLAGS64}"
10139N/Aexport LDFLAGS="${LDFLAGS64}"
10139N/Aexport PKG_CONFIG_PATH="${PKG_CONFIG_PATH64}"
10139N/A
10139N/Acd ../%{name}-%{version}-64
10139N/A
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir}/%{_arch64} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
12773N/A --with-dbus-daemondir=%{_libdir} \
12773N/A --mandir=%{_mandir} \
12773N/A --datadir=%{_datadir} \
12773N/A --disable-static
12773N/Amake -j $CPUS \
10139N/A pyexecdir=%{_libdir}/%{_arch64}/python%{python_version}/vendor-packages
10139N/Acd ../%{name}-%{version}
10139N/A
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
10139N/Aexport CFLAGS="$CFLAGS32"
10139N/Aexport LDFLAGS="$LDFLAGS32"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/A%endif
10139N/A%endif
15873N/A
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
12962N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
10139N/A --with-dbus-daemondir=%{_libdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --disable-static
10139N/Amake -j $CPUS \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10139N/A
10139N/A%install
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Acd ../%{name}-%{version}-64
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install \
10139N/A pyexecdir=%{_libdir}/%{_arch64}/python%{python_version}/vendor-packages
10139N/Acd ../%{name}-%{version}
10139N/A%endif
10139N/A%endif
10139N/A
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10139N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10633N/A%files
10139N/A%defattr(-, root, root)
10139N/A%config %{_sysconfdir}/dbus-1/session.conf
10139N/A%config %{_sysconfdir}/dbus-1/system.conf
18543N/A%{_bindir}/*
18543N/A%{_libdir}/libdbus*.so*
18274N/A%{_datadir}/man/*
18274N/A%{_datadir}/dbus-1/*
18236N/A
18236N/A%files devel
17546N/A%defattr(-, root, root)
17546N/A%{_libdir}/*.so
17546N/A%{_includedir}/dbus-1.0/*
17394N/A%{_libdir}/dbus-1.0/*
17394N/A%{_libdir}/pkgconfig/*
16836N/A%{_libdir}/python?.?/vendor-packages/*
16836N/A
16768N/A%changelog
16768N/A* Wed Mar 15 2007 - dougs@truemail.co.th
16459N/A- Removed CC64 and CC32. They are not needed anymore
16459N/A* Sun Feb 25 2007 - dougs@truemail.co.th
16459N/A- updated to include 64-bit build RFE: #6480511
16167N/A- patch to stop Sun Studio compiling GCC asm specific code
16167N/A* Wed Dec 13 2006 - damien.carbery@sun.com
15851N/A- Bump to 1.0.2.
15851N/A* Thu Nov 27 2006 - brian.cameron@sun.com
15448N/A- Minor cleanup. Remove python build dependancy since now python bindings
15448N/A are built in separate module.
15448N/A* Thu Nov 23 2006 - damien.carbery@sun.com
15448N/A- Removed upstream patches, 01, 02, 04, 05 and 06. Renumber remainder.
15338N/A* Wed Nov 22 2006 - damien.carbery@sun.com
15338N/A- Bump to 1.0.1.
15338N/A* Fri Nov 17 2006 - ghee.teo@sun.com
15261N/A- Added patch dbus-06-proxy-change-owner-crash.diff. This patch is only
15261N/A for 0.6x release of dbus, when dbus 1.0 is incorporated, this patch
15261N/A can be dropped.
14538N/A* Fri Oct 13 2006 - damien.carbery@sun.com
14538N/A- Delete .a and .la files.
14222N/A* Wed Aug 30 2006 - damien.carbery@sun.com
14222N/A- Add --datadir to configure call so that path in session.conf is expanded.
14166N/A* Thu Aug 03 2006 - padraig.obriain@sun.com
14166N/A- Updated dbus-03-dbus-launch.diff to avoid chewing idle CPU.
14166N/A* Wed Aug 02 2006 - brian.cameron@sun.com
14166N/A- Rewrote libexec patch based on Havoc's comments. Now pass in
14166N/A --with-daemondir to set daemon location.
14166N/A* Fri Jul 28 2006 - laca@sun.com
14105N/A- add patch priv.spec (from Artem Kachitchkine), makes dbus run as user
14105N/A 'daemon' and also with least privileges
14105N/A* Fri Jul 21 2006 - brian.cameron@sun.com
13995N/A- Add patch to move dbus-daemon to /usr/lib, required by ARC.
13995N/A* Tue May 02 2006 - laca@sun.com
13995N/A- add patch console.diff that allows D-Bus to authenticate console user
13995N/A* Sun Feb 26 2006 - laca@sun.com
13916N/A- Bump to 0.61.
13916N/A- move python stuff to vendor-packages, remove .pyo and *.la
13916N/A* Thu Jan 19 2006 - damien.carbery@sun.com
13892N/A- Remove upstream patch, 01-auth-external. Renumber remaining.
13892N/A* Tue Jan 17 2006 - damien.carbery@sun.com
13556N/A- Bump to 0.60.
13556N/A* Tue Oct 25 2005 - damien.carbery@sun.com
13542N/A- Remove patch3 as an include dir under _libdir is okay. Bump to 0.50. Disable
13542N/A python bindings as they fail. Bug 4878 files at freedesktop.org.
13460N/A* Fri Oct 21 2005 - damien.carbery@sun.com
13460N/A- Add patches to build on Solaris.
13427N/A* Tue Aug 30 2005 - glynn.foster@sun.com
13427N/A- Create the dbus-1 services directory
13427N/A* Tue Aug 16 2005 - damien.carbery@sun.com
13084N/A- Add python >= 2.4 dependency. Reformat description text.
13084N/A* Mon Aug 15 2005 - damien.carbery@sun.com
13084N/A- Bump to 0.35.2.
13068N/A* Mon Jun 20 2005 - matt.keenan@sun.com
13068N/A- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball
13001N/A* Thu Jun 09 2005 - laca@sun.com
13001N/A- add buildrequires glib2, libxml2
12971N/A* Thu May 12 2005 - glynn.foster@sun.com
12971N/A- Initial spec file for dbus.
12971N/A