10139N/A#
10139N/A# spec file for package dbus
10139N/A#
20886N/A# Copyright (c) 2005, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner yippi
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
17176N/A
17176N/A%define OSR 12712:1.2.16
17176N/A
10139N/AName: dbus
15322N/ALicense: GPL v2, AFL v2.1
10139N/AGroup: System/Libraries
22050N/AVersion: 1.6.4
11020N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: freedesktop.org
10139N/ASummary: Simple IPC library based on messages
10139N/ASource: http://dbus.freedesktop.org/releases/dbus/%{name}-%{version}.tar.gz
10139N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
11207N/A#owner:yippi date:2007-09-06 type:feature
16428N/A# System services are disabled by default in Solaris configuration since
16428N/A# they are not yet supported on Solaris.
12786N/APatch1: dbus-01-nosystemservice.diff
19019N/A# date:2010-08-16 owner:padraig type:bug doo:16787
18966N/APatch2: dbus-02-closefrom.diff
19044N/A# date:2010-10-20 owner:yippi type:bug bugster:6993687
19019N/APatch3: dbus-03-consoleuser.diff
20118N/A#owner:gheet date:2011-03-11 type:bug bugster:6956527
20118N/APatch4: dbus-04-cleanup-libs.diff
20832N/A#owner:yippi date:2011-06-24 type:bug
20832N/APatch5: dbus-05-compile.diff
20886N/A#owner:yippi date:2012-02-13 type:bug
20886N/APatch6: dbus-06-m4.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define glib2_version 2.6.4
10139N/A%define libxml2_version 2.6.19
10139N/ABuildRequires: glib2-devel >= %glib2_version
10139N/ABuildRequires: libxml2-devel >= %libxml2_version
10139N/A# FIXME: get python rpm: BuildRequires: python >= %python_version
10139N/ARequires: glib2 >= %glib2_version
10139N/ARequires: libxml2 >= %libxml2_version
10139N/A
10139N/A%description
10139N/AD-Bus is a message bus system, a simple way for applications to talk to one
10139N/Aanother.
10139N/AD-Bus supplies both a system daemon (for events such as "new hardware device
10139N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10139N/Ageneral IPC needs among user applications). Also, the message bus is built on
10139N/Atop of a general one-to-one message passing framework, which can be used by
10139N/Aany two apps to communicate directly (without going through the message bus
10139N/Adaemon).
10139N/A
10139N/A%package devel
10139N/ASummary: Simple IPC library based on messages
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AD-Bus is a message bus system, a simple way for applications to talk to one
10139N/Aanother.
10139N/A
10139N/AD-Bus supplies both a system daemon (for events such as "new hardware device
10139N/Aadded" or "printer queue changed") and a per-user-login-session daemon (for
10139N/Ageneral IPC needs among user applications). Also, the message bus is built on
10139N/Atop of a general one-to-one message passing framework, which can be used by
10139N/Aany two apps to communicate directly (without going through the message bus
10139N/Adaemon).
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
18966N/A%patch2 -p1
19019N/A%patch3 -p1
20118N/A%patch4 -p1
20776N/A%patch5 -p1
20886N/A%patch6 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
16777N/Alibtoolize -f
20832N/Aaclocal $ACLOCAL_FLAGS -I ./m4
13004N/Aautoheader
13004N/Aautomake -a -c -f
10139N/Aautoconf
11881N/Aexport CFLAGS="%optflags -D_REENTRANT"
11314N/Aexport LDFLAGS="%_ldflags"
11391N/Aexport PKG_CONFIG_PATH="%{_libdir}/pkgconfig"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
11314N/A --libdir=%{_libdir} \
11020N/A --libexecdir=%{_libexecdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
11314N/A --with-dbus-daemondir=%{_basedir}/lib \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
20776N/A%if %debug_build
20776N/A --enable-verbose-mode \
20776N/A%endif
20776N/A --disable-static \
20776N/A
10139N/Amake -j $CPUS \
11314N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10139N/Acd ../%{name}-%{version}
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
10139N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
11207N/A# Disable system services.
11328N/Arm $RPM_BUILD_ROOT%{_libexecdir}/dbus-daemon-launch-helper
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%config %{_sysconfdir}/dbus-1/session.conf
10139N/A%config %{_sysconfdir}/dbus-1/system.conf
10139N/A%{_bindir}/*
10139N/A%{_libdir}/libdbus*.so*
10139N/A%{_datadir}/man/*
10139N/A%{_datadir}/dbus-1/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/*.so
10139N/A%{_includedir}/dbus-1.0/*
10139N/A%{_libdir}/dbus-1.0/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/python?.?/vendor-packages/*
10139N/A
10139N/A%changelog
22050N/A* Sat Sep 15 2012 - brian.cameron@oracle.com
22050N/A- Bump to 1.6.4.
21825N/A* Tue Jun 05 2012 - brian.cameron@oracle.com
21825N/A- Bump to 1.6.0.
20903N/A* Wed May 02 2012 - brian.cameron@oracle.com
20903N/A- Bump to 1.4.20.
20886N/A* Mon Feb 13 2012 - brian.cameron@oracle.com
20886N/A- Bump to 1.4.18.
20835N/A* Wed Sep 21 2011 - brian.cameron@oracle.com
20835N/A- Bump to 1.4.16.
20832N/A* Tue Sep 13 2011 - brian.cameron@oracle.com
20832N/A- Bump to 1.4.14.
20832N/A* Fri Jun 24 2011 - brian.cameron@oracle.com
20776N/A- Add patch dbus-05-sigterm.diff to fix CR #6985971.
20358N/A* Fri Jun 10 2011 - brian.cameron@oracle.com
20358N/A- Bump to 1.2.28.
19856N/A* Tue Dec 21 2010 - brian.cameron@oracle.com
19856N/A- Bump to 1.2.26.
19028N/A* Wed Oct 20 2010 - brian.cameron@oracle.com
19028N/A- Add patch dbus-03-consoleuser.diff to fix bugster:6963885.
18966N/A* Mon Aug 16 2010 - padraig.obriain@oracle.com
18966N/A- Add dbus-02-closefrom.diff rto fix doo 16787.
18496N/A* Tue Mar 23 2010 - brian.cameron@sun.com
18496N/A- Bump to 1.2.24. Remove upstream patch dbus-02-fixcompile.diff.
18245N/A* Wed Feb 03 2010 - brian.cameron@sun.com
18245N/A- Bump to 1.2.20. Remove upstream patch dbus-02-getpwnam.diff. Add new patch
18245N/A dbus-02-fixcompile.diff needed to build.
16777N/A* Wed Jul 15 2009 - brian.cameron@sun.com
16777N/A- Bump to 1.2.16. Add patch dbus-02-getpwnam.diff to fix compile issue.
15636N/A* Thu Jan 08 2009 - brian.cameron@sun.com
15635N/A- Bump to 1.2.12.
15503N/A* Wed Dec 10 2008 - brian.cameron@sun.com
15503N/A- Bump to 1.2.8
15476N/A* Mon Dec 08 2008 - dave.lin@sun.com
15476N/A- Bump to 1.2.6.
15192N/A* Thu Oct 09 2008 - brian.cameron@sun.com
15192N/A- Bump to 1.2.4.
15192N/A D-Bus if it fails to connect the first time.
13824N/A* Thu Aug 07 2008 - brian.cameron@sun.com
13824N/A- Bump to 1.2.3. Remove upstream dbus-02-getauditsessiondata.diff patch.
13003N/A* Wed May 07 2008 - simon.zheng@sun.com
13003N/A- Add patch 02-getauditsessiondata.diff to add a interface
13003N/A "GetAdtAuditSessionData", getting audit data from socket connection.
13824N/A* Sun Apr 06 2008 - brian.cameron@sun.com
12786N/A- Bump to 1.2.1
13824N/A* Wed Feb 27 2008 - brian.cameron@sun.com
12485N/A- Bump to 1.1.20
12485N/A* Thu Jan 17 2008 - brian.cameron@sun.com
12222N/A- Bump to 1.1.4.
12485N/A* Thu Jan 17 2008 - brian.cameron@sun.com
12221N/A- Bump to 1.1.3. Remove upstream patches.
11902N/A* Wed Nov 07 2007 - padraig.obriain@sun.com
11902N/A- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
11902N/A See bugster 6615221.
11391N/A* Fri Oct 12 1007 - laca@sun.com
11391N/A- delete some env variable settings forgotten in the previous commit
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- convert to new style multi-ISA build
11207N/A* Thu Sep 06 2007 - brian.cameron@sun.com
11207N/A- Add patch dbus-04-nosystemservice.diff and do not ship
11207N/A dbus-daemon-launch-helper to disable D-Bus system services completely.
11207N/A Nothing in Solaris currently needs the D-Bus system service. The Linux
11207N/A solution specifies that --with-dbus-user is "messagebus". The idea is
11207N/A that the system daemon runs as this user and uses the root setgid
11207N/A script dbus-daemon-launch-helper to gain privilege when needed. It is
11207N/A likely that Sun would instead want to use a more secure least-privilege
11207N/A RBAC style solution for doing this, if we ever need to add this feature
11207N/A back.
11020N/A* Mon Aug 06 2007 - brian.cameron@sun.com
11020N/A- Bump to 0.74. Update patches.
10767N/A* Fri Jun 08 2007 - brian.cameron@sun.com
10767N/A- Remove dbus-01-dbus-launch.diff since it is no longer needed now
10767N/A that we've reworked the SUNWdtlogin-integration package to call
10767N/A dbus-launch from /usr/dt/config/Xsession.jds instead of Xinitrc.jds.
10392N/A* Sun Apr 1 2007 - laca@sun.com
10392N/A- add missing aclocal calls
10307N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10307N/A- Removed CC64 and CC32. They are not needed anymore
10139N/A* Sun Feb 25 2007 - dougs@truemail.co.th
10139N/A- updated to include 64-bit build RFE: #6480511
10139N/A- patch to stop Sun Studio compiling GCC asm specific code
10139N/A* Wed Dec 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.0.2.
10139N/A* Thu Nov 27 2006 - brian.cameron@sun.com
10139N/A- Minor cleanup. Remove python build dependancy since now python bindings
10139N/A are built in separate module.
10139N/A* Thu Nov 23 2006 - damien.carbery@sun.com
10139N/A- Removed upstream patches, 01, 02, 04, 05 and 06. Renumber remainder.
10139N/A* Wed Nov 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.0.1.
10139N/A* Fri Nov 17 2006 - ghee.teo@sun.com
10139N/A- Added patch dbus-06-proxy-change-owner-crash.diff. This patch is only
10139N/A for 0.6x release of dbus, when dbus 1.0 is incorporated, this patch
10139N/A can be dropped.
10139N/A* Fri Oct 13 2006 - damien.carbery@sun.com
10139N/A- Delete .a and .la files.
10139N/A* Wed Aug 30 2006 - damien.carbery@sun.com
10139N/A- Add --datadir to configure call so that path in session.conf is expanded.
10139N/A* Thu Aug 03 2006 - padraig.obriain@sun.com
10139N/A- Updated dbus-03-dbus-launch.diff to avoid chewing idle CPU.
10139N/A* Wed Aug 02 2006 - brian.cameron@sun.com
10139N/A- Rewrote libexec patch based on Havoc's comments. Now pass in
10139N/A --with-daemondir to set daemon location.
10139N/A* Fri Jul 28 2006 - laca@sun.com
10139N/A- add patch priv.spec (from Artem Kachitchkine), makes dbus run as user
10139N/A 'daemon' and also with least privileges
10139N/A* Fri Jul 21 2006 - brian.cameron@sun.com
10139N/A- Add patch to move dbus-daemon to /usr/lib, required by ARC.
10139N/A* Tue May 02 2006 - laca@sun.com
10139N/A- add patch console.diff that allows D-Bus to authenticate console user
10139N/A* Sun Feb 26 2006 - laca@sun.com
10139N/A- Bump to 0.61.
10139N/A- move python stuff to vendor-packages, remove .pyo and *.la
10139N/A* Thu Jan 19 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 01-auth-external. Renumber remaining.
10139N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.60.
10139N/A* Tue Oct 25 2005 - damien.carbery@sun.com
10139N/A- Remove patch3 as an include dir under _libdir is okay. Bump to 0.50. Disable
10139N/A python bindings as they fail. Bug 4878 files at freedesktop.org.
10139N/A* Fri Oct 21 2005 - damien.carbery@sun.com
10139N/A- Add patches to build on Solaris.
10139N/A* Tue Aug 30 2005 - glynn.foster@sun.com
10139N/A- Create the dbus-1 services directory
10139N/A* Tue Aug 16 2005 - damien.carbery@sun.com
10139N/A- Add python >= 2.4 dependency. Reformat description text.
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 0.35.2.
10139N/A* Mon Jun 20 2005 - matt.keenan@sun.com
10139N/A- dbus 0.23 is actually shipped with gnome 2.10 so bumping down tarball
10139N/A* Thu Jun 09 2005 - laca@sun.com
10139N/A- add buildrequires glib2, libxml2
10139N/A* Thu May 12 2005 - glynn.foster@sun.com
10139N/A- Initial spec file for dbus.