dbus-python.spec revision 20903
15395N/A#
15395N/A# spec file for package dbus-python
15395N/A#
15395N/A# Copyright (c) 2006, 2012, Oracle and/or its affiliates. All rights reserved.
15395N/A# This file and all modifications and additions to the pristine
15395N/A# package are under the same license as the package itself.
15395N/A#
15977N/A%define owner yippi
15395N/A# bugdb: bugzilla.freedesktop.org
15395N/A#
15395N/A%{?!pythonver:%define pythonver 2.6}
17180N/A
17180N/A%define OSR 4092:0.60
15395N/A
17033N/AName: dbus-python
17033N/ALicense: MIT
17035N/AVendor: freedesktop.org
17033N/AGroup: System/Libraries
17033N/AVersion: 1.0.0
15395N/ARelease: 1
17033N/ADistribution: Java Desktop System
15395N/ASummary: Python bindings for D-Bus
15395N/ASource: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
15395N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
15395N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15395N/ADocdir: %{_defaultdocdir}/doc
15395N/AAutoreqprov: on
15395N/APrereq: /sbin/ldconfig
15395N/A
15395N/ABuildRequires: glib2-devel >= %glib2_version
15395N/ABuildRequires: libxml2-devel >= %libxml2_version
16212N/ABuildRequires: python-devel >= %{pythonver}
17035N/ARequires: glib2 >= %glib2_version
17035N/ARequires: libxml2 >= %libxml2_version
17035N/ARequires: python >= %{pythonver}
15395N/A
15395N/A%description
15395N/APython bindings for D-Bus.
15395N/A
15395N/A%package devel
15395N/ASummary: Simple IPC library based on messages
15395N/AGroup: Development/Libraries
15395N/ARequires: %{name} = %{version}
15395N/A
15395N/A%description devel
15395N/APython bindings for D-Bus.
15395N/A
16039N/A%prep
15395N/A%setup -q
15395N/A
15395N/A%build
15395N/Aexport PYTHON=/usr/bin/python%{pythonver}
15395N/Aexport PYTHON_VERSION=%{pythonver}
17035N/Aaclocal $ACLOCAL_FLAGS -I ./m4
17035N/Aautoconf
16496N/Aautomake -a -c -f
16496N/Aexport CFLAGS="%optflags -D_REENTRANT"
16039N/Aexport LDFLAGS="%_ldflags"
16039N/A./configure --prefix=%{_prefix} \
15694N/A --includedir=%{_includedir} \
15694N/A --sysconfdir=%{_sysconfdir} \
15395N/A --libdir=%{_libdir} \
15395N/A --bindir=%{_bindir} \
15395N/A --localstatedir=%{_localstatedir} \
15395N/A --with-dbus-user=root \
15395N/A --with-dbus-daemondir=%{_basedir}/lib \
15395N/A --mandir=%{_mandir} \
15395N/A --datadir=%{_datadir} \
15395N/A --disable-static
15395N/Amake
15395N/A
15395N/A%install
15395N/Amake install DESTDIR=$RPM_BUILD_ROOT
15395N/A
15395N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
15395N/A
15395N/A# move to vendor-packages
15395N/APYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
(
cd ${PYLIBDIR}/site-packages
find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
)
rm -rf ${PYLIBDIR}/site-packages
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus*.so*
%{_datadir}/man/*
%{_datadir}/dbus-1/*
%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*
%{_libdir}/python?.?/vendor-packages/*
%changelog
* Wed May 02 2012 - Brian Cameron <brian.cameron@oracle.com>
- Bump to 1.0.0.
* Tue Sep 13 2011 - Brian Cameron <brian.cameron@oracle.com>
- Bump to 0.84.0.
* Mon Dec 27 2010 - Brian Cameron <brian.cameron@oracle.com>
- Bump to 0.83.2.
* Fri Feb 19 2010 - Brian Cameron <brian.cameron@sun.com>
- Bump to 0.83.1.
* Tue Oct 13 2009 - Brian Cameron <brian.cameron@sun.com>
- Do not install .pyo files.
* Thu Mar 19 2009 - brian.cameron@sun.com
- Remove patch dbus-python-01-fix-wrong-python25-includes.diff and instead
set PYTHON_VERSION, which also ensures that the right python includes are
used.
* Thu Mar 05 2009 - brian.cameron@sun.com
- Made it possible to build both Python 2.4 and 2.6 bindings.
* Mon Aug 15 2008 - patrick.ale@gmail.com
- Remove method to find python headers by means of python-config from
configure (Patch1) and add -I/usr/python2.4 to CFLAGS.
* Thu Jul 24 2008 - brian.cameron@sun.com
- bump to 0.83.0.
* Mon Dec 10 2007 - brian.cameron@sun.com
- Bump to 0.82.4.
* Wed Nov 07 2007 - padraig.obriain@sun.com
- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
See bugster 6615221
* Wed Oct 10 2007 - damien.carbery@sun.com
- Don't delete *.pyc files - they are needed.
* Fri Sep 28 2007 - laca@sun.com
- convert to new style multi-ISA build
* Mon Aug 06 2007 - brian.cameron@sun.com
- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
* Sun Apr 1 2007 - laca@sun.com
- add missing aclocal calls
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sat Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - damien.carbery@sun.com
- Bump to 0.80.2.
* Thu Jan 25 2007 - damien.carbery@sun.com
- Bump to 0.80.1. Use configure/make to build, not setup.py.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Created.