dbus-python.spec revision 20832
17289N/A#
17289N/A# spec file for package dbus-python
17289N/A#
17289N/A# Copyright 2007 Sun Microsystems, Inc.
17289N/A# This file and all modifications and additions to the pristine
17289N/A# package are under the same license as the package itself.
17289N/A#
17289N/A%define owner yippi
17289N/A# bugdb: bugzilla.freedesktop.org
17289N/A#
17289N/A%{?!pythonver:%define pythonver 2.6}
17289N/A
17289N/A%define OSR 4092:0.60
17289N/A
17289N/AName: dbus-python
17289N/ALicense: MIT
17289N/AVendor: freedesktop.org
17289N/AGroup: System/Libraries
17289N/AVersion: 0.84.0
17289N/ARelease: 1
17289N/ADistribution: Java Desktop System
17289N/ASummary: Python bindings for D-Bus
17289N/ASource: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
17289N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
17289N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17289N/ADocdir: %{_defaultdocdir}/doc
17289N/AAutoreqprov: on
17289N/APrereq: /sbin/ldconfig
17289N/A
17289N/ABuildRequires: glib2-devel >= %glib2_version
17289N/ABuildRequires: libxml2-devel >= %libxml2_version
17289N/ABuildRequires: python-devel >= %{pythonver}
17289N/ARequires: glib2 >= %glib2_version
17289N/ARequires: libxml2 >= %libxml2_version
17289N/ARequires: python >= %{pythonver}
17289N/A
17289N/A%description
17289N/APython bindings for D-Bus.
17289N/A
17289N/A%package devel
17289N/ASummary: Simple IPC library based on messages
17289N/AGroup: Development/Libraries
17289N/ARequires: %{name} = %{version}
17289N/A
17289N/A%description devel
17289N/APython bindings for D-Bus.
17289N/A
17289N/A%prep
17289N/A%setup -q
17289N/A
17289N/A%build
17289N/Aexport PYTHON=/usr/bin/python%{pythonver}
17289N/Aexport PYTHON_VERSION=%{pythonver}
17289N/Aaclocal $ACLOCAL_FLAGS -I ./m4
17289N/Aautoconf
17289N/Aautomake -a -c -f
17289N/Aexport CFLAGS="%optflags -D_REENTRANT"
17289N/Aexport LDFLAGS="%_ldflags"
17289N/A./configure --prefix=%{_prefix} \
17289N/A --includedir=%{_includedir} \
17289N/A --sysconfdir=%{_sysconfdir} \
17289N/A --libdir=%{_libdir} \
17289N/A --bindir=%{_bindir} \
17289N/A --localstatedir=%{_localstatedir} \
17289N/A --with-dbus-user=root \
17289N/A --with-dbus-daemondir=%{_basedir}/lib \
17289N/A --mandir=%{_mandir} \
17289N/A --datadir=%{_datadir} \
17289N/A --disable-static
17289N/Amake
17289N/A
17289N/A%install
17289N/Amake install DESTDIR=$RPM_BUILD_ROOT
17289N/A
17289N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
17289N/A
# move to vendor-packages
PYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
(
cd ${PYLIBDIR}/site-packages
find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
)
rm -rf ${PYLIBDIR}/site-packages
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus*.so*
%{_datadir}/man/*
%{_datadir}/dbus-1/*
%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*
%{_libdir}/python?.?/vendor-packages/*
%changelog
* Tue Sep 13 2011 - Brian Cameron <brian.cameron@oracle.com>
- Bump to 0.84.0.
* Mon Dec 27 2010 - Brian Cameron <brian.cameron@oracle.com>
- Bump to 0.83.2.
* Fri Feb 19 2010 - Brian Cameron <brian.cameron@sun.com>
- Bump to 0.83.1.
* Tue Oct 13 2009 - Brian Cameron <brian.cameron@sun.com>
- Do not install .pyo files.
* Thu Mar 19 2009 - brian.cameron@sun.com
- Remove patch dbus-python-01-fix-wrong-python25-includes.diff and instead
set PYTHON_VERSION, which also ensures that the right python includes are
used.
* Thu Mar 05 2009 - brian.cameron@sun.com
- Made it possible to build both Python 2.4 and 2.6 bindings.
* Mon Aug 15 2008 - patrick.ale@gmail.com
- Remove method to find python headers by means of python-config from
configure (Patch1) and add -I/usr/python2.4 to CFLAGS.
* Thu Jul 24 2008 - brian.cameron@sun.com
- bump to 0.83.0.
* Mon Dec 10 2007 - brian.cameron@sun.com
- Bump to 0.82.4.
* Wed Nov 07 2007 - padraig.obriain@sun.com
- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
See bugster 6615221
* Wed Oct 10 2007 - damien.carbery@sun.com
- Don't delete *.pyc files - they are needed.
* Fri Sep 28 2007 - laca@sun.com
- convert to new style multi-ISA build
* Mon Aug 06 2007 - brian.cameron@sun.com
- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
* Sun Apr 1 2007 - laca@sun.com
- add missing aclocal calls
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sat Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - damien.carbery@sun.com
- Bump to 0.80.2.
* Thu Jan 25 2007 - damien.carbery@sun.com
- Bump to 0.80.1. Use configure/make to build, not setup.py.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Created.