dbus-python.spec revision 16195
10139N/A#
10139N/A# spec file for package dbus-python
10139N/A#
16646N/A# Copyright 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
17368N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
17180N/A%{?!pythonver:%define pythonver 2.4}
17180N/A
17180N/AName: dbus-python
10139N/ALicense: MIT
17365N/AGroup: System/Libraries
10139N/AVersion: 0.83.0
17365N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Python bindings for D-Bus
10139N/ASource: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
10139N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
17368N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17365N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define python_version 2.4
10139N/ABuildRequires: glib2-devel >= %glib2_version
15395N/ABuildRequires: libxml2-devel >= %libxml2_version
10139N/ABuildRequires: python-devel >= %{pythonver}
10139N/ARequires: glib2 >= %glib2_version
10139N/ARequires: libxml2 >= %libxml2_version
10139N/ARequires: python >= %{pythonver}
10139N/A
10139N/A%description
10139N/APython bindings for D-Bus.
10139N/A
10139N/A%package devel
10139N/ASummary: Simple IPC library based on messages
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/APython bindings for D-Bus.
17365N/A
10139N/A%prep
10139N/A%setup -q
17365N/A
17365N/A%build
10139N/Aexport PYTHON=/usr/bin/python%{pythonver}
10139N/Aexport PYTHON_VERSION=%{pythonver}
10139N/Aaclocal $ACLOCAL_FLAGS -I ./m4
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/Aexport CFLAGS="%optflags -D_REENTRANT"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
10139N/A --with-dbus-daemondir=%{_basedir}/lib \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --disable-static
10139N/Amake
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A# move to vendor-packages
10139N/APYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
10139N/A[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
10139N/A(
10139N/A cd ${PYLIBDIR}/site-packages
10139N/A find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
10139N/A)
10139N/Arm -rf ${PYLIBDIR}/site-packages
10139N/A
10139N/A
10139N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%config %{_sysconfdir}/dbus-1/session.conf
17365N/A%config %{_sysconfdir}/dbus-1/system.conf
17365N/A%{_bindir}/*
16900N/A%{_libdir}/libdbus*.so*
16900N/A%{_datadir}/man/*
16646N/A%{_datadir}/dbus-1/*
16646N/A
15395N/A%files devel
15395N/A%defattr(-, root, root)
10312N/A%{_libdir}/*.so
10312N/A%{_includedir}/dbus-1.0/*
10139N/A%{_libdir}/dbus-1.0/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/python?.?/vendor-packages/*
10139N/A
%changelog
* Thu Mar 19 2009 - brian.cameron@sun.com
- Remove patch dbus-python-01-fix-wrong-python25-includes.diff and instead
set PYTHON_VERSION, which also ensures that the right python includes are
used.
* Thu Mar 05 2009 - brian.cameron@sun.com
- Made it possible to build both Python 2.4 and 2.6 bindings.
* Mon Aug 15 2008 - patrick.ale@gmail.com
- Remove method to find python headers by means of python-config from
configure (Patch1) and add -I/usr/python2.4 to CFLAGS.
* Thu Jul 24 2008 - brian.cameron@sun.com
- bump to 0.83.0.
* Mon Dec 10 2007 - brian.cameron@sun.com
- Bump to 0.82.4.
* Wed Nov 07 2007 - padraig.obriain@sun.com
- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
See bugster 6615221
* Wed Oct 10 2007 - damien.carbery@sun.com
- Don't delete *.pyc files - they are needed.
* Fri Sep 28 2007 - laca@sun.com
- convert to new style multi-ISA build
* Mon Aug 06 2007 - brian.cameron@sun.com
- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
* Sun Apr 1 2007 - laca@sun.com
- add missing aclocal calls
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sat Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - damien.carbery@sun.com
- Bump to 0.80.2.
* Thu Jan 25 2007 - damien.carbery@sun.com
- Bump to 0.80.1. Use configure/make to build, not setup.py.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Created.