dbus-python.spec revision 15322
11179N/A#
11179N/A# spec file for package dbus-python
11179N/A#
11179N/A# Copyright 2007 Sun Microsystems, Inc.
11179N/A# This file and all modifications and additions to the pristine
11179N/A# package are under the same license as the package itself.
11179N/A#
11179N/A# Owner: yippi
11179N/A# bugdb: bugzilla.freedesktop.org
11179N/A#
11179N/A%define pythonver 2.4
11179N/A
11179N/AName: dbus-python
11179N/ALicense: MIT
11179N/AGroup: System/Libraries
11179N/AVersion: 0.83.0
11179N/ARelease: 1
11179N/ADistribution: Java Desktop System
11179N/AVendor: Sun Microsystems, Inc.
11179N/ASummary: Python bindings for D-Bus
11179N/ASource: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
11179N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
11179N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11179N/ADocdir: %{_defaultdocdir}/doc
11179N/AAutoreqprov: on
11179N/APrereq: /sbin/ldconfig
11179N/A#owner:yippi date:2008-09-15 type:feature
11179N/A# This patch is by Patrick Ale <patrick.ale@gmail.com>.
11179N/APatch1: dbus-python-01-fix-wrong-python25-includes.diff
11179N/A
11179N/A%define python_version 2.4
11179N/ABuildRequires: glib2-devel >= %glib2_version
11179N/ABuildRequires: libxml2-devel >= %libxml2_version
11179N/ABuildRequires: python-devel >= %{pythonver}
11179N/ARequires: glib2 >= %glib2_version
11179N/ARequires: libxml2 >= %libxml2_version
11179N/ARequires: python >= %{pythonver}
11179N/A
11179N/A%description
11179N/APython bindings for D-Bus.
11179N/A
11179N/A%package devel
11179N/ASummary: Simple IPC library based on messages
11179N/AGroup: Development/Libraries
11179N/ARequires: %{name} = %{version}
11179N/A
11179N/A%description devel
11179N/APython bindings for D-Bus.
11179N/A
11179N/A%prep
11179N/A%setup -q
11179N/A%patch1 -p1
11179N/A
11179N/A%build
11179N/Aaclocal $ACLOCAL_FLAGS -I ./m4
11179N/Aautoconf
11179N/Aautomake -a -c -f
11179N/Aexport CFLAGS="%optflags -D_REENTRANT -I/usr/include/python2.4"
export LDFLAGS="%_ldflags"
./configure --prefix=%{_prefix} \
--includedir=%{_includedir} \
--sysconfdir=%{_sysconfdir} \
--libdir=%{_libdir} \
--bindir=%{_bindir} \
--localstatedir=%{_localstatedir} \
--with-dbus-user=root \
--with-dbus-daemondir=%{_basedir}/lib \
--mandir=%{_mandir} \
--datadir=%{_datadir} \
--disable-static
make
%install
make install DESTDIR=$RPM_BUILD_ROOT
# move to vendor-packages
PYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
(
cd ${PYLIBDIR}/site-packages
find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
)
rm -rf ${PYLIBDIR}/site-packages
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus*.so*
%{_datadir}/man/*
%{_datadir}/dbus-1/*
%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*
%{_libdir}/python?.?/vendor-packages/*
%changelog
* Mon Aug 15 2008 - patrick.ale@gmail.com
- Remove method to find python headers by means of python-config from
configure (Patch1) and add -I/usr/python2.4 to CFLAGS.
* Thu Jul 24 2008 - brian.cameron@sun.com
- bump to 0.83.0.
* Mon Dec 10 2007 - brian.cameron@sun.com
- Bump to 0.82.4.
* Wed Nov 07 2007 - padraig.obriain@sun.com
- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
See bugster 6615221
* Wed Oct 10 2007 - damien.carbery@sun.com
- Don't delete *.pyc files - they are needed.
* Fri Sep 28 2007 - laca@sun.com
- convert to new style multi-ISA build
* Mon Aug 06 2007 - brian.cameron@sun.com
- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
* Sun Apr 1 2007 - laca@sun.com
- add missing aclocal calls
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sat Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - damien.carbery@sun.com
- Bump to 0.80.2.
* Thu Jan 25 2007 - damien.carbery@sun.com
- Bump to 0.80.1. Use configure/make to build, not setup.py.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Created.