dbus-python.spec revision 11881
10139N/A#
10139N/A# spec file for package dbus-python
10139N/A#
11314N/A# Copyright 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: yippi
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
10139N/A%define pythonver 2.4
10139N/A
10139N/AName: dbus-python
10139N/ALicense: GPL/AFL
10139N/AGroup: System/Libraries
11020N/AVersion: 0.82.2
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Python bindings for D-Bus
10139N/ASource: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
10139N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define python_version 2.4
10139N/ABuildRequires: glib2-devel >= %glib2_version
10139N/ABuildRequires: libxml2-devel >= %libxml2_version
10139N/ABuildRequires: python-devel >= %{pythonver}
10139N/ARequires: glib2 >= %glib2_version
10139N/ARequires: libxml2 >= %libxml2_version
10139N/ARequires: python >= %{pythonver}
10139N/A
10139N/A%description
10139N/APython bindings for D-Bus.
10139N/A
10139N/A%package devel
10139N/ASummary: Simple IPC library based on messages
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/APython bindings for D-Bus.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A%build
11020N/Aaclocal $ACLOCAL_FLAGS -I ./m4
10139N/Aautoconf
10139N/Aautomake -a -c -f
11881N/Aexport CFLAGS="%optflags -D_REENTRANT"
11314N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
11314N/A --with-dbus-daemondir=%{_basedir}/lib \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --disable-static
10139N/Amake
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A# move to vendor-packages
10139N/APYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
10139N/A[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
10139N/A(
10139N/A cd ${PYLIBDIR}/site-packages
10139N/A find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
10139N/A)
10139N/Arm -rf ${PYLIBDIR}/site-packages
10139N/A
10139N/A
10139N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%config %{_sysconfdir}/dbus-1/session.conf
10139N/A%config %{_sysconfdir}/dbus-1/system.conf
10139N/A%{_bindir}/*
10139N/A%{_libdir}/libdbus*.so*
10139N/A%{_datadir}/man/*
10139N/A%{_datadir}/dbus-1/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/*.so
10139N/A%{_includedir}/dbus-1.0/*
10139N/A%{_libdir}/dbus-1.0/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/python?.?/vendor-packages/*
10139N/A
10139N/A%changelog
11881N/A* Wed Nov 7 2007 - padraig.obriain@sun.com
11881N/A- Add -D_REENTRANT. It was removed from SUNW spec file on Sep 28.
11881N/A See bugster 6615221
11377N/A* Wed Oct 10 2007 - damien.carbery@sun.com
11377N/A- Don't delete *.pyc files - they are needed.
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- convert to new style multi-ISA build
11020N/A* Mon Aug 06 2007 - brian.cameron@sun.com
11020N/A- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
10392N/A* Sun Apr 1 2007 - laca@sun.com
10392N/A- add missing aclocal calls
10307N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10307N/A- Removed CC64 and CC32. They are not needed anymore
10139N/A* Sat Feb 25 2007 - dougs@truemail.co.th
10139N/A- updated to include 64-bit build RFE: #6480511
10139N/A* Wed Feb 14 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.80.2.
10139N/A* Thu Jan 25 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.80.1. Use configure/make to build, not setup.py.
10139N/A* Thu Nov 27 2006 - brian.cameron@sun.com
10139N/A- Created.