dbus-python.spec revision 10307
10139N/A#
10139N/A# spec file for package dbus-python
10139N/A#
11314N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
19806N/A%define pythonver 2.4
10139N/A
18593N/AName: dbus-python
18593N/ALicense: GPL/AFL
10139N/AGroup: System/Libraries
15322N/AVersion: 0.80.2
18615N/ARelease: 1
10139N/ADistribution: Java Desktop System
18310N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Python bindings for D-Bus
10139N/ASource: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
10139N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define python_version 2.4
10139N/ABuildRequires: glib2-devel >= %glib2_version
10139N/ABuildRequires: libxml2-devel >= %libxml2_version
10139N/ABuildRequires: python-devel >= %{pythonver}
10139N/ARequires: glib2 >= %glib2_version
10139N/ARequires: libxml2 >= %libxml2_version
10139N/ARequires: python >= %{pythonver}
10139N/A
10139N/A%description
10139N/APython bindings for D-Bus.
10139N/A
10139N/A%package devel
10139N/ASummary: Simple IPC library based on messages
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/APython bindings for D-Bus.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Acd ..
16075N/Acp -pr %{name}-%{version} %{name}-%{version}-64
16195N/A%endif
11020N/A%endif
10139N/A
10139N/A
16195N/A%build
11314N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Aexport CFLAGS="${CFLAGS64}"
10139N/Aexport LDFLAGS="${LDFLAGS64}"
10139N/Aexport PKG_CONFIG_PATH="${PKG_CONFIG_PATH64}"
10139N/Aexport PYTHON=%{_bindir}/%{_arch64}/python
10139N/A
11314N/Acd ../%{name}-%{version}-64
10139N/A
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir}/%{_arch64} \
10139N/A --bindir=%{_bindir} \
17492N/A --localstatedir=%{_localstatedir} \
17492N/A --with-dbus-user=root \
10139N/A --with-dbus-daemondir=%{_libdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --disable-static
10139N/Amake
10139N/Acd ../%{name}-%{version}
10139N/A
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
10139N/Aexport CFLAGS="$CFLAGS32"
10139N/Aexport LDFLAGS="$LDFLAGS32"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport PYTHON=%{_bindir}/python
10139N/A%endif
10139N/A%endif
10139N/A
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
10139N/A --with-dbus-daemondir=%{_libdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --disable-static
10139N/Amake
10139N/A
10139N/A%install
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
18310N/Acd ../%{name}-%{version}-64
18310N/Amake install DESTDIR=$RPM_BUILD_ROOT
17492N/APYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
17492N/Amv ${PYLIBDIR}/site-packages ${PYLIBDIR}/vendor-packages
16195N/Amkdir -p ${PYLIBDIR}/vendor-packages/64
16195N/Amv ${PYLIBDIR}/vendor-packages/*.so ${PYLIBDIR}/vendor-packages/64
16195N/Arm -rf ${PYLIBDIR}/site-packages
16195N/Acd ../%{name}-%{version}
16075N/A%endif
16075N/A%endif
14333N/A
14333N/Amake install DESTDIR=$RPM_BUILD_ROOT
14333N/A
13660N/A# move to vendor-packages
13660N/APYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
12049N/A[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
12049N/A(
11902N/A cd ${PYLIBDIR}/site-packages
11902N/A find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
11881N/A)
11377N/Arm -rf ${PYLIBDIR}/site-packages
11377N/A
11314N/A
11314N/A# Delete precompiled py code (*.pyc). May not be compatibile with dest system.
11020N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.pyc" -exec rm {} ';'
11020N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
10392N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'
10392N/A
10307N/A%clean
10307N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%config %{_sysconfdir}/dbus-1/session.conf
10139N/A%config %{_sysconfdir}/dbus-1/system.conf
10139N/A%{_bindir}/*
10139N/A%{_libdir}/libdbus*.so*
10139N/A%{_datadir}/man/*
%{_datadir}/dbus-1/*
%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*
%{_libdir}/python?.?/vendor-packages/*
%changelog
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sat Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - damien.carbery@sun.com
- Bump to 0.80.2.
* Thu Jan 25 2007 - damien.carbery@sun.com
- Bump to 0.80.1. Use configure/make to build, not setup.py.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Created.