10139N/A#
10139N/A# spec file for package dbus-python
10139N/A#
20903N/A# Copyright (c) 2006, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner yippi
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
19806N/A%{?!pythonver:%define pythonver 2.6}
10139N/A
18593N/A%define OSR 4092:0.60
18593N/A
10139N/AName: dbus-python
15322N/ALicense: MIT
18615N/AVendor: freedesktop.org
10139N/AGroup: System/Libraries
22050N/AVersion: 1.1.1
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/ASummary: Python bindings for D-Bus
10139N/ASource: http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
10139N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/ABuildRequires: glib2-devel >= %glib2_version
10139N/ABuildRequires: libxml2-devel >= %libxml2_version
10139N/ABuildRequires: python-devel >= %{pythonver}
10139N/ARequires: glib2 >= %glib2_version
10139N/ARequires: libxml2 >= %libxml2_version
10139N/ARequires: python >= %{pythonver}
10139N/A
10139N/A%description
10139N/APython bindings for D-Bus.
10139N/A
10139N/A%package devel
10139N/ASummary: Simple IPC library based on messages
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/APython bindings for D-Bus.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A%build
16075N/Aexport PYTHON=/usr/bin/python%{pythonver}
16195N/Aexport PYTHON_VERSION=%{pythonver}
11020N/Aaclocal $ACLOCAL_FLAGS -I ./m4
10139N/Aautoconf
10139N/Aautomake -a -c -f
16195N/Aexport CFLAGS="%optflags -D_REENTRANT"
11314N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --localstatedir=%{_localstatedir} \
10139N/A --with-dbus-user=root \
11314N/A --with-dbus-daemondir=%{_basedir}/lib \
10139N/A --mandir=%{_mandir} \
10139N/A --datadir=%{_datadir} \
10139N/A --disable-static
10139N/Amake
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
17492N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
17492N/A
10139N/A# move to vendor-packages
10139N/APYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
10139N/A[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
10139N/A(
10139N/A cd ${PYLIBDIR}/site-packages
10139N/A find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
10139N/A)
10139N/Arm -rf ${PYLIBDIR}/site-packages
10139N/A
10139N/A
10139N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
10139N/Afind $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%config %{_sysconfdir}/dbus-1/session.conf
10139N/A%config %{_sysconfdir}/dbus-1/system.conf
10139N/A%{_bindir}/*
10139N/A%{_libdir}/libdbus*.so*
10139N/A%{_datadir}/man/*
10139N/A%{_datadir}/dbus-1/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/*.so
10139N/A%{_includedir}/dbus-1.0/*
10139N/A%{_libdir}/dbus-1.0/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/python?.?/vendor-packages/*
10139N/A
10139N/A%changelog
22050N/A* Sat Sep 15 2012 - Brian Cameron <brian.cameron@oracle.com>
22050N/A- Bump to 1.1.1.
20903N/A* Wed May 02 2012 - Brian Cameron <brian.cameron@oracle.com>
20903N/A- Bump to 1.0.0.
20832N/A* Tue Sep 13 2011 - Brian Cameron <brian.cameron@oracle.com>
20832N/A- Bump to 0.84.0.
19856N/A* Mon Dec 27 2010 - Brian Cameron <brian.cameron@oracle.com>
19856N/A- Bump to 0.83.2.
18310N/A* Fri Feb 19 2010 - Brian Cameron <brian.cameron@sun.com>
18310N/A- Bump to 0.83.1.
17492N/A* Tue Oct 13 2009 - Brian Cameron <brian.cameron@sun.com>
17492N/A- Do not install .pyo files.
16195N/A* Thu Mar 19 2009 - brian.cameron@sun.com
16195N/A- Remove patch dbus-python-01-fix-wrong-python25-includes.diff and instead
16195N/A set PYTHON_VERSION, which also ensures that the right python includes are
16195N/A used.
16075N/A* Thu Mar 05 2009 - brian.cameron@sun.com
16075N/A- Made it possible to build both Python 2.4 and 2.6 bindings.
14333N/A* Mon Aug 15 2008 - patrick.ale@gmail.com
14333N/A- Remove method to find python headers by means of python-config from
14333N/A configure (Patch1) and add -I/usr/python2.4 to CFLAGS.
13660N/A* Thu Jul 24 2008 - brian.cameron@sun.com
13660N/A- bump to 0.83.0.
12049N/A* Mon Dec 10 2007 - brian.cameron@sun.com
12049N/A- Bump to 0.82.4.
11902N/A* Wed Nov 07 2007 - padraig.obriain@sun.com
11902N/A- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
11881N/A See bugster 6615221
11377N/A* Wed Oct 10 2007 - damien.carbery@sun.com
11377N/A- Don't delete *.pyc files - they are needed.
11314N/A* Fri Sep 28 2007 - laca@sun.com
11314N/A- convert to new style multi-ISA build
11020N/A* Mon Aug 06 2007 - brian.cameron@sun.com
11020N/A- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
10392N/A* Sun Apr 1 2007 - laca@sun.com
10392N/A- add missing aclocal calls
10307N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10307N/A- Removed CC64 and CC32. They are not needed anymore
10139N/A* Sat Feb 25 2007 - dougs@truemail.co.th
10139N/A- updated to include 64-bit build RFE: #6480511
10139N/A* Wed Feb 14 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.80.2.
10139N/A* Thu Jan 25 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.80.1. Use configure/make to build, not setup.py.
10139N/A* Thu Nov 27 2006 - brian.cameron@sun.com
10139N/A- Created.