dbus-glib.spec revision 10307
17691N/A#
17691N/A# spec file for package dbus-glib
17691N/A#
17691N/A# Copyright (c) 2005 Sun Microsystems, Inc.
17691N/A# This file and all modifications and additions to the pristine
17691N/A# package are under the same license as the package itself.
17691N/A#
17691N/A# Owner: yippi
17691N/A# bugdb: bugzilla.freedesktop.org
17691N/A#
17691N/AName: dbus-glib
17691N/ALicense: GPL/AFL
17691N/AGroup: System/Libraries
17691N/AVersion: 0.73
17691N/ARelease: 1
18536N/ADistribution: Java Desktop System
17691N/AVendor: Sun Microsystems, Inc.
17691N/ASummary: Glib bindings for D-Bus
17691N/ASource: http://dbus.freedesktop.org/releases/dbus-glib/%{name}-%{version}.tar.gz
17691N/A#owner:yippi date:2006-11-27 type:bug bugzilla:10153
18536N/APatch1: dbus-glib-01-findlaunch.diff
17691N/AURL: http://www.freedesktop.org/wiki/Software_2fdbus
17691N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17691N/ADocdir: %{_defaultdocdir}/doc
17691N/AAutoreqprov: on
17691N/APrereq: /sbin/ldconfig
17691N/A
17691N/A%define glib2_version 2.6.4
17691N/A%define libxml2_version 2.6.19
17691N/ABuildRequires: glib2-devel >= %glib2_version
17691N/ABuildRequires: libxml2-devel >= %libxml2_version
17691N/A# FIXME: get python rpm: BuildRequires: python >= %python_version
17691N/ARequires: glib2 >= %glib2_version
17691N/ARequires: libxml2 >= %libxml2_version
17691N/A
17691N/A%description
17691N/AGlib bindings for D-Bus.
17691N/A
17691N/A%package devel
17691N/ASummary: Simple IPC library based on messages
17691N/AGroup: Development/Libraries
17691N/ARequires: %{name} = %{version}
17691N/A
17691N/A%description devel
17691N/AGlib bindings for D-Bus.
17691N/A
17691N/A%prep
17691N/A%setup -q
17691N/A%patch1 -p1
17691N/A%ifos solaris
17691N/A%ifarch amd64 sparcv9
17691N/Acd ..
17691N/Acp -pr %{name}-%{version} %{name}-%{version}-64
17691N/A%endif
17691N/A%endif
17691N/A
17691N/A%build
17691N/A%ifos linux
17691N/Aif [ -x /usr/bin/getconf ]; then
17691N/A CPUS=`getconf _NPROCESSORS_ONLN`
17691N/Afi
17691N/A%else
17691N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
17691N/A%endif
17691N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
17691N/A CPUS=1
17691N/Afi
17691N/A
17691N/A%ifos solaris
17691N/A%ifarch amd64 sparcv9
17691N/Aexport CFLAGS="${CFLAGS64}"
17691N/Aexport LDFLAGS="${LDFLAGS64}"
17691N/Aexport PKG_CONFIG_PATH="${PKG_CONFIG_PATH64}"
17691N/A
17691N/Acd ../%{name}-%{version}-64
17691N/A
17691N/Aautoconf
17691N/Aautomake -a -c -f
17691N/A./configure --prefix=%{_prefix} \
17691N/A --includedir=%{_includedir} \
17691N/A --sysconfdir=%{_sysconfdir} \
17691N/A --libdir=%{_libdir}/%{_arch64} \
17691N/A --bindir=%{_bindir} \
17691N/A --localstatedir=%{_localstatedir} \
17691N/A --with-dbus-user=root \
17691N/A --with-dbus-daemondir=%{_libdir} \
17691N/A --mandir=%{_mandir} \
17691N/A --datadir=%{_datadir} \
17691N/A --disable-static
17691N/Amake -j $CPUS \
17691N/A pyexecdir=%{_libdir}/%{_arch64}/python%{python_version}/vendor-packages
18536N/Acd ../%{name}-%{version}
18536N/A
18325N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
18325N/Aexport CFLAGS="$CFLAGS32"
18268N/Aexport LDFLAGS="$LDFLAGS32"
18268N/Aexport RPM_OPT_FLAGS="$CFLAGS"
17882N/A%endif
17882N/A%endif
17882N/A
17691N/Aautoconf
17691N/Aautomake -a -c -f
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
--includedir=%{_includedir} \
--sysconfdir=%{_sysconfdir} \
--libdir=%{_libdir} \
--bindir=%{_bindir} \
--localstatedir=%{_localstatedir} \
--with-dbus-user=root \
--with-dbus-daemondir=%{_libdir} \
--mandir=%{_mandir} \
--datadir=%{_datadir} \
--disable-static
make -j $CPUS \
pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
%install
%ifos solaris
%ifarch amd64 sparcv9
cd ../%{name}-%{version}-64
make DESTDIR=$RPM_BUILD_ROOT install \
pyexecdir=%{_libdir}/%{_arch64}/python%{python_version}/vendor-packages
cd ../%{name}-%{version}
%endif
%endif
make DESTDIR=$RPM_BUILD_ROOT install \
pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/services
find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
%post
/sbin/ldconfig
%postun
/sbin/ldconfig
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus*.so*
%{_datadir}/man/*
%{_datadir}/dbus-1/*
%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*
%{_libdir}/python?.?/vendor-packages/*
%changelog
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed CC64 and CC32. They are not needed anymore
* Sun Feb 25 2007 - dougs@truemail.co.th
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - damien.carbery@sun.com
- Bump to 0.73. Remove upstream patch 01-uninstalled-pc. Rename remainder.
* Thu Nov 27 2006 - brian.cameron@sun.com
- Created.