dasher.spec revision 10280
10139N/A#
10139N/A# spec file for package dasher
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: yippi
10139N/A#
10139N/A%include l10n.inc
10139N/AName: dasher
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
10139N/AVersion: 4.4.0
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Predictive text entry system
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/dasher/4.4/%{name}-%{version}.tar.bz2
10139N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
10139N/A# owner:yippi date:2006-04-27 type:branding
10139N/APatch1: dasher-01-menu-entry.diff
10139N/A# owner:dcarbery date:2007-01-04 type:bug bugzilla:388198
10139N/APatch2: dasher-02-joystick.diff
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/A
10139N/A%define gtk2_version 2.3.1
10139N/A%define GConf_version 2.4.0.1
10139N/A%define libgnomeui_version 2.6.0
10139N/A%define libwnck_version 2.6.0
10139N/A%define gnome_speech_version 0.3.0
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: GConf >= %{GConf_version}
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: libwnck >= %{libwnck_version}
10139N/ARequires: gnome-speech >= %{gnome_speech_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: GConf-devel >= %{GConf_version}
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: libwnck-devel >= %{libwnck_version}
10139N/ABuildRequires: gnome-speech-devel >= %{gnome_speech_version}
10139N/ABuildRequires: intltool
10139N/A
10139N/A%description
10139N/ADasher is a zooming predictive text entry system, designed for situations
10139N/Awhere keyboard input is impractical (for instance, accessibility or PDAs). It
10139N/Ais usable with highly limited amounts of physical input while still allowing
10139N/Ahigh rates of text entry.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10139N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
10139N/Aintltoolize -c -f --automake
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A ./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir}
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_bindir}/*
10139N/A%{_datadir}/applications
10139N/A%{_datadir}/dasher
10139N/A%{_datadir}/gnome/help
10139N/A%{_datadir}/icons
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/man
10139N/A%{_datadir}/omf
10139N/A
10139N/A%changelog
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 4.4.0.
10139N/A* Tue Mar 06 2007 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 03-return-value.
10139N/A* Mon Mar 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 4.3.5.
10139N/A* Wed Feb 14 2007 - damien.carbery@sun.com
10139N/A- Add patch, 03-return-value, to return values from functions (functions
10139N/A involved as in the process of being reimplemented). Fixes #407773.
10139N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
10139N/A- Add l10n tarball.
10139N/A* Tue Feb 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 4.3.4.
10139N/A* Thu Jan 04 2007 - damien.carbery@sun.com
10139N/A- Add patch, 02-joystick, to get module to build. It is a dreadful hack, but
10139N/A pushed upstream (#388198) to encourage the maintainer to find a better
10139N/A solution. Add intltoolize call to get l10n files installed.
10139N/A* Wed Dec 20 2006 - brian.cameron@sun.com
10139N/A- Remove nodividebyzero patch since it is no longer needed. New
10139N/A version of dasher no longer allows the problem to happen. Remove
10139N/A unnecessary linguas patch.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.3.3.
10139N/A* Thu Dec 14 2006 - brian.cameron@sun.com
10139N/A- Patch to avoid divide by zero which causes dasher to core dump.
10139N/A* Mon Dec 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.3.2. Remove upstream patches, 01-forte and 03-fixcompile. Renumber
10139N/A remainder.
10139N/A* Mon Nov 27 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.2.2.
10139N/A* Wed Oct 25 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.2.1.
10139N/A* Mon Sep 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.2.0.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.1.10.
10139N/A* Tue Aug 08 2006 - brian.cameron@sun.com
10139N/A- Bump to 4.1.9.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.1.8.
10139N/A* Web Jul 20 2006 - dermot.mccluskey@sun.com
10139N/A- Bump to 4.1.7.
10139N/A* Fri Jun 23 2006 - brian.cameron@sun.com
10139N/A- Bump to 4.1.4. Add patches to fix build, now call glib-gettextize.
10139N/A* Fri Apr 28 2006 - glynn.foster@sun.com
10139N/A- Add patch to move Dasher into Universal
10139N/A Access.
10139N/A* Mon Apr 3 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.0.2.
10139N/A* Sat Mar 18 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.0.1.
10139N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 4.0.0.
10139N/A* Sun Feb 26 2006 - damien.carbery@sun.com
10139N/A- Bump to 3.99.5.
10139N/A* Tue Feb 21 2006 - brian.cameron@sun.com
10139N/A- Add patch 1 to get dasher to compile with Forte.
10139N/A* Mon Feb 20 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 01-trace.
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 3.99.4.
10139N/A* Tue Jan 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 3.99.3.
10139N/A* Tue Jan 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 3.99.2.
10139N/A* Fri Jan 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 3.99.1.
10139N/A* Fri Sep 30 2005 - brian.cameron@sun.com
10139N/A- Add patch 1 to get dasher to compile. Got Trace.cpp from
10139N/A CVS head. Seems to be a bug in dasher that this file isn't
10139N/A included in the compile, so submitted a bug to bugzilla.
10139N/A I suspect Forte's stricter linking rules cause this issue
10139N/A on Solaris.
10139N/A* Thu Sep 08 2005 - damien.carbery@sun.com
10139N/A- Bump to 3.2.18.
10139N/A* Tue May 24 2005 - glynn.foster@sun.com
10139N/A- Initial spec
10139N/A