cairo.spec revision 18383
10139N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
12198N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner erwannc
10139N/A# bugdb: bugzilla.freedesktop.org
17596N/A#
10139N/A
17178N/A%define OSR 4091:1.0.2
17178N/A
17178N/AName: cairo
10139N/ALicense: LGPL
10139N/AGroup: System/Libraries
10139N/AVersion: 1.8.10
10139N/ARelease: 1
17631N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Vector graphics library
10139N/ASource: http://cairographics.org/releases/%{name}-%{version}.tar.gz
10139N/A#owner:erwannc date:2006-11-02 type:feature
17394N/APatch1: cairo-02-full-hinting.diff
10139N/A#owner:erwannc date:2008-10-28 type:bug doo:4187
10139N/APatch2: cairo-03-buggy-repeat.diff
10139N/AURL: http://www.cairographics.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}
10142N/AAutoreqprov: on
10142N/APrereq: /sbin/ldconfig
12773N/ARequires: freetype2
12773N/ABuildRequires:freetype2-devel
12773N/ARequires: fontconfig
10139N/ABuildRequires:fontconfig-devel
10139N/ARequires: SUNWpixman
10139N/A
10139N/A
10139N/A%description
10139N/ACairo is a vector graphics library with cross-device output
13269N/Asupport. Currently supported output targets include the X Window
13269N/ASystem and in-memory image buffers. Cairo is designed to produce
13868N/Aidentical output on all output media while taking advantage of
14258N/Adisplay hardware acceleration when available (eg. through the
15166N/AX Render Extension).
15166N/A
10139N/ACairo provides a stateful user-level API with capabilities similar to
10139N/Athe PDF 1.4 imaging model. Cairo provides operations including
10139N/Astroking and filling Bezier cubic splines, transforming and
10139N/Acompositing translucent images, and antialiased text rendering.
10139N/A
10139N/A
10139N/A%package devel
10139N/ASummary: Vector graphics library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/ACairo is a vector graphics library with cross-device output
10139N/Asupport. Currently supported output targets include the X Window
10139N/ASystem and in-memory image buffers. Cairo is designed to produce
10139N/Aidentical output on all output media while taking advantage of
10139N/Adisplay hardware acceleration when available (eg. through the
10139N/AX Render Extension).
10139N/A
10139N/ACairo provides a stateful user-level API with capabilities similar to
10139N/Athe PDF 1.4 imaging model. Cairo provides operations including
10139N/Astroking and filling Bezier cubic splines, transforming and
10139N/Acompositing translucent images, and antialiased text rendering.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
11461N/A
10139N/Aexport PATH=`pwd`:$PATH
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS -I build
10139N/Agtkdocize
10139N/Aautoheader
11461N/Aautomake -a -c -f
10139N/Aautoconf
10142N/A%if %option_with_debug
10139N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS"
10139N/A%else
13269N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DNDEBUG"
11959N/A%endif
10139N/A
10139N/Aexport LDFLAGS="%_ldflags"
13653N/A./configure \
15166N/A --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
17517N/A/sbin/ldconfig
16174N/A
10139N/A%postun
10139N/A/sbin/ldconfig
12773N/A
12773N/A%files
12773N/A%defattr(-,root,root)
12773N/A%{_libdir}/*.so.*
12773N/A
16632N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%doc AUTHORS ChangeLog COPYING NEWS README TODO
10139N/A%{_includedir}/*
10139N/A%{_libdir}/*.so
10139N/A%{_datadir}/gtk-doc/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A
10139N/A%changelog
10139N/A* Thu Mar 04 2010 - ginn.chen@sun.com
10139N/A- Bump to 1.8.10.
10139N/A* Tue Aug 25 2009 - christian.kelly@sun.com
10139N/A- Remove %include Solaris.inc, as it breaks the build.
10139N/A* Sun Jul 26 2009 - christian.kelly@sun.com
10139N/A- Bump to 1.8.8.
10139N/A* Web Feb 25 2009 - chris.wang@sun.com
10139N/A- bump to version 1.8.6
10139N/A* Thu Feb 12 2009 - jedy.wang@sun.com
10139N/A- Fix broken download link.
10139N/A* Fri Dec 12 2008 - chris.wang@sun.com
10139N/A- Add NDEBUG macro in CFLAGS
10139N/A* Wed Dec 10 2008 - dave.lin@sun.com
10139N/A- Removed upstreamed patch -uninstalled-pc.diff.
11461N/A* Mon Dec 08 2008 - dave.lin@sun.com
10139N/A- Bump to 1.8.4.
11461N/A* Tue Nov 18 2008 - darren.kenny@sun.com
10142N/A- Remove unneeded patch cairo-03-no-pixman-dep.diff, since we pixman should
10139N/A now be on the system (delivered by X). Renumber remaining patches.
10139N/A- Add Requires statement for SUNWpixman.
10139N/A* Wed Aug 13 2008 - damien.carbery@sun.com
10139N/A- Reenable patch2 (02-full-hinting) because the build machine is on snv_92 or
10139N/A greater.
10139N/A* Tue Aug 12 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.7.4.
10139N/A* Fri Jul 11 2008 - damien.carbery@sun.com
10139N/A- Disable 02-full-hinting patch as build machines use snv_91. freetype fix is
10139N/A in snv_92.
10139N/A* Thu Jul 10 2008 - erwann.chenede@sun.com
10139N/A- re-enabled cairo-02-full-hinting.diff patch as freetype is fixed now.
10139N/A* Thu Jun 12 2008 - damien.carbery@sun.com
10139N/A- Comment out patch2 because of change to Freetype in snv_91 breaks build.
10139N/A* Sun Apr 20 2008 - damien.carbery@sun.com
10139N/A- Add -D_POSIX_PTHREAD_SEMANTICS to CFLAGS to fix sparc build (ctime_r error).
10139N/A* Fri Apr 18 2008 - darren.kenny@sun.com
10139N/A- Temporarily remove depenency on pixman in pkg-config file since it's
10139N/A directly linked into libcairo until pixman is delivered by X.
10139N/A* Tue Jan 22 2008 - damien.carbery@sun.com
10139N/A- Revert to 1.4.14 as 1.5.6 requires pixman and this will be delivered by X
10139N/A Server group in the future. Remove obsolete patch 05-ctime_r: only an issue in
10139N/A 1.5.6.
10139N/A* Thu Jan 17 2008 - patrick.ale@gmail.com
10139N/A- Someone bumped up to snapshot 1.5.6.
10139N/A- Changed URL to fetch from snapshot dir rather than releases
10139N/A* Tue Jan 15 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.4.14.
10139N/A* Tue Nov 27 2007 - brian.cameron@sun.com
10139N/A- Bump to 1.4.12
10139N/A* Fri Aug 3 2007 - chris.wang@sun.com
10139N/A- merge patch cairo-02-8bit-fix.diff and cairo-05-null-struct-pointer.diff, and
10139N/A remove cairo-05-null-struct-pointer.diff from repository. revised patch
10139N/A cairo-02-8bit-fix.diff, added code to support 8bit Truecolor. This fixed bug
10139N/A 6555333, xscreensaver-demo crash when display set to 8 bit.
10139N/A* Mon Jul 23 2007 - chris.wang@sun.com
10139N/A- add patch cairo-05-null-struct-pointer.diff which fixed the bug nautilus
10139N/A crash when D&D files
10139N/A* Tue Jul 03 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.4.10.
17631N/A* Wed May 9 2007 - elaine.xiong@sun.com
17631N/A- Removed obsolete buggy_repeat path for Xsun.
17596N/A* Wed May 2 2007 - brian.cameron@sun.com
17596N/A- Bump to 1.4.6.
17394N/A* Sun Apr 1 2007 - laca@sun.com
17394N/A- add missing aclocal calls
17306N/A* Thu Mar 15 2007 - laca@sun.com
17306N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
17120N/A* Wed Mar 15 2007 - dougs@truemail.co.th
17120N/A- Changed source URL from snapshots to releases for 1.4.0
16834N/A* Wed Mar 15 2007 - dougs@truemail.co.th
16834N/A- Removed adding ccdir to PATH
16696N/A* Wed Mar 14 2007 - damien.carbery@sun.com
16696N/A- Bump to 1.4.0. Remove upstream patch, 04-endian-search. Renumber remainder.
16696N/A* Fri Feb 16 2007 - brian.cameron@sun.com
16632N/A- Add mediaLib patch and autoheader call needed for this patch.
16632N/A* Thu Dec 14 2006 - damien.carbery@sun.com
16632N/A- Correct url for unstable builds: s/releases/snapshots/.
16372N/A* Tue Dec 12 2006 - damien.carbery@sun.com
16632N/A- Readd a patch to fix bug 9124 (called 04-endian-search this time).
16158N/A* Mon Dec 11 2006 - damien.carbery@sun.com
16632N/A- Bump to 1.3.6. Remove upstream patch 04-float-word.
16158N/A* Fri Dec 08 2006 - brian.cameron@sun.com
16136N/A- Add patch description for 8-bit patch since I noticed the bugzilla bug.
16632N/A* Fri Nov 24 2006 - damien.carbery@sun.com
15868N/A- Bump to 1.3.2. Add patch 04-float-word to fix configure issue. Fixes #9124.
16632N/A* Fri Nov 3 2006 - laca@sun.com
15848N/A- use %gtk_doc_option in configure so that it can be disabled using
16632N/A --without-gtk-doc
15739N/A* Mon Oct 16 2006 brian.cameron@sun.com
16632N/A- Enable gtk-docs. This required adding gtkdocize and automake
15621N/A before calling configure
15621N/A* Mon Aug 28 2006 harry.lu@sun.com
15579N/A- Bumped to 1.2.4.
16632N/A* Fri Aug 11 2006 damien.carbery@sun.com
15448N/A- Remove upstream patch, 02-buggyx. Renumber others.
16632N/A* Fri Aug 11 2006 damien.carbery@sun.com
15166N/A- Bumped to 1.2.2.
15166N/A* Thu Jul 20 2006 damien.carbery@sun.com
15166N/A- Bumped to 1.2.0.
15166N/A* Wed Jun 14 2006 yandong.yao@sun.com
14538N/A- Fix bug 6434250: cairo will crash when access 0x0 bitmap image glyph
14538N/A Add patch cairo-04-g11n-0x0glyph-fix.diff
14258N/A* Wed Oct 26 2005 damien.carbery@sun.com
14258N/A- Bumped to 1.0.2.
14103N/A* Tue Oct 25 2005 brian.cameron@sun.com
14103N/A- Add patch 2 to workaround the buggy Xserver shipped with
13964N/A Solaris 10. This fixes the problem that the background
13964N/A would not get repainted when you would move an icon, view
13919N/A the root menu, etc. The same workaround is used in the
16632N/A code to resolve this problem on other platforms using an
13868N/A Xorg server older than 2.8.2 (we use 2.8.0 on Solaris 10).
13868N/A* Tue Sep 13 2005 brian.cameron@sun.com
13868N/A- Bumped to 1.0.0
13868N/A* Fri Aug 26 2005 laca@sun.com
13868N/A- add 64-bit bits
13817N/A* Tue Aug 16 2005 laca@sun.com
13818N/A- add some missing dependencies
13818N/A* Mon Aug 15 2005 glynn.foster@sun.com
13653N/A- Bump to 0.9.2
13653N/A* Mon Feb 28 2004 brian.cameron@sun.com
13641N/A- Add patch 01 so that we can build libsvg and libsvg-cairo.
13641N/A* Tue Feb 22 2004 brian.cameron@sun.com
13429N/A- created
13429N/A