cairo.spec revision 12199
15497N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
15497N/A# Owner: erwannc
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
10139N/AName: cairo
17185N/ALicense: LGPL
10139N/AGroup: System/Libraries
10139N/AVersion: 1.4.14
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Vector graphics library
15497N/ASource: http://cairographics.org/releases/%{name}-%{version}.tar.gz
10139N/A#owner:erwannc date:2000-00-00 type:feature bugzilla:6997
10139N/APatch1: cairo-01-uninstalled-pc.diff
10139N/A#owner:erwannc date:2006-06-09 type:bug bugzilla:4945 bugster:6555333
10139N/APatch2: cairo-02-8bit-fix.diff
10139N/A#owner:erwannc date:2006-11-02 type:feature
10139N/APatch3: cairo-03-full-hinting.diff
10139N/A#owner:yippi date:2007-02-14 type:feature bugzilla:10151
10139N/APatch4: cairo-04-mediaLib.diff
10139N/AURL: http://www.cairographics.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}
10139N/AAutoreqprov: on
19142N/APrereq: /sbin/ldconfig
10139N/ARequires: freetype2
10139N/ABuildRequires:freetype2-devel
10139N/ARequires: fontconfig
12719N/ABuildRequires:fontconfig-devel
19140N/A
10139N/A%description
10139N/ACairo is a vector graphics library with cross-device output
19142N/Asupport. Currently supported output targets include the X Window
15497N/ASystem and in-memory image buffers. Cairo is designed to produce
15497N/Aidentical output on all output media while taking advantage of
10139N/Adisplay hardware acceleration when available (eg. through the
10139N/AX Render Extension).
19013N/A
10139N/ACairo provides a stateful user-level API with capabilities similar to
10139N/Athe PDF 1.4 imaging model. Cairo provides operations including
10139N/Astroking and filling Bezier cubic splines, transforming and
10139N/Acompositing translucent images, and antialiased text rendering.
19142N/A
10139N/A
17961N/A%package devel
10139N/ASummary: Vector graphics library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/ACairo is a vector graphics library with cross-device output
10139N/Asupport. Currently supported output targets include the X Window
10139N/ASystem and in-memory image buffers. Cairo is designed to produce
10139N/Aidentical output on all output media while taking advantage of
10139N/Adisplay hardware acceleration when available (eg. through the
10139N/AX Render Extension).
10139N/A
15497N/ACairo provides a stateful user-level API with capabilities similar to
15497N/Athe PDF 1.4 imaging model. Cairo provides operations including
10139N/Astroking and filling Bezier cubic splines, transforming and
10139N/Acompositing translucent images, and antialiased text rendering.
15497N/A
15497N/A%prep
15497N/A%setup -q
15497N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
15497N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
17961N/Aexport PATH=`pwd`:$PATH
17961N/A
15497N/Aaclocal $ACLOCAL_FLAGS
15497N/Agtkdocize
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/Aexport CFLAGS="%optflags"
10139N/Aexport LDFLAGS="%_ldflags"
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/*.so.*
19324N/A
%files devel
%defattr(-,root,root)
%doc AUTHORS ChangeLog COPYING NEWS README TODO
%{_includedir}/*
%{_libdir}/*.so
%{_datadir}/gtk-doc/*
%{_libdir}/pkgconfig/*
%changelog
* Tue Jan 15 2008 - damien.carbery@sun.com
- Bump to 1.4.14.
* Tue Nov 27 2007 - brian.cameron@sun.com
- Bump to 1.4.12
* Fri Aug 3 2007 - chris.wang@sun.com
- merge patch cairo-02-8bit-fix.diff and cairo-05-null-struct-pointer.diff, and
remove cairo-05-null-struct-pointer.diff from repository. revised patch
cairo-02-8bit-fix.diff, added code to support 8bit Truecolor. This fixed bug
6555333, xscreensaver-demo crash when display set to 8 bit.
* Mon Jul 23 2007 - chris.wang@sun.com
- add patch cairo-05-null-struct-pointer.diff which fixed the bug nautilus
crash when D&D files
* Tue Jul 03 2007 - damien.carbery@sun.com
- Bump to 1.4.10.
* Wed May 9 2007 - elaine.xiong@sun.com
- Removed obsolete buggy_repeat path for Xsun.
* Wed May 2 2007 - brian.cameron@sun.com
- Bump to 1.4.6.
* Sun Apr 1 2007 - laca@sun.com
- add missing aclocal calls
* Thu Mar 15 2007 - laca@sun.com
- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
* Wed Mar 15 2007 - dougs@truemail.co.th
- Changed source URL from snapshots to releases for 1.4.0
* Wed Mar 15 2007 - dougs@truemail.co.th
- Removed adding ccdir to PATH
* Wed Mar 14 2007 - damien.carbery@sun.com
- Bump to 1.4.0. Remove upstream patch, 04-endian-search. Renumber remainder.
* Fri Feb 16 2007 - brian.cameron@sun.com
- Add mediaLib patch and autoheader call needed for this patch.
* Thu Dec 14 2006 - damien.carbery@sun.com
- Correct url for unstable builds: s/releases/snapshots/.
* Tue Dec 12 2006 - damien.carbery@sun.com
- Readd a patch to fix bug 9124 (called 04-endian-search this time).
* Mon Dec 11 2006 - damien.carbery@sun.com
- Bump to 1.3.6. Remove upstream patch 04-float-word.
* Fri Dec 08 2006 - brian.cameron@sun.com
- Add patch description for 8-bit patch since I noticed the bugzilla bug.
* Fri Nov 24 2006 - damien.carbery@sun.com
- Bump to 1.3.2. Add patch 04-float-word to fix configure issue. Fixes #9124.
* Fri Nov 3 2006 - laca@sun.com
- use %gtk_doc_option in configure so that it can be disabled using
--without-gtk-doc
* Mon Oct 16 2006 brian.cameron@sun.com
- Enable gtk-docs. This required adding gtkdocize and automake
before calling configure
* Mon Aug 28 2006 harry.lu@sun.com
- Bumped to 1.2.4.
* Fri Aug 11 2006 damien.carbery@sun.com
- Remove upstream patch, 02-buggyx. Renumber others.
* Fri Aug 11 2006 damien.carbery@sun.com
- Bumped to 1.2.2.
* Thu Jul 20 2006 damien.carbery@sun.com
- Bumped to 1.2.0.
* Wed Jun 14 2006 yandong.yao@sun.com
- Fix bug 6434250: cairo will crash when access 0x0 bitmap image glyph
Add patch cairo-04-g11n-0x0glyph-fix.diff
* Wed Oct 26 2005 damien.carbery@sun.com
- Bumped to 1.0.2.
* Tue Oct 25 2005 brian.cameron@sun.com
- Add patch 2 to workaround the buggy Xserver shipped with
Solaris 10. This fixes the problem that the background
would not get repainted when you would move an icon, view
the root menu, etc. The same workaround is used in the
code to resolve this problem on other platforms using an
Xorg server older than 2.8.2 (we use 2.8.0 on Solaris 10).
* Tue Sep 13 2005 brian.cameron@sun.com
- Bumped to 1.0.0
* Fri Aug 26 2005 laca@sun.com
- add 64-bit bits
* Tue Aug 16 2005 laca@sun.com
- add some missing dependencies
* Mon Aug 15 2005 glynn.foster@sun.com
- Bump to 0.9.2
* Mon Feb 28 2004 brian.cameron@sun.com
- Add patch 01 so that we can build libsvg and libsvg-cairo.
* Tue Feb 22 2004 brian.cameron@sun.com
- created