cairo.spec revision 10307
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
11314N/A# Owner: erwannc
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
10139N/AName: cairo
17185N/ALicense: LGPL
10139N/AGroup: System/Libraries
11314N/AVersion: 1.4.0
11314N/ARelease: 5
11314N/ADistribution: Java Desktop System
11314N/AVendor: Sun Microsystems, Inc.
11314N/ASummary: Vector graphics library
11314N/ASource: http://cairographics.org/snapshots/%{name}-%{version}.tar.gz
11314N/A#owner:erwannc date:2000-00-00 type:feature bugzilla:6997
11316N/APatch1: cairo-01-uninstalled-pc.diff
11314N/A#owner:erwannc date:2006-06-09 type:bug bugzilla:4945
10139N/APatch2: cairo-02-8bit-fix.diff
18688N/A#owner:erwannc date:2006-11-02 type:feature
18688N/APatch3: cairo-03-full-hinting.diff
10139N/A#owner:yippi date:2007-02-14 type:feature bugzilla:10151
19013N/APatch4: cairo-04-mediaLib.diff
10139N/AURL: http://www.cairographics.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12717N/ADocdir: %{_defaultdocdir}
19124N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
19941N/ARequires: freetype2
19941N/ABuildRequires:freetype2-devel
19931N/ARequires: fontconfig
10139N/ABuildRequires:fontconfig-devel
10139N/A
19142N/A%description
16401N/ACairo is a vector graphics library with cross-device output
16401N/Asupport. Currently supported output targets include the X Window
10139N/ASystem and in-memory image buffers. Cairo is designed to produce
10139N/Aidentical output on all output media while taking advantage of
10139N/Adisplay hardware acceleration when available (eg. through the
10139N/AX Render Extension).
13321N/A
16075N/ACairo provides a stateful user-level API with capabilities similar to
16443N/Athe PDF 1.4 imaging model. Cairo provides operations including
13321N/Astroking and filling Bezier cubic splines, transforming and
13321N/Acompositing translucent images, and antialiased text rendering.
16075N/A
18850N/A
18850N/A%package devel
10139N/ASummary: Vector graphics library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
19142N/ACairo is a vector graphics library with cross-device output
10139N/Asupport. Currently supported output targets include the X Window
10139N/ASystem and in-memory image buffers. Cairo is designed to produce
10139N/Aidentical output on all output media while taking advantage of
10139N/Adisplay hardware acceleration when available (eg. through the
10139N/AX Render Extension).
19142N/A
16401N/ACairo provides a stateful user-level API with capabilities similar to
10139N/Athe PDF 1.4 imaging model. Cairo provides operations including
19941N/Astroking and filling Bezier cubic splines, transforming and
19941N/Acompositing translucent images, and antialiased text rendering.
19931N/A
19941N/A%prep
19931N/A%setup -q
19931N/A%patch1 -p1
19931N/A##%patch2 -p1
19931N/A%patch3 -p1
19931N/A%patch4 -p1
19931N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
19126N/Acd ..
10139N/Acp -rp %{name}-%{version} %{name}-%{version}-64
19126N/A%endif
10139N/A%endif
19142N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
11314N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
11314N/A%endif
11314N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
11314N/A CPUS=1
11314N/Afi
11314N/A
11314N/A%ifos solaris
11314N/A%ifarch amd64 sparcv9
11314N/ACPUS=$(($CPUS*4))
10139N/A
10139N/Acd ../%name-%version-64
10139N/A
10139N/Aexport CFLAGS="$CFLAGS64"
11314N/Aexport RPM_OPT_FLAGS="$CFLAGS"
11314N/Aexport LDFLAGS="$LDFLAGS64"
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
10139N/A# pwd was added so the fake freetype-config created in SUNWgnome-base-libs.spec
11314N/A# is picked up instead of the one in /usr/sfw/bin which adds the wrong
11314N/A# -L and -R flags
10139N/Aexport PATH=`pwd`:$PATH
10139N/A
11314N/Agtkdocize
11314N/Aautoheader
19931N/Aautomake -a -c -f
19931N/Aautoconf
19941N/ACFLAGS="$RPM_OPT_FLAGS" \
20071N/A ./configure \
20071N/A --prefix=%{_prefix} \
19941N/A --libdir=%{_libdir}/%{_arch64} \
19941N/A --disable-gtk-doc
19931N/A
11314N/Amake -j $CPUS
11314N/A
11314N/Acd ../%name-%version
11314N/A
11314N/Aexport CFLAGS="$CFLAGS32"
11314N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/Aexport LDFLAGS="$LDFLAGS32"
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
10139N/A%endif
10139N/A%endif
10139N/A
10139N/Agtkdocize
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A ./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
18645N/A%install
18645N/A%ifos solaris
18645N/A%ifarch amd64 sparcv9
19941N/Acd ../%name-%version-64
19941N/Amake install DESTDIR=$RPM_BUILD_ROOT
19941N/Arm $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/*.a
19941N/Arm $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/*.la
19941N/Acd ../%name-%version
19931N/A%endif
19931N/A%endif
10139N/A
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%clean
14239N/Arm -rf $RPM_BUILD_ROOT
14239N/A
14410N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/*.so.*
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%doc AUTHORS ChangeLog COPYING NEWS README TODO
10139N/A%{_includedir}/*
10139N/A%{_libdir}/*.so
10139N/A%{_datadir}/gtk-doc/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A
13321N/A%changelog
10139N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10139N/A- Removed adding ccdir to PATH
10139N/A* Wed Mar 14 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.4.0. Remove upstream patch, 04-endian-search. Renumber remainder.
18624N/A* Fri Feb 16 2007 - brian.cameron@sun.com
18645N/A- Add mediaLib patch and autoheader call needed for this patch.
18624N/A* Thu Dec 14 2006 - damien.carbery@sun.com
18652N/A- Correct url for unstable builds: s/releases/snapshots/.
18645N/A* Tue Dec 12 2006 - damien.carbery@sun.com
18652N/A- Readd a patch to fix bug 9124 (called 04-endian-search this time).
18645N/A* Mon Dec 11 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.3.6. Remove upstream patch 04-float-word.
10139N/A* Fri Dec 08 2006 - brian.cameron@sun.com
10139N/A- Add patch description for 8-bit patch since I noticed the bugzilla bug.
10139N/A* Fri Nov 24 2006 - damien.carbery@sun.com
20182N/A- Bump to 1.3.2. Add patch 04-float-word to fix configure issue. Fixes #9124.
19952N/A* Fri Nov 3 2006 - laca@sun.com
19952N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Mon Oct 16 2006 brian.cameron@sun.com
10139N/A- Enable gtk-docs. This required adding gtkdocize and automake
10139N/A before calling configure
10139N/A* Mon Aug 28 2006 harry.lu@sun.com
10139N/A- Bumped to 1.2.4.
10139N/A* Fri Aug 11 2006 damien.carbery@sun.com
10139N/A- Remove upstream patch, 02-buggyx. Renumber others.
10139N/A* Fri Aug 11 2006 damien.carbery@sun.com
10139N/A- Bumped to 1.2.2.
10139N/A* Thu Jul 20 2006 damien.carbery@sun.com
10139N/A- Bumped to 1.2.0.
10139N/A* Wed Jun 14 2006 yandong.yao@sun.com
10139N/A- Fix bug 6434250: cairo will crash when access 0x0 bitmap image glyph
10139N/A Add patch cairo-04-g11n-0x0glyph-fix.diff
10139N/A* Wed Oct 26 2005 damien.carbery@sun.com
10139N/A- Bumped to 1.0.2.
10139N/A* Tue Oct 25 2005 brian.cameron@sun.com
10139N/A- Add patch 2 to workaround the buggy Xserver shipped with
10139N/A Solaris 10. This fixes the problem that the background
10139N/A would not get repainted when you would move an icon, view
10139N/A the root menu, etc. The same workaround is used in the
10139N/A code to resolve this problem on other platforms using an
10139N/A Xorg server older than 2.8.2 (we use 2.8.0 on Solaris 10).
10139N/A* Tue Sep 13 2005 brian.cameron@sun.com
10139N/A- Bumped to 1.0.0
10139N/A* Fri Aug 26 2005 laca@sun.com
10139N/A- add 64-bit bits
19941N/A* Tue Aug 16 2005 laca@sun.com
19931N/A- add some missing dependencies
19942N/A* Mon Aug 15 2005 glynn.foster@sun.com
20182N/A- Bump to 0.9.2
19942N/A* Mon Feb 28 2004 brian.cameron@sun.com
19931N/A- Add patch 01 so that we can build libsvg and libsvg-cairo.
19942N/A* Tue Feb 22 2004 brian.cameron@sun.com
20071N/A- created
20071N/A