cairo.spec revision 10139
10710N/A#
10710N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10710N/A# This file and all modifications and additions to the pristine
10710N/A# package are under the same license as the package itself.
10710N/A#
10710N/A# Owner: erwannc
10710N/A# bugdb: bugzilla.freedesktop.org
10710N/A#
10843N/AName: cairo
10843N/ALicense: LGPL
10710N/AGroup: System/Libraries
10710N/AVersion: 1.3.6
10710N/ARelease: 5
10881N/ADistribution: Java Desktop System
10710N/AVendor: Sun Microsystems, Inc.
10710N/ASummary: Vector graphics library
10710N/ASource: http://cairographics.org/snapshots/%{name}-%{version}.tar.gz
10710N/A#owner:erwannc date:2000-00-00 type:feature bugzilla:6997
10710N/APatch1: cairo-01-uninstalled-pc.diff
10710N/A#owner:erwannc date:2006-06-09 type:bug bugzilla:4945
10710N/APatch2: cairo-02-8bit-fix.diff
10710N/A#owner:erwannc date:2006-11-02 type:feature
10710N/APatch3: cairo-03-full-hinting.diff
10881N/A#owner:dcarbery date:2006-12-12 type:bug bugzilla:9124
10710N/APatch4: cairo-04-endian-search.diff
10881N/A#owner:yippi date:2007-02-14 type:feature
10710N/APatch5: cairo-05-mediaLib.diff
10881N/AURL: http://www.cairographics.org
10710N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10881N/ADocdir: %{_defaultdocdir}
10710N/AAutoreqprov: on
10881N/APrereq: /sbin/ldconfig
10710N/ARequires: freetype2
10710N/ABuildRequires:freetype2-devel
10710N/ARequires: fontconfig
10710N/ABuildRequires:fontconfig-devel
10710N/A
10710N/A%description
10710N/ACairo is a vector graphics library with cross-device output
10710N/Asupport. Currently supported output targets include the X Window
10710N/ASystem and in-memory image buffers. Cairo is designed to produce
10710N/Aidentical output on all output media while taking advantage of
10710N/Adisplay hardware acceleration when available (eg. through the
10710N/AX Render Extension).
10710N/A
10710N/ACairo provides a stateful user-level API with capabilities similar to
10710N/Athe PDF 1.4 imaging model. Cairo provides operations including
10710N/Astroking and filling Bezier cubic splines, transforming and
10710N/Acompositing translucent images, and antialiased text rendering.
10710N/A
10710N/A
10710N/A%package devel
10710N/ASummary: Vector graphics library
10710N/AGroup: Development/Libraries
10710N/ARequires: %{name} = %{version}
10710N/A
10710N/A%description devel
10710N/ACairo is a vector graphics library with cross-device output
10710N/Asupport. Currently supported output targets include the X Window
10710N/ASystem and in-memory image buffers. Cairo is designed to produce
10710N/Aidentical output on all output media while taking advantage of
10710N/Adisplay hardware acceleration when available (eg. through the
10710N/AX Render Extension).
10710N/A
10710N/ACairo provides a stateful user-level API with capabilities similar to
10710N/Athe PDF 1.4 imaging model. Cairo provides operations including
10710N/Astroking and filling Bezier cubic splines, transforming and
10710N/Acompositing translucent images, and antialiased text rendering.
10710N/A
10710N/A%prep
10710N/A%setup -q
10710N/A%patch1 -p1
10710N/A##%patch2 -p1
10710N/A%patch3 -p1
10710N/A%patch4 -p1
10710N/A%patch5 -p1
10710N/A
10710N/A%ifos solaris
10710N/A%ifarch amd64 sparcv9
10710N/Acd ..
10710N/Acp -rp %{name}-%{version} %{name}-%{version}-64
10710N/A%endif
10710N/A%endif
10710N/A
10710N/A%build
10710N/A%ifos linux
10710N/Aif [ -x /usr/bin/getconf ]; then
10710N/A CPUS=`getconf _NPROCESSORS_ONLN`
10710N/Afi
10710N/A%else
10710N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10710N/A%endif
10710N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10710N/A CPUS=1
10710N/Afi
10710N/A
10710N/A%ifos solaris
10710N/A%ifarch amd64 sparcv9
10710N/ACPUS=$(($CPUS*4))
10710N/A
10710N/Acd ../%name-%version-64
10710N/A
10710N/Aexport CFLAGS="$CFLAGS64"
10710N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10710N/Aexport LDFLAGS="$LDFLAGS64"
10710N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
10710N/Aexport CC=${CC64:-$CC}
10710N/Asave_PATH="$PATH"
10710N/Accdir=`dirname $CC`
10710N/A# pwd was added so the fake freetype-config created in SUNWgnome-base-libs.spec
10710N/A# is picked up instead of the one in /usr/sfw/bin which adds the wrong
10710N/A# -L and -R flags
10710N/Aexport PATH=`pwd`:$ccdir:$PATH
10710N/A
10710N/Agtkdocize
10710N/Aautoheader
10881N/Aautomake -a -c -f
10881N/Aautoconf
10881N/ACFLAGS="$RPM_OPT_FLAGS" \
10881N/A ./configure \
10881N/A --prefix=%{_prefix} \
10710N/A --libdir=%{_libdir}/%{_arch64} \
10710N/A --disable-gtk-doc
10710N/A
10710N/Amake -j $CPUS
10710N/A
10710N/Acd ../%name-%version
10710N/A
10710N/Aexport CFLAGS="$CFLAGS32"
10710N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10710N/Aexport LDFLAGS="$LDFLAGS32"
10710N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
10710N/Aexport CC=${CC32:-$CC}
10710N/Aexport PATH="$save_PATH"
10710N/A%endif
10710N/A%endif
10710N/A
10710N/Agtkdocize
10710N/Aautoheader
10710N/Aautomake -a -c -f
10710N/Aautoconf
10710N/ACFLAGS="$RPM_OPT_FLAGS" \
10710N/A ./configure \
10710N/A --prefix=%{_prefix} \
10710N/A --libdir=%{_libdir} \
10710N/A %{gtk_doc_option}
10710N/A
10761N/Amake -j $CPUS
10761N/A
10761N/A%install
10761N/A%ifos solaris
10710N/A%ifarch amd64 sparcv9
10710N/Acd ../%name-%version-64
10710N/Amake install DESTDIR=$RPM_BUILD_ROOT
10710N/Arm $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/*.a
10710N/Arm $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/*.la
10710N/Acd ../%name-%version
10710N/A%endif
10710N/A%endif
10710N/A
10710N/Amake install DESTDIR=$RPM_BUILD_ROOT
10710N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10710N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10710N/A
10710N/A%clean
10710N/Arm -rf $RPM_BUILD_ROOT
10710N/A
10710N/A%post
10710N/A/sbin/ldconfig
10710N/A
10710N/A%postun
10710N/A/sbin/ldconfig
10710N/A
10710N/A%files
10710N/A%defattr(-,root,root)
10710N/A%{_libdir}/*.so.*
10710N/A
10710N/A%files devel
10710N/A%defattr(-,root,root)
10710N/A%doc AUTHORS ChangeLog COPYING NEWS README TODO
10710N/A%{_includedir}/*
10710N/A%{_libdir}/*.so
10710N/A%{_datadir}/gtk-doc/*
10710N/A%{_libdir}/pkgconfig/*
10710N/A
10710N/A%changelog
10710N/A* Fri Feb 16 2007 - brian.cameron@sun.com
10710N/A- Add mediaLib patch and autoheader call needed for this patch.
10710N/A* Thu Dec 14 2006 - damien.carbery@sun.com
10710N/A- Correct url for unstable builds: s/releases/snapshots/.
10710N/A* Tue Dec 12 2006 - damien.carbery@sun.com
10710N/A- Readd a patch to fix bug 9124 (called 04-endian-search this time).
10710N/A* Mon Dec 11 2006 - damien.carbery@sun.com
10710N/A- Bump to 1.3.6. Remove upstream patch 04-float-word.
10710N/A* Fri Dec 08 2006 - brian.cameron@sun.com
10710N/A- Add patch description for 8-bit patch since I noticed the bugzilla bug.
10710N/A* Fri Nov 24 2006 - damien.carbery@sun.com
10710N/A- Bump to 1.3.2. Add patch 04-float-word to fix configure issue. Fixes #9124.
10710N/A* Fri Nov 3 2006 - laca@sun.com
10710N/A- use %gtk_doc_option in configure so that it can be disabled using
10710N/A --without-gtk-doc
10710N/A* Mon Oct 16 2006 brian.cameron@sun.com
10710N/A- Enable gtk-docs. This required adding gtkdocize and automake
10710N/A before calling configure
10710N/A* Mon Aug 28 2006 harry.lu@sun.com
10710N/A- Bumped to 1.2.4.
10710N/A* Fri Aug 11 2006 damien.carbery@sun.com
10710N/A- Remove upstream patch, 02-buggyx. Renumber others.
10710N/A* Fri Aug 11 2006 damien.carbery@sun.com
10710N/A- Bumped to 1.2.2.
10710N/A* Thu Jul 20 2006 damien.carbery@sun.com
10710N/A- Bumped to 1.2.0.
10710N/A* Wed Jun 14 2006 yandong.yao@sun.com
10710N/A- Fix bug 6434250: cairo will crash when access 0x0 bitmap image glyph
10710N/A Add patch cairo-04-g11n-0x0glyph-fix.diff
10710N/A* Wed Oct 26 2005 damien.carbery@sun.com
10710N/A- Bumped to 1.0.2.
10710N/A* Tue Oct 25 2005 brian.cameron@sun.com
10710N/A- Add patch 2 to workaround the buggy Xserver shipped with
10710N/A Solaris 10. This fixes the problem that the background
10710N/A would not get repainted when you would move an icon, view
10710N/A the root menu, etc. The same workaround is used in the
10710N/A code to resolve this problem on other platforms using an
10710N/A Xorg server older than 2.8.2 (we use 2.8.0 on Solaris 10).
10710N/A* Tue Sep 13 2005 brian.cameron@sun.com
10710N/A- Bumped to 1.0.0
10710N/A* Fri Aug 26 2005 laca@sun.com
10710N/A- add 64-bit bits
10710N/A* Tue Aug 16 2005 laca@sun.com
10710N/A- add some missing dependencies
10710N/A* Mon Aug 15 2005 glynn.foster@sun.com
10710N/A- Bump to 0.9.2
10710N/A* Mon Feb 28 2004 brian.cameron@sun.com
10710N/A- Add patch 01 so that we can build libsvg and libsvg-cairo.
10710N/A* Tue Feb 22 2004 brian.cameron@sun.com
10710N/A- created
10710N/A