20778N/A#
20778N/A# spec file for package cairo
10139N/A#
20903N/A# Copyright (c) 2004, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner erwannc
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
17176N/A
17176N/A%define OSR 4091:1.0.2
17176N/A
10139N/AName: cairo
19112N/ALicense: LGPL v2.1, MPL 1.1
10139N/AGroup: System/Libraries
20903N/AVersion: 1.12.2
11991N/ARelease: 1
10139N/ADistribution: Java Desktop System
18615N/AVendor: freedesktop.org
10139N/ASummary: Vector graphics library
20903N/ASource: http://cairographics.org/releases/%{name}-%{version}.tar.xz
10139N/A#owner:erwannc date:2006-11-02 type:feature
20778N/APatch1: cairo-01-full-hinting.diff
20903N/A# TODO: Some tests require spectre. We need to split spectre from the
20903N/A# SUNWgnome-pdf-viewer package to build cairo with it. For now
20903N/A# patch the code to just not build these tests.
20903N/A#owner:yippi date:2012-04-30 type:bug
20903N/APatch2: cairo-02-solaris.diff
10139N/AURL: http://www.cairographics.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/ARequires: freetype2
10139N/ABuildRequires:freetype2-devel
10139N/ARequires: fontconfig
10139N/ABuildRequires:fontconfig-devel
15377N/ARequires: SUNWpixman
10139N/A
17065N/A
10139N/A%description
10139N/ACairo is a vector graphics library with cross-device output
10139N/Asupport. Currently supported output targets include the X Window
10139N/ASystem and in-memory image buffers. Cairo is designed to produce
10139N/Aidentical output on all output media while taking advantage of
10139N/Adisplay hardware acceleration when available (eg. through the
10139N/AX Render Extension).
10139N/A
10139N/ACairo provides a stateful user-level API with capabilities similar to
10139N/Athe PDF 1.4 imaging model. Cairo provides operations including
10139N/Astroking and filling Bezier cubic splines, transforming and
10139N/Acompositing translucent images, and antialiased text rendering.
10139N/A
10139N/A
10139N/A%package devel
10139N/ASummary: Vector graphics library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/ACairo is a vector graphics library with cross-device output
10139N/Asupport. Currently supported output targets include the X Window
10139N/ASystem and in-memory image buffers. Cairo is designed to produce
10139N/Aidentical output on all output media while taking advantage of
10139N/Adisplay hardware acceleration when available (eg. through the
10139N/AX Render Extension).
10139N/A
10139N/ACairo provides a stateful user-level API with capabilities similar to
10139N/Athe PDF 1.4 imaging model. Cairo provides operations including
10139N/Astroking and filling Bezier cubic splines, transforming and
10139N/Acompositing translucent images, and antialiased text rendering.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
20903N/A%patch2 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10307N/Aexport PATH=`pwd`:$PATH
10139N/A
20903N/Aaclocal-1.11 $ACLOCAL_FLAGS -I build
10139N/Agtkdocize
10139N/Aautoheader
20903N/Aautomake-1.11 -a -c -f
10139N/Aautoconf
15513N/A%if %option_with_debug
15513N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS"
15513N/A%else
15513N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DNDEBUG"
15513N/A%endif
15513N/A
10318N/Aexport LDFLAGS="%_ldflags"
10318N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
10318N/A --bindir=%{_bindir} \
10139N/A %{gtk_doc_option}
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
20778N/Aexport PATH=`pwd`:$PATH
20778N/Aexport CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DNDEBUG"
20778N/Aexport LDFLAGS="%_ldflags"
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
20778N/A
20778N/Afind $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm {} \;
20778N/Afind $RPM_BUILD_ROOT%{_libdir} -name "*.a" -exec rm {} \;
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/*.so.*
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%doc AUTHORS ChangeLog COPYING NEWS README TODO
10139N/A%{_includedir}/*
10139N/A%{_libdir}/*.so
10139N/A%{_datadir}/gtk-doc/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A
10139N/A%changelog
20903N/A* Mon Ap4 30 2012 - brian.cameron@oracle.com
20903N/A- Bump to 1.12.2.
20778N/A* Tue Jul 05 2011 - brian.cameron@oracle.com
20778N/A- Bump to 1.10.2.
19040N/A* Thu Oct 21 2010 - ginn.chen@oracle.com
19040N/A- Remove cairo-03-buggy-repeat.diff to fix d.o.o. 17230.
18383N/A* Thu Mar 04 2010 - ginn.chen@sun.com
18383N/A- Bump to 1.8.10.
17097N/A* Tue Aug 25 2009 - christian.kelly@sun.com
17097N/A- Remove %include Solaris.inc, as it breaks the build.
16871N/A* Sun Jul 26 2009 - christian.kelly@sun.com
16871N/A- Bump to 1.8.8.
15970N/A* Web Feb 25 2009 - chris.wang@sun.com
15970N/A- bump to version 1.8.6
15970N/A* Thu Feb 12 2009 - jedy.wang@sun.com
15821N/A- Fix broken download link.
15513N/A* Fri Dec 12 2008 - chris.wang@sun.com
20778N/A- Add NDEBUG macro in CFLAGS.
15494N/A* Wed Dec 10 2008 - dave.lin@sun.com
15494N/A- Removed upstreamed patch -uninstalled-pc.diff.
15477N/A* Mon Dec 08 2008 - dave.lin@sun.com
15477N/A- Bump to 1.8.4.
15377N/A* Tue Nov 18 2008 - darren.kenny@sun.com
15377N/A- Remove unneeded patch cairo-03-no-pixman-dep.diff, since we pixman should
15377N/A now be on the system (delivered by X). Renumber remaining patches.
15377N/A- Add Requires statement for SUNWpixman.
13857N/A* Wed Aug 13 2008 - damien.carbery@sun.com
13857N/A- Reenable patch2 (02-full-hinting) because the build machine is on snv_92 or
13857N/A greater.
13847N/A* Tue Aug 12 2008 - damien.carbery@sun.com
13847N/A- Bump to 1.7.4.
13547N/A* Fri Jul 11 2008 - damien.carbery@sun.com
13547N/A- Disable 02-full-hinting patch as build machines use snv_91. freetype fix is
13547N/A in snv_92.
13531N/A* Thu Jul 10 2008 - erwann.chenede@sun.com
13531N/A- re-enabled cairo-02-full-hinting.diff patch as freetype is fixed now.
13394N/A* Thu Jun 12 2008 - damien.carbery@sun.com
13394N/A- Comment out patch2 because of change to Freetype in snv_91 breaks build.
12911N/A* Sun Apr 20 2008 - damien.carbery@sun.com
12911N/A- Add -D_POSIX_PTHREAD_SEMANTICS to CFLAGS to fix sparc build (ctime_r error).
12905N/A* Fri Apr 18 2008 - darren.kenny@sun.com
12905N/A- Temporarily remove depenency on pixman in pkg-config file since it's
12905N/A directly linked into libcairo until pixman is delivered by X.
12246N/A* Tue Jan 22 2008 - damien.carbery@sun.com
12246N/A- Revert to 1.4.14 as 1.5.6 requires pixman and this will be delivered by X
12246N/A Server group in the future. Remove obsolete patch 05-ctime_r: only an issue in
12246N/A 1.5.6.
12223N/A* Thu Jan 17 2008 - patrick.ale@gmail.com
12223N/A- Someone bumped up to snapshot 1.5.6.
20778N/A- Changed URL to fetch from snapshot dir rather than releases .
12199N/A* Tue Jan 15 2008 - damien.carbery@sun.com
12199N/A- Bump to 1.4.14.
11991N/A* Tue Nov 27 2007 - brian.cameron@sun.com
20778N/A- Bump to 1.4.12.
11006N/A* Fri Aug 3 2007 - chris.wang@sun.com
11006N/A- merge patch cairo-02-8bit-fix.diff and cairo-05-null-struct-pointer.diff, and
11006N/A remove cairo-05-null-struct-pointer.diff from repository. revised patch
11006N/A cairo-02-8bit-fix.diff, added code to support 8bit Truecolor. This fixed bug
11006N/A 6555333, xscreensaver-demo crash when display set to 8 bit.
10948N/A* Mon Jul 23 2007 - chris.wang@sun.com
10948N/A- add patch cairo-05-null-struct-pointer.diff which fixed the bug nautilus
20778N/A crash when D&D files.
10896N/A* Tue Jul 03 2007 - damien.carbery@sun.com
10896N/A- Bump to 1.4.10.
10588N/A* Wed May 9 2007 - elaine.xiong@sun.com
10588N/A- Removed obsolete buggy_repeat path for Xsun.
10562N/A* Wed May 2 2007 - brian.cameron@sun.com
10562N/A- Bump to 1.4.6.
10392N/A* Sun Apr 1 2007 - laca@sun.com
20778N/A- add missing aclocal calls.
10318N/A* Thu Mar 15 2007 - laca@sun.com
10318N/A- convert to new style of building multiple ISAs as per docs/multi-ISA.txt
10307N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10308N/A- Changed source URL from snapshots to releases for 1.4.0
10308N/A* Wed Mar 15 2007 - dougs@truemail.co.th
10307N/A- Removed adding ccdir to PATH
10293N/A* Wed Mar 14 2007 - damien.carbery@sun.com
10293N/A- Bump to 1.4.0. Remove upstream patch, 04-endian-search. Renumber remainder.
10139N/A* Fri Feb 16 2007 - brian.cameron@sun.com
10139N/A- Add mediaLib patch and autoheader call needed for this patch.
10139N/A* Thu Dec 14 2006 - damien.carbery@sun.com
10139N/A- Correct url for unstable builds: s/releases/snapshots/.
10139N/A* Tue Dec 12 2006 - damien.carbery@sun.com
10139N/A- Readd a patch to fix bug 9124 (called 04-endian-search this time).
10139N/A* Mon Dec 11 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.3.6. Remove upstream patch 04-float-word.
10139N/A* Fri Dec 08 2006 - brian.cameron@sun.com
10139N/A- Add patch description for 8-bit patch since I noticed the bugzilla bug.
10139N/A* Fri Nov 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.3.2. Add patch 04-float-word to fix configure issue. Fixes #9124.
10139N/A* Fri Nov 3 2006 - laca@sun.com
10139N/A- use %gtk_doc_option in configure so that it can be disabled using
10139N/A --without-gtk-doc
10139N/A* Mon Oct 16 2006 brian.cameron@sun.com
10139N/A- Enable gtk-docs. This required adding gtkdocize and automake
10139N/A before calling configure
10139N/A* Mon Aug 28 2006 harry.lu@sun.com
10139N/A- Bumped to 1.2.4.
10139N/A* Fri Aug 11 2006 damien.carbery@sun.com
10139N/A- Remove upstream patch, 02-buggyx. Renumber others.
10139N/A* Fri Aug 11 2006 damien.carbery@sun.com
10139N/A- Bumped to 1.2.2.
10139N/A* Thu Jul 20 2006 damien.carbery@sun.com
10139N/A- Bumped to 1.2.0.
10139N/A* Wed Jun 14 2006 yandong.yao@sun.com
10139N/A- Fix bug 6434250: cairo will crash when access 0x0 bitmap image glyph
10139N/A Add patch cairo-04-g11n-0x0glyph-fix.diff
10139N/A* Wed Oct 26 2005 damien.carbery@sun.com
10139N/A- Bumped to 1.0.2.
10139N/A* Tue Oct 25 2005 brian.cameron@sun.com
10139N/A- Add patch 2 to workaround the buggy Xserver shipped with
10139N/A Solaris 10. This fixes the problem that the background
10139N/A would not get repainted when you would move an icon, view
10139N/A the root menu, etc. The same workaround is used in the
10139N/A code to resolve this problem on other platforms using an
10139N/A Xorg server older than 2.8.2 (we use 2.8.0 on Solaris 10).
10139N/A* Tue Sep 13 2005 brian.cameron@sun.com
20778N/A- Bumped to 1.0.0.
10139N/A* Fri Aug 26 2005 laca@sun.com
20778N/A- add 64-bit bits.
10139N/A* Tue Aug 16 2005 laca@sun.com
20778N/A- add some missing dependencies.
10139N/A* Mon Aug 15 2005 glynn.foster@sun.com
10139N/A- Bump to 0.9.2
10139N/A* Mon Feb 28 2004 brian.cameron@sun.com
10139N/A- Add patch 01 so that we can build libsvg and libsvg-cairo.
10139N/A* Tue Feb 22 2004 brian.cameron@sun.com
20778N/A- Created.
20778N/A