bug-buddy.spec revision 11187
10139N/A#
10139N/A# spec file for package bug-buddy
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: mattman
10139N/A#
10139N/AName: bug-buddy
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
11131N/AVersion: 2.19.91
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: GNOME Bug Reporting Tool
11129N/ASource: http://ftp.gnome.org/pub/GNOME/sources/bug-buddy/2.19/bug-buddy-%{version}.tar.bz2
11187N/A# date:2004-11-08 type:feature owner:mattman bugster:5102045 bugzilla:473559
10139N/APatch1: bug-buddy-01-use-pstack.diff
11187N/A# date:2007-08-28 type:bug owner:mattman bugzilla:473561
11159N/APatch2: bug-buddy-02-enable-breakpad.diff
10139N/AURL: http://www.gnome.org/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_docdir}/bug-buddy
10139N/AAutoreqprov: on
10139N/A
10139N/A%define libgnomeui_version 2.6.0
10139N/A%define scrollkeeper_version 0.3.14
10139N/A%define gnome_desktop_version 2.6.1
10139N/A%define gnome_doc_utils_version 0.2.0
10139N/A
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: gnome-desktop >= %{gnome_desktop_version}
10139N/ABuildRequires: scrollkeeper >= %{scrollkeeper_version}
10139N/ABuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/APrereq: GConf
10139N/A
10139N/A%description
10139N/ABug Buddy for the GNOME 2.6 Desktop has been ported from the GNOME 1.x releases. Its purpose is to make bug-reporting for end-users as easy as possible. It can generate backtraces of crashes and include the information with the bugreport.
10139N/A
10139N/A%prep
10139N/A%setup -q
11129N/A%patch1 -p1
11129N/A%patch2 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aglib-gettextize --copy --force
10139N/Aintltoolize --force --copy
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoconf
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/A
10139N/A# FIXME: Disable scrollkeeper for now
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --disable-scrollkeeper
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/A
10139N/Arm $RPM_BUILD_ROOT%{_datadir}/applications/bug-buddy*.desktop
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="bug-buddy.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%files
10139N/A%doc AUTHORS COPYING ChangeLog NEWS README
10139N/A%defattr (-, root, root)
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/bug-buddy/bug-buddy.*
10139N/A%{_datadir}/bug-buddy/gdb-cmd
10139N/A%{_datadir}/bug-buddy/gnome.png
10139N/A%{_datadir}/bug-buddy/bugzilla/*
10139N/A%{_datadir}/gnome/help/bug-buddy/*
10139N/A%{_datadir}/mime-info/*
10139N/A%{_bindir}/bug-buddy
10139N/A%{_datadir}/omf/bug-buddy/*.omf
10139N/A%{_datadir}/pixmaps/*.png
10139N/A%{_datadir}/man/man1/bug-buddy.1.gz
10139N/A%{_sysconfdir}/gconf/schemas/bug-buddy.schemas
10139N/A%{_datadir}/application-registry/*.applications
11131N/A%{_libdir}/gtk-2.0/modules/*
10139N/A
10139N/A
10139N/A%changelog
11159N/A* Fri Aug 31 2007 - matt.keenan@sun.com
11159N/A- Rename patch 02 from disable to enable
11129N/A* Tue Aug 28 2007 - matt.keenan@sun.com
11131N/A- Bump to 2.19.91
11131N/A* Tue Aug 28 2007 - matt.keenan@sun.com
11129N/A- Bump back to 2.19.0
11129N/A- Rework bug-buddy-01-use-pstack.diff
11129N/A- Add new patch bug-buddy-02-disable-breakpad.diff so that it compiles
11051N/A* Thu Aug 14 2007 - damien.carbery@sun.com
11051N/A- Unbump to 2.18.1 to get module to build.
11036N/A* Thu Aug 09 2007 - damien.carbery@sun.com
11036N/A- Add patch, 02-solaris-int, to fix some Solaris specific issues.
11036N/A* Tue Jul 31 2007 - damien.carbery@sun.com
10981N/A- Bump to 2.19.0.
10477N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10477N/A- Bump to 2.18.1.
10477N/A* Tue Mar 13 2007 - damien.carbery@sun.com
10285N/A- Bump to 2.18.0.
10477N/A* Tue Mar 06 2007 - damien.carbery@sun.com
10207N/A- Bump to 2.17.4. Remove deletion of ximian.png as the file is not installed.
10139N/A* Mon Dec 18 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.3.
10139N/A* Tue Dec 05 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.2.
10139N/A* Tue Sep 05 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.0.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.90.
10139N/A* Fri Jul 21 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.0.
10139N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.0.
10139N/A* Tue Feb 28 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.90.
10139N/A* Tue Jan 17 2006 - glynn.foster@sun.com
10139N/A- Bump 2.13.0
10139N/A* Tue Nov 29 2005 - laca@sun.com
10139N/A- remove javahelp stuff
10139N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.1
10139N/A* Sat Sep 17 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.12.0
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.92.
10139N/A* Mon Aug 15 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.01.
10139N/A* Fri Aug 05 2005 - glynn.foster@sun.com
10139N/A- Remove the bug reporting branding patch for the moment - we don't even
10139N/A ship bug buddy with Solaris, but now with opensolaris.org we should point
10139N/A to upstream.
10139N/A* Fri May 20 2005 - glynn.foster@sun.com
10139N/A- Update to 2.10.0
10139N/A* Thu Mar 31 2005 - damien.carbery@sun.com
10139N/A- Updated docs tarball (bug-buddy-docs-0.6linux) from maeve.anslow@sun.com.
10139N/A* Wed Feb 09 2005 - damien.carbery@sun.com
10139N/A- Integrated updated Linux specific docs tarball from maeve.anslow@sun.com.
10139N/A Added %ifos to accomodate this.
10139N/A* Thu Jan 27 2005 - kazuhiko.maekawa@sun.com
10139N/A- Put l10n help tarball for Cinnabar-linux
10139N/A* Tue Jan 25 2005 - glynn.foster@sun.com
10139N/A- Bring back bug-buddy into the Linux build, removing and merging
10139N/A some patches.
10139N/A* Mon Nov 08 2004 - leena.gunda@wipro.com
10139N/A- Added bug-buddy-05-use-pstack.diff to use pstack to get the stack
10139N/A trace on Solaris as gdb is not available. Fixes bug #5102045.
10139N/A* Wed Aug 25 2004 - Kazuhiko.Maekawa@sun.com
10139N/A- Added l10n help contents with patch
10139N/A* Fri Aug 20 2004 - damien.carbery@sun.com
10139N/A- Integrated updated docs tarball from breda.mccolgan@sun.com.
10139N/A* Thu Aug 05 2004 - damien.carbery@sun.com
10139N/A- Integrated docs tarball from breda.mccolgan@sun.com
10139N/A- Added patch to compensate for Makefiles removed from new tarball.
10139N/A* Wed Jul 21 2004 - damien.carbery@sun.com
10139N/A- Add patch to remove --export-dynamic which breaks Solaris build.
10139N/A- Add $ACLOCAL_FLAGS to build on Solaris.
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to bug-buddy-l10n-po-1.2.tar.bz2
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to bug-buddy-l10n-po-1.1.tar.bz2
10139N/A* Fri May 07 2004 - matt.keenan@sun.com
10139N/A- Bump to 2.6.1
10139N/A* Sun Apr 18 2004 - laca@sun.com
10139N/A- enable javahelp conversion on Solaris
10139N/A* Thu Apr 01 2004 - matt.keenan@sun.com
10139N/A- javahelp conversion
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to bug-buddy-l10n-po-1.0.tar.bz2
10139N/A* Wed Mar 24 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.6.0
10139N/A* Tue Mar 16 2004 - glynn.foster@sun.com
10139N/A- Bump to 2.5.92. Remove localized online help since it's upstream
10139N/A in the tarball. Remove help button since we're working from head
10139N/A and we'll get it with the next iteration. Remove random branding
10139N/A in the user interface, just increases more time spent doing pointless
10139N/A localizations. Remove the ximian branding patch, since it needs to be
10139N/A redone, and we shouldn't do the sendmail edits in that patch.
10139N/A* Tue Mar 16 2004 - glynn.foster@sun.com
10139N/A- Removed man, menu patches since we're doing this in spec file now.
10139N/A Merged potfile patches and reorder the rest.
10139N/A* Thu Mar 11 2004 - yuriy.kuznetsov@sun.com
10139N/A- added bug-buddy-09-g11n-potfiles.diff
10139N/A* Wed Mar 03 2004 - balamurali.viswanathan@wipro.com
10139N/A- Added patch bug-buddy-08-enable-help.diff to provide help.
10139N/A* Mon Feb 23 2004 - matt.keenan@sun.com
10139N/A- Bump to 2.5.3, update l10n
10139N/A- Re-merge all patches
10139N/A* Wed Dec 17 2003 - glynn.foster@sun.com
10139N/A- Bump to 2.5.1
10139N/A* Thu Nov 13 2003 - glynn.foster@sun.com
10139N/A- Remove menu entry
10139N/A* Fri Oct 10 2003 - niall.power@sun.com
10139N/A- Updated to version 2.4.0
10139N/A* Thu Oct 9 2003 - Laca@sun.com
10139N/A- removed %post, fixed %files list and removed ximian.png.
10139N/A* Wed Sep 17 2003 - matt.keenan@sun.com
10139N/A- Man page change, package tarball version of man page
10139N/A* Tue Aug 19 2003 - Laszlo.Kovacs@sun.com
10139N/A- add bug-buddy-04-remove-ximian-druid-pages.diff
10139N/A* Tue Aug 05 2003 - Laszlo.Kovacs@sun.com
10139N/A- add bug-buddy-03-sensical-check-removed.diff
10139N/A* Tue Aug 05 2003 - glynn.foster@sun.com
10139N/A- Update tarball, bump version, reset release.
10139N/A* Fri Aug 01 2003 - glynn.foster@sun.com
10139N/A- Add menu category thing
10139N/A* Tue May 13 2003 - matt.keenan@sun.com
10139N/A- initial Sun Release