blueprint.spec revision 12132
10791N/A#
10791N/A# spec file for package blueprint
10791N/A#
10791N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10791N/A# This file and all modifications and additions to the pristine
10791N/A# package are under the same license as the package itself.
10791N/A#
10791N/A# Owner: erwannc
10791N/A#
10791N/AName: blueprint
11049N/ASummary: Engine for GTK2 Blue Print Theme
10791N/A# NOTE: If the version is bumped the new tarball must be uploaded to the
10791N/A# Sun Download Center. Contact GNOME RE for assistance.
10791N/A%ifos solaris
10791N/AVersion: 0.9.20
10791N/A%define tarball_version %{version}
11389N/A%else
10791N/AVersion: 0.9.16
10791N/A%define tarball_version %{version}-os
10791N/A%endif
10791N/ARelease: 41
10791N/ALicense: LGPL
10791N/ADistribution: Java Desktop System
10791N/AVendor: Sun Microsystems, Inc.
10791N/AGroup: System/GUI/GNOME
10791N/ASource: http://dlc.sun.com/osol/jds/downloads/extras/%{name}-%{tarball_version}.tar.bz2
10791N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10791N/AURL: http://www.sun.com/software/javadesktopsystem/
10791N/A
10791N/A%define gtk2_version 2.4.0
10791N/A%define intltool_version 0.30
10791N/ABuildRequires: gtk2 >= %{gtk2_version}
10791N/ABuildRequires: intltool >= %{intltool_version}
10791N/A
10791N/A%description
10791N/AThis package contains the Blueprint theme engine for GTK2
10791N/A
10791N/A%prep
10791N/A%setup -q -n %name-%tarball_version
10791N/A
10791N/A%build
10791N/A%ifos linux
11282N/Aif [ -x /usr/bin/getconf ]; then
11282N/A CPUS=`getconf _NPROCESSORS_ONLN`
10791N/Afi
10791N/A%else
10791N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10791N/A%endif
10791N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10791N/A CPUS=1
11049N/Afi
11049N/A
10791N/Alibtoolize --force
10791N/Aintltoolize --force --copy --automake
10791N/Aaclocal $ACLOCAL_FLAGS -I .
10791N/Aautomake -a -c -f
10791N/Aautoconf
10791N/Aexport CFLAGS="%optflags"
10791N/Aexport LDFLAGS="%_ldflags"
10791N/A./configure --prefix=%{_prefix} \
10791N/A --libdir=%{_libdir} \
10791N/A --sysconfdir=%{_sysconfdir}
11049N/Amake -j $CPUS
10791N/Acd -
10791N/A
10791N/A%install
10791N/Amake DESTDIR=$RPM_BUILD_ROOT install
10791N/Amkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine
10791N/Acp -p AUTHORS COPYING ChangeLog NEWS README $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine
10791N/A
10791N/A# Hack to install images into %{_datadir}/pixmaps with blueprint prefix
10791N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
10791N/Amkdir -p /tmp/blueprint-pixmaps
10791N/Ainstallfiles=`find icons/48x48 -name "*.png"`
10791N/Afor i in $installfiles; do
10791N/A echo -- Installing $i to %{_datadir}/pixmaps with blueprint- prefix ;
10791N/A i_base=`basename $i`
10791N/A cp $i $RPM_BUILD_ROOT%{_datadir}/pixmaps/blueprint-${i_base}
10791N/Adone;
10791N/A
10791N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.a
10791N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.la
10791N/A
10791N/A%clean
10791N/Arm -rf $RPM_BUILD_ROOT
10791N/A
10791N/A%files
10791N/A%defattr(-, root, root)
10791N/A%doc AUTHORS COPYING ChangeLog NEWS README
10791N/A%{_defaultdocdir}/blueprint-engine/ChangeLog
10791N/A%{_defaultdocdir}/blueprint-engine/AUTHORS
10791N/A%{_defaultdocdir}/blueprint-engine/COPYING
10791N/A%{_defaultdocdir}/blueprint-engine/README
10791N/A%{_defaultdocdir}/blueprint-engine/NEWS
10791N/A%{_libdir}/gtk-2.0/*/engines/*.so
10791N/A%{_datadir}/themes/*
11282N/A%{_datadir}/icons/*
10791N/A%{_datadir}/locale/*
10791N/A%{_datadir}/pixmaps/*
10791N/A
10791N/A%changelog
10791N/A* Wed Aug 29 2007 - damien.carbery@sun.com
10791N/A- Add intltoolize calls to update intltool scripts.
10791N/A* Fri May 18 2007 - laca@sun.com
10791N/A- set CFLAGS/LDFLAGS and configure options such that we can use this spec
10791N/A file for the 64-bit build too
10791N/A- write a nicer loop for copying icons with blueprint- prefix
10791N/A* Fri Jun 23 2006 - brian.cameron@sun.com
10791N/A- Change "cp -a" to "cp -p" so it works with Solaris cp command.
10791N/A* Thu Feb 10 2005 - muktha.narayan@wipro.com
10791N/A- Bumped the tarball to include icons required to fix
10791N/A #5088581.
10791N/A* Mon Jan 31 2005 - takao.fujiwara@sun.com
10791N/A- Updated %build to stop build error
10791N/A* Fri Jan 28 2005 - muktha.narayan@wipro.com
10791N/A- Bumped the tarball which includes the fix for #5088581 and
10791N/A merged blueprint-01-g11n-icon.diff in the tarball.
10791N/A* Fri Jan 28 2005 - takao.fujiwara@sun.com
10791N/A- Updated %build to add automake
10791N/A* Wed Jan 12 2005 - takao.fujiwara@sun.com
10791N/A- Removed blueprint-01-g11n-alllinguas.diff. Use l10n-configure.sh
10791N/A- Added blueprint-01-g11n-icon.diff to fix 5083114
10791N/A* Thu Sep 16 2004 - ciaran.mcdermott@sun.com
10791N/A- Added blueprint-01-g11n-alllinguas.diff to include cs,hu linguas
10791N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10791N/A- Updated l10n content to blueprint-l10n-po-1.2.tar.bz2
10791N/A* Wed Jul 07 2004 - niall.power@sun.com
10791N/A- ported to rpm4
10791N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10791N/A- added "-j $CPUS" to make to speed up builds
10791N/A* Wed Jun 2 2004 - glynn.foster@sun.com
10791N/A- Bump to 0.9.5
10791N/A* Wed May 12 2004 - damien.donlon@sun.com
10791N/A- Updated l10n content to blueprint-l10n-po-1.1.tar.bz2
10791N/A* Wed Mar 31 2004 - brian.cameron@sun.com
10791N/A- replace tar jxf with the more solaris friendly
10791N/A bzcat piped through tar
10791N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10791N/A- Adding blueprint-l10n-po-1.0.tar.bz2 l10n content
10791N/A* Fri Mar 12 2004 Niall Power <niall.power@sun.com>
10791N/A- remove "rm -rf" evil from the install stage
10791N/A* Mon Feb 16 2004 Niall Power <niall.power@sun.com>
10791N/A- add ACLOCAL_FLAGS to aclocal invocation
10791N/A- do not use the -printf argument with find - it
10791N/A doesn't work on Solaris (pipe through sed instead)
10791N/A* Fri Jan 19 2004 Takao Fujiwara <takao.fujiwara@sun.com>
10791N/A- Modified blueprint.spec for i18n
11269N/A* Thu Aug 14 2003 - <laca@sun.com>
11269N/A- remove *.a, *.la
11269N/A* Wed Jul 02 2003 Erwann Chenede - <erwann.chenede@sun.com>
10791N/A- cleanup + icons theme addition
10791N/A* Mon May 12 2003 Erwann Chenede - <erwann.chenede@sun.com>
10791N/A- initial implementation of the spec file
10791N/A
11269N/A