10139N/A#
10139N/A# spec file for package blueprint
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner erwannc
10139N/A#
17180N/A
18644N/A%define OSR developed in the open, no OSR needed:n/a
17180N/A
10139N/AName: blueprint
10139N/ASummary: Engine for GTK2 Blue Print Theme
12132N/A# NOTE: If the version is bumped the new tarball must be uploaded to the
12132N/A# Sun Download Center. Contact GNOME RE for assistance.
10139N/A%ifos solaris
11041N/AVersion: 0.9.20
10139N/A%define tarball_version %{version}
10139N/A%else
10139N/AVersion: 0.9.16
10139N/A%define tarball_version %{version}-os
10139N/A%endif
10139N/ARelease: 41
19112N/ALicense: LGPL v2
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/AGroup: System/GUI/GNOME
10139N/ASource: http://dlc.sun.com/osol/jds/downloads/extras/%{name}-%{tarball_version}.tar.bz2
16349N/ASource1: l10n-configure.sh
16349N/A#owner:fujiwara date:2009-04-10 type:bug bugster:6675046
16349N/APatch1: blueprint-01-rtl-icons.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/AURL: http://www.sun.com/software/javadesktopsystem/
10139N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define intltool_version 0.30
10139N/ABuildRequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: intltool >= %{intltool_version}
10139N/A
10139N/A%description
10139N/AThis package contains the Blueprint theme engine for GTK2
10139N/A
10139N/A%prep
10139N/A%setup -q -n %name-%tarball_version
16349N/A%patch1 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
11137N/Aintltoolize --force --copy --automake
12773N/A
12773N/Abash -x %SOURCE1 --enable-copyright
12773N/A
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautomake -a -c -f
10139N/Aautoconf
10668N/Aexport CFLAGS="%optflags"
10668N/Aexport LDFLAGS="%_ldflags"
10668N/A./configure --prefix=%{_prefix} \
10668N/A --libdir=%{_libdir} \
10139N/A --sysconfdir=%{_sysconfdir}
10139N/Amake -j $CPUS
10139N/Acd -
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Amkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine
10139N/Acp -p AUTHORS COPYING ChangeLog NEWS README $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine
10139N/A
10139N/A# Hack to install images into %{_datadir}/pixmaps with blueprint prefix
10139N/Amkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
10139N/Amkdir -p /tmp/blueprint-pixmaps
10139N/Ainstallfiles=`find icons/48x48 -name "*.png"`
10139N/Afor i in $installfiles; do
10668N/A echo -- Installing $i to %{_datadir}/pixmaps with blueprint- prefix ;
10668N/A i_base=`basename $i`
10668N/A cp $i $RPM_BUILD_ROOT%{_datadir}/pixmaps/blueprint-${i_base}
10139N/Adone;
10139N/A
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS COPYING ChangeLog NEWS README
10139N/A%{_defaultdocdir}/blueprint-engine/ChangeLog
10139N/A%{_defaultdocdir}/blueprint-engine/AUTHORS
10139N/A%{_defaultdocdir}/blueprint-engine/COPYING
10139N/A%{_defaultdocdir}/blueprint-engine/README
10139N/A%{_defaultdocdir}/blueprint-engine/NEWS
10139N/A%{_libdir}/gtk-2.0/*/engines/*.so
10139N/A%{_datadir}/themes/*
10139N/A%{_datadir}/icons/*
10139N/A%{_datadir}/locale/*
10139N/A%{_datadir}/pixmaps/*
10139N/A
10139N/A%changelog
16349N/A* Fri Apr 10 2009 - takao.fujiwara@sun.com
16349N/A- Add patch rtl-icons.diff CR 6675046
11137N/A* Wed Aug 29 2007 - damien.carbery@sun.com
11137N/A- Add intltoolize calls to update intltool scripts.
10668N/A* Fri May 18 2007 - laca@sun.com
10668N/A- set CFLAGS/LDFLAGS and configure options such that we can use this spec
10668N/A file for the 64-bit build too
10668N/A- write a nicer loop for copying icons with blueprint- prefix
10139N/A* Fri Jun 23 2006 - brian.cameron@sun.com
10139N/A- Change "cp -a" to "cp -p" so it works with Solaris cp command.
10139N/A* Thu Feb 10 2005 - muktha.narayan@wipro.com
10139N/A- Bumped the tarball to include icons required to fix
10139N/A #5088581.
10139N/A* Mon Jan 31 2005 - takao.fujiwara@sun.com
10139N/A- Updated %build to stop build error
10139N/A* Fri Jan 28 2005 - muktha.narayan@wipro.com
10139N/A- Bumped the tarball which includes the fix for #5088581 and
10139N/A merged blueprint-01-g11n-icon.diff in the tarball.
10139N/A* Fri Jan 28 2005 - takao.fujiwara@sun.com
10139N/A- Updated %build to add automake
10139N/A* Wed Jan 12 2005 - takao.fujiwara@sun.com
10139N/A- Removed blueprint-01-g11n-alllinguas.diff. Use l10n-configure.sh
10139N/A- Added blueprint-01-g11n-icon.diff to fix 5083114
10139N/A* Thu Sep 16 2004 - ciaran.mcdermott@sun.com
10139N/A- Added blueprint-01-g11n-alllinguas.diff to include cs,hu linguas
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to blueprint-l10n-po-1.2.tar.bz2
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed Jun 2 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.9.5
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to blueprint-l10n-po-1.1.tar.bz2
10139N/A* Wed Mar 31 2004 - brian.cameron@sun.com
10139N/A- replace tar jxf with the more solaris friendly
10139N/A bzcat piped through tar
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Adding blueprint-l10n-po-1.0.tar.bz2 l10n content
10139N/A* Fri Mar 12 2004 Niall Power <niall.power@sun.com>
10139N/A- remove "rm -rf" evil from the install stage
10139N/A* Mon Feb 16 2004 Niall Power <niall.power@sun.com>
10139N/A- add ACLOCAL_FLAGS to aclocal invocation
10139N/A- do not use the -printf argument with find - it
10139N/A doesn't work on Solaris (pipe through sed instead)
10139N/A* Fri Jan 19 2004 Takao Fujiwara <takao.fujiwara@sun.com>
10139N/A- Modified blueprint.spec for i18n
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- remove *.a, *.la
10139N/A* Wed Jul 02 2003 Erwann Chenede - <erwann.chenede@sun.com>
10139N/A- cleanup + icons theme addition
10139N/A* Mon May 12 2003 Erwann Chenede - <erwann.chenede@sun.com>
10139N/A- initial implementation of the spec file
10139N/A