avahi.spec revision 15687
18861N/A#
18861N/A# spec file for package avahi
18861N/A#
18861N/A# Copyright (c) 2006 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/AName: avahi
18861N/ALicense: Other
18861N/AGroup: System/Libraries
18861N/AVersion: 0.6.23
18861N/ARelease: 1
18861N/ADistribution: Java Desktop System
18861N/AVendor: Sun Microsystems, Inc.
18861N/ASummary: System which facilitates service discovery on a local network.
18861N/ASource: http://www.avahi.org/download/%{name}-%{version}.tar.gz
18861N/ASource1: l10n-configure.sh
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch1: avahi-01-config-bonjour.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch2: avahi-02-browse-service.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch3: avahi-03-entry.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch4: avahi-04-internal.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch5: avahi-05-resolve-service.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch6: avahi-06-server.diff
20857N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch7: avahi-07-daemon.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch8: avahi-08-man-page.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch9: avahi-09-resolve-host-name.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch10: avahi-10-resolve-address.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
20857N/APatch11: avahi-11-browse-domain.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch12: avahi-12-browse.diff
18861N/A# date:2007-06-12 owner:padraig type:feature
18861N/APatch13: avahi-13-remove-debug-trap.diff
18861N/A# date:2009-01-20 owner:fujiwara type:bug bugid:122 bugster:6795230 state:upstream
18861N/APatch14: avahi-14-desktop.diff
18861N/AURL: http://ww.avahi.org/
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ADocdir: %{_defaultdocdir}/doc
18861N/AAutoreqprov: on
18861N/APrereq: /sbin/ldconfig
18861N/A
18861N/A%define libdaemon_version 0.11
18861N/A%define dbus_version 1.1.2
18861N/A%define python_version 2.4
18861N/A
18861N/ARequires: libdaemon >= %{libdaemon-version}
18861N/ABuildRequires: libdaemon-devel >= %{libdaemon-version}
18861N/A
18861N/ARequires: dbus >= %{dbus-version}
18861N/ABuildRequires: dbus-devel >= %{dbus-version}
18861N/A
18861N/A%description
18861N/AAvahi is a system which facilitates service discovery on a local network.
18861N/AThis means that you can plug your laptop or computer into a network and
18861N/Ainstantly be able to view other people you can chat with, find printers
18861N/Ato print to or find files being shared. This kind of technology is also
18861N/Ain Apple's Bonjour.
18861N/A
18861N/A
18861N/A%package devel
18861N/ASummary: System which facilitiates service disconvery on a local network.
18861N/AGroup: Development/Libraries
18861N/ARequires: %{name} = %{version}
18861N/A
18861N/A%description devel
18861N/AAvahi is a system which facilitates service discovery on a local network.
18861N/AThis measn thyat you can plug your laptop or computer into a network and
18861N/Ainstantly be able to view other people you can chat with, find printers
18861N/Ato print to or find files being shared. This kind of technology is also
18861N/Ain Apple's Bonjour.
18861N/A
18861N/A
18861N/A%prep
18861N/A%setup -q
18861N/A%patch1 -p1
18861N/A%patch2 -p1
18861N/A%patch3 -p1
18861N/A%patch4 -p1
18861N/A%patch5 -p1
18861N/A%patch6 -p1
18861N/A%patch7 -p1
18861N/A%patch8 -p1
18861N/A%patch9 -p1
18861N/A%patch10 -p1
18861N/A%patch11 -p1
19315N/A%patch12 -p1
19632N/A%patch13 -p1
%patch14 -p1
%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
CONFLAGS="--prefix=%{_prefix} \
--with-avahi-user=daemon \
--with-avahi-group=other \
--sysconfdir=%{_sysconfdir} \
--localstatedir=%{_localstatedir} \
--mandir=%{_mandir} \
--with-distro=none \
--disable-qt3 \
--disable-qt4 \
--disable-mono \
--disable-monodoc \
--enable-tests \
--disable-compat-howl \
--disable-compat-libdns_sd \
--enable-expat \
--disable-autoipd \
--disable-gdbm \
--enable-dbm"
libtoolize --force
glib-gettextize -f
intltoolize --force --copy
bash -x %SOURCE1 --enable-copyright
autoreconf
autoheader
autoconf
CFLAGS="$RPM_OPT_FLAGS"
./configure $CONFLAGS
make -j $CPUS \
pyexecdir=%{_libdir}/python%{python_version}/vendor-packages
%install
make DESTDIR=$RPM_BUILD_ROOT install \
pythondir=%{_libdir}/python%{python_version}/vendor-packages
rm -rf $RPM_BUILD_ROOT%{_libdir}/libavahi*a
rm -rf $RPM_BUILD_ROOT%{_localstatedir}
find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/avahi/avahi-daemon.conf
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/avahi/avahi-dnsconfd.action
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/avahi/hosts
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/avahi/services/sftp-ssh.service
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/avahi/services/ssh.service
rm -rf $RPM_BUILD_ROOT%{_sbindir}/avahi-dnsconfd
rm -rf $RPM_BUILD_ROOT%{_bindir}/avahi-discover-standalone
rm -rf $RPM_BUILD_ROOT%{_bindir}/avahi-bookmarks
rm -rf $RPM_BUILD_ROOT%{_mandir}/man5/avahi-daemon.conf.5
rm -rf $RPM_BUILD_ROOT%{_mandir}/man5/avahi.hosts.5
rm -rf $RPM_BUILD_ROOT%{_mandir}/man5/avahi.service.5
rm -rf $RPM_BUILD_ROOT%{_mandir}/man5
rm -rf $RPM_BUILD_ROOT%{_mandir}/man8
rm -rf $RPM_BUILD_ROOT%{_mandir}/man1/avahi-bookmarks.1
%post
/sbin/ldconfig
%postun
/sbin/ldconfig
%changelog
* Tue Jan 20 2009 - takao.fujiwara@sun.com
- Add patch avahi-14-desktop.diff
- Remove patch avahi-14-show-menu-items.diff
* Wed Aug 06 2008 - padraig.obriain@sun.com
- Add patch avahi-14-show-menu-items.diff for 6726720.
See http://www.avahi.org/ticket/234.
* Thu Jun 26 2008 - padraig.obriain@sun.com
- Uprev to 0.6.23; add calls to libtoolize and autoreconf
* Fri Jun 06 2008 - padraig.obriain@sun.com
- Uprev to 0.6.22; remove patch -14.
* Thu Sep 20 2007 - padraig.obriain@sun.com
- Add patch avahi-14-ui.diff to fix crash when no services are found.
* Tue June 12 2007 - padraig.obriain@sun.com
- Initial spec file for avahi.