audiofile.spec revision 10148
10139N/A#
10139N/A# spec file for package audiofile
10139N/A#
12119N/A# Copyright 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A#
17180N/AName: audiofile
17180N/ALicense: LGPL
17180N/AGroup: System/Library/GNOME
10139N/AVersion: 0.2.6
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
17394N/ASummary: audiofile -
14538N/ASource: http://www.68k.org/~michael/audiofile/audiofile-%{version}.tar.gz
10139N/A# This patch makes it possible to build esound with audiofile before
10139N/A# audiofile before it is installed. Sort of like an uninstalled.pc file.
10139N/A# This patch adds a slightly hacked version of the audiofile-config file to
17394N/A# the build directory with some hacks that allow esound to find the right
12559N/A# compiler options to build in our environment. Might be better to enhance
12773N/A# audiofile to use actual pc files, though not sure it is worth the effort.
12773N/A#owner:yippi date:2004-02-25 type:feature
12773N/APatch1: audiofile-01-uninstalled.pc.diff
10139N/AURL: http://www.68k.org/~michael/audiofile/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
14166N/ADocdir: %{_defaultdocdir}/%{name}
16459N/AAutoreqprov: on
10139N/ARequires: audiofile
16459N/A
10139N/A%description
16459N/AThe Audio File Library provides a uniform and elegant API for accessing
16768N/Aa variety of audio file formats, such as AIFF/AIFF-C, WAVE, NeXT/Sun
16459N/A.snd/.au, Berkeley/IRCAM/CARL Sound File, Audio Visual Research, Amiga
15261N/AIFF/8SVX, and NIST SPHERE. Supported compression formats are currently
16459N/AG.711 mu-law and A-law and IMA and MS ADPCM.
16488N/A
16488N/A%prep
17546N/A%setup -q
17546N/A%patch1 -p1
17999N/A
17999N/A%ifos solaris
10420N/A%ifarch amd64 sparcv9
10139N/Acd ..
10139N/Acp -rp audiofile-%{version} audiofile-%{version}-64
10139N/A%endif
10139N/A%endif
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/A%ifos solaris
10139N/A%ifarch amd64 sparcv9
10139N/Aexport CFLAGS="$CFLAGS64"
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
10139N/Aexport CC=${CC64:-$CC}
10139N/Asave_PATH="$PATH"
10139N/Accdir=`dirname $CC`
10142N/Aexport PATH=$ccdir:$PATH
10139N/A
10139N/Acd ../audiofile-%version-64
10139N/A
14166N/Alibtoolize --force
10139N/Aaclocal
10139N/Aautoconf
10139N/Aautomake -a -c -f
10139N/A./configure --prefix=%{_prefix} \
16488N/A --bindir=%{_bindir}/%{_arch64} \
17546N/A --libdir=%{_libdir}/%{_arch64} \
17999N/A --with-esd-dir=%{_libexecdir} \
13019N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir}
10139N/Amake -j$CPUS
10139N/Acd ../audiofile-%version
10139N/A
10139N/Aexport CC=${CC32:-$CC}
10139N/Aexport PATH="$save_PATH"
10139N/Aexport PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
10139N/Aexport CFLAGS="$CFLAGS32"
10139N/Aexport RPM_OPT_FLAGS="$CFLAGS"
10139N/A%endif
10139N/A%endif
10139N/A
10139N/Alibtoolize --force
12773N/Aaclocal
12773N/Aautoconf
12773N/Aautomake -a -c -f
12773N/ACFLAGS="$RPM_OPT_FLAGS" \
12773N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --with-esd-dir=%{_libexecdir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --mandir=%{_mandir}
10139N/Amake -j$CPUS
10139N/A
10139N/A
10139N/A%install
10139N/A%ifos solaris
15873N/A%ifarch amd64 sparcv9
10139N/Acd ../audiofile-%version-64
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Acd ../audiofile-%version
12962N/A%endif
10139N/A%endif
10139N/A
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_libdir}/*
10139N/A%{_bindir}/*
10139N/A
10139N/A%changelog
10139N/A* Wed Feb 28 2007 - laca@sun.com
10139N/A- update patch to use an uninstalled pkg-config .pc file instead of
10139N/A an uninstalled audiofile-config file, because the new esound only
10139N/A uses the .pc files
10139N/A* Sun Feb 18 2007 - laca@sun.com
10139N/A- create (split from SUNWgnome-audio.spec)
10139N/A